Not the answer you need?
Register and ask your own question!

percona clister not replicating new created database

giomandagiomanda ContributorInactive User Role Beginner
I am running a percona xtradb cluster of three nodes (per1, per2, per3). So far everything is working as expected however i an having an issue. I created a new database "testdb" on one of the servers (per1) and then i also created a new user "testuser" and gave full permissions on the new database.

Thing is the new database is not replicated on the other servers. I have checked my.cnf and i dont see anywhere specifying a specific database to be replicated. Apart from this, so far the other databases are properly replicated.

Any ideas?

Comments

  • giomandagiomanda Contributor Inactive User Role Beginner
    Just saw that there was a file inside mysql/cond.d that was full of replicate-do-db statements jene why no replication of relevant database was not working. I have another question. How do you proceed from there?

    Do you include replicate-do-db for the new db
    reload mysql service
    create database

    Could this cause any issue since the database is not yet created or should you first create the database and then modify the config to include replicate-do-db
  • jriverajrivera Percona Support Engineer Percona Staff Role
    Which version of PXC are you using? Is it possible you created a MyISAM database? MyISAM databases are not replicated in PXC.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.