Not the answer you need?
Register and ask your own question!

Percona XtraDB Cluster Node is not synced. in remote server

ali_fattahiali_fattahi EntrantCurrent User Role Novice
Hello dear friends
I've a problem with new node . I created new node and all of the configs is the same as other nodes and it synced by other nodes .
I used haproxy and mysqlchk script in xinetd for checking cluster in remote server ,
when I run :
/usr/bin/clustercheck
in local machine I got :
HTTP/1.1 200 OK
Content-Type: text/plain
Connection: close
Content-Length: 40

Percona XtraDB Cluster Node is synced.

till here all of things are good , but when I want to test from remote machine or run
telnet 127.0.0.1 9200
I got :
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
HTTP/1.1 503 Service Unavailable
Content-Type: text/plain
Connection: close
Content-Length: 44

Percona XtraDB Cluster Node is not synced.
Connection closed by foreign host.


in the local working well , but the response in remote machine is incorrect ,
in the log of clustercheck script shows :
Warning: Using a password on the command line interface can be insecure.
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (13)


how can I solve it ?

Comments

  • ali_fattahiali_fattahi Entrant Current User Role Novice
    The problem was in /var/lib/mysql permission
    to solve :
    chmod 777 /var/lib/mysql
    
  • ShahriyarRShahriyarR Contributor Inactive User Role Beginner
  • jriverajrivera Percona Support Engineer Percona Staff Role
    I would not recommend chmod 777 to the datadir, better check your error log to find the real problem.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.