Not the answer you need?
Register and ask your own question!

/etc/default/garbd is not configured yet

umarzukiumarzuki ContributorCurrent User Role Beginner
percona-xtradb-cluster-galera-3.x
Version: 3.9.3494.trusty

when I installed this package and configure /etc/default/garbd as below, it gave me that /etc/default/garbd is not configured yet message.


# Copyright (C) 2012 Codership Oy
# This config file is to be sourced by garb service script.

# REMOVE THIS AFTER CONFIGURATION

# A space-separated list of node addresses (address[:port]) in the cluster
GALERA_NODES="10.1.1.100:4567 10.1.1.101:4567"

# Galera cluster name, should be the same as on the rest of the nodes.
GALERA_GROUP="dbcluster"

# Optional Galera internal options string (e.g. SSL settings)
# see http://www.codership.com/wiki/doku.php?id=galera_parameters
# GALERA_OPTIONS=""

# Log file for garbd. Optional, by default logs to syslog
# Deprecated for CentOS7, use journalctl to query the log for garbd
LOG_FILE="/var/log/garbd.log"

Comments

  • umarzukiumarzuki Contributor Current User Role Beginner
    manually running command would temporarily solve this. Example for 2 node percona xtradb cluster 5.6 with 1 arbitrator

    $ sudo garbd --address="gcomm://10.1.1.100:4567,10.1.1.101:4567" --group dbcluster --options pc.wait_prim=no --log /var/log/garbd.log -d
  • jcamoinjcamoin Entrant Current User Role Beginner
    It's write there :

    # REMOVE THIS AFTER CONFIGURATION

    Remove the line and it's works !!!!

    enjoy
  • umarzukiumarzuki Contributor Current User Role Beginner
    ah...thanks. I missed that one.
  • sanjay92sanjay92 Contributor Current User Role Beginner
    It did not work for me on Ubuntu OS 14.x.

    [email protected]:/var/log# cat /etc/default/garbd | grep -v '#'

    GALERA_NODES=" 192.168.56.102:4567 192.168.56.103:4567"

    GALERA_GROUP="mysql_cluster"

    GALERA_OPTIONS="pc.wait_prim=no"

    LOG_FILE="/var/log/garbd.log"
    [email protected]:/var/log#


    Issue was with log file :

    To fix service startup issue:

    [[email protected] ~]# touch /var/log/garbd.log && chown nobody /var/log/garbd.log
    [[email protected] ~]# /etc/init.d/garb start
    Starting /usr/bin/garbd: [ OK ]
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.