Not the answer you need?
Register and ask your own question!

Unable to install percona tool kit

Rajesh HiriyannaRajesh Hiriyanna EntrantInactive User Role Beginner
Hi ,

I am trying to install "percona-toolkit-2.2.14-1.noarch.rpm" on the production box running MySQL 5.5.39 on Linux CentOS 6.6.

when i executed rpm -ivh percona-toolkit-2.2.14-1.noarch.rpm, i received the following dependencies but is failing on DBD::MySQL

# rpm -ivh percona-toolkit-2.2.14-1.noarch.rpm
warning: percona-toolkit-2.2.14-1.noarch.rpm: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
error: Failed dependencies:
perl(DBD::mysql) >= 1.0 is needed by percona-toolkit-2.2.14-1.noarch
perl(IO::Socket::SSL) is needed by percona-toolkit-2.2.14-1.noarch
perl(Term::ReadKey) is needed by percona-toolkit-2.2.14-1.noarch
[[email protected] mysql]# rpm -ivh perl-TermReadKey-2.30-3.el6.rfx.x86_64.rpm
warning: perl-TermReadKey-2.30-3.el6.rfx.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
Preparing... ########################################### [100%]
1:perl-TermReadKey ########################################### [100%]
[[email protected] mysql]# rpm -ivh perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch.rpm
warning: perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
error: Failed dependencies:
perl(Net::SSLeay) >= 1.21 is needed by perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch
[[email protected] mysql]# rpm -ivh perl-Net-SSLeay-1.36-1.el6.rfx.x86_64.rpm
warning: perl-Net-SSLeay-1.36-1.el6.rfx.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
Preparing... ########################################### [100%]
1:perl-Net-SSLeay ########################################### [100%]
[[email protected] mysql]# rpm -ivh perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch.rpm
warning: perl-IO-Socket-SSL-1.44-1.el6.rfx.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
Preparing... ########################################### [100%]
1:perl-IO-Socket-SSL ########################################### [100%]
[[email protected] mysql]# rpm -ivh perl-DBD-MySQL-4.022-1.el6.rfx.x86_64.rpm
warning: perl-DBD-MySQL-4.022-1.el6.rfx.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 6b8d79e6: NOKEY
error: Failed dependencies:
mysql is needed by perl-DBD-MySQL-4.022-1.el6.rfx.x86_64

[[email protected] mysql]#

Kindly let me know how to fix this error

Thanks,
Rajesh

Comments

  • thanhqb1thanhqb1 Entrant Current User Role Beginner
    oh thanks vinamuss tag cot
  • jaimejaime Contributor Current User Role Beginner
    Hi,
    This is most likely due to not installing MySQL-shared or MySQL-shared-compat package. Can you send the output of: rpm -qa|egrep -i 'mysql|percona'

    Thanks.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.