Not the answer you need?
Register and ask your own question!

Innobackupex - MySQL server has gone away when SET SESSION lock_wait_timeout=31536000

mrpk1906mrpk1906 EntrantLegacy User Role Beginner
Hi,

I have mysql server 5.5 with > 300GB data.
I tried create a slave from this master server.

When i run innobackupex, it died at SET SESSION lock_wait_timeout=31536000

This is error:
DBD::mysql::db do failed: MySQL server has gone away at /usr/bin/innobackupex line 3045.
innobackupex: got a fatal error with the following stacktrace: at /usr/bin/innobackupex line 3048
        main::mysql_query('HASH(0x19b4fed0)', 'SET SESSION lock_wait_timeout=31536000') called at /usr/bin/innobackupex line 3456
        main::mysql_lock_tables('HASH(0x19b4fed0)') called at /usr/bin/innobackupex line 1991
        main::backup() called at /usr/bin/innobackupex line 1601
innobackupex: Error:
Error executing 'SET SESSION lock_wait_timeout=31536000': DBD::mysql::db do failed: MySQL server has gone away at /usr/bin/innobackupex line 3045.
150322 21:25:24  innobackupex: Waiting for ibbackup (pid=30331) to finish


I tried repeat 2 times but same errors.

I read tutorial at http://www.percona.com/doc/percona-xtrabackup/2.1/innobackupex/improved_ftwrl.html
and set options same this tut but not success.

Sorry, my english is very poor :D

Thanks!

Comments

  • wagnerbianchiwagnerbianchi Remote DBA Current User Role Patron
    Not sure if this is connected with max_allowed_packet, but, is this a teste environment? Can you SET max_allowed_packet a little bit higher than the current value and test again?
  • mirfanmirfan Database Administrator Inactive User Role Beginner
    What version of xtrabackup you are using ?
    $ xtrabackup --version

    Also, can you please show me exact command you used to take backup along with my.cnf contents.
  • mrpk1906mrpk1906 Entrant Legacy User Role Beginner
    Hi,

    Thanks for your support,

    @wagnerbianchi: I set max_allowed_packet to 1GB, wait_timeout and interactive_timeout=28800 ( default ), lock_wait_timeout= 1 year (default) but same error.

    @mirfan: i'm using lastest version of xtrabackup

    Update: I reinstall xtrabackup with version 2.0.8 and this issue solved.

    Thanks!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.