Not the answer you need?
Register and ask your own question!

CentOS 6.5 And Percona XtraDB Cluster Just Doesn't Work?

skinfrakkiskinfrakki EntrantInactive User Role Beginner
I can easily get Ubuntu/Debian clustering working. However, CentOS I get nothing but errors:
141219 14:42:55 mysqld_safe mysqld from pid file /var/lib/mysql/perconadb2.hsmovedev.com.pid ended
141219 14:43:30 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
141219 14:43:30 mysqld_safe WSREP: Running position recovery with --log_error='/var/lib/mysql/wsrep_recovery.WnB5jJ' --pid-file='/var/lib/mysql/perconadb2.hsmovedev.com-recover.pid'
141219 14:43:32 mysqld_safe WSREP: Recovered position cab4275d-87c6-11e4-8794-87a6df8cd654:0
141219 14:43:32 [Note] WSREP: wsrep_start_position var submitted: 'cab4275d-87c6-11e4-8794-87a6df8cd654:0'
141219 14:43:32 [Note] WSREP: Read nil XID from storage engines, skipping position init
141219 14:43:32 [Note] WSREP: wsrep_load(): loading provider library '/usr/lib64/libgalera_smm.so'
141219 14:43:32 [Note] WSREP: wsrep_load(): Galera 2.11(r318911d) by Codership Oy <[email protected]> loaded successfully.
141219 14:43:32 [Note] WSREP: Found saved state: cab4275d-87c6-11e4-8794-87a6df8cd654:-1
141219 14:43:32 [Note] WSREP: Reusing existing '/var/lib/mysql//galera.cache'.
141219 14:43:32 [Note] WSREP: Passing config to GCS: base_host = 192.168.102.210; base_port = 4567; cert.log_conflicts = no; debug = no; evs.inactive_check_period = PT0.5S; evs.inactive_timeout = PT15S; evs.join_retrans_period = PT1S; evs.max_install_timeouts = 3; evs.send_window = 4; evs.stats_report_period = PT1M; evs.suspect_timeout = PT5S; evs.user_send_window = 2; evs.view_forget_timeout = PT24H; gcache.dir = /var/lib/mysql/; gcache.keep_pages_size = 0; gcache.mem_size = 0; gcache.name = /var/lib/mysql//galera.cache; gcache.page_size = 128M; gcache.size = 128M; gcs.fc_debug = 0; gcs.fc_factor = 1.0; gcs.fc_limit = 16; gcs.fc_master_slave = no; gcs.max_packet_size = 64500; gcs.max_throttle = 0.25; gcs.recv_q_hard_limit = 9223372036854775807; gcs.recv_q_soft_limit = 0.25; gcs.sync_donor = no; gmcast.version = 0; pc.announce_timeout = PT3S; pc.checksum = false; pc.ignore_quorum = false; pc.ignore_sb = false; pc.npvo = false; pc.version = 0; pc.wait_prim = true; pc.wait_prim_timeout = P30S; pc.weight = 1; protonet.backend = asio;
141219 14:43:32 [Note] WSREP: Assign initial position for certification: 0, protocol version: -1
141219 14:43:32 [Note] WSREP: wsrep_sst_grab()
141219 14:43:32 [Note] WSREP: Start replication
141219 14:43:32 [Note] WSREP: Setting initial position to cab4275d-87c6-11e4-8794-87a6df8cd654:0
141219 14:43:32 [Note] WSREP: protonet asio version 0
141219 14:43:32 [Note] WSREP: backend: asio
141219 14:43:32 [Note] WSREP: GMCast version 0
141219 14:43:32 [Note] WSREP: (14146b78, 'tcp://0.0.0.0:4567') listening at tcp://0.0.0.0:4567
141219 14:43:32 [Note] WSREP: (14146b78, 'tcp://0.0.0.0:4567') multicast: , ttl: 1
141219 14:43:32 [Note] WSREP: EVS version 0
141219 14:43:32 [Note] WSREP: PC version 0
141219 14:43:32 [Note] WSREP: gcomm: connecting to group 'my_centos_cluster', peer '192.168.102.209:,192.168.102.210:,192.168.102.211:'
141219 14:43:32 [Warning] WSREP: (14146b78, 'tcp://0.0.0.0:4567') address 'tcp://192.168.102.210:4567' points to own listening address, blacklisting
141219 14:43:35 [Warning] WSREP: no nodes coming from prim view, prim not possible
141219 14:43:36 [Warning] WSREP: last inactive check more than PT1.5S ago (PT3.50768S), skipping check
141219 14:44:05 [ERROR] WSREP: failed to open gcomm backend connection: 110: failed to reach primary view: 110 (Connection timed out)
at gcomm/src/pc.cpp:connect():141
141219 14:44:05 [ERROR] WSREP: gcs/src/gcs_core.cpp:long int gcs_core_open(gcs_core_t*, const char*, const char*, bool)():204: Failed to open backend connection: -110 (Connection timed out)
141219 14:44:05 [ERROR] WSREP: gcs/src/gcs.cpp:long int gcs_open(gcs_conn_t*, const char*, const char*, bool)():1303: Failed to open channel 'my_centos_cluster' at 'gcomm://192.168.102.209,192.168.102.210,192.168.102.211': -110 (Connection timed out)
141219 14:44:05 [ERROR] WSREP: gcs connect failed: Connection timed out
141219 14:44:05 [ERROR] WSREP: wsrep::connect() failed: 7
141219 14:44:05 [ERROR] Aborting

141219 14:44:05 [Note] WSREP: Service disconnected.
141219 14:44:06 [Note] WSREP: Some threads may fail to exit.
141219 14:44:06 [Note] /usr/sbin/mysqld: Shutdown complete

141219 14:44:06 mysqld_safe mysqld from pid file /var/lib/mysql/perconadb2.hsmovedev.com.pid ended

I followed the guide to the letter, telnet to the ports jsut fine on the master. What is the issue?

Comments

  • skinfrakkiskinfrakki Entrant Inactive User Role Beginner
    Really not helping. Tried both CentOS 6.5 and 7. Failures on both. Really just need a solution that works. The other thread never concluded the issue
  • skinfrakkiskinfrakki Entrant Inactive User Role Beginner
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Warning] WSREP: access file(gvwstate.dat) failed(No such file or directory)
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: restore pc from disk failed
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: GMCast version 0
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: (875ea8fb, 'tcp://0.0.0.0:4567') listening at tcp://0.0.0.0:4567
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: (875ea8fb, 'tcp://0.0.0.0:4567') multicast: , ttl: 1
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: EVS version 0
    Jan 2 11:16:53 db2 mysqld: 2015-01-02 11:16:53 2715 [Note] WSREP: gcomm: connecting to group 'my_centos_cluster', peer '192.168.102.232:'
    Jan 2 11:16:54 db2 systemd: Time has been changed
    Jan 2 11:16:56 db2 kernel: hv_balloon: Received INFO_TYPE_MAX_PAGE_CNT
    Jan 2 11:16:56 db2 kernel: hv_balloon: Data Size is 8
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Warning] WSREP: no nodes coming from prim view, prim not possible
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: view(view_id(NON_PRIM,875ea8fb,1) memb {
    Jan 2 11:16:56 db2 mysqld: 875ea8fb,0
    Jan 2 11:16:56 db2 mysqld: } joined {
    Jan 2 11:16:56 db2 mysqld: } left {
    Jan 2 11:16:56 db2 mysqld: } partitioned {
    Jan 2 11:16:56 db2 mysqld: })
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: gcomm: connected
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Changing maximum packet size to 64500, resulting msg size: 32636
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Shifting CLOSED -> OPEN (TO: 0)
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Opened channel 'my_centos_cluster'
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Waiting for SST to complete.
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: New COMPONENT: primary = no, bootstrap = no, my_idx = 0, memb_num = 1
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Flow-control interval: [16, 16]
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: Received NON-PRIMARY.
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: New cluster view: global state: :-1, view# -1: non-Primary, number of nodes: 1, my index: 0, protocol version -1
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Note] WSREP: wsrep_notify_cmd is not defined, skipping notification.
    Jan 2 11:16:57 db2 mysqld: 2015-01-02 11:16:57 2715 [Warning] WSREP: last inactive check more than PT1.5S ago (PT3.51805S), skipping check
  • przemekprzemek Percona Support Engineer Percona Staff Role
    Hi skinfrakki,
    Percona XtraDB Cluster works on both Debian/Ubuntu as well as RedHat and Centos 5,6 and 7. In fact I think most PXC users are probably on Centos 6 now.
    The errors you show above means this node cannot to connect to any existing cluster member and also it is not the one to be bootstrapped.
    In the first log it seems the node was not able to even connect to any other node on startup, hence it timeouted,
    In the second log, the line:
    Jan 2 11:16:56 db2 mysqld: 2015-01-02 11:16:56 2715 [Warning] WSREP: no nodes coming from prim view, prim not possible
    shows it seems to connect somewhere, but not to any primary component.

    Please check if all the needed TCP ports are opened between all the nodes and also initialize your cluster on first started node with bootstrap, for example:
    service mysql bootstrap-pxc
    
    Then once you start the next nodes, they should connect properly to this one.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.