Not the answer you need?
Register and ask your own question!

Can not build cluster

Lelik1985Lelik1985 EntrantCurrent User Role Beginner
Hi
I have two nodes on Ubuntu 12.04 Server 64 bit

When i bootstrap first node, in error log i can see

[Warning] WSREP: access file(gvwstate.dat) failed(No such file or directory)

but it is start

When i start second node

I can see that errors in log
[Warning] WSREP: access file(gvwstate.dat) failed(No such file or directory)
[Warning] WSREP: (5b571936, 'tcp://0.0.0.0:4567') address 'tcp://10.1.1.13:4567' points to own listening address, blacklisting
[Warning] WSREP: Gap in state sequence. Need state transfer.
[Warning] WSREP: Failed to prepare for incremental state transfer: Local state UUID (00000000-0000-0000-0000-000000000000) does not match group state UUID (2f13e6f3-845d-11e4-a92a-1353578a748d): 1 (Operation not permitted)
[Warning] WSREP: 1.0 (xtradb1): State transfer to 0.0 (xtradb2) failed: -22 (Invalid argument)
[ERROR] WSREP: gcs/src/gcs_group.cpp:int gcs_group_handle_join_msg(gcs_group_t*, const gcs_recv_msg_t*)():722: Will never receive state. Need to abort.
[ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '10.1.1.13' --auth 'sstuser:s3cretPass' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '20901' '' : 1 (Operation not permitted)
[ERROR] WSREP: Failed to read uuid:seqno from joiner script.
[ERROR] WSREP: SST failed: 1 (Operation not permitted)
[ERROR] Aborting




Percona Xtradb Cluster version is 5.6.21-25.8-938.precise on two nodes

Config on first node
skip-name-resolve

explicit_defaults_for_timestamp=TRUE
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_provider_options = 'socket.checksum = 1;'
#wsrep_cluster_address=gcomm://10.1.1.12,10.1.1.13
wsrep_cluster_address=gcomm://
wsrep_slave_threads = 96
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
wsrep_node_address=10.1.1.12
wsrep_node_name=xtradb1
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=stalker_db_cluster
wsrep_sst_auth="sstuser:s3cretPass"




Config on second node

skip-name-resolve

explicit_defaults_for_timestamp=TRUE
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_provider_options = 'socket.checksum = 1;'
wsrep_cluster_address=gcomm://10.1.1.12,10.1.1.13
#wsrep_cluster_address=gcomm://
wsrep_slave_threads = 96
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
wsrep_node_address=10.1.1.13
wsrep_node_name=xtradb2
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=stalker_db_cluster
wsrep_sst_auth="sstuser:s3cretPass"




What is WRONG ?

I alredy have 3 working well clusters on previos version of percona cluster ?
What is wrong with new one ?

Can someone help ?

Comments

  • jriverajrivera Percona Support Engineer Percona Staff Role
    Do you still encounter the problem? If so, can you attach the innobackup.backup.log on donor node and innobackup.prepare.log on joiner node?
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.