Not the answer you need?
Register and ask your own question!

Cluster dos not synchronized

Lelik1985Lelik1985 EntrantCurrent User Role Beginner
Hi
I have two nodes with version 5.6.21-25.8-938.precise

| wsrep_local_state | 4 |
| wsrep_local_state_comment | Synced |
| wsrep_cert_index_size | 91 |
| wsrep_causal_reads | 0 |
| wsrep_cert_interval | 0.000022 |
| wsrep_incoming_addresses | 10.1.1.12:3306,10.1.1.13:3306 |
| wsrep_evs_delayed | |
| wsrep_evs_evict_list | |
| wsrep_evs_repl_latency | 0/0/0/0/0 |
| wsrep_evs_state | OPERATIONAL |
| wsrep_gcomm_uuid | 87ae0011-83ab-11e4-9fc0-d65c844c8cea |
| wsrep_cluster_conf_id | 30 |
| wsrep_cluster_size | 2 |
| wsrep_cluster_state_uuid | 1abb2b3e-82ff-11e4-824a-a24ee1e11d16 |
| wsrep_cluster_status | Primary |
| wsrep_connected | ON |
| wsrep_local_bf_aborts | 0 |
| wsrep_local_index | 0 |
| wsrep_provider_name | Galera |
| wsrep_provider_vendor | Codership Oy <[email protected]> |
| wsrep_provider_version | 3.8(rf6147dd) |
| wsrep_ready | ON |



clustercheck says

clustercheck root pass
HTTP/1.1 200 OK
Content-Type: text/plain
Connection: close
Content-Length: 40

Percona XtraDB Cluster Node is synced.



But second node dos not have one table in database

and in error log i see

2014-12-14 18:35:44 53445 [Warning] InnoDB: Cannot open table test_db/all_cities from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.


also that
[Warning] WSREP: access file(gvwstate.dat) failed(No such file or directory)


from config:

explicit_defaults_for_timestamp=TRUE
wsrep_provider=/usr/lib/libgalera_smm.so
#wsrep_provider_options = 'pc.ignore_sb = true'
#wsrep_provider_options = 'socket.checksum = 1;'
wsrep_cluster_address=gcomm://10.1.1.12,10.1.1.13
#wsrep_cluster_address=gcomm://
wsrep_slave_threads = 128
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
wsrep_node_address=10.1.1.12
wsrep_node_name=xtradb1
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=test_db_cluster
wsrep_sst_auth="sstuser:s3cretPass"




I have now working well other cluster with 10 nodes
There is version 5.6.20-25.7-886.precise

What is different betwen new version and previos ?
Something changed in config ?

How can i install previos worked version ?

Thank you
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.