Not the answer you need?
Register and ask your own question!

--use-memory= - No backup speed increase?

pamamolfpamamolf EntrantLegacy User Role Beginner
Hi

I was try to run a backup of my database only using:
innobackupex --no-timestamp --databases="databasename" /backup/mysql

and if i am not wrong that uses the default ram 100mb value and it takes to finish the backup 18 minutes.

Then i run it using:
innobackupex --no-timestamp --use-memory=8G --databases="databasename" backup/mysql

and it takes exactly the same time 18 minutes.

Why i don't get any speed increase of backup?

Thanks

Comments

  • scott.nemesscott.nemes MySQL Sage Current User Role Patron
    Hi pamamolf;

    The --use-memory option is only valid during the apply-log step, so that will not help speed up the backup itself

    If you have InnoDB file per table enabled, look at the --parallel option which may help speed up the backup. Note if you are not using file per table that option will not help since all of your table data will be in the one ibdata1 file.

    The limiting factor for backup speed tends to be your disk speed. So the best way to speed up your backup is to have it write to a separate disk or physical partition so that the backup is not competing with your database (and other processes) for drive access.

    http://www.percona.com/doc/percona-xtrabackup/2.2/innobackupex/innobackupex_option_reference.html#cmdoption-innobackupex--parallel

    -Scott
  • pamamolfpamamolf Entrant Legacy User Role Beginner
    Thanks scott.nemes :)
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.