Not the answer you need?
Register and ask your own question!

XtraBackup Error when using apply-log

epincepinc EntrantInactive User Role Beginner
I was trying out XtraBackup but am getting this error when I try to apply-log......

"no innodb_data_file_path option in group mysqld in server configuration file"

I do not have that statement in my cnf file because I am using innodb-file-per-table

What am I doing wrong here? Thanks.

Comments

  • mirfanmirfan Database Administrator Inactive User Role Beginner
    Can you please share your my.cnf and exact command you used to take backup along with backup log to identify what causing the issue.
    Also show me the output of

    $ xtrbackup --version
  • sibidassibidas Entrant Legacy User Role Beginner
    I had the same issue. I was able to successfully start the apply-log process after adding the following inside the file backup-my.cnf which is precent in the backup dir.
    innodb_data_file_path=ibdata1:10M:autoextend

    I got the value of innodb_data_file_path from the server from which I took the backup. Issue the command "show variables like 'innodb_data_file_path' " in mysql prompt of master and put that value here. Hope this helps.
  • niljoshiniljoshi MySQL Sage Inactive User Role Beginner
    Hi,

    Agree with sibidas, you should add innodb_data_file_path settings to my.cnf because xtrabackup will get all innodb related details while taking backup and stored in backup-my.cnf (in backup dir) . Even if you are using innodb_file_per_table, you'll have system tablespace i.e ibdata1. You can add path in backup-my.cnf and try to prepare again.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.