Not the answer you need?
Register and ask your own question!

2nd node not joining cluster

awcodeawcode EntrantInactive User Role Beginner
This is my first attempt at creating a percona cluster although been using percona server for years.

I have followed this guide which has mostly worked.
http://www.percona.com/doc/percona-xtradb-cluster/5.5/howtos/3nodesec2.html
Just spotted that this guide was for 5.5 while I am on 5.6 but guess they should be compatible.

Bootstrapping the first node seems to have worked fine, however trying to start the second node and it just stalls.

The results from error.log on the 2nd node are below.
Nothing relevant in syslog and nothing showing in the primary nodes logs.
Any ideas on whats going on?

2014-11-04 10:04:57 9229 [Note] WSREP: Passing config to GCS: base_host = 10.10.0.25; base_port = 4567; cert.log_conflicts = no; debug = no; evs.inactive_check_period = PT0.5S; evs.inactive_timeout = PT15S; evs.join_retrans_period = PT1S; evs.max_install_timeouts = 3; evs.send_window = 4; evs.stats_report_period = PT1M; evs.suspect_timeout = PT5S; evs.user_send_window = 2; evs.view_forget_timeout = PT24H; gcache.dir = /var/lib/mysql/; gcache.keep_pages_size = 0; gcache.mem_size = 0; gcache.name = /var/lib/mysql//galera.cache; gcache.page_size = 128M; gcache.size = 128M; gcs.fc_debug = 0; gcs.fc_factor = 1.0; gcs.fc_limit = 16; gcs.fc_master_slave = no; gcs.max_packet_size = 64500; gcs.max_throttle = 0.25; gcs.recv_q_hard_limit = 9223372036854775807; gcs.recv_q_soft_limit = 0.25; gcs.sync_donor = no; gmcast.segment = 0; gmcast.version = 0; pc.announce_timeout = PT3S; pc.checksum = false; pc.ignore_quorum = false; pc.ignore_sb = false; pc.npvo = false; pc.recovery = 1; pc.version = 0; pc.wait_prim = true; pc.wait_prim_timeout = P30S; pc.weig
2014-11-04 10:04:57 9229 [Note] WSREP: Service thread queue flushed.
2014-11-04 10:04:57 9229 [Note] WSREP: Assign initial position for certification: 0, protocol version: -1
2014-11-04 10:04:57 9229 [Note] WSREP: wsrep_sst_grab()
2014-11-04 10:04:57 9229 [Note] WSREP: Start replication
2014-11-04 10:04:57 9229 [Note] WSREP: Setting initial position to cf26dccc-6403-11e4-a7c5-2eead30442d4:0
2014-11-04 10:04:57 9229 [Note] WSREP: protonet asio version 0
2014-11-04 10:04:57 9229 [Note] WSREP: Using CRC-32C for message checksums.
2014-11-04 10:04:57 9229 [Note] WSREP: backend: asio
2014-11-04 10:04:57 9229 [Warning] WSREP: access file(gvwstate.dat) failed(No such file or directory)
2014-11-04 10:04:57 9229 [Note] WSREP: restore pc from disk failed
2014-11-04 10:04:57 9229 [Note] WSREP: GMCast version 0
2014-11-04 10:04:57 9229 [Note] WSREP: (08118397, 'tcp://0.0.0.0:4567') listening at tcp://0.0.0.0:4567
2014-11-04 10:04:57 9229 [Note] WSREP: (08118397, 'tcp://0.0.0.0:4567') multicast: , ttl: 1
2014-11-04 10:04:57 9229 [Note] WSREP: EVS version 0
2014-11-04 10:04:57 9229 [Note] WSREP: PC version 0
2014-11-04 10:04:57 9229 [Note] WSREP: gcomm: connecting to group 'CloudMngrPerconaCluster', peer '10.10.0.249:'
2014-11-04 10:05:00 9229 [Warning] WSREP: no nodes coming from prim view, prim not possible
2014-11-04 10:05:00 9229 [Note] WSREP: gcomm: connected
2014-11-04 10:05:00 9229 [Note] WSREP: Changing maximum packet size to 64500, resulting msg size: 32636
2014-11-04 10:05:00 9229 [Note] WSREP: Shifting CLOSED -> OPEN (TO: 0)
2014-11-04 10:05:00 9229 [Note] WSREP: Opened channel 'CloudMngrPerconaCluster'
2014-11-04 10:05:00 9229 [Note] WSREP: Waiting for SST to complete.
2014-11-04 10:05:00 9229 [Note] WSREP: New COMPONENT: primary = no, bootstrap = no, my_idx = 0, memb_num = 1
2014-11-04 10:05:00 9229 [Note] WSREP: Flow-control interval: [16, 16]
2014-11-04 10:05:00 9229 [Note] WSREP: Received NON-PRIMARY.
2014-11-04 10:05:00 9229 [Note] WSREP: New cluster view: global state: cf26dccc-6403-11e4-a7c5-2eead30442d4:0, view# -1: non-Primary, number of nodes: 1, my index: 0, protocol version -1
2014-11-04 10:05:00 9229 [Note] WSREP: wsrep_notify_cmd is not defined, skipping notification.
2014-11-04 10:05:01 9229 [Warning] WSREP: last inactive check more than PT1.5S ago (PT3.50257S), skipping check

Comments

  • przemekprzemek Percona Support Engineer Percona Staff Role
    The error says this node could not reach any primary component, so either the bootstrapped node was not OK or something is blocking communication.
  • jithjith Entrant Current User Role Beginner
    Hi, I am a naive user and for the first time implementing Percona XtraDB cluster. Both the nodes do not get bootstraped. I am getting the following error. Could anyone point me to rectify this problem and make it work?

    /etc/init.d/mysql bootstrap-pxc
    [....] Bootstrapping Percona XtraDB Cluster database server: mysqld .[....] The
    [FAILr quit without updating PID file (/var/run/mysqld/mysqld.pid). ... failed!
    failed!

    Both the nodes have same problem
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.