Not the answer you need?
Register and ask your own question!

Skipping table - it would be checksummed in 1 chunk but replicas have too many rows

epincepinc EntrantInactive User Role Beginner
I am getting this error on a series of random tables every night I try to run the pt-table-checksum script

Every night the tables affected are different, and these tables are not in use by anyone else when the script is run

I manually count the records on each replica and they match the server

What could be the issue here?

Skipping table XXXX because on the master it would be checksummed in one chunk but on these replicas it has too many rows:
88687 rows on Replica1
86422 rows on Replica2

Comments

  • mirfanmirfan Database Administrator Inactive User Role Beginner
    Make sure all your tables should contains primary or unique key as pt-table-checksum requires primary key or unique key to divide a table into chunks. Ever changing table statistics can be problem. Try with trun off innodb_stats_on_metadata before checksum. Try setting up different value for --chunk-size-limit and --chunk-time although this can increase server load because of bigger chunks. Running ANALYZE TABLE before checksum may help too. And it's good idea to run with PTDEBUG option to enable debugging output for pt-table-checksum.
  • epincepinc Entrant Inactive User Role Beginner
    Hi! Thank you very much for your reply. I will try those suggestions
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.