Not the answer you need?
Register and ask your own question!

Problem with views

jdbravojdbravo EntrantInactive User Role Beginner
Hi,

I created a view in one of the nodes, and it created it in the other node too.

The problem is that it only has data in the node where I created it and not in the other node.

What can be happening?
Server version: 5.6.20-68.0-56 Percona XtraDB Cluster (GPL), Release rel68.0, Revision 888, WSREP version 25.7, wsrep_25.7.r4126

Thanks,

Comments

  • jdbravojdbravo Entrant Inactive User Role Beginner
    The problem is not the view, is a table that doesn't have results in one of the nodes.

    Node1:
    mysql> select archivo from bi_some limit 1,2;
    +
    +
    | archivo |
    +
    +
    | 12015600000 |
    | 105494 |
    +
    +
    2 rows in set (0.00 sec)


    Node 2:

    mysql> select archivo from bi_some limit 1,2; Empty set (0.00 sec)


    But the cluster is reporting that is sync
    mysql> SELECT 1 FROM dual;
    +---+
    | 1 |
    +---+
    | 1 |
    +---+
    1 row in set (0.00 sec)


    /usr/bin/clustercheck clustercheck password 0
    HTTP/1.1 200 OK
    Content-Type: text/plain
    Connection: close
    Content-Length: 40

    Percona XtraDB Cluster Node is synced.


    I dumped a very large .sql in one of the nodes, and apparently it dind't propagated the data to the other node.
  • przemekprzemek Percona Support Engineer Percona Staff Role
    Looks like MyISAM table? :)
  • jdbravojdbravo Entrant Inactive User Role Beginner
    You are right!

    Thanks for your help!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.