Not the answer you need?
Register and ask your own question!

Xtrabackup failing on 5.6

shadowshadow EntrantInactive User Role Beginner
Using the latest xtrabackup 2.2.4 on mysql 5.6.16, trying to prepare the backup consistently crashes out with:


xtrabackup: export metadata of table 'vbulletin/threadviews' to file `./vbulletin/threadviews.exp` (2 indexes)
xtrabackup: name=GEN_CLUST_INDEX, id.low=7773, page=3
xtrabackup: name=threadid, id.low=7774, page=4
xtrabackup: export metadata of table 'vbulletin/attachmentviews' to file `./vbulletin/attachmentviews.exp` (2 indexes)
xtrabackup: name=GEN_CLUST_INDEX, id.low=7581, page=3
xtrabackup: name=postid, id.low=7582, page=4
xtrabackup: export metadata of table 'vbulletin/postindex' to file `./vbulletin/postindex.exp` (1 indexes)
xtrabackup: name=wordid, id.low=7725, page=3

[notice (again)]
If you use binary log and don't use any hack of group commit,
the binary log position seems to be:
InnoDB: Last MySQL binlog file position 0 1058288605, file name db2.000080

xtrabackup: starting shutdown with innodb_fast_shutdown = 0
innobackupex: Error:
innobackupex: ibbackup failed line 2617.


Dumping out $cmdline at 2617 shows it's running: xtrabackup --defaults-file="/mnt/backup/my.cnf" --defaults-group="mysqld" --prepare --target-dir=/mnt/backup/2014-09-23 --export --tmpdir=/mnt/mysql/tmp


Syntax I'm calling it with is pretty standard:

innobackupex --defaults-file=/mnt/backup/my.cnf --socket=/tmp/mysql.sock --no-timestamp --slave-info /mnt/backup/2014-09-23 --host=localhost
innobackupex --export --defaults-file=/mnt/backup/my.cnf --socket=/tmp/mysql.sock --apply-log /mnt/backup/2014-09-23 --host=localhost


/mnt/backup/my.cnf is:

[mysqld]
server-id = 13
relay-log = db3-relay-bin
log-bin = db3

skip-slave-start
skip-name-resolve
skip-external-locking
log-warnings

max_connections = 2048
open_files_limit = 8192
key_buffer = 256M
max_connect_errors = 64

read_buffer_size = 1M
read_rnd_buffer_size = 4M
sort_buffer_size = 1M
tmp_table_size = 128M
max_heap_table_size = 128M
myisam_sort_buffer_size = 256M

table_open_cache = 16384
thread_cache_size = 256

wait_timeout = 300
connect_timeout = 10

max_allowed_packet = 16M
bulk_insert_buffer_size = 16M

query_cache_limit = 2M
query_cache_size = 0
# query_prealloc_size = 16384
# query_alloc_block_size = 16384
query_cache_type = 0

tmpdir = /mnt/mysql/tmp

slow_query_log = 1
long_query_time = 2
slow_query_log_file = /var/lib/mysql/slow.log

innodb_file_per_table
innodb_buffer_pool_size = 5G
innodb_additional_mem_pool_size = 20M
innodb_log_buffer_size = 8M
innodb_data_file_path = ibdata1:100M:autoextend
innodb_flush_log_at_trx_commit = 2
innodb_thread_concurrency = 24

innodb_io_capacity = 300
innodb_read_io_threads = 6
innodb_write_io_threads = 6
innodb_adaptive_flushing = 1

innodb_log_file_size=256M
innodb_log_files_in_group=2

[mysql]
default-character-set = utf8

[client]
user=root
password=XXXXXXXXXXX

[xtrabackup]
datadir = /mnt/mysql/mysql
target_dir = /mnt/backup/


This was working fine when we were on 5.5, pretty sure it broke around the time we moved to 5.6. Originally ran into this on 2.2.3 so upgraded to 2.2.4 but no improvement. Any suggestions on how to troubleshoot further?
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.