Not the answer you need?
Register and ask your own question!

"Unknow variable wsrep_cluster_address" (actually wsrep_*) after upgrade 5.5 -> 5.6

joepmeloen12joepmeloen12 ContributorInactive User Role Novice
Following http://www.percona.com/doc/percona-server/5.6/upgrading_guide_55_56.html I just upgrade a 3-node PXC (test) cluster tot 5.6 All fine, though after upgrading the 1st node (rest of cluster is down) and starting it, I get the following (started with --wsrep_cluster_address=gcomm://)

014-09-15 13:22:30 1413 [Warning] Using unique option prefix myisam_recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
2014-09-15 13:22:30 1413 [Note] Plugin 'FEDERATED' is disabled.
2014-09-15 13:22:30 1413 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-09-15 13:22:30 1413 [Note] InnoDB: The InnoDB memory heap is disabled
2014-09-15 13:22:30 1413 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2014-09-15 13:22:30 1413 [Note] InnoDB: Memory barrier is not used
2014-09-15 13:22:30 1413 [Note] InnoDB: Compressed tables use zlib 1.2.8
2014-09-15 13:22:30 1413 [Note] InnoDB: Using Linux native AIO
2014-09-15 13:22:30 1413 [Note] InnoDB: Using CPU crc32 instructions
2014-09-15 13:22:30 1413 [Note] InnoDB: Initializing buffer pool, size = 500.0M
2014-09-15 13:22:30 1413 [Note] InnoDB: Completed initialization of buffer pool
2014-09-15 13:22:30 1413 [Note] InnoDB: Highest supported file format is Barracuda.
2014-09-15 13:22:30 1413 [Note] InnoDB: 128 rollback segment(s) are active.
2014-09-15 13:22:30 1413 [Note] InnoDB: Waiting for purge to start
2014-09-15 13:22:30 1413 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.20-68.0 started; log sequence number 15578194093
2014-09-15 13:22:30 1413 [ERROR] mysqld: unknown variable 'wsrep_cluster_address=gcomm://node2,node3'
2014-09-15 13:22:30 1413 [ERROR] Aborting

When I remove wsrep_cluster_address, the next wsrep_* will appear as being unknown. They all fail. AFAICS all packages were installed correctly :

[email protected]:~# dpkg --get-selections | grep -v deinstall| grep -i percona
libperconaserverclient18.1 install
percona-server-client-5.6 install
percona-server-common-5.6 install
percona-server-server-5.6 install

Ubuntu information:

[email protected]:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

Anyone have a clue what I'm doing wrong here?

Comments

  • joepmeloen12joepmeloen12 Contributor Inactive User Role Novice
    Well, in case somebody has the same: turns out that de-installing *all* percona related software and re-installing 5.6 fixed this. Probably it's wise to deinstall 5.5 before installing 5.6.
  • joepmeloen12joepmeloen12 Contributor Inactive User Role Novice
    Another update: per the manual I used

    sudo apt-get install percona-server-server-5.6

    .. to install the new version. That part didn't work (for me, at last). I did succeed by using

    sudo apt-get install percona-xtradb-cluster-56

    A clear case of RTRFM.. read the RIGHT fine manual. Leaving this post here anyway in case somebody reads the wrong manual like I did.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.