Not the answer you need?
Register and ask your own question!

File name ./ib_logfile0 InnoDB: File operation call: 'open' returned OS error 71.

ergamonergamon EntrantLegacy User Role Beginner
Hello, i got the same problem as discussed in this topic:
http://www.percona.com/forums/questions-discussions/percona-xtrabackup/13396-file-name-ib_logfile0-innodb-file-operation-call-open-returned-os-error-71
But i cant solve it with changing permissions, everything is setup for me correctly (as i think).
I have 3 freebsd servers, two with 10.0 and latest percona server from ports (5.6.19-67.0-log) and one with 9.0-release with 5.6.15-log.
What i tried to do:
- When i built this tool from ports, it gave me that error and i had an error with xtrabackup tool too.
After that i tried to deinstall tool from ports and to compile from source latest 2.2.6 version directly. During compilation process I also got an error that you should fix too. That error was at "make" stage at about 70-80% and it said me that xtrabackup_version.h was not found. That error was also in freebsd 9.0, but i couldnt understand what it wants from me but luckily i already know how to correct that error in 10.0 version of freebsd. So i simply had to go into /source_folder/storage/innobase/xtrabackup/src/ and found there xtrabackup_version.h.in instead of xtrabackup_version.h. After that i simply renamed that file into correct type and completed build process with make install. After that i had the same error with innobackupex script, but suddenly xtrabackup started to work fine on all builds of freebsd, so i could make that backup directly but without myisam tables.
If you need some further information or access to one of servers to make tests, let me know.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.