Not the answer you need?
Register and ask your own question!

extra-lsndir option not read from defaults-extra-file

sensersenser EntrantCurrent User Role Beginner
Hello,

I use xtrabackup on debian wheezy x86_64 to backup mysql server 5.5.37. Version of xtrabackup is "percona-xtrabackup 2.2.3-4982-1.wheezy amd64".
Here is the content of xtrabackup.conf file:

[mysqld]

[xtrabackup]
target-dir = /mnt/data/DB_backup
ibbackup = /usr/bin/xtrabackup
compress
compress-threads = 5
compress-chunk-size = 256K
parallel = 5
user = xxxxx
password = xxxxx
encrypt = AES256
encrypt-key-file = enc.key
encrypt-threads = 5
encrypt-chunk-size = 256K
extra-lsndir = /mnt/data/DB_backup/lsn

I create base backups with following command:

/usr/bin/innobackupex --defaults-extra-file=xtrabackup.conf --ibbackup=xtrabackup /mnt/data/DB_backup

Runing innobackupex produces this xtrabackup call:

innobackupex: Starting ibbackup with command: xtrabackup --defaults-extra-file="xtrabackup.conf" --defaults-group="mysqld" --backup --suspend-at-end --target-dir=/mnt/data/DB_backup/2014-08-21_13-38-19 --tmpdir=/tmp --extra-lsndir='/tmp'

As you can see the last option (extra-lsndir) from xtrabackup.conf file has been ignored and replaced with (default) '/tmp' dir. Other options are parsed and imported successfully.

Is there a way to place that option in defaults-extra-file so innobackupex to read it.

Regards.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.