Not the answer you need?
Register and ask your own question!

Replication performance degraded after update from 5.5.38-rel35.2 to 5.6.19-rel67.0

BogdarBogdar EntrantCurrent User Role Beginner
Hello!

I'm going to migrate from 5.5 to 5.6, but found serious performance degradation in master-slave replication on my OLTP workload (~25% lost)

Hardware: Dell R720 (2x8 cores, 2.6Ghz) as masters and Dell R420 (2x6 cores, 2.5Ghz ) as slaves.
Software: CentOS 6 amd64 with all latest updates, Percona sever from Percona's yum repo.

Replication topology:

OldMaster (5.5) -> OldSlave (5.5)
OldMaster (5.5) -> NewMaster (5.6) -> NewSalve (5.6)

Both NewSlave and OldSlave have same amount of RAM and same SSD in RAID1 with 512Mb writeback cache (Dell PERC H710)
Both NewMaster and OldMaster have dedicated RAID array for binlogs.
Test condition: on July 17 evening I stop replication both at the same time. Next morning when I started replication, replication delay was about 36000 seconds for both slaves.

OldSlave (5.5) performed logs replay in 1h 28m with performance of 24000 DML/sec in last hour.
NewSlave (5.6) performed logs replay in 1h 54m with performance of 19300 DML/sec in last hour.
So both 5.5 and 5.6 slaves has same workload, same hardware and same MySQL configs, but 5.6 is much slower.

I don't see neither IO nor networks bottlenecks in iostat/vmstat in progress. Could you pleae advice me how to get my replication performance back to normal speed ?

Configs attached.

Thank you in advance!
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.