Not the answer you need?
Register and ask your own question!

Percona innobackupex restoring problem

kannan2410kannan2410 EntrantInactive User Role Beginner
Hi All,
I have a problem while restoring my full backup using innobackupex, below are the steps which i am doing.

1) innobackupex --user=root --password=test123 /data/backup/innobackupex/Full/

2) innobackupex --apply-log --redo-only /data/backup/innobackupex/Full/2014-07-03_14-39-24/

3) /etc/init.d/mysql stop

removing files from mysql data dir..

4) rm -rf /data/mysql/data/*

restoring backup to datadir (/data/mysql/data)

5) innobackupex --copy-back /data/backup/innobackupex/Full/2014-07-03_14-39-24/

6) chown -R mysql:mysql /data/mysql/data/

7) /etc/init.d/mysql start

Upto this everything is perfect. I didn't get any error. successfully started mysql..

but no data available on my database..The error is below while checking the tables..

mysql> select * from db.User1;
ERROR 1146 (42S02): Table 'db.User1' doesn't exist

Can anyone help me here..?
Thanks in advance..

Comments

  • psongpsong Contributor Inactive User Role Beginner
    What do "ls -l /data/mysql/data" and "ls -l /data/mysql/data/db" show?  Btw, when you prepare a full backup, it is better to leave out --redo-only and allow the prepare step to rollback uncommitted transactions. And so it would save time to start up the server on the prepared data. 
  • kannan2410kannan2410 Entrant Inactive User Role Beginner
    Hi psong,

    It works fine after leaving (--redo-only) while preparing full backup..

    Thanks a lot. :)
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.