Not the answer you need?
Register and ask your own question!

build more connection on each request

tohidtohid EntrantCurrent User Role Beginner
i setup percona cluster with only one node for simpilicity .. every thing is fine and works , but i found that when i establish a connection to that , more than one connection are generated !
this is my process on mysql before new connection request :

mysql> show processlist;

+----+
+
+
+
+
+
+
+
+
+
| Id | User | Host | db | Command | Time | State | Info | Rows_sent | Rows_examined |
+----+
+
+
+
+
+
+
+
+
+
| 1 | system user | | NULL | Sleep | 523 | NULL | NULL | 0 | 0 |
| 2 | system user | | NULL | Sleep | 523 | wsrep aborter idle | NULL | 0 | 0 |
| 16 | root | localhost | NULL | Query | 0 | init | show processlist | 0 | 0 |
+----+
+
+
+
+
+
+
+
+
+


and after new connection is request by root user , this is what happen :

mysql> show processlist;

+----+
+
+
+
+
+
+
+
+
+
| Id | User | Host | db | Command | Time | State | Info | Rows_sent | Rows_examined |
+----+
+
+
+
+
+
+
+
+
+
| 1 | system user | | NULL | Sleep | 530 | NULL | NULL | 0 | 0 |
| 2 | system user | | NULL | Sleep | 530 | wsrep aborter idle | NULL | 0 | 0 |
| 16 | root | localhost | NULL | Query | 0 | init | show processlist | 0 | 0 |
| 17 | root | 192.168.1.200:2402 | NULL | Sleep | 1 | | NULL | 5 | 5 |
| 19 | root | 192.168.1.200:2404 | NULL | Sleep | 0 | | NULL | 0 | 0 |
| 20 | root | 192.168.1.200:2405 | NULL | Sleep | 0 | | NULL | 0 | 0 |
+----+
+
+
+
+
+
+
+
+
+



also this is my.cnf config :

[mysqld]
#port=4949
# Path to Galera library
wsrep_provider=/usr/lib64/libgalera_smm.so
# Cluster connection URL
wsrep_cluster_address=gcomm://192.168.1.149,192.168.1.150
# In order for Galera to work correctly binlog format should be ROW
binlog_format=ROW
# MyISAM storage engine has only experimental support
default_storage_engine=InnoDB
# This changes how |InnoDB| autoincrement locks are managed and is a requirement for Galera
innodb_autoinc_lock_mode=2
wsrep_node_address=192.168.1.149
wsrep_sst_method=rsync
wsrep_cluster_name=aryanic_cluster



what the problem is ? any suggesstion ?

Comments

  • tohidtohid Entrant Current User Role Beginner
    sorry , i found this happen if i connect to percona via mysql query browser or mysql workbench.... any body have this experience like me ?
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.