Not the answer you need?
Register and ask your own question!

Cluster does not execute INSERT and UPDATE, many "wsrep in pre-commit stage"

emakonemakon EntrantInactive User Role Beginner
Hi,

we have a cluster with 3 nodes. Everything worked fine until now. All nodes are up, but they do not execute INSERTs, UPDATEs. SELECTS are executed. How do we get the cluster back to work?

Regards

Martin

Comments

  • emakonemakon Entrant Inactive User Role Beginner
    I did some more investigation. The "SHOW ENGINE INNODB STATUS" shows many locked tables. But still no idea what to do... We can access the servers without any problem.
  • emakonemakon Entrant Inactive User Role Beginner
    I stopped node 3 and restarted it. Now it makes a full SST (why?). This may take a while... A few queries have been executed, but now node 1 and 2 are still stuck.
  • emakonemakon Entrant Inactive User Role Beginner
    One of our programmers created a new table and inserted some data (5 MB). Does this lock the whole cluster??
  • emakonemakon Entrant Inactive User Role Beginner
    Ok, the cluster is still blocked. We have to take it down. What causes the cluster to fail like that?
  • przemekprzemek Percona Support Engineer Percona Staff Role
    What kind of table was that? What is the "show create table tablename\G".
    You need to provide at least the output of
    show status like 'ws%';
    
    and relevant error log parts to help you on that.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.