Not the answer you need?
Register and ask your own question!

innobackupex failed at fil_cur.cc:293

sevmaxsevmax EntrantInactive User Role Participant
Hello,
I have been using innobackupex for a while on a number of databases, but today I faced an issue which I haven't seen before.
During initial backup of 470Gb MySQL database innobackupex fails with the following error:
Assertion "to_read % cursor->page_size == 0" failed at fil_cur.cc:293
Aborted
innobackupex: Error: The xtrabackup child process has died at /usr/bin/innobackupex line 2642.
I tried to make a backup on a local disk, on nfs mount and using nc. I tried to do it in tar.gz, tar and raw files.
Every time it failed somewhere at the end of the backup process, because resulted files are almost the same size as an initial ones.

Ubuntu 12.04 LTS

# uname -a
Linux mysql1 3.5.0-45-generic #68~precise1-Ubuntu SMP Wed Dec 4 16:18:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

# mysql --version
mysql Ver 14.14 Distrib 5.5.35, for debian-linux-gnu (x86_64) using readline 6.2

# innobackupex --version
InnoDB Backup Utility v1.5.1-xtrabackup

# xtrabackup --version
xtrabackup version 2.1.7 for Percona Server 5.1.73 unknown-linux-gnu (x86_64) (revision id: 721)

Appreciate any help there.
Thank you.

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.