Not the answer you need?
Register and ask your own question!

Agents show: Exit: 201

HubertusKrogmannHubertusKrogmann ContributorInactive User Role Contributor
Hello
I installed pt-agent on 2 servers but no data seems to reach "the cloud".
in the agents view Status says Exit 201. what does that mean?

Hubertus

Comments

  • HubertusKrogmannHubertusKrogmann Contributor Inactive User Role Contributor
    I did a
    /usr/bin/pt-agent --stop
    /usr/bin/pt-agent --daemonize
    Now service is OK again, lets see if I get some data.
  • HubertusKrogmannHubertusKrogmann Contributor Inactive User Role Contributor
    No, query analytics says:
    "The agent is running but it has not sent any data yet. This is normal when the agent first starts. If no data is sent after 15 minutes, please request support."
  • HubertusKrogmannHubertusKrogmann Contributor Inactive User Role Contributor
    Solution: copy ~$your_uid_0_user/.pt_agent.conf ~root/
  • kurt_fikurt_fi Entrant Inactive User Role Beginner
    Hi, I'm having the same problem. pt-agent installs fine and is running on the server, but no data is transmitted. On the web ui it shows Exit 201. I'm running MariaDB 5.5.35 on CentOS 6.5. This is the log:


    2014-02-09 23:17:05
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    Exit: 201


    2014-02-09 23:17:05
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    continue-running-if-file-has-data exit status not zero, stopping tasks


    2014-02-09 23:17:05
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    continue-running-if-file-has-data: [ -s 'master-slow.log' ] > /dev/null (runtime: 0.004309 exit: 1)


    2014-02-09 23:17:05
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    store-file-contents: cat '/var/lib/pt-agent/meta/rotate-slow-query-log-all-5.1.meta.slow_query_log_file' > /var/spool/pt-agent/.tmp/1391980621.query-history-all-5.1.output.5 (runtime: 0.007304 exit: 0)


    2014-02-09 23:17:05
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    run-service: '/usr/bin//pt-agent' --run-service rotate-slow-query-log-all-5.1 > /dev/null (runtime: 2.248339 exit: 200)


    2014-02-09 23:17:03
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    empty-trash: [ -f '/var/spool/pt-agent/.trash/old-slow-query-logs' ] && xargs rm -f < '/var/spool/pt-agent/.trash/old-slow-query-logs' && rm -f '/var/spool/pt-agent/.trash/old-slow-query-logs' || true > /dev/null (runtime: 0.005151 exit: 0)


    2014-02-09 23:17:03
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    move-file-if-file-exists: [ -f '/var/lib/pt-agent/meta/query-history-all-5.1.meta.end_offset' ] && mv '/var/lib/pt-agent/meta/query-history-all-5.1.meta.end_offset' '/var/lib/pt-agent/meta/query-history-all-5.1.meta.start_offset' || true > /dev/null (runtime: 0.004432 exit: 0)


    2014-02-09 23:17:02
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    save-utc-timestamp: TZ='UTC' date +'%Y-%m-%dT%H:%M:00' > /var/lib/pt-agent/meta/query-history-all-5.1.meta.end_ts (runtime: 0.006376 exit: 0)


    2014-02-09 23:17:02
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    move-file-if-file-exists: [ -f '/var/lib/pt-agent/meta/query-history-all-5.1.meta.end_ts' ] && mv '/var/lib/pt-agent/meta/query-history-all-5.1.meta.end_ts' '/var/lib/pt-agent/meta/query-history-all-5.1.meta.start_ts' || true > /dev/null (runtime: 0.007923 exit: 0)


    2014-02-09 23:17:01
    2014-02-09 23:17:05
    Info
    4277
    query-history-all-5.1 run
    Running query-history-all-5.1

  • kurt_fikurt_fi Entrant Inactive User Role Beginner
    Help would be appreciated for my problem. The solution provided by HubertusKrogmann doesn't make sense for me since my root's uid is 0 and the file is located in root's home directory.
  • exulaexula Entrant Current User Role Beginner
    I'm having the exact same problems.

    Is there a way to turn on debugging on the agent?
  • MattMatt Entrant Inactive User Role Beginner
    On my second server I have exact same issue (Exit: 201 on continue-running-if-file-has-data exit status not zero, stopping tasks)
  • jriverajrivera Percona Support Engineer Percona Staff Role
    @exula - try adding PTDEBUG=1 infront of the command to enable debugging. http://www.percona.com/doc/percona-toolkit/2.2/pt-agent.html#environment

    pt-agent --install preferrably should be run as root (sudo -i), also make sure that .pt-agent.conf is inside /root/ directory.
  • kurt_fikurt_fi Entrant Inactive User Role Beginner
    When running with PTDEBUG=1, I'm finding lots of this in the log:
    Percona::Agent::Logger:4972 20712 Read error: read timeout at /usr/bin/pt-agent line 4959, <STDIN> line 24.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.