Not the answer you need?
Register and ask your own question!

Unable to start MySQL...help, pls

Paul_PPaul_P EntrantInactive User Role Beginner
Hello, I have MySQL 5.5.27, Source Distribution (which i inherited), running on CentOS 6.3. I ran into corruption on my federated DB, specifically on one of the partitioned tables. I am in a situation now where MySQL is looping with assertion failures because I renamed the corrupted partition.....and MySQL never starts. I have tried the innodb_force_recovery options..but none seem to make a difference as MySQL still just loops and wont start. I have plenty of good backups...but cant apply them. Any ideas of what i should try next? thank you.

Comments

  • niljoshiniljoshi MySQL Sage Inactive User Role Beginner
    Hi,

    Is it possible for you to provide full error.log ? If you have complete backup then why don't you move old data dir, started with new and restore backup?
  • ashokkumar2003ashokkumar2003 Contributor Inactive User Role Beginner
    Please let us know your mysql error logs / error messages which are you getting during the mysql service and also you can restore complete backup and single table backup. Also check the folder permission.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.