Not the answer you need?
Register and ask your own question!

server quit without updating PID file

mohammad6006mohammad6006 EntrantCurrent User Role Beginner
i save this configuration for my.cnf :
[mysql]

# CLIENT #
port                           = 3306
socket                         = /var/lib/mysql/mysql.sock

[mysqld]

# GENERAL #
user                           = mysql
default-storage-engine         = InnoDB
socket                         = /var/lib/mysql/mysql.sock
pid-file                       = /var/lib/mysql/server.pid

# MyISAM #
key-buffer-size                = 33554432
myisam-recover                 = FORCE,BACKUP

# SAFETY #
max-allowed-packet             = 16777216
max-connect-errors             = 1000000
skip-name-resolve
sql-mode                       = STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_AUTO_VALUE_ON_ZERO,NO_ENGINE_SUBSTITUTION,NO_ZERO_DATE,NO_ZERO_IN_DATE,ONLY_FULL_GROUP_BY
sysdate-is-now                 = 1
innodb                         = FORCE
innodb-strict-mode             = 1

# DATA STORAGE #
datadir                        = /var/lib/mysql

# BINARY LOGGING #
log-bin                        = /var/lib/mysql/mysql-bin
expire-logs-days               = 14
sync-binlog                    = 1

# CACHES AND LIMITS #
tmp-table-size                 = 32M
max-heap-table-size            = 32M
query-cache-type               = 0
query-cache-size               = 0
max-connections                = 500
thread-cache-size              = 50
open-files-limit               = 65535
table-definition-cache         = 4096
table-open-cache               = 5000

# INNODB #
innodb-flush-method            = O_DIRECT
innodb-log-files-in-group      = 2
innodb-log-file-size           = 256M
innodb-flush-log-at-trx-commit = 1
innodb-file-per-table          = 1
innodb-buffer-pool-size        = 12G

# LOGGING #
log-error                      = /var/lib/mysql/server-error.log
log-queries-not-using-indexes  = 1
slow-query-log                 = 1
slow-query-log-file            = /var/lib/mysql/server-slow.log
but after restart mysql
server.pid deleted and ERROR! The server quit without updating PID file (/var/lib/mysql/server.pid).


what can i do?


i disable SELinux and reboot but not solve

default settings:

mysql> show variables like 'innodb_log_file_size';
+
+
+
| Variable_name | Value |
+
+
+
| innodb_log_file_size | 5242880 |
+
+
+
1 row in set (0.00 sec)


mysql> show variables like 'datadir';
+
+
+
| Variable_name | Value |
+
+
+
| datadir | /var/lib/mysql/ |
+
+
+
1 row in set (0.00 sec)

mysql> show variables like 'innodb_data%';
+
+
+
| Variable_name | Value |
+
+
+
| innodb_data_file_path | ibdata1:10M:autoextend |
| innodb_data_home_dir | |
+
+
+
2 rows in set (0.00 sec)

Comments

  • mirfanmirfan Database Administrator Inactive User Role Beginner
    Did you checked mysql error log ? It will provide more details what causing it. Can you please show relevant error log entries for that from /var/lib/mysql/server-error.log file.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.