Not the answer you need?
Register and ask your own question!

Percona 5.5.32 mysql pam plugin bug?

KlavsKKlavsK EntrantCurrent User Role Beginner
Hi, I have installed Percona rpms on a CentOS6 server:
Percona-Server-client-55-5.5.32-rel31.0.549.rhel6.x86_64
Percona-Server-shared-compat-5.5.32-rel31.0.549.rhel6.x86_64
Percona-Server-shared-55-5.5.32-rel31.0.549.rhel6.x86_64
Percona-Server-server-55-5.5.32-rel31.0.549.rhel6.x86_64

But when I try to enable the auth_pam plugin:
mysql> INSTALL PLUGIN auth_pam_server SONAME 'auth_pam.so';
ERROR 1127 (HY000): Can't find symbol 'auth_pam_server' in library

Everything looks fine:
mysql> show variables like '%plugin%';
+
+
+
| Variable_name | Value |
+
+
+
| plugin_dir | /usr/lib64/mysql/plugin/ |
+
+
+
1 row in set (0.00 sec)

mysql> exit
Bye
[[email protected] ~]# ls /usr/lib64/mysql/plugin/auth_pam.so -l
-rwxr-xr-x. 1 root root 13136 Jul 1 05:26 /usr/lib64/mysql/plugin/auth_pam.so



I found one(!) hit on google: http://www.percona.com/forums/questions-discussions/mysql-and-percona-server/7233-pam-plugin-not-working
But since I haven't compiled this plugin myself (Percona has) - I find it odd, that it should have been compiled wrongly.. ?

Comments

  • KlavsKKlavsK Entrant Current User Role Beginner
    Just tried updating to 5.5.33 from Percona. Same problem :(
  • KlavsKKlavsK Entrant Current User Role Beginner
    I just tried compiling from bzr - it fails with the exact same message :(
    mysql> install plugin auth_pam_server soname 'auth_pam.so';
    ERROR 1127 (HY000): Can't find symbol 'auth_pam_server' in library
  • przemekprzemek Percona Support Engineer Percona Staff Role
    Hi,

    OK, so this is undocumented change in how you install the plugin. I have filled a new bug to correct this in manual page:
    https://bugs.launchpad.net/percona-server/+bug/1229132

    So, basically, use this command:
    INSTALL PLUGIN auth_pam SONAME 'auth_pam.so';
    
  • KlavsKKlavsK Entrant Current User Role Beginner
    thank you - that helped :)

    I obviously should have tried a few variants :)
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.