Not the answer you need?
Register and ask your own question!

pt-table-checksum 'skipping table .. too many rows' with stock params

mrubinmrubin EntrantInactive User Role Beginner
Hello,

I'm receiving the below error:

07-20T02:00:08 Skipping table dropbox.ProcessBootUps because on the master it would be checksummed in one chunk but on these replicas it has too many rows:
46198 rows on ......
The current chunk size limit is 31014 rows (chunk size=15507 * chunk size limit=2.0).

With the following command-line:

pt-table-checksum --replicate=dropbox.checksums --nocheck-replication-filters --databases=dropbox --defaults-file=/root/.my.cnf

I've seen online that this error may result from messing with chunk params (e.g. setting chunk size equal to 0?), but I am not doing that. I have other tables with ~150 million rows and those seem to get processed fine.

I tried to poke around the source code a bit.. it looks like "$o->get('explain')" didn't return true and in the else, "$nibble_iter->one_nibble()" returned true. I'm guessing that one_nibble() returns true if the table should be processed in one go... but why would that return true here if the table is too big?

Thanks for any advice.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.