Not the answer you need?
Register and ask your own question!

Show engine innodb status output empty

sprwl_0827sprwl_0827 ContributorCurrent User Role Beginner
Hi there ,



On DB2 master I'm seeing this very weird problem show engine innodb status command output is totally empty .On other two servers this command is working fine.


on DB2 - No errors in error.log ,mysql version (PS 5.5.28) is same as others db server, db permissions correct , other commands are working fine . Not sure if this problem started after pod move or it was always present since Pod sjh build.



Have anyone seen such problem before ,can yoy please share yr experiences and what's the cause and fix of this issue.



mysql> show engine innodb status\G;

*************************** 1. row ***************************

Type: InnoDB

Name:

Status:

1 row in set (0.00 sec)



ERROR:

No query specified





Please share yr thoughts .

Comments

  • przemekprzemek Percona Support Engineer Percona Staff Role
    Are you sure your mysql client has no custom pager set before you execute the command? Try "nopager" command before you run "show engine innodb status\G"
    Also do the other InnoDB status variables work well? Like can you see the output of this:
    show global status like 'innodb%';
    
  • sprwl_0827sprwl_0827 Contributor Current User Role Beginner
    Thanks Pzemek for replying. With restarting of mysql issue was gone .But there was no "nopager" setting on and all other outputs were working well . I still wonder what was stopping innodb to print innodb status.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.