# Uncategorized

**URL:** https://forums.percona.com/c/uncategorized/1.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [Cluster remains in Primary state after 2 of 4 nodes are stopped](https://forums.percona.com/t/cluster-remains-in-primary-state-after-2-of-4-nodes-are-stopped/39405)

<div class="topic-metadata">

**Author:** [@SQLCaesar](https://forums.percona.com/u/SQLCaesar)\
**Replies:** 6\
**Last updated:** [September 24, 2025, 6:28pm UTC](https://forums.percona.com/t/cluster-remains-in-primary-state-after-2-of-4-nodes-are-stopped/39405 "2025-09-24T18:28:07Z")

</div>

Hi there, I am running a Percona XtraDB Cluster with 4 nodes in my lab environment. After stopping 2 nodes, I still see that the cluster status is reported as Primary. My expectation was that with only 2 nodes left (a…

---

## [Unable to bootstrap Percona XtraDB cluster](https://forums.percona.com/t/unable-to-bootstrap-percona-xtradb-cluster/39444)

<div class="topic-metadata">

**Author:** [@Krishnareddy](https://forums.percona.com/u/Krishnareddy)\
**Replies:** 2\
**Last updated:** [September 23, 2025, 11:25am UTC](https://forums.percona.com/t/unable-to-bootstrap-percona-xtradb-cluster/39444 "2025-09-23T11:25:32Z")

</div>

Hi, I have configured below details in my.cnf of first node, But while bootstrap It’s not coming up.

---

## [Pmm-server upgrade from 2.33 to version 3](https://forums.percona.com/t/pmm-server-upgrade-from-2-33-to-version-3/39432)

<div class="topic-metadata">

**Author:** [@ulka01](https://forums.percona.com/u/ulka01)\
**Replies:** 7\
**Last updated:** [September 23, 2025, 5:43am UTC](https://forums.percona.com/t/pmm-server-upgrade-from-2-33-to-version-3/39432 "2025-09-23T05:43:25Z")

</div>

Hi, I tried to upgrade pmm-server from version 2.33 to version 3 , but it failed. docker ps -a shows this CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS …

---

## [Percona Platform Access Token - Validation issue](https://forums.percona.com/t/percona-platform-access-token-validation-issue/39284)

<div class="topic-metadata">

**Author:** [@tharakesh.kandregula](https://forums.percona.com/u/tharakesh.kandregula)\
**Replies:** 1\
**Last updated:** [September 9, 2025, 8:27am UTC](https://forums.percona.com/t/percona-platform-access-token-validation-issue/39284 "2025-09-09T08:27:34Z")

</div>

hi, after past token and click on validation, I am getting Internal Server error. any idea, what could be wrong?

---

## [Timeout error while Taking PBM Backup](https://forums.percona.com/t/timeout-error-while-taking-pbm-backup/39181)

<div class="topic-metadata">

**Author:** [@sumitkumar.gupta](https://forums.percona.com/u/sumitkumar.gupta)\
**Replies:** 4\
**Last updated:** [August 26, 2025, 10:42am UTC](https://forums.percona.com/t/timeout-error-while-taking-pbm-backup/39181 "2025-08-26T10:42:13Z")

</div>

Hi Team, We have recently upgrade PBM to 2.9.1 version but looks like ‘backup.timeouts.startingStatus“ doesn’t support anymore. \[root@ANVGAPDSIPMA02 yamlFiles\]# pbm config --list pitr: enabled: false oplogSpanMin: 1…

---

## [PGQL patroni cluster](https://forums.percona.com/t/pgql-patroni-cluster/38955)

<div class="topic-metadata">

**Author:** [@Sdash](https://forums.percona.com/u/Sdash)\
**Replies:** 3\
**Last updated:** [August 5, 2025, 5:41pm UTC](https://forums.percona.com/t/pgql-patroni-cluster/38955 "2025-08-05T17:41:34Z")

</div>

Hello, I have 2 DC, In which we have 2 PGSQL server with 3 etcd Node in each DC. Is it recommended to have 3 etcd for each DC? What are pros and cons ? How Replication will happen with above scenario ? Looking for ex…

---

## [Questions on step by step guide to perform keyring plugin to keyring components](https://forums.percona.com/t/questions-on-step-by-step-guide-to-perform-keyring-plugin-to-keyring-components/38876)

<div class="topic-metadata">

**Author:** [@Charly\_Wu](https://forums.percona.com/u/Charly_Wu)\
**Replies:** 1\
**Last updated:** [July 29, 2025, 1:51pm UTC](https://forums.percona.com/t/questions-on-step-by-step-guide-to-perform-keyring-plugin-to-keyring-components/38876 "2025-07-29T13:51:11Z")

</div>

Is there any guide on detailed steps on how to perform the keyring plugin to keyring component migration?, e.g. on offline migration: do we need to stop mysql server first? do we need to create keyring component files …

---

## [Add new images registrt](https://forums.percona.com/t/add-new-images-registrt/38710)

<div class="topic-metadata">

**Author:** [@mohamed](https://forums.percona.com/u/mohamed)\
**Replies:** 1\
**Last updated:** [July 18, 2025, 12:48pm UTC](https://forums.percona.com/t/add-new-images-registrt/38710 "2025-07-18T12:48:33Z")

</div>

i have installed percona everest with helm chart now i am trying to install postgressql db i need to specify custom registry to pull custom images for postgres is that avaialble

---

## [Postgis restore issue in percona](https://forums.percona.com/t/postgis-restore-issue-in-percona/38700)

<div class="topic-metadata">

**Author:** [@mohamed](https://forums.percona.com/u/mohamed)\
**Replies:** 2\
**Last updated:** [July 16, 2025, 5:32pm UTC](https://forums.percona.com/t/postgis-restore-issue-in-percona/38700 "2025-07-16T17:32:50Z")

</div>

i have a database postgis , now i have taken dump from it to restore on percona postgres db but i face issue in extensions of postgis on percona i tried to install the extensions manually i failed is there solution can…

---

## [Unable to log-in with admin/non-Google user when autologin is activated in Google Auth settings](https://forums.percona.com/t/unable-to-log-in-with-admin-non-google-user-when-autologin-is-activated-in-google-auth-settings/38673)

<div class="topic-metadata">

**Author:** [@Frederic\_Gauthier-Bo](https://forums.percona.com/u/Frederic_Gauthier-Bo)\
**Replies:** 1\
**Last updated:** [July 14, 2025, 3:36pm UTC](https://forums.percona.com/t/unable-to-log-in-with-admin-non-google-user-when-autologin-is-activated-in-google-auth-settings/38673 "2025-07-14T15:36:54Z")

</div>

Hi there, Here is the context: following the least privilege principle, we have a dedicated admin user account that we use to manage PMM and we have normal user accounts on the side that we use in our day to day working…

---

## [Unable to add 3rd node to percona mysql cluster 8.0.26](https://forums.percona.com/t/unable-to-add-3rd-node-to-percona-mysql-cluster-8-0-26/38658)

<div class="topic-metadata">

**Author:** [@ulka01](https://forums.percona.com/u/ulka01)\
**Replies:** 3\
**Last updated:** [July 14, 2025, 2:23am UTC](https://forums.percona.com/t/unable-to-add-3rd-node-to-percona-mysql-cluster-8-0-26/38658 "2025-07-14T02:23:37Z")

</div>

Hi, I am unable to add 3rd node to percona galera cluster. The version is 8.0.26. We are getting errors as below: Logs on joiner node: 2025-07-13T10:33:45.229167Z 0 \[ERROR\] \[MY-000000\] \[WSREP-SST\] Killing SST (13760…

---

## [Percona mysql ldap authenticaion got failed](https://forums.percona.com/t/percona-mysql-ldap-authenticaion-got-failed/30493)

<div class="topic-metadata">

**Author:** [@Manilal\_Ramanujan](https://forums.percona.com/u/Manilal_Ramanujan)\
**Replies:** 1\
**Last updated:** [July 10, 2025, 7:51am UTC](https://forums.percona.com/t/percona-mysql-ldap-authenticaion-got-failed/30493 "2025-07-10T07:51:38Z")

</div>

CREATE USER ‘manilal\_cfn’@‘localhost’ IDENTIFIED WITH authentication\_ldap\_simple BY ‘uid=manilal\_cfn,dc=idm,dc=genasys,dc=sandbox’; The Percona MySQL Docker container has been successfully set up. However, I would like …

---

## [Question on deployment/syncing operators via Argo CD](https://forums.percona.com/t/question-on-deployment-syncing-operators-via-argo-cd/38507)

<div class="topic-metadata">

**Author:** [@jbolin](https://forums.percona.com/u/jbolin)\
**Replies:** 0\
**Last updated:** [June 30, 2025, 5:29pm UTC](https://forums.percona.com/t/question-on-deployment-syncing-operators-via-argo-cd/38507 "2025-06-30T17:29:48Z")

</div>

When deploying operators (particularly PCX and PostgreSQL) are the CRDs installed as part of the initial deployment and do the new CRDs have to be applied when syncing a new version of the operators? I don’t see a refer…

---

## [MySQL Shell Backup - Dump Instance / Dump Schema without Pausing Group Replication](https://forums.percona.com/t/mysql-shell-backup-dump-instance-dump-schema-without-pausing-group-replication/38489)

<div class="topic-metadata">

**Author:** [@jojojthomas](https://forums.percona.com/u/jojojthomas)\
**Replies:** 3\
**Last updated:** [June 30, 2025, 3:19pm UTC](https://forums.percona.com/t/mysql-shell-backup-dump-instance-dump-schema-without-pausing-group-replication/38489 "2025-06-30T15:19:27Z")

</div>

Hope everyone is doing well. We have a ~6.5 TB MySQL InnoDB Cluster (3 nodes - single primary topology) on version 8.0.36 (Percona Server (GPL)). The MySQL Shell backup currently acquires a lock and consequently causes r…

---

## [Question about PBM Agent Deployment for 3-Node MongoDB Replica Set](https://forums.percona.com/t/question-about-pbm-agent-deployment-for-3-node-mongodb-replica-set/38490)

<div class="topic-metadata">

**Author:** [@Shahid\_Aman](https://forums.percona.com/u/Shahid_Aman)\
**Replies:** 1\
**Last updated:** [June 30, 2025, 11:13am UTC](https://forums.percona.com/t/question-about-pbm-agent-deployment-for-3-node-mongodb-replica-set/38490 "2025-06-30T11:13:34Z")

</div>

Hi all, I have set up a MongoDB cluster with 3 nodes, configured as a single replica set (1 replica set, 3 nodes: 1 primary and 2 secondaries). I am planning to use Percona Backup for MongoDB (PBM) for backup management…

---

## [Disaster recovery for mysql database](https://forums.percona.com/t/disaster-recovery-for-mysql-database/38286)

<div class="topic-metadata">

**Author:** [@Aditya1523](https://forums.percona.com/u/Aditya1523)\
**Replies:** 2\
**Last updated:** [June 30, 2025, 5:54am UTC](https://forums.percona.com/t/disaster-recovery-for-mysql-database/38286 "2025-06-30T05:54:02Z")

</div>

Hello Percona Support, I’m running the Percona Operator with a Percona XtraDB Cluster (image: percona/percona-xtradb-cluster:8.0.31-23.2) on Kubernetes. I’ve configured: storages: ostore: type: s3 verifyTLS: …

---

## [Debian 12 AMD/Intel needed apt for Mongo 4.2](https://forums.percona.com/t/debian-12-amd-intel-needed-apt-for-mongo-4-2/38161)

<div class="topic-metadata">

**Author:** [@jbiancot](https://forums.percona.com/u/jbiancot)\
**Replies:** 3\
**Last updated:** [June 11, 2025, 12:40pm UTC](https://forums.percona.com/t/debian-12-amd-intel-needed-apt-for-mongo-4-2/38161 "2025-06-11T12:40:01Z")

</div>

Greetings programs, I have been taking care of upgrading some VMs from Debian 11 to Debian 12, on some VMs we have Mongo 4.0 because a old software which is depends of it: Learning Locker aka “LRS”. I am unable to find…

---

## [Starting up a node slows everybody down till it's done syncing](https://forums.percona.com/t/starting-up-a-node-slows-everybody-down-till-its-done-syncing/38238)

<div class="topic-metadata">

**Author:** [@alexl9](https://forums.percona.com/u/alexl9)\
**Replies:** 1\
**Last updated:** [June 8, 2025, 2:55pm UTC](https://forums.percona.com/t/starting-up-a-node-slows-everybody-down-till-its-done-syncing/38238 "2025-06-08T14:55:56Z")

</div>

is it normal when starting a node for it to slow down the cluster? It takes about 30 min for startup to complete after which the cluster responsiveness returns to normal.

---

## [Resolving excessive binlog growth on mysql 8.4 xtradb cluster](https://forums.percona.com/t/resolving-excessive-binlog-growth-on-mysql-8-4-xtradb-cluster/38080)

<div class="topic-metadata">

**Author:** [@jtlarson](https://forums.percona.com/u/jtlarson)\
**Replies:** 1\
**Last updated:** [May 26, 2025, 1:26pm UTC](https://forums.percona.com/t/resolving-excessive-binlog-growth-on-mysql-8-4-xtradb-cluster/38080 "2025-05-26T13:26:36Z")

</div>

TL;DR: Are binlogs required on mysql 8.4 xtradb cluster? And if so, what are my options for limiting excessive binlog growth without risking the cluster health? What are the impacts of disabling them? I have a 3-node my…

---

## [Cannot Upgrade PXC Image Tag Using SmartUpdate Strategy and upgradeOptions](https://forums.percona.com/t/cannot-upgrade-pxc-image-tag-using-smartupdate-strategy-and-upgradeoptions/38087)

<div class="topic-metadata">

**Author:** [@coderick](https://forums.percona.com/u/coderick)\
**Replies:** 0\
**Last updated:** [May 26, 2025, 5:02am UTC](https://forums.percona.com/t/cannot-upgrade-pxc-image-tag-using-smartupdate-strategy-and-upgradeoptions/38087 "2025-05-26T05:02:09Z")

</div>

I’m attempting to upgrade the Percona XtraDB Cluster (PXC) image tag using the SmartUpdate strategy in the updateStrategy field, along with some options under upgradeOptions, but the upgrade does not proceed as expected.…

---

## [Audit log filter not working after upgrade from Percona 8.0.41 to 8.4.4](https://forums.percona.com/t/audit-log-filter-not-working-after-upgrade-from-percona-8-0-41-to-8-4-4/37992)

<div class="topic-metadata">

**Author:** [@redssr](https://forums.percona.com/u/redssr)\
**Replies:** 1\
**Last updated:** [May 22, 2025, 4:38pm UTC](https://forums.percona.com/t/audit-log-filter-not-working-after-upgrade-from-percona-8-0-41-to-8-4-4/37992 "2025-05-22T16:38:46Z")

</div>

Dear friends, Thanks again for solving my previous issue on How to skip select or all read operation in audit\_log\_filter in percona 8.4 - #5 by redssr thread Now i am in different issue, While upgrading from Percona 8.…

---

## [Percona xtradb cluster 1.13 readiness probe failure in kubernetes with kubeadm](https://forums.percona.com/t/percona-xtradb-cluster-1-13-readiness-probe-failure-in-kubernetes-with-kubeadm/38055)

<div class="topic-metadata">

**Author:** [@dongzhang263](https://forums.percona.com/u/dongzhang263)\
**Replies:** 0\
**Last updated:** [May 22, 2025, 7:29am UTC](https://forums.percona.com/t/percona-xtradb-cluster-1-13-readiness-probe-failure-in-kubernetes-with-kubeadm/38055 "2025-05-22T07:29:12Z")

</div>

kubectl get pods -n infra -owide NAME READY STATUS RESTARTS AGE IP NODE NOMINATED NODE READINESS GATES cluster1-haproxy-0 …

---

## [Synchronous replication - PostgreSQL 17](https://forums.percona.com/t/synchronous-replication-postgresql-17/37942)

<div class="topic-metadata">

**Author:** [@Umashankar\_Balasubra](https://forums.percona.com/u/Umashankar_Balasubra)\
**Replies:** 1\
**Last updated:** [May 14, 2025, 3:13pm UTC](https://forums.percona.com/t/synchronous-replication-postgresql-17/37942 "2025-05-14T15:13:03Z")

</div>

In synchronous replication, if Primary (pgnode1) goes down, then pgnode 2 (standby) becomes primary and write operations are hung in pgnode2 with below error DETAIL: The transaction has already committed locally, but mig…

---

## [How to create pmm-client in docker container to monitor MySQL database (in seperate a container)](https://forums.percona.com/t/how-to-create-pmm-client-in-docker-container-to-monitor-mysql-database-in-seperate-a-container/37802)

<div class="topic-metadata">

**Author:** [@sh123](https://forums.percona.com/u/sh123)\
**Replies:** 10\
**Last updated:** [May 13, 2025, 11:03pm UTC](https://forums.percona.com/t/how-to-create-pmm-client-in-docker-container-to-monitor-mysql-database-in-seperate-a-container/37802 "2025-05-13T23:03:17Z")

</div>

I was following these instructions here to setup pmm-client in a container: Set up PMM Client - Percona Monitoring and Management I’m running version 2.3.5, but I’m then struggling to get the pmm-agent to add MySQL mon…

---

## [ProxySQL added to "PPM Inventory" but the status remain N/A](https://forums.percona.com/t/proxysql-added-to-ppm-inventory-but-the-status-remain-n-a/37612)

<div class="topic-metadata">

**Author:** [@Harutyun\_Grigoryan](https://forums.percona.com/u/Harutyun_Grigoryan)\
**Replies:** 5\
**Last updated:** [April 29, 2025, 12:53pm UTC](https://forums.percona.com/t/proxysql-added-to-ppm-inventory-but-the-status-remain-n-a/37612 "2025-04-29T12:53:59Z")

</div>

I’ve added a ProxySQL Service to the PMM Inventory by running pmm-admin add proxysql --username=radmin --password=radmin --host=172.30.18.212 --port=6032 --service-name=proxysql-service --debug on the ProxySQ…

---

## [Change location of Percona XtraDB](https://forums.percona.com/t/change-location-of-percona-xtradb/37723)

<div class="topic-metadata">

**Author:** [@mikejhathaway](https://forums.percona.com/u/mikejhathaway)\
**Replies:** 2\
**Last updated:** [April 25, 2025, 6:26pm UTC](https://forums.percona.com/t/change-location-of-percona-xtradb/37723 "2025-04-25T18:26:27Z")

</div>

Hi Folks, After changing the location of my Percona XtraDB data files I am seeing this error: \[Server\] Plugin mysqlx reported: ‘Setup of socket: ‘/var/lib/mysql/mysqlx.sock’ failed, can’t create lock file /var/lib/mysq…

---

## [Data at rest encryption mongoDb percona Server 8.0](https://forums.percona.com/t/data-at-rest-encryption-mongodb-percona-server-8-0/37722)

<div class="topic-metadata">

**Author:** [@Pramod\_Kumar\_Gupta](https://forums.percona.com/u/Pramod_Kumar_Gupta)\
**Replies:** 1\
**Last updated:** [April 25, 2025, 6:25am UTC](https://forums.percona.com/t/data-at-rest-encryption-mongodb-percona-server-8-0/37722 "2025-04-25T06:25:59Z")

</div>

how to enable data at rest encryption in percona mongodb 8.0 and how to give root user and admin password in docker-compose

---

## [Unable to register pmm-agent on pmm server](https://forums.percona.com/t/unable-to-register-pmm-agent-on-pmm-server/37706)

<div class="topic-metadata">

**Author:** [@sadi](https://forums.percona.com/u/sadi)\
**Replies:** 7\
**Last updated:** [April 24, 2025, 11:07am UTC](https://forums.percona.com/t/unable-to-register-pmm-agent-on-pmm-server/37706 "2025-04-24T11:07:28Z")

</div>

Hi team, i have installed pmm3-server and pmm3-client on 2 machines. I am reciving following error while registering pmm-agent on pmm server using command: pmm-admin config --server-insecure-tls --server-url=https://ad…

---

## [Run Pmm on VM WITHROUT DOCKER](https://forums.percona.com/t/run-pmm-on-vm-withrout-docker/37673)

<div class="topic-metadata">

**Author:** [@nekki\_r.kamalov](https://forums.percona.com/u/nekki_r.kamalov)\
**Replies:** 3\
**Last updated:** [April 21, 2025, 11:33am UTC](https://forums.percona.com/t/run-pmm-on-vm-withrout-docker/37673 "2025-04-21T11:33:08Z")

</div>

Hi! I’ve checked this manual Install PMM Server with Docker container - Percona Monitoring and Management All the option includes Docker. I want to install Pmm-server on VM directly. Without any container mechanisms. …

---

## [Add custom lines into vmagent under pmm-agent](https://forums.percona.com/t/add-custom-lines-into-vmagent-under-pmm-agent/37577)

<div class="topic-metadata">

**Author:** [@nekki\_r.kamalov](https://forums.percona.com/u/nekki_r.kamalov)\
**Replies:** 7\
**Last updated:** [April 16, 2025, 8:19am UTC](https://forums.percona.com/t/add-custom-lines-into-vmagent-under-pmm-agent/37577 "2025-04-16T08:19:45Z")

</div>

We have pmm-agent and standalone vmagent on same host pmm has autogenerated configuration file /usr/local/percona/pmm/tmp/agent\_type\_vm\_agent/b6a9f90d-3c40-4459-9a1a-2ab99e9d3a40/vmagentscrapecfg I’ve tried to add this…

[Previous page](https://forums.percona.com/c/uncategorized/1.md?page=1)

[Next page](https://forums.percona.com/c/uncategorized/1.md?page=3)
