# Percona Operator for PostgreSQL

**URL:** https://forums.percona.com/c/postgresql/percona-kubernetes-operator-for-postgresql/68.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Percona Operator for PostgreSQL category](https://forums.percona.com/t/about-the-percona-operator-for-postgresql-category/10411)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0

</div>

Have questions about Percona Operator for PostgreSQL? Ask them in this topic and discuss with the community and Percona experts! The Percona Operator for PostgreSQL is based on best practices for configuration and setup…

---

## [Openshift - operator upgrade - OLM wants to upgrade 2.9.0 straight to 3.1.0](https://forums.percona.com/t/openshift-operator-upgrade-olm-wants-to-upgrade-2-9-0-straight-to-3-1-0/41289)

<div class="topic-metadata">

**Author:** [@eprevost](https://forums.percona.com/u/eprevost)\
**Replies:** 2\
**Last updated:** [September 23, 2026, 10:11pm UTC](https://forums.percona.com/t/openshift-operator-upgrade-olm-wants-to-upgrade-2-9-0-straight-to-3-1-0/41289 "2026-09-23T22:11:27Z")

</div>

Hi, I have Percona Operator for Postgresql certified version 2.9.0-cw installed on an Openshift cluster. According to documentation, we have to go through all minor versions, so to upgrade from 2.9.0 to 3.1.0, 3.0.0 mu…

---

## [PG Operator 3.0.0+ compatibility with certified pgBackRest images](https://forums.percona.com/t/pg-operator-3-0-0-compatibility-with-certified-pgbackrest-images/41259)

<div class="topic-metadata">

**Author:** [@a.veselov.s](https://forums.percona.com/u/a.veselov.s)\
**Replies:** 2\
**Last updated:** [September 10, 2026, 6:33pm UTC](https://forums.percona.com/t/pg-operator-3-0-0-compatibility-with-certified-pgbackrest-images/41259 "2026-09-10T18:33:09Z")

</div>

Description: The percona/percona-pgbackrest:2.58.0-2 image is mentioned in the Percona certified images documentation for the operator v3.0.0. Unfortunately, using this image is blocked by a fatal mismatch between the p…

---

## [Timescaledb support](https://forums.percona.com/t/timescaledb-support/31490)

<div class="topic-metadata">

**Author:** [@martin.schack](https://forums.percona.com/u/martin.schack)\
**Replies:** 4\
**Last updated:** [September 9, 2026, 3:38pm UTC](https://forums.percona.com/t/timescaledb-support/31490 "2026-09-09T15:38:47Z")

</div>

Description: I’ve been asked by different colleagues if I can provide the “timescaledb” extension for them. Seems like this is a very popular extension. Do you have any plans to integrate this for upcoming releases? D…

---

## [Open-Source Kubernetes Version Support](https://forums.percona.com/t/open-source-kubernetes-version-support/41069)

<div class="topic-metadata">

**Author:** [@Srinivas](https://forums.percona.com/u/Srinivas)\
**Replies:** 3\
**Last updated:** [July 16, 2026, 12:37pm UTC](https://forums.percona.com/t/open-source-kubernetes-version-support/41069 "2026-07-16T12:37:11Z")

</div>

Description: What is the Open-Source Kubernetes version supported for Percona Operator 2.8.2 version Steps to Reproduce: This is information request to know the supported Kubernetes version for Percona Postgres operator…

---

## [Patroni replication behaves the same regardless of the value set for synchronous\_mode\_strict](https://forums.percona.com/t/patroni-replication-behaves-the-same-regardless-of-the-value-set-for-synchronous-mode-strict/40856)

<div class="topic-metadata">

**Author:** [@Srinivas](https://forums.percona.com/u/Srinivas)\
**Replies:** 1\
**Last updated:** [June 23, 2026, 5:38am UTC](https://forums.percona.com/t/patroni-replication-behaves-the-same-regardless-of-the-value-set-for-synchronous-mode-strict/40856 "2026-06-23T05:38:41Z")

</div>

Percona Operator Version: 2.8.2 Postgres Version: 16 We have defined the below parameters related to Patroni replication. It is expected that writes will continue when the parameter synchronous\_mode\_strict set to false…

---

## [High memory usage of PostgreSQL leader pod](https://forums.percona.com/t/high-memory-usage-of-postgresql-leader-pod/40727)

<div class="topic-metadata">

**Author:** [@an-toine](https://forums.percona.com/u/an-toine)\
**Replies:** 11\
**Last updated:** [May 21, 2026, 7:16am UTC](https://forums.percona.com/t/high-memory-usage-of-postgresql-leader-pod/40727 "2026-05-21T07:16:38Z")

</div>

Description: Hello ! We are using the Percona PostgreSQL operator to instanciate databases in a Kubernetes cluster. Lately, we have received alerts about the leader pod being evicted because of memory pressure on a nod…

---

## [The former primary pod did not start as a replica during few scenarios](https://forums.percona.com/t/the-former-primary-pod-did-not-start-as-a-replica-during-few-scenarios/40819)

<div class="topic-metadata">

**Author:** [@Srinivas](https://forums.percona.com/u/Srinivas)\
**Replies:** 0\
**Last updated:** [May 20, 2026, 7:37am UTC](https://forums.percona.com/t/the-former-primary-pod-did-not-start-as-a-replica-during-few-scenarios/40819 "2026-05-20T07:37:24Z")

</div>

The former primary pod did not start as a replica during few scenarios either during network isolation or when its worker node was unavailable. Below are performed to start former primary pod as replica and pod stuck at…

---

## [What is the future of backup with pgBackRest](https://forums.percona.com/t/what-is-the-future-of-backup-with-pgbackrest/40743)

<div class="topic-metadata">

**Author:** [@Baptiste\_Mille-Mathi](https://forums.percona.com/u/Baptiste_Mille-Mathi)\
**Replies:** 1\
**Last updated:** [May 5, 2026, 6:52am UTC](https://forums.percona.com/t/what-is-the-future-of-backup-with-pgbackrest/40743 "2026-05-05T06:52:57Z")

</div>

Hi PbBackRest developer announced last week he would stop developing it. I’m sure in the coming months it won’t be an issue, but what in the mid-term future? Do guys have some ideas ?

---

## [Integration with cert-manager - custom issuer](https://forums.percona.com/t/integration-with-cert-manager-custom-issuer/40739)

<div class="topic-metadata">

**Author:** [@spronin](https://forums.percona.com/u/spronin)\
**Replies:** 2\
**Last updated:** [May 3, 2026, 5:25pm UTC](https://forums.percona.com/t/integration-with-cert-manager-custom-issuer/40739 "2026-05-03T17:25:46Z")

</div>

Description: I want to use my own Issuer and cert-manager with PostgreSQL Operator. Right now when I have cert-manager deployed, Operator creates the Issuer , Certificate resources and Secrets for me. All self-signed. It…

---

## [Percona pgbackrest backup pod is failing in operator 2.8.2](https://forums.percona.com/t/percona-pgbackrest-backup-pod-is-failing-in-operator-2-8-2/40658)

<div class="topic-metadata">

**Author:** [@Srinivas](https://forums.percona.com/u/Srinivas)\
**Replies:** 4\
**Last updated:** [April 23, 2026, 2:21am UTC](https://forums.percona.com/t/percona-pgbackrest-backup-pod-is-failing-in-operator-2-8-2/40658 "2026-04-23T02:21:50Z")

</div>

Description: We have installed Percona operator 2.8.2 with pgbackrest image \[root@bastion-node pg-db\]# oc describe pod pg-cluster-sa-pg-db-backup-9xd8-p8qvz Events: Type Reason Age Fro…

---

## [\[PPGC\] Adding loadBalancerIP into proxy.pgBouncer.expose specs](https://forums.percona.com/t/ppgc-adding-loadbalancerip-into-proxy-pgbouncer-expose-specs/40677)

<div class="topic-metadata">

**Author:** [@b.balmon](https://forums.percona.com/u/b.balmon)\
**Replies:** 1\
**Last updated:** [April 20, 2026, 12:42pm UTC](https://forums.percona.com/t/ppgc-adding-loadbalancerip-into-proxy-pgbouncer-expose-specs/40677 "2026-04-20T12:42:19Z")

</div>

Description: Hi, I have been trying to manage the LoadBalancerIPs of my PPGC Clusters. I am using Octavia as the LoadBalancer Controller with Openstack. In order to control the IP of the PPGC Cluster LoadBalancer Serv…

---

## [Any easy way to update the password of \_crunchypgbouncer?](https://forums.percona.com/t/any-easy-way-to-update-the-password-of-crunchypgbouncer/40106)

<div class="topic-metadata">

**Author:** [@Michel\_Filipe](https://forums.percona.com/u/Michel_Filipe)\
**Replies:** 1\
**Last updated:** [March 13, 2026, 7:32pm UTC](https://forums.percona.com/t/any-easy-way-to-update-the-password-of-crunchypgbouncer/40106 "2026-03-13T19:32:13Z")

</div>

Description: There are two servers: primary and standby. The replication streaming is configured for them, so I would like to have the same password between them to avoid any kind of password issue during a failover. To…

---

## [Certified images when using Redhat Openshift certified operator](https://forums.percona.com/t/certified-images-when-using-redhat-openshift-certified-operator/40340)

<div class="topic-metadata">

**Author:** [@eprevost](https://forums.percona.com/u/eprevost)\
**Replies:** 1\
**Last updated:** [March 6, 2026, 6:50am UTC](https://forums.percona.com/t/certified-images-when-using-redhat-openshift-certified-operator/40340 "2026-03-06T06:50:29Z")

</div>

When using the certified operator from Openshift’s OperatorHub, the CR template to create a database cluster refers to images on registry.connect.redhat.com/percona/ instead of docker.io. On Percona certified images - P…

---

## [DCS failsafe mode for PG operator](https://forums.percona.com/t/dcs-failsafe-mode-for-pg-operator/36516)

<div class="topic-metadata">

**Author:** [@Joshua\_Sierles](https://forums.percona.com/u/Joshua_Sierles)\
**Replies:** 3\
**Last updated:** [March 4, 2026, 11:55am UTC](https://forums.percona.com/t/dcs-failsafe-mode-for-pg-operator/36516 "2026-03-04T11:55:05Z")

</div>

Hello, I noticed that when the k8s API is unavailable, both primary and replicas in a PG cluster go down since Patroni cannot reach k8s. Is it safe to enable DCS failsafe mode using this operator? Are there examples on…

---

## [Can't start backup. Previous backup is still in progress](https://forums.percona.com/t/cant-start-backup-previous-backup-is-still-in-progress/37913)

<div class="topic-metadata">

**Author:** [@pstekunov](https://forums.percona.com/u/pstekunov)\
**Replies:** 6\
**Last updated:** [February 26, 2026, 6:14am UTC](https://forums.percona.com/t/cant-start-backup-previous-backup-is-still-in-progress/37913 "2026-02-26T06:14:42Z")

</div>

Description: Backup jobs not created anymore Steps to Reproduce: Version: 2.6.0 Logs: 2025-05-12T12:53:44.628Z INFO Can’t start backup. Previous backup is still in progress {“controller”: “perconapgbackup”, “controller…

---

## [Full and incremental backups conflicting and stopping all backups](https://forums.percona.com/t/full-and-incremental-backups-conflicting-and-stopping-all-backups/33157)

<div class="topic-metadata">

**Author:** [@seacom](https://forums.percona.com/u/seacom)\
**Replies:** 6\
**Last updated:** [February 26, 2026, 6:07am UTC](https://forums.percona.com/t/full-and-incremental-backups-conflicting-and-stopping-all-backups/33157 "2026-02-26T06:07:28Z")

</div>

Description: I have incremental backups scheduled at 5 minute intervals and a nightly full backup. For the past several months this is worked great, the pgbackrest lock file has always conflicted causing a failed job som…

---

## [Kubectl apply reports spurious errors with conflicts using the Percona yaml](https://forums.percona.com/t/kubectl-apply-reports-spurious-errors-with-conflicts-using-the-percona-yaml/40230)

<div class="topic-metadata">

**Author:** [@Glenn\_Glazer](https://forums.percona.com/u/Glenn_Glazer)\
**Replies:** 1\
**Last updated:** [February 17, 2026, 7:41pm UTC](https://forums.percona.com/t/kubectl-apply-reports-spurious-errors-with-conflicts-using-the-percona-yaml/40230 "2026-02-17T19:41:57Z")

</div>

Description: kubectrl apply reports errors with conflicts using the Percona yaml and only partially succeeds. Steps to Reproduce: I am following the instructions here: I created the namespace no problem gglazer@Gl…

---

## [Turn off SSL when connecting to bouncer](https://forums.percona.com/t/turn-off-ssl-when-connecting-to-bouncer/21851)

<div class="topic-metadata">

**Author:** [@scott\_molinari](https://forums.percona.com/u/scott_molinari)\
**Replies:** 16\
**Last updated:** [February 10, 2026, 8:49pm UTC](https://forums.percona.com/t/turn-off-ssl-when-connecting-to-bouncer/21851 "2026-02-10T20:49:08Z")

</div>

Hi, I’m new to the database operator scene. I have two questions. I’m getting this error when connecting to the bouncer service. ERROR: SQLSTATE\[08006\] \[7\] connection to server at "postgres-db-pg-db-pgbouncer.postgres…

---

## [Convert the architecture from PostgreSQL distribution to PostgreSQL operator](https://forums.percona.com/t/convert-the-architecture-from-postgresql-distribution-to-postgresql-operator/40127)

<div class="topic-metadata">

**Author:** [@Tinesh\_Sakthi\_R1](https://forums.percona.com/u/Tinesh_Sakthi_R1)\
**Replies:** 3\
**Last updated:** [February 2, 2026, 3:28pm UTC](https://forums.percona.com/t/convert-the-architecture-from-postgresql-distribution-to-postgresql-operator/40127 "2026-02-02T15:28:08Z")

</div>

This is our finalized architecture for a PostgreSQL failover scenario across two data centers. This will be provided as a suggested approach for our enterprise on-premise customers who want to implement high availabil…

---

## [Percona postgresql operator frequent crashing due to leader election failure](https://forums.percona.com/t/percona-postgresql-operator-frequent-crashing-due-to-leader-election-failure/39892)

<div class="topic-metadata">

**Author:** [@vasanthnataraj](https://forums.percona.com/u/vasanthnataraj)\
**Replies:** 2\
**Last updated:** [December 16, 2025, 11:30am UTC](https://forums.percona.com/t/percona-postgresql-operator-frequent-crashing-due-to-leader-election-failure/39892 "2025-12-16T11:30:42Z")

</div>

Description: The Percona PostgreSQL operator is crashing due to leader election failure - it’s unable to communicate with the Kubernetes API server to maintain its leadership lease. if i try to change the operator lease…

---

## [Failed to create Pod: patroni-version-check](https://forums.percona.com/t/failed-to-create-pod-patroni-version-check/39671)

<div class="topic-metadata">

**Author:** [@Luke](https://forums.percona.com/u/Luke)\
**Replies:** 3\
**Last updated:** [November 29, 2025, 5:23pm UTC](https://forums.percona.com/t/failed-to-create-pod-patroni-version-check/39671 "2025-11-29T17:23:37Z")

</div>

Description: An error is logged during reconciliation when attempting to create the patroni-version-check pod if resources requests are set on the PerconaPGCluster resource. This seems to be caused by the PodLevelResour…

---

## [Arm64 percona/pg-db](https://forums.percona.com/t/arm64-percona-pg-db/36413)

<div class="topic-metadata">

**Author:** [@dalu](https://forums.percona.com/u/dalu)\
**Replies:** 4\
**Last updated:** [October 17, 2025, 3:24pm UTC](https://forums.percona.com/t/arm64-percona-pg-db/36413 "2025-10-17T15:24:45Z")

</div>

Description: Trying to install percona/pg-db with helm tries to pull the amd64 images (I guess) and not the arm64 images, if they even exist. How can I use arm64 images? Steps to Reproduce: helm install pg-operator per…

---

## [Percona PG-DB Helm chart does not have tolerations for all components](https://forums.percona.com/t/percona-pg-db-helm-chart-does-not-have-tolerations-for-all-components/38308)

<div class="topic-metadata">

**Author:** [@Raffaele\_Piccolo](https://forums.percona.com/u/Raffaele_Piccolo)\
**Replies:** 1\
**Last updated:** [September 28, 2025, 1:55pm UTC](https://forums.percona.com/t/percona-pg-db-helm-chart-does-not-have-tolerations-for-all-components/38308 "2025-09-28T13:55:05Z")

</div>

Description: Hi all, I am currently working with Percona Operator for PostgreSQL and Percona PostgreSQL DB. I am deploying both using helm charts from the official github repository (percona-helm-charts/charts at main ·…

---

## [Cron job issue for postgresql backup to s3 ](https://forums.percona.com/t/cron-job-issue-for-postgresql-backup-to-s3/32225)

<div class="topic-metadata">

**Author:** [@Surya\_Tyagi](https://forums.percona.com/u/Surya_Tyagi)\
**Replies:** 5\
**Last updated:** [September 22, 2025, 1:38pm UTC](https://forums.percona.com/t/cron-job-issue-for-postgresql-backup-to-s3/32225 "2025-09-22T13:38:51Z")

</div>

Descriptions We are using operator v2.4.0 , when i configured the backup to s3 or local (pvc) full and incremental . Using the following config in cr.yaml of the helm chart - spec: backups: pgbackrest: configurati…

---

## [Create PG Cluster via user interface not yaml](https://forums.percona.com/t/create-pg-cluster-via-user-interface-not-yaml/39212)

<div class="topic-metadata">

**Author:** [@kase007](https://forums.percona.com/u/kase007)\
**Replies:** 3\
**Last updated:** [September 1, 2025, 11:18pm UTC](https://forums.percona.com/t/create-pg-cluster-via-user-interface-not-yaml/39212 "2025-09-01T23:18:21Z")

</div>

Description: Could someone please help with creation of PGCluster via Operator in RedHat Openshift via user interface not the yaml itself? Is there any guide how to achive so? When I do so it never creates a POD. Also, …

---

## [pgBackRest Path Issue with Percona PostgreSQL Operator 2.7.0](https://forums.percona.com/t/pgbackrest-path-issue-with-percona-postgresql-operator-2-7-0/39173)

<div class="topic-metadata">

**Author:** [@ra2](https://forums.percona.com/u/ra2)\
**Replies:** 1\
**Last updated:** [August 22, 2025, 7:57am UTC](https://forums.percona.com/t/pgbackrest-path-issue-with-percona-postgresql-operator-2-7-0/39173 "2025-08-22T07:57:54Z")

</div>

\# pgBackRest Path Issue with Percona PostgreSQL Operator 2.7.0 ## Issue Summary The Percona PostgreSQL Operator 2.7.0 has a critical incompatibility with the pgBackRest image \`percona/percona-pgbackrest:2.55.0\` that pr…

---

## [Trying to create a PostGIS database through Percona Everest UI but can't find any PostGIS options, even though PostgreSQL Operator is enabled. How can I enable PostGIS extension?](https://forums.percona.com/t/trying-to-create-a-postgis-database-through-percona-everest-ui-but-cant-find-any-postgis-options-even-though-postgresql-operator-is-enabled-how-can-i-enable-postgis-extension/38728)

<div class="topic-metadata">

**Author:** [@kamal1](https://forums.percona.com/u/kamal1)\
**Replies:** 1\
**Last updated:** [July 28, 2025, 9:02pm UTC](https://forums.percona.com/t/trying-to-create-a-postgis-database-through-percona-everest-ui-but-cant-find-any-postgis-options-even-though-postgresql-operator-is-enabled-how-can-i-enable-postgis-extension/38728 "2025-07-28T21:02:17Z")

</div>

Description: I am trying to use Percona Everest and Percona Operator to create a new PostgreSQL database with PostGIS extension enabled. However, when attempting to create the database through the Everest interface, I ca…

---

## [Backup Issued to Google Storage (GS)](https://forums.percona.com/t/backup-issued-to-google-storage-gs/38233)

<div class="topic-metadata">

**Author:** [@samir\_esnet](https://forums.percona.com/u/samir_esnet)\
**Replies:** 4\
**Last updated:** [July 7, 2025, 3:34pm UTC](https://forums.percona.com/t/backup-issued-to-google-storage-gs/38233 "2025-07-07T15:34:34Z")

</div>

Description: Trying to get backup to a GCS bucket to work with either a S3 compatible pattern or Google storage pattern. Neither patter seems to work. Steps to Reproduce: Backup config: backups: pgbackrest: …

---

## [Connecting to Postgres](https://forums.percona.com/t/connecting-to-postgres/38218)

<div class="topic-metadata">

**Author:** [@samir\_esnet](https://forums.percona.com/u/samir_esnet)\
**Replies:** 2\
**Last updated:** [June 6, 2025, 3:46pm UTC](https://forums.percona.com/t/connecting-to-postgres/38218 "2025-06-06T15:46:39Z")

</div>

Description: Trying to connect to my Postgres database. Ideally, it’d be nice if port forwarding would allow me to connect to the service on localhost, but for now, just trying to stick to the instructions to get a basic…

[Next page](https://forums.percona.com/c/postgresql/percona-kubernetes-operator-for-postgresql/68.md?page=1)
