# Percona Distribution for PostgreSQL

**URL:** https://forums.percona.com/c/postgresql/percona-distribution-for-postgresql/21.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Percona Distribution for PostgreSQL category](https://forums.percona.com/t/about-the-percona-distribution-for-postgresql-category/26)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 0

</div>

Percona Distribution for PostgreSQL provides the best and most critical enterprise components from the open-source community, in a single distribution, designed and tested to work together.

---

## [Percona Patroni EOL Support with Ubuntu Pro for 22.04](https://forums.percona.com/t/percona-patroni-eol-support-with-ubuntu-pro-for-22-04/40892)

<div class="topic-metadata">

**Author:** [@zubin.parihar.bcgeu](https://forums.percona.com/u/zubin.parihar.bcgeu)\
**Replies:** 4\
**Last updated:** [August 17, 2026, 6:32am UTC](https://forums.percona.com/t/percona-patroni-eol-support-with-ubuntu-pro-for-22-04/40892 "2026-08-17T06:32:14Z")

</div>

Hey folks, Ubuntu 22.04 LTS has an EOL on April 2027 However, if we purchase Ubuntu Pro, that gives us 10 - 15 Years of support via Canonical. However, if we install Percona Apt Repos for Patroni+PostgreSQL 17, is the…

---

## [PPG RPMs for RHEL10 missing](https://forums.percona.com/t/ppg-rpms-for-rhel10-missing/38879)

<div class="topic-metadata">

**Author:** [@ziegenberg](https://forums.percona.com/u/ziegenberg)\
**Replies:** 22\
**Last updated:** [June 23, 2026, 10:06pm UTC](https://forums.percona.com/t/ppg-rpms-for-rhel10-missing/38879 "2026-06-23T22:06:20Z")

</div>

When trying to install PostgreSQL (any version) on a RHEL 10 machine I get the following error message from percona-release: $ percona-release setup -y ppg-15 Specified repository is not supported for current operating…

---

## [Is Master Master Replication possible](https://forums.percona.com/t/is-master-master-replication-possible/40926)

<div class="topic-metadata">

**Author:** [@deepak.kv](https://forums.percona.com/u/deepak.kv)\
**Replies:** 1\
**Last updated:** [June 18, 2026, 6:53am UTC](https://forums.percona.com/t/is-master-master-replication-possible/40926 "2026-06-18T06:53:49Z")

</div>

I have 7 nodes PostgreSQL, Etcd, Patroni cluster setup. In which, 3 nodes are on-premises and 4 nodes are on cloud. I want to make 1 master in on-premises setup and 1 master in cloud setup. I also want Master-Master Repl…

---

## [Llvmjit.so fails to load in percona-postgresql-17 container](https://forums.percona.com/t/llvmjit-so-fails-to-load-in-percona-postgresql-17-container/40690)

<div class="topic-metadata">

**Author:** [@chemp](https://forums.percona.com/u/chemp)\
**Replies:** 6\
**Last updated:** [June 8, 2026, 11:50am UTC](https://forums.percona.com/t/llvmjit-so-fails-to-load-in-percona-postgresql-17-container/40690 "2026-06-08T11:50:37Z")

</div>

Hello, I have encountered this issue while working with this image: perconalab/percona-distribution-postgresql-with-postgis:17.9. When PostgreSQL’s JIT compiler activates, loading /usr/pgsql-17/lib/llvmjit.so fails with…

---

## [Physical replication slot created through patroni configuration has retained the wal beyond default max\_wal\_size = 1 GB](https://forums.percona.com/t/physical-replication-slot-created-through-patroni-configuration-has-retained-the-wal-beyond-default-max-wal-size-1-gb/40735)

<div class="topic-metadata">

**Author:** [@deepak.kv](https://forums.percona.com/u/deepak.kv)\
**Replies:** 4\
**Last updated:** [May 25, 2026, 7:46am UTC](https://forums.percona.com/t/physical-replication-slot-created-through-patroni-configuration-has-retained-the-wal-beyond-default-max-wal-size-1-gb/40735 "2026-05-25T07:46:40Z")

</div>

We have created 3 node postgresql, patroni, etcd High Availability and Failover cluster. For this cluster, patroni configuration is as below - namespace: ${NAMESPACE} scope: ${SCOPE} name: ${NODE\_NAME} restapi: list…

---

## [Percona Postgres: Primary promotion happened during parameter change and behavior during pod delete forcefully](https://forums.percona.com/t/percona-postgres-primary-promotion-happened-during-parameter-change-and-behavior-during-pod-delete-forcefully/40811)

<div class="topic-metadata">

**Author:** [@Srinivas](https://forums.percona.com/u/Srinivas)\
**Replies:** 0\
**Last updated:** [May 18, 2026, 11:07am UTC](https://forums.percona.com/t/percona-postgres-primary-promotion-happened-during-parameter-change-and-behavior-during-pod-delete-forcefully/40811 "2026-05-18T11:07:27Z")

</div>

Please clarify understanding to the below questions. We changed the parameter “patroni.leaderLeaseDurationSeconds,” which triggered a pod restart one at a time for both the primary and replica pods. We also observed a…

---

## [Percona-pgbouncer 1.25 LDAP support](https://forums.percona.com/t/percona-pgbouncer-1-25-ldap-support/39843)

<div class="topic-metadata">

**Author:** [@neopolis](https://forums.percona.com/u/neopolis)\
**Replies:** 3\
**Last updated:** [April 14, 2026, 3:46am UTC](https://forums.percona.com/t/percona-pgbouncer-1-25-ldap-support/39843 "2026-04-14T03:46:44Z")

</div>

Hello, I use Percona distribution for PostgreSQL with 18.1 version and installed packages from Percona Repo . I found that pgbouncer-1.25-0 version supports LDAP authentification. So, I installed package percona-pgboun…

---

## [Trouble installing/using "percona-release" repository manager](https://forums.percona.com/t/trouble-installing-using-percona-release-repository-manager/40351)

<div class="topic-metadata">

**Author:** [@butlerkl](https://forums.percona.com/u/butlerkl)\
**Replies:** 9\
**Last updated:** [March 13, 2026, 2:22pm UTC](https://forums.percona.com/t/trouble-installing-using-percona-release-repository-manager/40351 "2026-03-13T14:22:55Z")

</div>

Hello, I am brand new to both PostgreSQL & Percona. I am attempting to work through the installation document on my RHEL 9.7 development environment and am unable to successfully install the “percona-release” repository …

---

## [Recommended way to install extensions](https://forums.percona.com/t/recommended-way-to-install-extensions/40349)

<div class="topic-metadata">

**Author:** [@Gertvdb](https://forums.percona.com/u/Gertvdb)\
**Replies:** 6\
**Last updated:** [March 12, 2026, 1:47pm UTC](https://forums.percona.com/t/recommended-way-to-install-extensions/40349 "2026-03-12T13:47:28Z")

</div>

What is the recommended way to install extensions that is not packaged in the Percona repo, like pg\_cron, for use with the Percona PostgreSQL distribution? We have been using the (Ubuntu DEB) packages from PGDG for it, …

---

## [Repository ppg-17.6 returns 404](https://forums.percona.com/t/repository-ppg-17-6-returns-404/40000)

<div class="topic-metadata">

**Author:** [@anju](https://forums.percona.com/u/anju)\
**Replies:** 2\
**Last updated:** [March 12, 2026, 6:30am UTC](https://forums.percona.com/t/repository-ppg-17-6-returns-404/40000 "2026-03-12T06:30:16Z")

</div>

Description The ppg-17.6-release-x86\_64 repository configured in the percona-postgresql-operator:2.8.0-ppg17.6-postgres-gis3.3.8 container image returns a 404 error, causing microdnf update to fail during downstream imag…

---

## [Percona pgbackrest compatibility](https://forums.percona.com/t/percona-pgbackrest-compatibility/40289)

<div class="topic-metadata">

**Author:** [@did16](https://forums.percona.com/u/did16)\
**Replies:** 1\
**Last updated:** [February 25, 2026, 10:59am UTC](https://forums.percona.com/t/percona-pgbackrest-compatibility/40289 "2026-02-25T10:59:24Z")

</div>

Hi In my company, we are going to use the Percona PostgreSQL distribution, and we would like to know if it’s possible to perform backups with Percona’s pgBackRest tool for PostgreSQL instances from PGDG? Thanks in adva…

---

## [Percona Distribution for PostgreSQL 18 | pgBackRest Restore Issue with Patroni HA](https://forums.percona.com/t/percona-distribution-for-postgresql-18-pgbackrest-restore-issue-with-patroni-ha/39906)

<div class="topic-metadata">

**Author:** [@asad121](https://forums.percona.com/u/asad121)\
**Replies:** 4\
**Last updated:** [January 27, 2026, 7:37pm UTC](https://forums.percona.com/t/percona-distribution-for-postgresql-18-pgbackrest-restore-issue-with-patroni-ha/39906 "2026-01-27T19:37:22Z")

</div>

Hi We have installed Percona Distribution for PostgreSQL 18 with High Availability (Patroni) in our test environment as part of our preparation for production. Environment Overview PostgreSQL: Percona Distribution for…

---

## [Need Clarification: Best Practice for pgBackRest Configuration in Multi-DC Patroni Standby Cluster](https://forums.percona.com/t/need-clarification-best-practice-for-pgbackrest-configuration-in-multi-dc-patroni-standby-cluster/39980)

<div class="topic-metadata">

**Author:** [@Tinesh\_Sakthi\_R1](https://forums.percona.com/u/Tinesh_Sakthi_R1)\
**Replies:** 3\
**Last updated:** [January 13, 2026, 5:15pm UTC](https://forums.percona.com/t/need-clarification-best-practice-for-pgbackrest-configuration-in-multi-dc-patroni-standby-cluster/39980 "2026-01-13T17:15:32Z")

</div>

Hello everyone, I’m looking for some guidance and best practices regarding the configuration of pgBackRest in a multi-data center Patroni PostgreSQL setup. Current Setup: Two data centers (DC1 & DC2) DC1: Host…

---

## [Percona PostgreSQL Operator: Restore Fails with 'No Completed Backups Found' Error Despite Successful Backups in AWS S3](https://forums.percona.com/t/percona-postgresql-operator-restore-fails-with-no-completed-backups-found-error-despite-successful-backups-in-aws-s3/35605)

<div class="topic-metadata">

**Author:** [@ankitjodhani](https://forums.percona.com/u/ankitjodhani)\
**Replies:** 6\
**Last updated:** [December 8, 2025, 9:58am UTC](https://forums.percona.com/t/percona-postgresql-operator-restore-fails-with-no-completed-backups-found-error-despite-successful-backups-in-aws-s3/35605 "2025-12-08T09:58:44Z")

</div>

Percona PostgreSQL Operator: Restore Fails with ‘No Completed Backups Found’ Error Despite Successful Backups in AWS S3 :man\_raising\_hand: Hi Everyone, I’m reaching out after spending weeks troubleshooting this issue an…

---

## [PGDB Restore and Backup Error](https://forums.percona.com/t/pgdb-restore-and-backup-error/39574)

<div class="topic-metadata">

**Author:** [@Kushal\_Sultania](https://forums.percona.com/u/Kushal_Sultania)\
**Replies:** 1\
**Last updated:** [November 12, 2025, 3:52am UTC](https://forums.percona.com/t/pgdb-restore-and-backup-error/39574 "2025-11-12T03:52:33Z")

</div>

I have a kubernetes cluster i am migrating from one to another. I want to restore previous cluster data to new one. When i try to create a normal restore cr and not use datasource , there is a initia backup taken , is t…

---

## [Bug in pg\_stat\_monitor version 2.1 . Database Hungs](https://forums.percona.com/t/bug-in-pg-stat-monitor-version-2-1-database-hungs/36906)

<div class="topic-metadata">

**Author:** [@harish.jaipu](https://forums.percona.com/u/harish.jaipu)\
**Replies:** 6\
**Last updated:** [November 8, 2025, 12:19am UTC](https://forums.percona.com/t/bug-in-pg-stat-monitor-version-2-1-database-hungs/36906 "2025-11-08T00:19:15Z")

</div>

Version psql (PostgreSQL) 16.6 - Percona Distribution. Database goes hung when the pg\_stat\_monitor query runs to fetch metrics. During this time no logs were gernerated in the error log and database was unresponsive and…

---

## [Question about performance impact when change log\_statement from ddl to all](https://forums.percona.com/t/question-about-performance-impact-when-change-log-statement-from-ddl-to-all/39655)

<div class="topic-metadata">

**Author:** [@cuongtm02](https://forums.percona.com/u/cuongtm02)\
**Replies:** 2\
**Last updated:** [October 30, 2025, 3:04pm UTC](https://forums.percona.com/t/question-about-performance-impact-when-change-log-statement-from-ddl-to-all/39655 "2025-10-30T15:04:07Z")

</div>

Hi, We plan to audit all action of Percona postgresql v17 by change log\_statement from ddl to all, please advise: 1/ performance impact, is there any document for compare performance when change this parameter for busy…

---

## [Patroni and pgBackRest - full restore problem](https://forums.percona.com/t/patroni-and-pgbackrest-full-restore-problem/28077)

<div class="topic-metadata">

**Author:** [@pirolas](https://forums.percona.com/u/pirolas)\
**Replies:** 4\
**Last updated:** [October 23, 2025, 7:34am UTC](https://forums.percona.com/t/patroni-and-pgbackrest-full-restore-problem/28077 "2025-10-23T07:34:44Z")

</div>

Hello everyone, I’ve being trying hard to understand what’s going on with my configuration, maybe I’m the problem. For context I’ve a two node cluster, with patroni and postgresql in it, plus three node cluster of etcd…

---

## [Postgres crashes and goes to the recovering mode after patching to 16.10](https://forums.percona.com/t/postgres-crashes-and-goes-to-the-recovering-mode-after-patching-to-16-10/39508)

<div class="topic-metadata">

**Author:** [@harish.jaipu](https://forums.percona.com/u/harish.jaipu)\
**Replies:** 1\
**Last updated:** [October 13, 2025, 1:02pm UTC](https://forums.percona.com/t/postgres-crashes-and-goes-to-the-recovering-mode-after-patching-to-16-10/39508 "2025-10-13T13:02:29Z")

</div>

Database reported core dump messages and kept going to recovery mode and was not starting up. postgres=# select \* from pg\_extension ; WARNING: terminating connection because of crash of another server process DETAIL:…

---

## [Percona backup restore from beta to dev env](https://forums.percona.com/t/percona-backup-restore-from-beta-to-dev-env/39265)

<div class="topic-metadata">

**Author:** [@Kushal\_Sultania](https://forums.percona.com/u/Kushal_Sultania)\
**Replies:** 4\
**Last updated:** [September 9, 2025, 9:34am UTC](https://forums.percona.com/t/percona-backup-restore-from-beta-to-dev-env/39265 "2025-09-09T09:34:03Z")

</div>

We are running postgres from percona (pgdb) in beta environment inside kubernetes cluster with backups configured to cloud s3 service. Trying to restore the backup in dev environment which is based on docker compose. Th…

---

## [Where are percona distribution for PostgreSQL rpm?](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121)

<div class="topic-metadata">

**Author:** [@did16](https://forums.percona.com/u/did16)\
**Replies:** 7\
**Last updated:** [August 19, 2025, 11:58am UTC](https://forums.percona.com/t/where-are-percona-distribution-for-postgresql-rpm/39121 "2025-08-19T11:58:00Z")

</div>

Hi Where can I download the percona distribution for PostgreSQL rpm packages ? I can’t find them ? I can not use the percona repository in my firm. I have to download rpm packages manually.

---

## [Problem with installing percona-pgaudit17-17.1-1.el8.x86\_64.rpm](https://forums.percona.com/t/problem-with-installing-percona-pgaudit17-17-1-1-el8-x86-64-rpm/39129)

<div class="topic-metadata">

**Author:** [@did16](https://forums.percona.com/u/did16)\
**Replies:** 6\
**Last updated:** [August 18, 2025, 9:55am UTC](https://forums.percona.com/t/problem-with-installing-percona-pgaudit17-17-1-1-el8-x86-64-rpm/39129 "2025-08-18T09:55:18Z")

</div>

Hi I need to install pgaudit in order to install percona-ppg-server17-17.5-1.el8.x86\_64.rpm: yum install percona-pgaudit17-17.1-1.el8.x86\_64.rpm and I get :slight\_smile: It will install PGDG rpm packages and that d…

---

## [Percona distribution for postgresql and licence](https://forums.percona.com/t/percona-distribution-for-postgresql-and-licence/39122)

<div class="topic-metadata">

**Author:** [@did16](https://forums.percona.com/u/did16)\
**Replies:** 2\
**Last updated:** [August 14, 2025, 5:09pm UTC](https://forums.percona.com/t/percona-distribution-for-postgresql-and-licence/39122 "2025-08-14T17:09:39Z")

</div>

hi Do we need to pay a licence fee to use the Percona Distribution for PostgreSQL server? thanks in advance

---

## [Percona error when create new postgres db](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684)

<div class="topic-metadata">

**Author:** [@mohamed](https://forums.percona.com/u/mohamed)\
**Replies:** 3\
**Last updated:** [August 9, 2025, 3:13am UTC](https://forums.percona.com/t/percona-error-when-create-new-postgres-db/38684 "2025-08-09T03:13:35Z")

</div>

i have deployed percona everest on kubernetes dashboard withthe main helm chart everything running smoothly but when i try to create new postgres db i faced this issue mean while same chart have been deployed and work…

---

## [Gosu binary in arm64 image](https://forums.percona.com/t/gosu-binary-in-arm64-image/38549)

<div class="topic-metadata">

**Author:** [@scheibling](https://forums.percona.com/u/scheibling)\
**Replies:** 1\
**Last updated:** [July 4, 2025, 10:45am UTC](https://forums.percona.com/t/gosu-binary-in-arm64-image/38549 "2025-07-04T10:45:35Z")

</div>

It looks like there are some issues with the container image builds (percona/percona-distribution-postgresql), where the AMD64 version of gosu is included in the ARM64 images leading to the container not starting up prop…

---

## [Specified repository does not exist: http://repo.percona.com/ppg-17/](https://forums.percona.com/t/specified-repository-does-not-exist-http-repo-percona-com-ppg-17/38445)

<div class="topic-metadata">

**Author:** [@tahl](https://forums.percona.com/u/tahl)\
**Replies:** 3\
**Last updated:** [June 25, 2025, 3:57pm UTC](https://forums.percona.com/t/specified-repository-does-not-exist-http-repo-percona-com-ppg-17/38445 "2025-06-25T15:57:48Z")

</div>

Oracle Linux 9. dnf module disable postgresql dnf config-manager --set-enabled ol9\_codeready\_builder dnf install perl-IPC-Run -y dnf install https://repo.percona.com/yum/percona-release-latest.noarch.rpm (Installed: …

---

## [Psql is bug？this issue was also encountered in postgresql 16.3](https://forums.percona.com/t/psql-is-bug-this-issue-was-also-encountered-in-postgresql-16-3/31608)

<div class="topic-metadata">

**Author:** [@gwy195600](https://forums.percona.com/u/gwy195600)\
**Replies:** 18\
**Last updated:** [June 11, 2025, 1:15pm UTC](https://forums.percona.com/t/psql-is-bug-this-issue-was-also-encountered-in-postgresql-16-3/31608 "2025-06-11T13:15:34Z")

</div>

\[postgres@ora23ai ~\]$ psql psql (15.7) Type “help” for help. malloc(): corrupted top size Aborted (core dumped) saw the same core dump file from the /var/log/messages \[root@ora23ai ~\]# coredumpctl list TIME …

---

## [Create DB and Users at start](https://forums.percona.com/t/create-db-and-users-at-start/23360)

<div class="topic-metadata">

**Author:** [@Satheesh\_Kumar](https://forums.percona.com/u/Satheesh_Kumar)\
**Replies:** 1\
**Last updated:** [May 20, 2025, 1:58pm UTC](https://forums.percona.com/t/create-db-and-users-at-start/23360 "2025-05-20T13:58:07Z")

</div>

Hi I am using pg-db and pg-operator and installing using helm but what i want is i need to create few database and users at start I saw the options in values.yaml users: name: pg databases: zoo options: “SUPERUSE…

---

## [How to Setup OpenShift Route/Direct URL to Connect to PostgreSQL Databases](https://forums.percona.com/t/how-to-setup-openshift-route-direct-url-to-connect-to-postgresql-databases/37944)

<div class="topic-metadata">

**Author:** [@gaceta7181](https://forums.percona.com/u/gaceta7181)\
**Replies:** 0\
**Last updated:** [May 14, 2025, 2:36pm UTC](https://forums.percona.com/t/how-to-setup-openshift-route-direct-url-to-connect-to-postgresql-databases/37944 "2025-05-14T14:36:41Z")

</div>

I am working on a project right now for GE Aerospace where I need to setup a Route in OpenShift and create a Direct URL to connect to Postgres databases externally and use that to connect to the databases instead of usin…

[Next page](https://forums.percona.com/c/postgresql/percona-distribution-for-postgresql/21.md?page=1)
