# PostgreSQL

**URL:** https://forums.percona.com/c/postgresql/25.md?page=1

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 2

---

## [ERROR: permission denied for table \<tablename\>](https://forums.percona.com/t/error-permission-denied-for-table-tablename/40684)

<div class="topic-metadata">

**Author:** [@jruffer](https://forums.percona.com/u/jruffer)\
**Replies:** 3\
**Last updated:** [April 21, 2026, 9:28am UTC](https://forums.percona.com/t/error-permission-denied-for-table-tablename/40684 "2026-04-21T09:28:35Z")

</div>

grant select on all tables in schema schemaname to username; I don’t unserstand what I’m missing.

---

## [\[PPGC\] Adding loadBalancerIP into proxy.pgBouncer.expose specs](https://forums.percona.com/t/ppgc-adding-loadbalancerip-into-proxy-pgbouncer-expose-specs/40677)

<div class="topic-metadata">

**Author:** [@b.balmon](https://forums.percona.com/u/b.balmon)\
**Replies:** 1\
**Last updated:** [April 20, 2026, 12:42pm UTC](https://forums.percona.com/t/ppgc-adding-loadbalancerip-into-proxy-pgbouncer-expose-specs/40677 "2026-04-20T12:42:19Z")

</div>

Description: Hi, I have been trying to manage the LoadBalancerIPs of my PPGC Clusters. I am using Octavia as the LoadBalancer Controller with Openstack. In order to control the IP of the PPGC Cluster LoadBalancer Serv…

---

## [Loading keys over wire and evicting keys from cache in pg\_tde](https://forums.percona.com/t/loading-keys-over-wire-and-evicting-keys-from-cache-in-pg-tde/40633)

<div class="topic-metadata">

**Author:** [@WOXX](https://forums.percona.com/u/WOXX)\
**Replies:** 0\
**Last updated:** [April 15, 2026, 4:18am UTC](https://forums.percona.com/t/loading-keys-over-wire-and-evicting-keys-from-cache-in-pg-tde/40633 "2026-04-15T04:18:31Z")

</div>

Hi in pg\_tde, is it possible to set up eviction so keys are evicted from memory after a certain amount of time (or maybe inactivity or no connections) and required to be reloaded to use that db again? Or even not cache k…

---

## [Percona-pgbouncer 1.25 LDAP support](https://forums.percona.com/t/percona-pgbouncer-1-25-ldap-support/39843)

<div class="topic-metadata">

**Author:** [@neopolis](https://forums.percona.com/u/neopolis)\
**Replies:** 3\
**Last updated:** [April 14, 2026, 3:46am UTC](https://forums.percona.com/t/percona-pgbouncer-1-25-ldap-support/39843 "2026-04-14T03:46:44Z")

</div>

Hello, I use Percona distribution for PostgreSQL with 18.1 version and installed packages from Percona Repo . I found that pgbouncer-1.25-0 version supports LDAP authentification. So, I installed package percona-pgboun…

---

## [Upgrade from 17.9 to 18.3.1 seems stuck](https://forums.percona.com/t/upgrade-from-17-9-to-18-3-1-seems-stuck/40625)

<div class="topic-metadata">

**Author:** [@christopher](https://forums.percona.com/u/christopher)\
**Replies:** 1\
**Last updated:** [April 14, 2026, 1:33am UTC](https://forums.percona.com/t/upgrade-from-17-9-to-18-3-1-seems-stuck/40625 "2026-04-14T01:33:15Z")

</div>

I have been trying to upgrade from version 17.9 to 18.3.1 on Ubuntu 24.04 for a couple days but seem to be stuck half way through. The initial attempt proceeded as documented but ran into trouble because I had not prein…

---

## [Ppg-16.10 - 404 Not Found](https://forums.percona.com/t/ppg-16-10-404-not-found/40414)

<div class="topic-metadata">

**Author:** [@harish.grandhi](https://forums.percona.com/u/harish.grandhi)\
**Replies:** 1\
**Last updated:** [March 27, 2026, 1:17pm UTC](https://forums.percona.com/t/ppg-16-10-404-not-found/40414 "2026-03-27T13:17:47Z")

</div>

https://repo.percona.com/ppg-16.10/ is unable to access and getting 404 Not Found. At the same time other ppg-16.10 repos are accessible

---

## [How to verify whether the 256 bit AES encryption option applied? and not using the default 128](https://forums.percona.com/t/how-to-verify-whether-the-256-bit-aes-encryption-option-applied-and-not-using-the-default-128/40410)

<div class="topic-metadata">

**Author:** [@roko](https://forums.percona.com/u/roko)\
**Replies:** 1\
**Last updated:** [March 27, 2026, 4:49am UTC](https://forums.percona.com/t/how-to-verify-whether-the-256-bit-aes-encryption-option-applied-and-not-using-the-default-128/40410 "2026-03-27T04:49:48Z")

</div>

Hi, Using Percona server 18 with TDE Reading the source code 256bit option the default is aes\_128 I added the 256 option to postgresql.conf pg\_tde.cipher = ‘aes\_256’ I would like to know how to verify the encryp…

---

## [Has pg\_tde added support for open-source PostgreSQL yet, or is it still unsupported?](https://forums.percona.com/t/has-pg-tde-added-support-for-open-source-postgresql-yet-or-is-it-still-unsupported/40368)

<div class="topic-metadata">

**Author:** [@kimjinju](https://forums.percona.com/u/kimjinju)\
**Replies:** 1\
**Last updated:** [March 18, 2026, 6:50am UTC](https://forums.percona.com/t/has-pg-tde-added-support-for-open-source-postgresql-yet-or-is-it-still-unsupported/40368 "2026-03-18T06:50:27Z")

</div>

Hello, Team. I have seen previous discussions stating that pg\_tde requires core engine patches to work fully. Has there been any progress since then? Can the current version of pg\_tde now be used on standard Community …

---

## [Any easy way to update the password of \_crunchypgbouncer?](https://forums.percona.com/t/any-easy-way-to-update-the-password-of-crunchypgbouncer/40106)

<div class="topic-metadata">

**Author:** [@Michel\_Filipe](https://forums.percona.com/u/Michel_Filipe)\
**Replies:** 1\
**Last updated:** [March 13, 2026, 7:32pm UTC](https://forums.percona.com/t/any-easy-way-to-update-the-password-of-crunchypgbouncer/40106 "2026-03-13T19:32:13Z")

</div>

Description: There are two servers: primary and standby. The replication streaming is configured for them, so I would like to have the same password between them to avoid any kind of password issue during a failover. To…

---

## [Trouble installing/using "percona-release" repository manager](https://forums.percona.com/t/trouble-installing-using-percona-release-repository-manager/40351)

<div class="topic-metadata">

**Author:** [@butlerkl](https://forums.percona.com/u/butlerkl)\
**Replies:** 9\
**Last updated:** [March 13, 2026, 2:22pm UTC](https://forums.percona.com/t/trouble-installing-using-percona-release-repository-manager/40351 "2026-03-13T14:22:55Z")

</div>

Hello, I am brand new to both PostgreSQL & Percona. I am attempting to work through the installation document on my RHEL 9.7 development environment and am unable to successfully install the “percona-release” repository …

---

## [Recommended way to install extensions](https://forums.percona.com/t/recommended-way-to-install-extensions/40349)

<div class="topic-metadata">

**Author:** [@Gertvdb](https://forums.percona.com/u/Gertvdb)\
**Replies:** 6\
**Last updated:** [March 12, 2026, 1:47pm UTC](https://forums.percona.com/t/recommended-way-to-install-extensions/40349 "2026-03-12T13:47:28Z")

</div>

What is the recommended way to install extensions that is not packaged in the Percona repo, like pg\_cron, for use with the Percona PostgreSQL distribution? We have been using the (Ubuntu DEB) packages from PGDG for it, …

---

## [Repository ppg-17.6 returns 404](https://forums.percona.com/t/repository-ppg-17-6-returns-404/40000)

<div class="topic-metadata">

**Author:** [@anju](https://forums.percona.com/u/anju)\
**Replies:** 2\
**Last updated:** [March 12, 2026, 6:30am UTC](https://forums.percona.com/t/repository-ppg-17-6-returns-404/40000 "2026-03-12T06:30:16Z")

</div>

Description The ppg-17.6-release-x86\_64 repository configured in the percona-postgresql-operator:2.8.0-ppg17.6-postgres-gis3.3.8 container image returns a 404 error, causing microdnf update to fail during downstream imag…

---

## [Any PostgreSQL people in the north of England?](https://forums.percona.com/t/any-postgresql-people-in-the-north-of-england/40350)

<div class="topic-metadata">

**Author:** [@sjwood0](https://forums.percona.com/u/sjwood0)\
**Replies:** 0\
**Last updated:** [March 10, 2026, 9:03pm UTC](https://forums.percona.com/t/any-postgresql-people-in-the-north-of-england/40350 "2026-03-10T21:03:17Z")

</div>

Hi folks, Starting 19th March at 6pm myself & a co-worker are starting a PostgreSQL user group for the north of England. We’ll run it every quarter and the first event on is on the 19th of March at the Amazon offices in…

---

## [Postgres cluster to cluster replication with pg\_tde encyption at DBs and WALs](https://forums.percona.com/t/postgres-cluster-to-cluster-replication-with-pg-tde-encyption-at-dbs-and-wals/40330)

<div class="topic-metadata">

**Author:** [@bourasg](https://forums.percona.com/u/bourasg)\
**Replies:** 3\
**Last updated:** [March 9, 2026, 11:32am UTC](https://forums.percona.com/t/postgres-cluster-to-cluster-replication-with-pg-tde-encyption-at-dbs-and-wals/40330 "2026-03-09T11:32:54Z")

</div>

Hello, We have a full working primary cluster (A) with pg\_tde encyption at DBs and WALs. We want to replicate its data to a different standby (B) cluster , but still without any success. Fortunately we are on a Lab ,t…

---

## [Certified images when using Redhat Openshift certified operator](https://forums.percona.com/t/certified-images-when-using-redhat-openshift-certified-operator/40340)

<div class="topic-metadata">

**Author:** [@eprevost](https://forums.percona.com/u/eprevost)\
**Replies:** 1\
**Last updated:** [March 6, 2026, 6:50am UTC](https://forums.percona.com/t/certified-images-when-using-redhat-openshift-certified-operator/40340 "2026-03-06T06:50:29Z")

</div>

When using the certified operator from Openshift’s OperatorHub, the CR template to create a database cluster refers to images on registry.connect.redhat.com/percona/ instead of docker.io. On Percona certified images - P…

---

## [DCS failsafe mode for PG operator](https://forums.percona.com/t/dcs-failsafe-mode-for-pg-operator/36516)

<div class="topic-metadata">

**Author:** [@Joshua\_Sierles](https://forums.percona.com/u/Joshua_Sierles)\
**Replies:** 3\
**Last updated:** [March 4, 2026, 11:55am UTC](https://forums.percona.com/t/dcs-failsafe-mode-for-pg-operator/36516 "2026-03-04T11:55:05Z")

</div>

Hello, I noticed that when the k8s API is unavailable, both primary and replicas in a PG cluster go down since Patroni cannot reach k8s. Is it safe to enable DCS failsafe mode using this operator? Are there examples on…

---

## [How to connect PMM to the quickstart postgres database](https://forums.percona.com/t/how-to-connect-pmm-to-the-quickstart-postgres-database/40249)

<div class="topic-metadata">

**Author:** [@Glenn\_Glazer](https://forums.percona.com/u/Glenn_Glazer)\
**Replies:** 9\
**Last updated:** [March 3, 2026, 3:03pm UTC](https://forums.percona.com/t/how-to-connect-pmm-to-the-quickstart-postgres-database/40249 "2026-03-03T15:03:23Z")

</div>

I created a database using the kubernetes quickstart here: With kubectl - Percona Operator for PostgreSQL I can connect to it using: kubectl run -i --rm --tty pg-client --image=perconalab/percona-distribution-postgresq…

---

## [Can't start backup. Previous backup is still in progress](https://forums.percona.com/t/cant-start-backup-previous-backup-is-still-in-progress/37913)

<div class="topic-metadata">

**Author:** [@pstekunov](https://forums.percona.com/u/pstekunov)\
**Replies:** 6\
**Last updated:** [February 26, 2026, 6:14am UTC](https://forums.percona.com/t/cant-start-backup-previous-backup-is-still-in-progress/37913 "2026-02-26T06:14:42Z")

</div>

Description: Backup jobs not created anymore Steps to Reproduce: Version: 2.6.0 Logs: 2025-05-12T12:53:44.628Z INFO Can’t start backup. Previous backup is still in progress {“controller”: “perconapgbackup”, “controller…

---

## [Full and incremental backups conflicting and stopping all backups](https://forums.percona.com/t/full-and-incremental-backups-conflicting-and-stopping-all-backups/33157)

<div class="topic-metadata">

**Author:** [@seacom](https://forums.percona.com/u/seacom)\
**Replies:** 6\
**Last updated:** [February 26, 2026, 6:07am UTC](https://forums.percona.com/t/full-and-incremental-backups-conflicting-and-stopping-all-backups/33157 "2026-02-26T06:07:28Z")

</div>

Description: I have incremental backups scheduled at 5 minute intervals and a nightly full backup. For the past several months this is worked great, the pgbackrest lock file has always conflicted causing a failed job som…

---

## [Percona pgbackrest compatibility](https://forums.percona.com/t/percona-pgbackrest-compatibility/40289)

<div class="topic-metadata">

**Author:** [@did16](https://forums.percona.com/u/did16)\
**Replies:** 1\
**Last updated:** [February 25, 2026, 10:59am UTC](https://forums.percona.com/t/percona-pgbackrest-compatibility/40289 "2026-02-25T10:59:24Z")

</div>

Hi In my company, we are going to use the Percona PostgreSQL distribution, and we would like to know if it’s possible to perform backups with Percona’s pgBackRest tool for PostgreSQL instances from PGDG? Thanks in adva…

---

## [Request for guidance: pg\_tde WAL encryption behavior with pgBackRest PITR](https://forums.percona.com/t/request-for-guidance-pg-tde-wal-encryption-behavior-with-pgbackrest-pitr/40115)

<div class="topic-metadata">

**Author:** [@asad121](https://forums.percona.com/u/asad121)\
**Replies:** 4\
**Last updated:** [February 24, 2026, 6:46am UTC](https://forums.percona.com/t/request-for-guidance-pg-tde-wal-encryption-behavior-with-pgbackrest-pitr/40115 "2026-02-24T06:46:52Z")

</div>

Hello team :waving\_hand: We are currently testing pg\_tde with pgBackRest on Percona Distribution for PostgreSQL 18, and we would really appreciate your guidance to better understand the expected and supported behavior a…

---

## [Orafce extension problem "Invalid summary version"](https://forums.percona.com/t/orafce-extension-problem-invalid-summary-version/40245)

<div class="topic-metadata">

**Author:** [@PawelDes](https://forums.percona.com/u/PawelDes)\
**Replies:** 1\
**Last updated:** [February 18, 2026, 9:19pm UTC](https://forums.percona.com/t/orafce-extension-problem-invalid-summary-version/40245 "2026-02-18T21:19:48Z")

</div>

Hi, need to install the orafce extension, but it is not available in the Percona contrib modules and utilities repository. After installing orafce from the official PostgreSQL repository, it does not work correctly and …

---

## [Kubectl apply reports spurious errors with conflicts using the Percona yaml](https://forums.percona.com/t/kubectl-apply-reports-spurious-errors-with-conflicts-using-the-percona-yaml/40230)

<div class="topic-metadata">

**Author:** [@Glenn\_Glazer](https://forums.percona.com/u/Glenn_Glazer)\
**Replies:** 1\
**Last updated:** [February 17, 2026, 7:41pm UTC](https://forums.percona.com/t/kubectl-apply-reports-spurious-errors-with-conflicts-using-the-percona-yaml/40230 "2026-02-17T19:41:57Z")

</div>

Description: kubectrl apply reports errors with conflicts using the Percona yaml and only partially succeeds. Steps to Reproduce: I am following the instructions here: I created the namespace no problem gglazer@Gl…

---

## [Seeking best practices and real world experiences around managing, tuning, and operating PostgreSQL and MongoDB databases in production environments at scale](https://forums.percona.com/t/seeking-best-practices-and-real-world-experiences-around-managing-tuning-and-operating-postgresql-and-mongodb-databases-in-production-environments-at-scale/40180)

<div class="topic-metadata">

**Author:** [@Sachin\_R](https://forums.percona.com/u/Sachin_R)\
**Replies:** 1\
**Last updated:** [February 17, 2026, 3:00pm UTC](https://forums.percona.com/t/seeking-best-practices-and-real-world-experiences-around-managing-tuning-and-operating-postgresql-and-mongodb-databases-in-production-environments-at-scale/40180 "2026-02-17T15:00:25Z")

</div>

Hi everyone, I’m looking to start a discussion around real world database administration challenges for PostgreSQL and MongoDB in production environments. Specifically, I’m interested in hearing from DBAs and platform …

---

## [Turn off SSL when connecting to bouncer](https://forums.percona.com/t/turn-off-ssl-when-connecting-to-bouncer/21851)

<div class="topic-metadata">

**Author:** [@scott\_molinari](https://forums.percona.com/u/scott_molinari)\
**Replies:** 16\
**Last updated:** [February 10, 2026, 8:49pm UTC](https://forums.percona.com/t/turn-off-ssl-when-connecting-to-bouncer/21851 "2026-02-10T20:49:08Z")

</div>

Hi, I’m new to the database operator scene. I have two questions. I’m getting this error when connecting to the bouncer service. ERROR: SQLSTATE\[08006\] \[7\] connection to server at "postgres-db-pg-db-pgbouncer.postgres…

---

## [Convert the architecture from PostgreSQL distribution to PostgreSQL operator](https://forums.percona.com/t/convert-the-architecture-from-postgresql-distribution-to-postgresql-operator/40127)

<div class="topic-metadata">

**Author:** [@Tinesh\_Sakthi\_R1](https://forums.percona.com/u/Tinesh_Sakthi_R1)\
**Replies:** 3\
**Last updated:** [February 2, 2026, 3:28pm UTC](https://forums.percona.com/t/convert-the-architecture-from-postgresql-distribution-to-postgresql-operator/40127 "2026-02-02T15:28:08Z")

</div>

This is our finalized architecture for a PostgreSQL failover scenario across two data centers. This will be provided as a suggested approach for our enterprise on-premise customers who want to implement high availabil…

---

## [Percona Distribution for PostgreSQL 18 | pgBackRest Restore Issue with Patroni HA](https://forums.percona.com/t/percona-distribution-for-postgresql-18-pgbackrest-restore-issue-with-patroni-ha/39906)

<div class="topic-metadata">

**Author:** [@asad121](https://forums.percona.com/u/asad121)\
**Replies:** 4\
**Last updated:** [January 27, 2026, 7:37pm UTC](https://forums.percona.com/t/percona-distribution-for-postgresql-18-pgbackrest-restore-issue-with-patroni-ha/39906 "2026-01-27T19:37:22Z")

</div>

Hi We have installed Percona Distribution for PostgreSQL 18 with High Availability (Patroni) in our test environment as part of our preparation for production. Environment Overview PostgreSQL: Percona Distribution for…

---

## [Need Clarification: Best Practice for pgBackRest Configuration in Multi-DC Patroni Standby Cluster](https://forums.percona.com/t/need-clarification-best-practice-for-pgbackrest-configuration-in-multi-dc-patroni-standby-cluster/39980)

<div class="topic-metadata">

**Author:** [@Tinesh\_Sakthi\_R1](https://forums.percona.com/u/Tinesh_Sakthi_R1)\
**Replies:** 3\
**Last updated:** [January 13, 2026, 5:15pm UTC](https://forums.percona.com/t/need-clarification-best-practice-for-pgbackrest-configuration-in-multi-dc-patroni-standby-cluster/39980 "2026-01-13T17:15:32Z")

</div>

Hello everyone, I’m looking for some guidance and best practices regarding the configuration of pgBackRest in a multi-data center Patroni PostgreSQL setup. Current Setup: Two data centers (DC1 & DC2) DC1: Host…

---

## [How do you use a Kubernetes ServiceAccount (KSA) with Percona Postgres + gcsfuse?](https://forums.percona.com/t/how-do-you-use-a-kubernetes-serviceaccount-ksa-with-percona-postgres-gcsfuse/40026)

<div class="topic-metadata">

**Author:** [@karthik\_rathod](https://forums.percona.com/u/karthik_rathod)\
**Replies:** 0\
**Last updated:** [January 11, 2026, 5:54pm UTC](https://forums.percona.com/t/how-do-you-use-a-kubernetes-serviceaccount-ksa-with-percona-postgres-gcsfuse/40026 "2026-01-11T17:54:38Z")

</div>

I’m running the Percona Operator for PostgreSQL and trying to hook it up to cloud workload identity (GKE / IRSA style auth). I tried setting a Kubernetes ServiceAccount on my Postgres instance pods through the PerconaPG…

---

## [Failed to parse mountpoint with missing type field error](https://forums.percona.com/t/failed-to-parse-mountpoint-with-missing-type-field-error/39939)

<div class="topic-metadata">

**Author:** [@Butterfly](https://forums.percona.com/u/Butterfly)\
**Replies:** 1\
**Last updated:** [December 30, 2025, 2:09pm UTC](https://forums.percona.com/t/failed-to-parse-mountpoint-with-missing-type-field-error/39939 "2025-12-30T14:09:15Z")

</div>

I’m running into errors when trying to create Vault keys and I’m running out of ideas on why this is happening. Does anyone have advice on ways to extract more detailed logs to debug this issue? My Vault policy configur…

[Previous page](https://forums.percona.com/c/postgresql/25.md)

[Next page](https://forums.percona.com/c/postgresql/25.md?page=2)
