# Percona Toolkit

**URL:** https://forums.percona.com/c/polyglot-projects/percona-toolkit/13.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Percona Toolkit category](https://forums.percona.com/t/about-the-percona-toolkit-category/18)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 0\
**Last updated:** [December 30, 2020, 4:18pm UTC](https://forums.percona.com/t/about-the-percona-toolkit-category/18 "2020-12-30T16:18:21Z")

</div>

A set of utilities for MySQL®, MariaDB®, MongoDB®, & PostgreSQL.

---

## [Troubleshooting Percona Toolkit and How to Report a Bug](https://forums.percona.com/t/troubleshooting-percona-toolkit-and-how-to-report-a-bug/6163)

<div class="topic-metadata">

**Author:** [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)\
**Replies:** 0\
**Last updated:** [January 29, 2018, 7:39am UTC](https://forums.percona.com/t/troubleshooting-percona-toolkit-and-how-to-report-a-bug/6163 "2018-01-29T07:39:08Z")

</div>

We have a separate system for recording and reporting on bugs, for Percona Toolkit and for other Percona software. The forum is oriented towards discussion and advice rather than to bug reporting and fixing. Here are a …

---

## [Pt-osc / MariaDB 11.4 - triggers on new table where DEFINER was role1 - created with DEFINER as user (role1@%)](https://forums.percona.com/t/pt-osc-mariadb-11-4-triggers-on-new-table-where-definer-was-role1-created-with-definer-as-user-role1/41213)

<div class="topic-metadata">

**Author:** [@psumner](https://forums.percona.com/u/psumner)\
**Replies:** 2\
**Last updated:** [September 21, 2026, 5:03am UTC](https://forums.percona.com/t/pt-osc-mariadb-11-4-triggers-on-new-table-where-definer-was-role1-created-with-definer-as-user-role1/41213 "2026-09-21T05:03:33Z")

</div>

\<user\>@\<server\>:~$ pt-online-schema-change --version pt-online-schema-change 3.6.0 Recently ran pt-osc to add an index on a table which has after update/insert/delete triggers, all with DEFINER=role1 After successfully…

---

## [When will Percona Toolkit 3.7.2 be available?](https://forums.percona.com/t/when-will-percona-toolkit-3-7-2-be-available/40486)

<div class="topic-metadata">

**Author:** [@chris-card](https://forums.percona.com/u/chris-card)\
**Replies:** 10\
**Last updated:** [September 7, 2026, 1:54pm UTC](https://forums.percona.com/t/when-will-percona-toolkit-3-7-2-be-available/40486 "2026-09-07T13:54:42Z")

</div>

When will Percona Toolkit 3.7.2 be available? I want the fix for Jira

---

## [Pt-online schema change altering host IP; can't bypass replication checks](https://forums.percona.com/t/pt-online-schema-change-altering-host-ip-cant-bypass-replication-checks/40922)

<div class="topic-metadata">

**Author:** [@Alex\_Porter](https://forums.percona.com/u/Alex_Porter)\
**Replies:** 12\
**Last updated:** [June 26, 2026, 4:59pm UTC](https://forums.percona.com/t/pt-online-schema-change-altering-host-ip-cant-bypass-replication-checks/40922 "2026-06-26T16:59:19Z")

</div>

Hello, I’m trying to use pt-online-schema-change version 3.7.1 with MySQL 8.0.42 on AWS Aurora. I’m having the same issue described here, where it’s changing my host string to an IP address I can’t access. I’m tried s…

---

## [Pt-table-checksum 3.7.1: SHOW REPLICAS issued against MariaDB on builds with non-default version\_comment](https://forums.percona.com/t/pt-table-checksum-3-7-1-show-replicas-issued-against-mariadb-on-builds-with-non-default-version-comment/40774)

<div class="topic-metadata">

**Author:** [@samjvaughan](https://forums.percona.com/u/samjvaughan)\
**Replies:** 3\
**Last updated:** [May 14, 2026, 10:58pm UTC](https://forums.percona.com/t/pt-table-checksum-3-7-1-show-replicas-issued-against-mariadb-on-builds-with-non-default-version-comment/40774 "2026-05-14T22:58:52Z")

</div>

(apologies - tried to submit on Jira but I get persistent “you are not authorised” errors) pt-table-checksum 3.7.1: SHOW REPLICAS issued against MariaDB on builds with non-default version\_comment Summary pt-table-checks…

---

## [Package Conflicts with MariaDB 10.11 Community Repo and percona-toolkit on RHEL9](https://forums.percona.com/t/package-conflicts-with-mariadb-10-11-community-repo-and-percona-toolkit-on-rhel9/40020)

<div class="topic-metadata">

**Author:** [@fst](https://forums.percona.com/u/fst)\
**Replies:** 2\
**Last updated:** [January 12, 2026, 9:34am UTC](https://forums.percona.com/t/package-conflicts-with-mariadb-10-11-community-repo-and-percona-toolkit-on-rhel9/40020 "2026-01-12T09:34:35Z")

</div>

Hello everyone, I am having a problem installing the toolkit on RHEL9 and MariaDB 10.11 from the community repository. When I try to install it, there is always a package conflict between MariaDB-common (required by Ma…

---

## [MariaDB 11.8.5 error Argument "" isn't numeric in numeric comparison (\<=\>) at /usr/bin/pt-deadlock-logger line 5200](https://forums.percona.com/t/mariadb-11-8-5-error-argument-isnt-numeric-in-numeric-comparison-at-usr-bin-pt-deadlock-logger-line-5200/39875)

<div class="topic-metadata">

**Author:** [@poltpolt](https://forums.percona.com/u/poltpolt)\
**Replies:** 3\
**Last updated:** [January 2, 2026, 9:35am UTC](https://forums.percona.com/t/mariadb-11-8-5-error-argument-isnt-numeric-in-numeric-comparison-at-usr-bin-pt-deadlock-logger-line-5200/39875 "2026-01-02T09:35:42Z")

</div>

Hi on Ubuntu 24.04 i installed official deb pt-deadlock-logger 3.7.0 and mariadbd Ver 11.8.5-MariaDB-ubu2404-log I get the error from the topic, anybody has any ideeas and the line 5200 starts like this: foreach m…

---

## [Adverse effects of specifying --no-checkplan for pt-online-schema-change?](https://forums.percona.com/t/adverse-effects-of-specifying-no-checkplan-for-pt-online-schema-change/4557)

<div class="topic-metadata">

**Author:** [@dw\_rchau](https://forums.percona.com/u/dw_rchau)\
**Replies:** 2\
**Last updated:** [October 26, 2025, 3:12pm UTC](https://forums.percona.com/t/adverse-effects-of-specifying-no-checkplan-for-pt-online-schema-change/4557 "2025-10-26T15:12:56Z")

</div>

Hi there, I’ve recently run into a situation where I could not perform online alter table operations to modify the type of one column from tinyint(3) unsigned to int(10) unsigned using the pt-online-schema-change withou…

---

## [When is percona-toolkit coming to RHEL10?](https://forums.percona.com/t/when-is-percona-toolkit-coming-to-rhel10/39422)

<div class="topic-metadata">

**Author:** [@Seth\_Lohr](https://forums.percona.com/u/Seth_Lohr)\
**Replies:** 6\
**Last updated:** [October 1, 2025, 4:53pm UTC](https://forums.percona.com/t/when-is-percona-toolkit-coming-to-rhel10/39422 "2025-10-01T16:53:11Z")

</div>

For my own records, this is related to SOC-5151 It’s not listed as an option here: https://www.percona.com/percona-toolkit

---

## [Script pt-online-schema-change set new\_table\_name for all records in history table](https://forums.percona.com/t/script-pt-online-schema-change-set-new-table-name-for-all-records-in-history-table/39481)

<div class="topic-metadata">

**Author:** [@infis](https://forums.percona.com/u/infis)\
**Replies:** 0\
**Last updated:** [October 1, 2025, 8:13am UTC](https://forums.percona.com/t/script-pt-online-schema-change-set-new-table-name-for-all-records-in-history-table/39481 "2025-10-01T08:13:08Z")

</div>

I execute multiple jobs and found in history table pt\_osc\_history all records with one value in new\_table\_name field. In script I see: $ tail -n +9797 pt-online-schema-change | head -n 6 if ( $o-\>get('history') ) { …

---

## [Percona Toolkit 3.7 not showing for yum repo](https://forums.percona.com/t/percona-toolkit-3-7-not-showing-for-yum-repo/39448)

<div class="topic-metadata">

**Author:** [@jhbremer1](https://forums.percona.com/u/jhbremer1)\
**Replies:** 1\
**Last updated:** [September 25, 2025, 7:09am UTC](https://forums.percona.com/t/percona-toolkit-3-7-not-showing-for-yum-repo/39448 "2025-09-25T07:09:14Z")

</div>

Hello, I’m trying to update Percona Toolkit (specifically, the pt-table-checksum program) from 3.6→3.7. I’m running MySQL 8.4 instances, so that version of the toolkit is needed due to the keyword changes related to sla…

---

## [\--where clause incorrectly applied to child tables in pt-online-schema-change (causes “unknown column” error)](https://forums.percona.com/t/where-clause-incorrectly-applied-to-child-tables-in-pt-online-schema-change-causes-unknown-column-error/39442)

<div class="topic-metadata">

**Author:** [@rukbat](https://forums.percona.com/u/rukbat)\
**Replies:** 1\
**Last updated:** [September 24, 2025, 6:47pm UTC](https://forums.percona.com/t/where-clause-incorrectly-applied-to-child-tables-in-pt-online-schema-change-causes-unknown-column-error/39442 "2025-09-24T18:47:33Z")

</div>

Hello, when using pt-online-schema-change with the --where option on a table that has foreign-key child tables, the tool crashes during the row-estimate phase for each child. Steps to reproduce: Create two tables with…

---

## [Pt-archiver When archiving data, when encountering table data containing line breaks, an abnormal export occurs](https://forums.percona.com/t/pt-archiver-when-archiving-data-when-encountering-table-data-containing-line-breaks-an-abnormal-export-occurs/39285)

<div class="topic-metadata">

**Author:** [@baker](https://forums.percona.com/u/baker)\
**Replies:** 5\
**Last updated:** [September 16, 2025, 11:32am UTC](https://forums.percona.com/t/pt-archiver-when-archiving-data-when-encountering-table-data-containing-line-breaks-an-abnormal-export-occurs/39285 "2025-09-16T11:32:18Z")

</div>

I encountered a peculiar exception while archiving data using the pt-archiver tool. After investigation, I discovered that a varchar field in my source table contained a line break in its data. This altered the original …

---

## [When pt-archiver archives MySQL json fields, garbled characters appear](https://forums.percona.com/t/when-pt-archiver-archives-mysql-json-fields-garbled-characters-appear/39307)

<div class="topic-metadata">

**Author:** [@baker](https://forums.percona.com/u/baker)\
**Replies:** 2\
**Last updated:** [September 16, 2025, 4:50am UTC](https://forums.percona.com/t/when-pt-archiver-archives-mysql-json-fields-garbled-characters-appear/39307 "2025-09-16T04:50:23Z")

</div>

The scenario is as follows: This is the command executed: pt-archiver --limit 5000 --txn-size 5000 --progress 5000 --statistics --bulk-insert --charset=utf8mb4 --no-check-charset --no-check-columns Table character set…

---

## [Getting error "Plugin caching\_sha2\_password could not be loaded" on PT-QUERY-DIGEST](https://forums.percona.com/t/getting-error-plugin-caching-sha2-password-could-not-be-loaded-on-pt-query-digest/39308)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 3\
**Last updated:** [September 11, 2025, 11:05am UTC](https://forums.percona.com/t/getting-error-plugin-caching-sha2-password-could-not-be-loaded-on-pt-query-digest/39308 "2025-09-11T11:05:43Z")

</div>

Hello dear Percona team, after modifying our users from “mysql\_native\_password“ to “caching\_sha2\_password“ authentication plugin, a script that calls “pt-query-digest“ started to fail with this error: DBI connect(';hos…

---

## [Pt-online-schema-change with master-master replication, how that work?](https://forums.percona.com/t/pt-online-schema-change-with-master-master-replication-how-that-work/38871)

<div class="topic-metadata">

**Author:** [@TAndreotti](https://forums.percona.com/u/TAndreotti)\
**Replies:** 4\
**Last updated:** [July 30, 2025, 6:10am UTC](https://forums.percona.com/t/pt-online-schema-change-with-master-master-replication-how-that-work/38871 "2025-07-30T06:10:17Z")

</div>

Hi, I have a master-master cluster (with an arbitrator to make the third node). My cluster contains 1000 databases with 170 tables. Our app connects through the cluster using an IP failover, so if the first server crash…

---

## [HELP pt-query-digest for PROCESSLIST](https://forums.percona.com/t/help-pt-query-digest-for-processlist/5420)

<div class="topic-metadata">

**Author:** [@kpanacy\_olb](https://forums.percona.com/u/kpanacy_olb)\
**Replies:** 5\
**Last updated:** [July 3, 2025, 10:46am UTC](https://forums.percona.com/t/help-pt-query-digest-for-processlist/5420 "2025-07-03T10:46:52Z")

</div>

Hello, I used Maatkit before it became Percona Toolkit and could regularly run this: mk-query-digest --processlist h=host,D=db,u=uname,p=pwd --print --interval 0.5 \> /tmp/process\_qry.log When I try to run pt-query-dige…

---

## [Pt-archiver --columns with alias](https://forums.percona.com/t/pt-archiver-columns-with-alias/38142)

<div class="topic-metadata">

**Author:** [@luisgasca](https://forums.percona.com/u/luisgasca)\
**Replies:** 1\
**Last updated:** [June 26, 2025, 7:23am UTC](https://forums.percona.com/t/pt-archiver-columns-with-alias/38142 "2025-06-26T07:23:52Z")

</div>

I need to export a given value which is extracted with a call to a function. Like so: SELECT getCountry(md) as geo FROM table It seems that --columns 'getCountry(md) as geo' does not work DBD::mysql::st execute failed…

---

## [Percona Toolkit in two repositories with different version](https://forums.percona.com/t/percona-toolkit-in-two-repositories-with-different-version/38439)

<div class="topic-metadata">

**Author:** [@AndreasM](https://forums.percona.com/u/AndreasM)\
**Replies:** 3\
**Last updated:** [June 25, 2025, 11:30am UTC](https://forums.percona.com/t/percona-toolkit-in-two-repositories-with-different-version/38439 "2025-06-25T11:30:06Z")

</div>

Hi all, just stumbled on a problem installing the newest version of percona-toolkit. I knew from your website that there is a new release 3.7.0-2 out there. I have percona-toolkit installed from your repositories and …

---

## [Pt-query-digest no truncate long params on history mode](https://forums.percona.com/t/pt-query-digest-no-truncate-long-params-on-history-mode/38001)

<div class="topic-metadata">

**Author:** [@PavelVD](https://forums.percona.com/u/PavelVD)\
**Replies:** 0\
**Last updated:** [May 19, 2025, 8:54am UTC](https://forums.percona.com/t/pt-query-digest-no-truncate-long-params-on-history-mode/38001 "2025-05-19T08:54:28Z")

</div>

Hi all. When i collect report pt-query-digest to file - i see on long query trim for long parameters list (example) id in (2,3,4,5,6,6,7,8,8,9,124,324,25,24,524,6,264./\* … omited XXXX items … \*/ But when i run pt-quer…

---

## [Problem with installing percona-toolkit 3.7.0](https://forums.percona.com/t/problem-with-installing-percona-toolkit-3-7-0/37371)

<div class="topic-metadata">

**Author:** [@Amir\_Kheirabadi](https://forums.percona.com/u/Amir_Kheirabadi)\
**Replies:** 1\
**Last updated:** [April 17, 2025, 11:26pm UTC](https://forums.percona.com/t/problem-with-installing-percona-toolkit-3-7-0/37371 "2025-04-17T23:26:03Z")

</div>

Hey, I’m having trouble installing percona-toolkit on Amazon Linux. The system currently has version 3.6.0 installed, but we need to upgrade to 3.7.0 to address some CVEs. However, it looks like version 3.7.0 isn’t avai…

---

## [Pt-deadlock-logger - "The client was disconnected by the server because of inactivity."](https://forums.percona.com/t/pt-deadlock-logger-the-client-was-disconnected-by-the-server-because-of-inactivity/37628)

<div class="topic-metadata">

**Author:** [@nunop](https://forums.percona.com/u/nunop)\
**Replies:** 3\
**Last updated:** [April 16, 2025, 1:39am UTC](https://forums.percona.com/t/pt-deadlock-logger-the-client-was-disconnected-by-the-server-because-of-inactivity/37628 "2025-04-16T01:39:11Z")

</div>

Hello, I have a long-running pt-deadlock-logger running on docker, that should catch all deadlocks happening, and logs to PERCONA\_SCHEMA. The problem is that it seems it keeps a “forever open” connection to the MySQL s…

---

## [Toolkit - pt-table-checksum - MariaDB 10.5](https://forums.percona.com/t/toolkit-pt-table-checksum-mariadb-10-5/37475)

<div class="topic-metadata">

**Author:** [@alfadown](https://forums.percona.com/u/alfadown)\
**Replies:** 3\
**Last updated:** [April 4, 2025, 6:04pm UTC](https://forums.percona.com/t/toolkit-pt-table-checksum-mariadb-10-5/37475 "2025-04-04T18:04:04Z")

</div>

I am trying to perform a replication audit between two MariaDB 10.5 instances using pt-table-checksum.... I am encountering errors, despite the options to bypass the checks. I created a percona.dsns table with the foll…

---

## [Percona Toolkit users are invited to an online stream with the developer](https://forums.percona.com/t/percona-toolkit-users-are-invited-to-an-online-stream-with-the-developer/37332)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0\
**Last updated:** [March 24, 2025, 2:11pm UTC](https://forums.percona.com/t/percona-toolkit-users-are-invited-to-an-online-stream-with-the-developer/37332 "2025-03-24T14:11:49Z")

</div>

Join us on March 27, 2025, at 13:30 GMT / 9:30 ET for an informative live stream featuring Sveta Smirnova, Principal Support Engineering Coordinator at Percona. In this session, Sveta will discuss the recent updates in M…

---

## [Pt-online-schema-change - failed with "Cannot determine the key\_len of the chunk index"](https://forums.percona.com/t/pt-online-schema-change-failed-with-cannot-determine-the-key-len-of-the-chunk-index/32487)

<div class="topic-metadata">

**Author:** [@virin\_t](https://forums.percona.com/u/virin_t)\
**Replies:** 16\
**Last updated:** [March 10, 2025, 3:45pm UTC](https://forums.percona.com/t/pt-online-schema-change-failed-with-cannot-determine-the-key-len-of-the-chunk-index/32487 "2025-03-10T15:45:13Z")

</div>

Hi I am trying to run pt-online-schema-change on a table like below pt-online-schema-change –alter=“CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4\_general\_ci” –chunk-size=100000 –chunk-time=1 –max-load threads…

---

## [Pt-online-schema-change error Can't connect to local MySQL server](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072)

<div class="topic-metadata">

**Author:** [@ph\_h](https://forums.percona.com/u/ph_h)\
**Replies:** 5\
**Last updated:** [March 10, 2025, 7:35am UTC](https://forums.percona.com/t/pt-online-schema-change-error-cant-connect-to-local-mysql-server/37072 "2025-03-10T07:35:38Z")

</div>

help me Ubuntu 24.04.2 LTS pt-online-schema-change 3.7.0 pt-online-schema-change --user=qos\_dev --ask-pass --host=rm-2ze81ryvx0k42106h239.mysql.rds.aliyuncs.com --port=3306 --alter “ADD COLUMN t\_id int NOT NULL DEFAUL…

---

## [Pt-table-checksum not compatible with MySQL 8.0.28?](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410)

<div class="topic-metadata">

**Author:** [@steffen](https://forums.percona.com/u/steffen)\
**Replies:** 2\
**Last updated:** [February 19, 2025, 6:51pm UTC](https://forums.percona.com/t/pt-table-checksum-not-compatible-with-mysql-8-0-28/14410 "2025-02-19T18:51:05Z")

</div>

Hi everyone, I tried to use pt-table-checksum (3.3.1) for checking a MySQL 8.0.28 replication. All I get is this error message: 02-15T16:39:25 Error checksumming table schemaname.tablename: Error executing checksum que…

---

## [Expire\_logs\_days =\> binlog\_expire\_logs\_seconds](https://forums.percona.com/t/expire-logs-days-binlog-expire-logs-seconds/36741)

<div class="topic-metadata">

**Author:** [@nunop](https://forums.percona.com/u/nunop)\
**Replies:** 1\
**Last updated:** [February 17, 2025, 2:41pm UTC](https://forums.percona.com/t/expire-logs-days-binlog-expire-logs-seconds/36741 "2025-02-17T14:41:00Z")

</div>

In pt-variable-advisor: WARN expire\_logs\_days: Binary logs are enabled, but automatic purging is not enabled. If you do not purge binary logs, your disk will fill up. expire\_logs\_days is deprecated, and this is what …

---

## [Innodb\_log\_file\_size =\> innodb\_redo\_log\_capacity](https://forums.percona.com/t/innodb-log-file-size-innodb-redo-log-capacity/36742)

<div class="topic-metadata">

**Author:** [@nunop](https://forums.percona.com/u/nunop)\
**Replies:** 1\
**Last updated:** [February 17, 2025, 2:39pm UTC](https://forums.percona.com/t/innodb-log-file-size-innodb-redo-log-capacity/36742 "2025-02-17T14:39:17Z")

</div>

In pt-variable-advisor: WARN innodb\_log\_file\_size: The InnoDB log file size is set to its default value, which is not usable on production systems. innodb\_log\_file\_size is deprecated, and this is what we should use n…

[Next page](https://forums.percona.com/c/polyglot-projects/percona-toolkit/13.md?page=1)
