# Percona Cloud Tools

**URL:** https://forums.percona.com/c/polyglot-projects/percona-cloud-tools/16.md?page=1

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 2

---

## [Query Profile is displaying the wrong query in the Query Plan section.](https://forums.percona.com/t/query-profile-is-displaying-the-wrong-query-in-the-query-plan-section/3756)

<div class="topic-metadata">

**Author:** [@rossiwa](https://forums.percona.com/u/rossiwa)\
**Replies:** 0\
**Last updated:** [September 19, 2014, 12:30pm UTC](https://forums.percona.com/t/query-profile-is-displaying-the-wrong-query-in-the-query-plan-section/3756 "2014-09-19T12:30:46Z")

</div>

The Query Profile page is displaying the wrong query in the query plan section of the page. For example, the query rank and query detail section show a UPDATE … statement. However, the query plan section is showing a SEL…

---

## [Unable to receive query analytics - agent error](https://forums.percona.com/t/unable-to-receive-query-analytics-agent-error/3745)

<div class="topic-metadata">

**Author:** [@bmorton](https://forums.percona.com/u/bmorton)\
**Replies:** 1\
**Last updated:** [September 17, 2014, 8:49pm UTC](https://forums.percona.com/t/unable-to-receive-query-analytics-agent-error/3745 "2014-09-17T20:49:13Z")

</div>

Waiting for API to ack qan\_1405566379376419373: read tcp 162.220.4.204:443: i/o timeout These happen repeatedly in my logs. Any ideas?

---

## ["access denied" failure](https://forums.percona.com/t/access-denied-failure/3608)

<div class="topic-metadata">

**Author:** [@pblazek](https://forums.percona.com/u/pblazek)\
**Replies:** 4\
**Last updated:** [August 27, 2014, 5:30pm UTC](https://forums.percona.com/t/access-denied-failure/3608 "2014-08-27T17:30:14Z")

</div>

I have just removed 1.0.3 and installed 1.0.4 on a server. I get: Warning 2014-07-10 13:16:09 mm-mysql-db1.towxchange.net Failed to connect to MySQL after 1 tries (Error 1045: Access denied for user ‘percona-agent’@‘loc…

---

## [pt-agent not rotate mysql-slow-log](https://forums.percona.com/t/pt-agent-not-rotate-mysql-slow-log/3700)

<div class="topic-metadata">

**Author:** [@szenobio](https://forums.percona.com/u/szenobio)\
**Replies:** 3\
**Last updated:** [August 27, 2014, 9:56am UTC](https://forums.percona.com/t/pt-agent-not-rotate-mysql-slow-log/3700 "2014-08-27T09:56:24Z")

</div>

Hi, I’m installed percona-agent-1.0.6-x86\_64.tar.gz. The tool work fine, but not rotate mysql-slow-log. In gui I configure Max slow query log size on 1GB but the file on disk is 5GB. I have this error on log from gui in…

---

## [getting 404 error on install](https://forums.percona.com/t/getting-404-error-on-install/3490)

<div class="topic-metadata">

**Author:** [@altmannmarcelo](https://forums.percona.com/u/altmannmarcelo)\
**Replies:** 5\
**Last updated:** [July 4, 2014, 2:35am UTC](https://forums.percona.com/t/getting-404-error-on-install/3490 "2014-07-04T02:35:31Z")

</div>

When I’m trying to install the percona-agent it’s exiting due a 404 error: \[root&#64;blog percona-agent-1.0.1-x86\_64\]# ./install Detected Linux x86\_64 CTRL-C at any time to quit API host: v2-cloud-api.percona.com API …

---

## [Running remotely?](https://forums.percona.com/t/running-remotely/3302)

<div class="topic-metadata">

**Author:** [@pauls](https://forums.percona.com/u/pauls)\
**Replies:** 3\
**Last updated:** [June 26, 2014, 11:06am UTC](https://forums.percona.com/t/running-remotely/3302 "2014-06-26T11:06:28Z")

</div>

How do you run pt-agent on another server that has internet access? We get an error about pt-agent@localhost not being able to login, even though we specified the host and user name at startup.

---

## [Sensitive Data In Queries](https://forums.percona.com/t/sensitive-data-in-queries/3474)

<div class="topic-metadata">

**Author:** [@Ruskicowboy](https://forums.percona.com/u/Ruskicowboy)\
**Replies:** 1\
**Last updated:** [June 6, 2014, 3:12am UTC](https://forums.percona.com/t/sensitive-data-in-queries/3474 "2014-06-06T03:12:32Z")

</div>

I’m testing this tool out on a DB that doesn’t have any sensitive data on it, but if the tool works out to be something we’d want to use, what would be a good way to keep things like encryption keys out of your logs?

---

## [Be careful with pt-agent](https://forums.percona.com/t/be-careful-with-pt-agent/3448)

<div class="topic-metadata">

**Author:** [@jeffstoner](https://forums.percona.com/u/jeffstoner)\
**Replies:** 1\
**Last updated:** [June 5, 2014, 3:59pm UTC](https://forums.percona.com/t/be-careful-with-pt-agent/3448 "2014-06-05T15:59:07Z")

</div>

When you run “pt-agent --install”, the configuration file it creates, /etc/percona/agent/my.cnf, will contain the username and password of a user with SUPER privileges. While this is necessary for the agent to function, …

---

## [How to uninstall?](https://forums.percona.com/t/how-to-uninstall/3473)

<div class="topic-metadata">

**Author:** [@noodlesnz](https://forums.percona.com/u/noodlesnz)\
**Replies:** 4\
**Last updated:** [May 19, 2014, 4:40pm UTC](https://forums.percona.com/t/how-to-uninstall/3473 "2014-05-19T16:40:31Z")

</div>

I didn’t realize that the agent would modify the long query time variable on my server. I already consolidate the slow query log from all my servers to one place so I now have a 700MB slow log file for today and I only t…

---

## [Unable to Install or get results sent , Mysql 5.6 not being detected](https://forums.percona.com/t/unable-to-install-or-get-results-sent-mysql-5-6-not-being-detected/3242)

<div class="topic-metadata">

**Author:** [@reallyimran](https://forums.percona.com/u/reallyimran)\
**Replies:** 3\
**Last updated:** [April 26, 2014, 2:12pm UTC](https://forums.percona.com/t/unable-to-install-or-get-results-sent-mysql-5-6-not-being-detected/3242 "2014-04-26T14:12:46Z")

</div>

My System Details : CentOS release 6.5 (Final) MySQL : Server version: 5.6.15-56 Percona Server (GPL), Release rel63.0, Revision 519 How I installed : I followed the guide on the website. Added the percona tools repo…

---

## [Rotation of query log](https://forums.percona.com/t/rotation-of-query-log/3410)

<div class="topic-metadata">

**Author:** [@piotr](https://forums.percona.com/u/piotr)\
**Replies:** 2\
**Last updated:** [April 19, 2014, 3:35am UTC](https://forums.percona.com/t/rotation-of-query-log/3410 "2014-04-19T03:35:12Z")

</div>

Hi! After enabling pt-agent daemon our server is producing large amount of slow query logs. Unfortunately after sending data to Percona Cloud servers, logs are rotated with current timestamp and not deleted. This is qui…

---

## [Adding users to Org](https://forums.percona.com/t/adding-users-to-org/3390)

<div class="topic-metadata">

**Author:** [@jeffstoner](https://forums.percona.com/u/jeffstoner)\
**Replies:** 2\
**Last updated:** [April 15, 2014, 7:52am UTC](https://forums.percona.com/t/adding-users-to-org/3390 "2014-04-15T07:52:54Z")

</div>

How do I add a user to my “organization” so they can view the reports? It’s not intuitively obvious.

---

## [Error starting query-history-all-5.1/ Unknown system variable 'log\_slow\_admin\_statements'](https://forums.percona.com/t/error-starting-query-history-all-5-1-unknown-system-variable-log-slow-admin-statements/3263)

<div class="topic-metadata">

**Author:** [@Matt](https://forums.percona.com/u/Matt)\
**Replies:** 2\
**Last updated:** [March 13, 2014, 4:25pm UTC](https://forums.percona.com/t/error-starting-query-history-all-5-1-unknown-system-variable-log-slow-admin-statements/3263 "2014-03-13T16:25:41Z")

</div>

I can’t seem to get any queries sent from my server. Here are error entries from my log: \[TABLE=“class: wysiwyg\_table\_table wysiwyg\_table\_table-bordered wysiwyg\_table\_table-condensed wysiwyg\_table\_table-orange wysiwyg\_ta…

---

## [Agents show: Exit: 201](https://forums.percona.com/t/agents-show-exit-201/3237)

<div class="topic-metadata">

**Author:** [@HubertusKrogmann](https://forums.percona.com/u/HubertusKrogmann)\
**Replies:** 9\
**Last updated:** [February 13, 2014, 9:51am UTC](https://forums.percona.com/t/agents-show-exit-201/3237 "2014-02-13T09:51:41Z")

</div>

Hello I installed pt-agent on 2 servers but no data seems to reach “the cloud”. in the agents view Status says Exit 201. what does that mean? Hubertus

---

## [Error starting query-history-all-5.1](https://forums.percona.com/t/error-starting-query-history-all-5-1/3203)

<div class="topic-metadata">

**Author:** [@ResHippie](https://forums.percona.com/u/ResHippie)\
**Replies:** 4\
**Last updated:** [January 20, 2014, 9:22pm UTC](https://forums.percona.com/t/error-starting-query-history-all-5-1/3203 "2014-01-20T21:22:51Z")

</div>

Error starting query-history-all-5.1, check /var/lib/pt-agent/logs/start-stop.log and /var/lib/pt-agent/logs/query-history-all-5.1.run I’m getting this as my status on both of the servers that I have set up. There is n…

[Previous page](https://forums.percona.com/c/polyglot-projects/percona-cloud-tools/16.md)
