# PMM 3.x

**URL:** https://forums.percona.com/c/percona-monitoring-and-management-pmm/pmm-3/84.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the PMM 3.x category](https://forums.percona.com/t/about-the-pmm-3-x-category/36417)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0\
**Last updated:** [January 30, 2025, 12:08pm UTC](https://forums.percona.com/t/about-the-pmm-3-x-category/36417 "2025-01-30T12:08:04Z")

</div>

Welcome to the PMM 3 Forum Category! This space is dedicated to discussions about version 3 of Percona Monitoring and Management. We welcome your questions and feedback. New Features in PMM 3: Security Enhancements: R…

---

## [PMM - disk latency graph](https://forums.percona.com/t/pmm-disk-latency-graph/41290)

<div class="topic-metadata">

**Author:** [@Andrey\_Virus](https://forums.percona.com/u/Andrey_Virus)\
**Replies:** 3\
**Last updated:** [September 29, 2026, 3:17pm UTC](https://forums.percona.com/t/pmm-disk-latency-graph/41290 "2026-09-29T15:17:30Z")

</div>

In PMM there is a “Disk Latency” graph. Its description says: Shows average latency for read and write IO operations. Higher than typical latency for highly loaded storage indicates saturation (overload) and is a frequ…

---

## [Python cryptography package version in docker image is outdated and vulnerable?](https://forums.percona.com/t/python-cryptography-package-version-in-docker-image-is-outdated-and-vulnerable/41233)

<div class="topic-metadata">

**Author:** [@jnicol](https://forums.percona.com/u/jnicol)\
**Replies:** 1\
**Last updated:** [September 3, 2026, 8:30am UTC](https://forums.percona.com/t/python-cryptography-package-version-in-docker-image-is-outdated-and-vulnerable/41233 "2026-09-03T08:30:37Z")

</div>

Hello, Our security scanning tool is reporting a high severity vulnerability on the version of python cryptography bundled in the docker image (PMM version 3.9.1). This has been open for some time and the package has n…

---

## [PMM not starting after upgrade to 3.9.1](https://forums.percona.com/t/pmm-not-starting-after-upgrade-to-3-9-1/41211)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 2\
**Last updated:** [August 27, 2026, 12:23pm UTC](https://forums.percona.com/t/pmm-not-starting-after-upgrade-to-3-9-1/41211 "2026-08-27T12:23:40Z")

</div>

Hello Percona team, after performing an upgrade from PMM 3.7.1 to 3.9.1 (Docker) the upgrated container is not coming up with no apparent reasons. Running a “docker logs ” I get this: Running as UID 1000 Creating ngin…

---

## [PMM 3.6 Remote MySQL service on Windows connects successfully but remains Down (mysql\_up = 0](https://forums.percona.com/t/pmm-3-6-remote-mysql-service-on-windows-connects-successfully-but-remains-down-mysql-up-0/41065)

<div class="topic-metadata">

**Author:** [@smitha](https://forums.percona.com/u/smitha)\
**Replies:** 2\
**Last updated:** [July 16, 2026, 8:33am UTC](https://forums.percona.com/t/pmm-3-6-remote-mysql-service-on-windows-connects-successfully-but-remains-down-mysql-up-0/41065 "2026-07-16T08:33:30Z")

</div>

Environment PMM Server 3.6 Oracle Linux 8 Podman MySQL 5.7.13 Enterprise on Windows Server Problem I am adding a Windows-hosted MySQL instance using: Inventory → Add Service → MySQL (Remote) The service is created …

---

## [How to configure proxy for PMM Server?](https://forums.percona.com/t/how-to-configure-proxy-for-pmm-server/40786)

<div class="topic-metadata">

**Author:** [@bentse](https://forums.percona.com/u/bentse)\
**Replies:** 2\
**Last updated:** [July 15, 2026, 4:15pm UTC](https://forums.percona.com/t/how-to-configure-proxy-for-pmm-server/40786 "2026-07-15T16:15:01Z")

</div>

We have a dockerized PMM3 installation in a partly locked infra: internet can be reached through proxy. There’s a note about this here: Network and firewall requirements - Percona Monitoring and Management configure a…

---

## [PMM 3.8.1 and MongoDB 8.3](https://forums.percona.com/t/pmm-3-8-1-and-mongodb-8-3/41035)

<div class="topic-metadata">

**Author:** [@PatrickV](https://forums.percona.com/u/PatrickV)\
**Replies:** 2\
**Last updated:** [July 8, 2026, 11:30am UTC](https://forums.percona.com/t/pmm-3-8-1-and-mongodb-8-3/41035 "2026-07-08T11:30:00Z")

</div>

Hello, I’m using latest version of PMM and MongoDB. I add 3 mongodb to pmm with : pmm-admin add mongodb –username=pmm –password=mypass –host=myhost1 –port=myport –query-source=profiler –environment=acc –cluster=…

---

## [PMM3 + mongodb. 2 questions - about mongodb\_mongolog\_agent and Query Analytics panel](https://forums.percona.com/t/pmm3-mongodb-2-questions-about-mongodb-mongolog-agent-and-query-analytics-panel/40045)

<div class="topic-metadata">

**Author:** [@G\_Sl](https://forums.percona.com/u/G_Sl)\
**Replies:** 3\
**Last updated:** [June 2, 2026, 8:36am UTC](https://forums.percona.com/t/pmm3-mongodb-2-questions-about-mongodb-mongolog-agent-and-query-analytics-panel/40045 "2026-06-02T08:36:28Z")

</div>

Firts of all, thx four your beautifull app guys! It really helps ! So we use pmm server 3.3.0 with pmm-client-3.4.1 for gathering stats from mongodb nodes. And found some problems. 1. After restart mongod service , m…

---

## [Why does pg\_stat\_monitor trigger a PostgreSQL restart?](https://forums.percona.com/t/why-does-pg-stat-monitor-trigger-a-postgresql-restart/39942)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 6\
**Last updated:** [May 9, 2026, 9:28pm UTC](https://forums.percona.com/t/why-does-pg-stat-monitor-trigger-a-postgresql-restart/39942 "2026-05-09T21:28:00Z")

</div>

PostgreSQL version 14.17, PMM 3.4.1., pg\_stat\_monitor 2.2 The server has 32GB RAM, 28% allocated for huge pages, shared\_buffers size is 25%. The PostgreSQL logs contain the following entries: received immediate shutdow…

---

## [Pmm 3.7.0 system summary dislay error](https://forums.percona.com/t/pmm-3-7-0-system-summary-dislay-error/40702)

<div class="topic-metadata">

**Author:** [@cmj\_cmj](https://forums.percona.com/u/cmj_cmj)\
**Replies:** 5\
**Last updated:** [May 8, 2026, 1:41am UTC](https://forums.percona.com/t/pmm-3-7-0-system-summary-dislay-error/40702 "2026-05-08T01:41:46Z")

</div>

hi, my friends, i get this error on the pmm system summary, but it’s ok when i run the command manually on the client, i check the path setting is ok to search the perl command,so why this happen?

---

## [Pmm-client v3.7.0 conflicting with itself](https://forums.percona.com/t/pmm-client-v3-7-0-conflicting-with-itself/40715)

<div class="topic-metadata">

**Author:** [@asnyp](https://forums.percona.com/u/asnyp)\
**Replies:** 2\
**Last updated:** [April 27, 2026, 10:50am UTC](https://forums.percona.com/t/pmm-client-v3-7-0-conflicting-with-itself/40715 "2026-04-27T10:50:57Z")

</div>

Hi everyone, I have set up the pmm to monitor some database instances across different hosts but I keep getting alerts that the pmm-client package has a conflict defined with itself: # dnf install pmm-client Installed:…

---

## [PMM 3.6.0: Drilldown Logs App not found](https://forums.percona.com/t/pmm-3-6-0-drilldown-logs-app-not-found/40707)

<div class="topic-metadata">

**Author:** [@shigaev.s](https://forums.percona.com/u/shigaev.s)\
**Replies:** 1\
**Last updated:** [April 24, 2026, 2:43pm UTC](https://forums.percona.com/t/pmm-3-6-0-drilldown-logs-app-not-found/40707 "2026-04-24T14:43:58Z")

</div>

Hello! After updating PMM from 3.5.0 to 3.6.0, Drilldown Logs doesn’t work. The UI changed significantly in 3.6. Previously, you could open Drilldown from the menu, but now you can’t. And when going from Explore to Dr…

---

## [Upgrade from 3.6 to 3.7 fails](https://forums.percona.com/t/upgrade-from-3-6-to-3-7-fails/40670)

<div class="topic-metadata">

**Author:** [@ks27](https://forums.percona.com/u/ks27)\
**Replies:** 1\
**Last updated:** [April 18, 2026, 4:41pm UTC](https://forums.percona.com/t/upgrade-from-3-6-to-3-7-fails/40670 "2026-04-18T16:41:19Z")

</div>

Just pulled pmm 3.7, started as usual, but the container stays “unhealthy” and postgresgl14.log shows a lot of 2026-04-18 13:06:05.050 UTC \[1175\] FATAL: password authentication failed for user “pmm-managed” 2026-04-18…

---

## [PMM3.7 - Getting error "refused to connect" on all panels after upgrade to 3.7.0](https://forums.percona.com/t/pmm3-7-getting-error-refused-to-connect-on-all-panels-after-upgrade-to-3-7-0/40635)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 3\
**Last updated:** [April 17, 2026, 7:46am UTC](https://forums.percona.com/t/pmm3-7-getting-error-refused-to-connect-on-all-panels-after-upgrade-to-3-7-0/40635 "2026-04-17T07:46:50Z")

</div>

Hello dear Percona team, after upgrading PMM from 3.5.0 to 3.7.0, we started to observed an error on some pages. Not the entire page, actually, but on frames within the page. The console loads without any issues, and we…

---

## [PMM3.7 - Getting error "tls: failed to verify certificate: x509: certificate is valid for" while adding a MySQL database](https://forums.percona.com/t/pmm3-7-getting-error-tls-failed-to-verify-certificate-x509-certificate-is-valid-for-while-adding-a-mysql-database/40581)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 4\
**Last updated:** [April 9, 2026, 7:36am UTC](https://forums.percona.com/t/pmm3-7-getting-error-tls-failed-to-verify-certificate-x509-certificate-is-valid-for-while-adding-a-mysql-database/40581 "2026-04-09T07:36:32Z")

</div>

Hello dear Percona team, I am testing PMM 3.7 (Docker container). Setup was all good, but while adding a MySQL database as a target with this command: sudo pmm-admin add mysql --server-url='https://admin:\<pwd\>@\<host-wh…

---

## [Documentation gap: PMM\_CLICKHOUSE\_IS\_CLUSTER / PMM\_CLICKHOUSE\_CLUSTER\_NAME for HA + external ClickHouse](https://forums.percona.com/t/documentation-gap-pmm-clickhouse-is-cluster-pmm-clickhouse-cluster-name-for-ha-external-clickhouse/40591)

<div class="topic-metadata">

**Author:** [@ddkozyreva](https://forums.percona.com/u/ddkozyreva)\
**Replies:** 0\
**Last updated:** [April 9, 2026, 1:13am UTC](https://forums.percona.com/t/documentation-gap-pmm-clickhouse-is-cluster-pmm-clickhouse-cluster-name-for-ha-external-clickhouse/40591 "2026-04-09T01:13:56Z")

</div>

Hi team! I’d like to flag a documentation gap that cost us several hours of debugging in a PMM 3.6.0 HA setup with an external 3-node ClickHouse cluster (one shard, three replicas, ZooKeeper present, macros configured). …

---

## [Possible HA issue with /srv/pmm-encryption.key not being shared between nodes](https://forums.percona.com/t/possible-ha-issue-with-srv-pmm-encryption-key-not-being-shared-between-nodes/40583)

<div class="topic-metadata">

**Author:** [@ddkozyreva](https://forums.percona.com/u/ddkozyreva)\
**Replies:** 1\
**Last updated:** [April 8, 2026, 10:30am UTC](https://forums.percona.com/t/possible-ha-issue-with-srv-pmm-encryption-key-not-being-shared-between-nodes/40583 "2026-04-08T10:30:45Z")

</div>

Hi team, I’ve been running a 3-node PMM Server HA cluster (PMM 3.6.0, Docker, deployed per the official HA guide with shared external PostgreSQL and ClickHouse) and ran into something that looks like a regression compar…

---

## [Discovered a bug in PMM 3.6.0 PostgreSQL exporter (CloudSQL)](https://forums.percona.com/t/discovered-a-bug-in-pmm-3-6-0-postgresql-exporter-cloudsql/40384)

<div class="topic-metadata">

**Author:** [@Simeon\_Petkov](https://forums.percona.com/u/Simeon_Petkov)\
**Replies:** 1\
**Last updated:** [April 2, 2026, 7:58pm UTC](https://forums.percona.com/t/discovered-a-bug-in-pmm-3-6-0-postgresql-exporter-cloudsql/40384 "2026-04-02T19:58:08Z")

</div>

Hello all, Yesterday after some debugging I have found that PostgreSQL exporter crashes when adding a new CloudSQL service when in “pg\_settings” we have “google\_dataplex.max\_messages” with a value like “-1:132” More de…

---

## [Renaming node and service](https://forums.percona.com/t/renaming-node-and-service/40408)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 3\
**Last updated:** [March 30, 2026, 3:18am UTC](https://forums.percona.com/t/renaming-node-and-service/40408 "2026-03-30T03:18:18Z")

</div>

Help! How to rename a host and services without an unregister operation? So as not to lose all the metric history for the host and its services. PMM version 3.5.0

---

## [\[RFC\] Redesigning QAN: Help us nail the new UX/UI](https://forums.percona.com/t/rfc-redesigning-qan-help-us-nail-the-new-ux-ui/40401)

<div class="topic-metadata">

**Author:** [@pedro.fernandes](https://forums.percona.com/u/pedro.fernandes)\
**Replies:** 0\
**Last updated:** [March 25, 2026, 8:37am UTC](https://forums.percona.com/t/rfc-redesigning-qan-help-us-nail-the-new-ux-ui/40401 "2026-03-25T08:37:37Z")

</div>

Hi everyone, The PMM team is working on a major frontend-focused redesign for Query Analytics (QAN). Our goal is to make troubleshooting faster and less cluttered without losing the deep technical DNA you rely on. W…

---

## [Not able to change pmm password in kube](https://forums.percona.com/t/not-able-to-change-pmm-password-in-kube/39369)

<div class="topic-metadata">

**Author:** [@Pramod\_Kumar\_Gupta](https://forums.percona.com/u/Pramod_Kumar_Gupta)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:32am UTC](https://forums.percona.com/t/not-able-to-change-pmm-password-in-kube/39369 "2026-03-24T08:32:59Z")

</div>

change-admin-password pramod123 this command show changed successfully but its not working i am using this deployment apiVersion: apps/v1 kind: Deployment metadata: name: pmm-server namespace: pmm spec: replicas…

---

## [PMM Discovery Error](https://forums.percona.com/t/pmm-discovery-error/39791)

<div class="topic-metadata">

**Author:** [@Sarma\_Chavali](https://forums.percona.com/u/Sarma_Chavali)\
**Replies:** 2\
**Last updated:** [March 24, 2026, 8:20am UTC](https://forums.percona.com/t/pmm-discovery-error/39791 "2026-03-24T08:20:20Z")

</div>

Description: We have installed PMM from AWS Market place; Trying to add RDS server discovery AWS using below methos IAM user credentials IAM Role(with assume role) Got timeout error; We have downloaded the logs;In li…

---

## [How i can create custom dashboard which is all rds instances running in B account via Assume role between A and B accounts](https://forums.percona.com/t/how-i-can-create-custom-dashboard-which-is-all-rds-instances-running-in-b-account-via-assume-role-between-a-and-b-accounts/39818)

<div class="topic-metadata">

**Author:** [@vasu1](https://forums.percona.com/u/vasu1)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:15am UTC](https://forums.percona.com/t/how-i-can-create-custom-dashboard-which-is-all-rds-instances-running-in-b-account-via-assume-role-between-a-and-b-accounts/39818 "2026-03-24T08:15:13Z")

</div>

Hello Team, I have a few questions regarding PMM 3.x and its integration with multiple AWS accounts. Environment Details I have multiple AWS accounts (A, B, C, D, etc.). PMM Server is deployed using the AWS Marke…

---

## [QAN: Is there a way to change a column in Overview to show "Sum" or "Per Query stats" instead?](https://forums.percona.com/t/qan-is-there-a-way-to-change-a-column-in-overview-to-show-sum-or-per-query-stats-instead/40042)

<div class="topic-metadata">

**Author:** [@laund](https://forums.percona.com/u/laund)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:06am UTC](https://forums.percona.com/t/qan-is-there-a-way-to-change-a-column-in-overview-to-show-sum-or-per-query-stats-instead/40042 "2026-03-24T08:06:28Z")

</div>

Hello! In QAN, when i click on a query to see its details, its statistics shows me 3 views/aggregates of the stats: Rate/Second Sum Per Query Stats But when i add a column to the overview, it seems to always use “Rat…

---

## [MongoDB Collection overview - missing data](https://forums.percona.com/t/mongodb-collection-overview-missing-data/40381)

<div class="topic-metadata">

**Author:** [@MarekPlichta](https://forums.percona.com/u/MarekPlichta)\
**Replies:** 1\
**Last updated:** [March 20, 2026, 11:26am UTC](https://forums.percona.com/t/mongodb-collection-overview-missing-data/40381 "2026-03-20T11:26:01Z")

</div>

Edit: I managed to fix it. For anyone dealing with a similar problem, the issue was that the default max-collections-limit is set to 200, but since my instance had over 300 collections in total, it wasn’t getting collect…

---

## [Missing \`orgs:read\` permission as "Admin" since upgrade to PMM v3.6.0](https://forums.percona.com/t/missing-orgs-read-permission-as-admin-since-upgrade-to-pmm-v3-6-0/40357)

<div class="topic-metadata">

**Author:** [@hvtilborg](https://forums.percona.com/u/hvtilborg)\
**Replies:** 4\
**Last updated:** [March 16, 2026, 3:35pm UTC](https://forums.percona.com/t/missing-orgs-read-permission-as-admin-since-upgrade-to-pmm-v3-6-0/40357 "2026-03-16T15:35:28Z")

</div>

Although I have the “Admin” role (provisioned using generic OAuth), I cannot open PMM v3.6.0’s: Opening “Configuration” \> “Org. management” \> “Organizations”, results in: While opening “Configuration” \> “Org. ma…

---

## [PMM 3.6.0 – ClickHouse background merge loop on system.metric\_log causing 100% CPU and repeated MEMORY\_LIMIT\_EXCEEDED](https://forums.percona.com/t/pmm-3-6-0-clickhouse-background-merge-loop-on-system-metric-log-causing-100-cpu-and-repeated-memory-limit-exceeded/40362)

<div class="topic-metadata">

**Author:** [@Henryx](https://forums.percona.com/u/Henryx)\
**Replies:** 1\
**Last updated:** [March 15, 2026, 9:34am UTC](https://forums.percona.com/t/pmm-3-6-0-clickhouse-background-merge-loop-on-system-metric-log-causing-100-cpu-and-repeated-memory-limit-exceeded/40362 "2026-03-15T09:34:54Z")

</div>

Hello, I am experiencing a severe performance issue with PMM 3.6.0 where the server becomes extremely slow and CPU usage reaches 100% continuously. Investigation shows that ClickHouse repeatedly attempts background mer…

---

## [UI annoyances when PMM upgrades are disabled in v3.6.0](https://forums.percona.com/t/ui-annoyances-when-pmm-upgrades-are-disabled-in-v3-6-0/40356)

<div class="topic-metadata">

**Author:** [@hvtilborg](https://forums.percona.com/u/hvtilborg)\
**Replies:** 3\
**Last updated:** [March 13, 2026, 2:25pm UTC](https://forums.percona.com/t/ui-annoyances-when-pmm-upgrades-are-disabled-in-v3-6-0/40356 "2026-03-13T14:25:07Z")

</div>

Because reasons™, we have disabled upgrades for PMM (using PMM\_ENABLE\_UPDATES=false). This results in some UI annoyances in PMM v3.6.0: In the “Updates” pane, there are very many non-numbers: In the menu, “Updates” …

---

## [Connect\_timeout=1s is too short](https://forums.percona.com/t/connect-timeout-1s-is-too-short/40338)

<div class="topic-metadata">

**Author:** [@zoyaaboujaish](https://forums.percona.com/u/zoyaaboujaish)\
**Replies:** 1\
**Last updated:** [March 7, 2026, 2:52pm UTC](https://forums.percona.com/t/connect-timeout-1s-is-too-short/40338 "2026-03-07T14:52:18Z")

</div>

Main Issue: frequent connection drops are occurring to certain databases connected to PMM. The drop is happening because the connect timeout value is not long enough for the current setup to establish a connection. The …

---

## [PMM databases showed intermittent "down" status due to scrape timeouts being too short](https://forums.percona.com/t/pmm-databases-showed-intermittent-down-status-due-to-scrape-timeouts-being-too-short/40328)

<div class="topic-metadata">

**Author:** [@zoyaaboujaish](https://forums.percona.com/u/zoyaaboujaish)\
**Replies:** 3\
**Last updated:** [March 4, 2026, 7:45pm UTC](https://forums.percona.com/t/pmm-databases-showed-intermittent-down-status-due-to-scrape-timeouts-being-too-short/40328 "2026-03-04T19:45:40Z")

</div>

Is there a better way to resolve this issue permanently?\*\* Problem\*\* PMM databases showed intermittent “down” status due to scrape timeouts being too short: HR jobs: 9s (too short) MR jobs: 13.5s (too short) LR…

[Next page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/pmm-3/84.md?page=1)
