# PMM 2.x

**URL:** https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=4

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 5

---

## [PMM Server/Client Docker SSL Issue](https://forums.percona.com/t/pmm-server-client-docker-ssl-issue/20126)

<div class="topic-metadata">

**Author:** [@jbl1](https://forums.percona.com/u/jbl1)\
**Replies:** 11\
**Last updated:** [April 6, 2023, 6:08am UTC](https://forums.percona.com/t/pmm-server-client-docker-ssl-issue/20126 "2023-04-06T06:08:53Z")

</div>

Following using the docs: Secure - Percona Monitoring and Management Using docker images: percona/pmm-server:2 percona/pmm-client:2 I’m running pmm-server on vm0 and I’m able to bring up the UI and see that the conne…

---

## [Multi channel replication in MariaDB 10.5](https://forums.percona.com/t/multi-channel-replication-in-mariadb-10-5/32257)

<div class="topic-metadata">

**Author:** [@tee952](https://forums.percona.com/u/tee952)\
**Replies:** 2\
**Last updated:** [August 14, 2024, 6:14pm UTC](https://forums.percona.com/t/multi-channel-replication-in-mariadb-10-5/32257 "2024-08-14T18:14:54Z")

</div>

Description: I am trying to setup replication monitoring for multi channel replication in MariaDB 10.5.21, but would like to see status of the replication for each channel individually. Can anyone let me know if this ca…

---

## [Does pg\_stat\_statements extension view needs to be created on all databases](https://forums.percona.com/t/does-pg-stat-statements-extension-view-needs-to-be-created-on-all-databases/32260)

<div class="topic-metadata">

**Author:** [@rups](https://forums.percona.com/u/rups)\
**Replies:** 4\
**Last updated:** [August 14, 2024, 4:22pm UTC](https://forums.percona.com/t/does-pg-stat-statements-extension-view-needs-to-be-created-on-all-databases/32260 "2024-08-14T16:22:15Z")

</div>

Hello, Does the extension needs to be created on each database separately for the QAN to capture the sqls ? ##Reference: Install the extension. psql postgres postgres -c "CREATE EXTENSION pg\_stat\_statements SCHEMA p…

---

## [Setting up the client connection to PMM server](https://forums.percona.com/t/setting-up-the-client-connection-to-pmm-server/32019)

<div class="topic-metadata">

**Author:** [@aniketwalke](https://forums.percona.com/u/aniketwalke)\
**Replies:** 1\
**Last updated:** [August 5, 2024, 8:54am UTC](https://forums.percona.com/t/setting-up-the-client-connection-to-pmm-server/32019 "2024-08-05T08:54:19Z")

</div>

Dear Members, I am trying to use PMM as monitoring platform for our postgres and mysql estate i am new to this community. I have installed PMM server on docker and downloaded binaries for client for redhat. I have con…

---

## [How to configure a deadlock alert on pmm integrated alerting](https://forums.percona.com/t/how-to-configure-a-deadlock-alert-on-pmm-integrated-alerting/31956)

<div class="topic-metadata">

**Author:** [@Tato](https://forums.percona.com/u/Tato)\
**Replies:** 0\
**Last updated:** [August 1, 2024, 7:35pm UTC](https://forums.percona.com/t/how-to-configure-a-deadlock-alert-on-pmm-integrated-alerting/31956 "2024-08-01T19:35:18Z")

</div>

Description: How to configure a deadlock alet on pmm integrated alerting. Steps to Reproduce: Try to add an alert on deadlocks using pmm integrated alerting. Version: PMM from 2.27 to 2.42 Logs: Expected Result: Send …

---

## [Not able to take the backup in the pmm dashboard for the mongoDB replicasets](https://forums.percona.com/t/not-able-to-take-the-backup-in-the-pmm-dashboard-for-the-mongodb-replicasets/31928)

<div class="topic-metadata">

**Author:** [@nagaa](https://forums.percona.com/u/nagaa)\
**Replies:** 2\
**Last updated:** [August 1, 2024, 10:38am UTC](https://forums.percona.com/t/not-able-to-take-the-backup-in-the-pmm-dashboard-for-the-mongodb-replicasets/31928 "2024-08-01T10:38:10Z")

</div>

Description: not able to take the backup in the pmm dashboard from the containerised configuration eventhogh we can take a backup form pbm from the mongoDB replicasets but not able to do in the dashboard.The error we a…

---

## [MySQL Replication Summary, PMM](https://forums.percona.com/t/mysql-replication-summary-pmm/31843)

<div class="topic-metadata">

**Author:** [@egel](https://forums.percona.com/u/egel)\
**Replies:** 1\
**Last updated:** [July 28, 2024, 2:51pm UTC](https://forums.percona.com/t/mysql-replication-summary-pmm/31843 "2024-07-28T14:51:38Z")

</div>

Description: PMM, MySQL Replication Summary, shows that no IO and no SQL threads are running when they are up. Steps to Reproduce: Run GR cluster gr1, gr2, gr3, on one of the nodes, perhaps gr1, setup asynch replicati…

---

## [Azure metrics exporter not working](https://forums.percona.com/t/azure-metrics-exporter-not-working/24273)

<div class="topic-metadata">

**Author:** [@ben5556\_K](https://forums.percona.com/u/ben5556_K)\
**Replies:** 2\
**Last updated:** [July 25, 2024, 6:02am UTC](https://forums.percona.com/t/azure-metrics-exporter-not-working/24273 "2024-07-25T06:02:22Z")

</div>

Description: Azure metrics exporter not working Steps to Reproduce: Enable Azure Monitoring technical preview feature. Add managed database service and enable Azure metrics checkbox while doing so. Version: 2.38.0 Log…

---

## [Issues with PMM Server on Docker - EC2 Instance Replicating Percona MySQL 8.0.32](https://forums.percona.com/t/issues-with-pmm-server-on-docker-ec2-instance-replicating-percona-mysql-8-0-32/31651)

<div class="topic-metadata">

**Author:** [@khaled1](https://forums.percona.com/u/khaled1)\
**Replies:** 2\
**Last updated:** [July 22, 2024, 9:44am UTC](https://forums.percona.com/t/issues-with-pmm-server-on-docker-ec2-instance-replicating-percona-mysql-8-0-32/31651 "2024-07-22T09:44:03Z")

</div>

Description: I have a PMM server running as a Docker container on an EC2 instance. This EC2 instance serves as a replica of a master server running Percona for MySQL 8.0.32, managing approximately 3,000 databases with a…

---

## [Pmm-agent with proxysql exporter error: "Error scraping for collect.runtime\_mysql\_servers\\"](https://forums.percona.com/t/pmm-agent-with-proxysql-exporter-error-error-scraping-for-collect-runtime-mysql-servers/28337)

<div class="topic-metadata">

**Author:** [@marinse0](https://forums.percona.com/u/marinse0)\
**Replies:** 5\
**Last updated:** [July 19, 2024, 9:13am UTC](https://forums.percona.com/t/pmm-agent-with-proxysql-exporter-error-error-scraping-for-collect-runtime-mysql-servers/28337 "2024-07-19T09:13:08Z")

</div>

Dears. Having an issue with pmm-agent and proxysql exporter Pmm-agent is excessively logging en error in message log, causing log files growth. Error is: Feb 6 16:48:57 hostname pmm-agent\[800105\]: time="2024-02-06T1…

---

## [Alert Rule Templates - Native Grafana](https://forums.percona.com/t/alert-rule-templates-native-grafana/31522)

<div class="topic-metadata">

**Author:** [@meyerder](https://forums.percona.com/u/meyerder)\
**Replies:** 1\
**Last updated:** [July 16, 2024, 2:01pm UTC](https://forums.percona.com/t/alert-rule-templates-native-grafana/31522 "2024-07-16T14:01:31Z")

</div>

I have been trying to figure out or find a means… While I love to use the entire PMM stack, some customers are bound to use Grafana Native (Enterprise). Does a means exist to add the Alert Rule Templates to Grafana Na…

---

## [PMM LDAP not consistent](https://forums.percona.com/t/pmm-ldap-not-consistent/31621)

<div class="topic-metadata">

**Author:** [@Dennis](https://forums.percona.com/u/Dennis)\
**Replies:** 3\
**Last updated:** [July 16, 2024, 7:14am UTC](https://forums.percona.com/t/pmm-ldap-not-consistent/31621 "2024-07-16T07:14:30Z")

</div>

Description: I work with the default Percona PMM-server 2 docker image and try to get the grafana LDAP settings persistent. I am unable to mount alternative versions of grafana.ini and ldap.toml, i think because of the s…

---

## [PMM 2.x Buffer Pool Size of Total RAM is showing N/A](https://forums.percona.com/t/pmm-2-x-buffer-pool-size-of-total-ram-is-showing-n-a/31526)

<div class="topic-metadata">

**Author:** [@jknight](https://forums.percona.com/u/jknight)\
**Replies:** 2\
**Last updated:** [July 10, 2024, 12:12pm UTC](https://forums.percona.com/t/pmm-2-x-buffer-pool-size-of-total-ram-is-showing-n-a/31526 "2024-07-10T12:12:39Z")

</div>

Description: Monitoring 8 servers and all have N/A in the MySQL /MySQL Instance Summary/Buffer Pool Size of Total RAM Version: PMM 2.42.0. Used the Quick start guide to install on Debian 10/11/12. Running Percona MySQ…

---

## [Pmm query analytics Query notification receiving function inquiry](https://forums.percona.com/t/pmm-query-analytics-query-notification-receiving-function-inquiry/31496)

<div class="topic-metadata">

**Author:** [@tnwls3879](https://forums.percona.com/u/tnwls3879)\
**Replies:** 1\
**Last updated:** [July 10, 2024, 12:42am UTC](https://forums.percona.com/t/pmm-query-analytics-query-notification-receiving-function-inquiry/31496 "2024-07-10T00:42:49Z")

</div>

Among the query information collected from pmm query analytics, is there a function that can alert you to queries with high load?

---

## [In Query Analytics, the same statement executed in different databases will only be counted once](https://forums.percona.com/t/in-query-analytics-the-same-statement-executed-in-different-databases-will-only-be-counted-once/24168)

<div class="topic-metadata">

**Author:** [@frank.pan](https://forums.percona.com/u/frank.pan)\
**Replies:** 12\
**Last updated:** [July 5, 2024, 3:43am UTC](https://forums.percona.com/t/in-query-analytics-the-same-statement-executed-in-different-databases-will-only-be-counted-once/24168 "2024-07-05T03:43:35Z")

</div>

Description: We found that in Query Analytics, the same statement executed in different databases will only be counted once. Steps to Reproduce: Our database architecture uses MySQL’s sharding, for example, there are 8 …

---

## [PMM and AWS Aurora Serverless V2 MySQL](https://forums.percona.com/t/pmm-and-aws-aurora-serverless-v2-mysql/31371)

<div class="topic-metadata">

**Author:** [@mikecou](https://forums.percona.com/u/mikecou)\
**Replies:** 2\
**Last updated:** [July 3, 2024, 5:03pm UTC](https://forums.percona.com/t/pmm-and-aws-aurora-serverless-v2-mysql/31371 "2024-07-03T17:03:48Z")

</div>

Description: The docs say that PMM works with AWS Aurora. Does it work with the AWS Aurora Serverless V2 MySQL 8? I have four serverless clusters that I manage and would like to try PMM, just don’t know if it would wor…

---

## [The server PMM has hung in maintenance mode](https://forums.percona.com/t/the-server-pmm-has-hung-in-maintenance-mode/30962)

<div class="topic-metadata">

**Author:** [@Leslaw\_Jakubowski](https://forums.percona.com/u/Leslaw_Jakubowski)\
**Replies:** 2\
**Last updated:** [July 3, 2024, 2:18pm UTC](https://forums.percona.com/t/the-server-pmm-has-hung-in-maintenance-mode/30962 "2024-07-03T14:18:41Z")

</div>

During update server PMM 2.X hung up and after restart server it is still in maintance mode - how to restart update process? Regards, Leslaw

---

## [How can I access pmm server from port other than 443/80. As they are pre-occupied by the Apache Web-Server](https://forums.percona.com/t/how-can-i-access-pmm-server-from-port-other-than-443-80-as-they-are-pre-occupied-by-the-apache-web-server/31346)

<div class="topic-metadata">

**Author:** [@Mantresh\_Kumar](https://forums.percona.com/u/Mantresh_Kumar)\
**Replies:** 5\
**Last updated:** [July 2, 2024, 10:12am UTC](https://forums.percona.com/t/how-can-i-access-pmm-server-from-port-other-than-443-80-as-they-are-pre-occupied-by-the-apache-web-server/31346 "2024-07-02T10:12:02Z")

</div>

Description: \[Detailed description of the issue or question\] I’m using port no 30009. How can I access pmm-server? I dont want https. I want to access it on 30009. But unable to do so, I’m getting 302 status code. And a…

---

## [Active metrics concern](https://forums.percona.com/t/active-metrics-concern/29999)

<div class="topic-metadata">

**Author:** [@Enh-erdene\_Lhagvasur](https://forums.percona.com/u/Enh-erdene_Lhagvasur)\
**Replies:** 1\
**Last updated:** [June 25, 2024, 10:34am UTC](https://forums.percona.com/t/active-metrics-concern/29999 "2024-06-25T10:34:48Z")

</div>

I have 1 concern about active metric. I thinks before this metric is same like a active connections but it is different . what is this metric ? this metric is a active transactions?

---

## [Appliance File(s) Updates needed](https://forums.percona.com/t/appliance-file-s-updates-needed/29569)

<div class="topic-metadata">

**Author:** [@meyerder](https://forums.percona.com/u/meyerder)\
**Replies:** 1\
**Last updated:** [June 25, 2024, 9:51am UTC](https://forums.percona.com/t/appliance-file-s-updates-needed/29569 "2024-06-25T09:51:35Z")

</div>

\*\*Edit seems to load fine in VMware but not ESXI so Ill have to dig around some… Any Chance that the OVF file can be updated? Its so old it really does not run… It is setup on Virtual box 2.2 which is well archaic (and…

---

## [No data in mongo-db collections](https://forums.percona.com/t/no-data-in-mongo-db-collections/28899)

<div class="topic-metadata">

**Author:** [@amir\_darvish](https://forums.percona.com/u/amir_darvish)\
**Replies:** 1\
**Last updated:** [June 25, 2024, 9:43am UTC](https://forums.percona.com/t/no-data-in-mongo-db-collections/28899 "2024-06-25T09:43:28Z")

</div>

Description: I’m new with PMM and i run it to monitor mongo-db Steps to Reproduce: In mongo-db collection details , there is no data in collection panel , How can i run this section? i also set mongo-db profile and i c…

---

## [Unable to Install PMM Server Without Internet Connection](https://forums.percona.com/t/unable-to-install-pmm-server-without-internet-connection/31119)

<div class="topic-metadata">

**Author:** [@Marshall\_Ditto](https://forums.percona.com/u/Marshall_Ditto)\
**Replies:** 2\
**Last updated:** [June 25, 2024, 9:34am UTC](https://forums.percona.com/t/unable-to-install-pmm-server-without-internet-connection/31119 "2024-06-25T09:34:54Z")

</div>

hi, We have a Linux system without internet access and have tried multiple methods to install the PMM server, but haven’t succeeded. We couldn’t find the RPM or any manual package to install, and we are currently stuck.…

---

## [Yum update Fails on AWS Marketplace Instance](https://forums.percona.com/t/yum-update-fails-on-aws-marketplace-instance/31200)

<div class="topic-metadata">

**Author:** [@davidl](https://forums.percona.com/u/davidl)\
**Replies:** 5\
**Last updated:** [June 24, 2024, 3:47pm UTC](https://forums.percona.com/t/yum-update-fails-on-aws-marketplace-instance/31200 "2024-06-24T15:47:48Z")

</div>

Hi, I’ve been running PMM on the marketplace AWS instance, Oracle Linux, and I’ve done a simple yum update. The web interface helpfully told me some of PMM’s files hadn’t updated or something so I rebooted the instance.…

---

## [Getting Extra Replication Channel in PMM](https://forums.percona.com/t/getting-extra-replication-channel-in-pmm/31103)

<div class="topic-metadata">

**Author:** [@Asuwini\_P](https://forums.percona.com/u/Asuwini_P)\
**Replies:** 1\
**Last updated:** [June 24, 2024, 11:11am UTC](https://forums.percona.com/t/getting-extra-replication-channel-in-pmm/31103 "2024-06-24T11:11:00Z")

</div>

Description: Recently, we encountered an issue with displaying the replication status. While our production environment has three replication channels, PMM shows four channels intermittently. The additional channel occas…

---

## [RED Method for MySQL Query Analyses - please give it a try](https://forums.percona.com/t/red-method-for-mysql-query-analyses-please-give-it-a-try/7705)

<div class="topic-metadata">

**Author:** [@Peter](https://forums.percona.com/u/Peter)\
**Replies:** 1\
**Last updated:** [June 22, 2024, 7:57pm UTC](https://forums.percona.com/t/red-method-for-mysql-query-analyses-please-give-it-a-try/7705 "2024-06-22T19:57:39Z")

</div>

I have implemented new dashboard for PMM2 which allows to analyse MySQL Performance using popular RED (Rate-Errors-Duration Method) You can check more details on this blog post You can install it from grafana.c…

---

## [Single pane of glass to check replication status across all servers](https://forums.percona.com/t/single-pane-of-glass-to-check-replication-status-across-all-servers/31108)

<div class="topic-metadata">

**Author:** [@mcarlson](https://forums.percona.com/u/mcarlson)\
**Replies:** 3\
**Last updated:** [June 21, 2024, 4:18pm UTC](https://forums.percona.com/t/single-pane-of-glass-to-check-replication-status-across-all-servers/31108 "2024-06-21T16:18:41Z")

</div>

We are in the process of migrating from another solution to PMM, and while we love the additional information that PMM can provide, we’re finding one sticking point that we would love to alter. Right now, from what we c…

---

## [Server\_error: server error: 502: details: - not AWS](https://forums.percona.com/t/server-error-server-error-502-details-not-aws/31092)

<div class="topic-metadata">

**Author:** [@jknight](https://forums.percona.com/u/jknight)\
**Replies:** 1\
**Last updated:** [June 20, 2024, 7:20pm UTC](https://forums.percona.com/t/server-error-server-error-502-details-not-aws/31092 "2024-06-20T19:20:49Z")

</div>

PMM is getting server\_error: server error: 502: details:. It has been running for a couple of months but just stated having this issue. I can issue the docker restart pmm-server and the dashboard will start up and fine…

---

## [Failed to get connection service info: timeout (context deadline exceeded) when trying to add MySQL with pmm-admin](https://forums.percona.com/t/failed-to-get-connection-service-info-timeout-context-deadline-exceeded-when-trying-to-add-mysql-with-pmm-admin/31100)

<div class="topic-metadata">

**Author:** [@Davesson](https://forums.percona.com/u/Davesson)\
**Replies:** 1\
**Last updated:** [June 20, 2024, 12:08pm UTC](https://forums.percona.com/t/failed-to-get-connection-service-info-timeout-context-deadline-exceeded-when-trying-to-add-mysql-with-pmm-admin/31100 "2024-06-20T12:08:37Z")

</div>

Description: Removed a mysql server from pmm2 as we wanted to disable tablestats but can’t reconnect it due to “failed to get connection service info: timeout (context deadline exceeded).” Command: pmm-admin add mysql -…

---

## [How to verify the value of the parameter DISABLE\_UPDATES](https://forums.percona.com/t/how-to-verify-the-value-of-the-parameter-disable-updates/31021)

<div class="topic-metadata">

**Author:** [@Olivier\_Studer](https://forums.percona.com/u/Olivier_Studer)\
**Replies:** 2\
**Last updated:** [June 14, 2024, 8:38am UTC](https://forums.percona.com/t/how-to-verify-the-value-of-the-parameter-disable-updates/31021 "2024-06-14T08:38:15Z")

</div>

Hi all, I want to enable the update of PMM 2. I run PMM with Podman. I need help to understand, to use and configure the " Environment variables" by example DISABLE\_UPDATES. How to check if this variable is used in my…

---

## [Secure way to acess PMM](https://forums.percona.com/t/secure-way-to-acess-pmm/30985)

<div class="topic-metadata">

**Author:** [@Apostolos\_Karavias](https://forums.percona.com/u/Apostolos_Karavias)\
**Replies:** 2\
**Last updated:** [June 13, 2024, 7:22am UTC](https://forums.percona.com/t/secure-way-to-acess-pmm/30985 "2024-06-13T07:22:54Z")

</div>

Hello all, After some time testing the PMM it’s time to migrate our monitoring to it. I’m trying to find the best way to access/secure the Instance. For now, it will be a docker setup on one server. I have found how t…

[Previous page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=3)

[Next page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=5)
