# PMM 2.x

**URL:** https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [Mongdb replicaSet Monitoring](https://forums.percona.com/t/mongdb-replicaset-monitoring/35791)

<div class="topic-metadata">

**Author:** [@Pramod\_Kumar\_Gupta](https://forums.percona.com/u/Pramod_Kumar_Gupta)\
**Replies:** 1\
**Last updated:** [December 24, 2024, 12:47pm UTC](https://forums.percona.com/t/mongdb-replicaset-monitoring/35791 "2024-12-24T12:47:44Z")

</div>

I have mongo cluster using these commands docker run -d --rm -p 27017:27017 --name mongo1 --network perconaNetwork mongo:7 mongod --replSet myReplicaSet --bind\_ip localhost,mongo1 docker run -d --rm -p 27018:27017 --na…

---

## [Slow log as query source but still get expensive perfschema queries](https://forums.percona.com/t/slow-log-as-query-source-but-still-get-expensive-perfschema-queries/35625)

<div class="topic-metadata">

**Author:** [@Davesson](https://forums.percona.com/u/Davesson)\
**Replies:** 2\
**Last updated:** [December 13, 2024, 10:19am UTC](https://forums.percona.com/t/slow-log-as-query-source-but-still-get-expensive-perfschema-queries/35625 "2024-12-13T10:19:01Z")

</div>

Description: I’ve added a mysql server with slowlog as query source: pmm-admin add mysql --query-source=slowlog --size-slow-logs=1GiB --disable-tablestats=true --username=pmm --password=xxxxxx mysql-0 10.0.10.10:3306 C…

---

## [Multiple services/servers with Monitoring status as failed in PMM Inventory/Services MongoDB](https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627)

<div class="topic-metadata">

**Author:** [@yuvaraj\_m](https://forums.percona.com/u/yuvaraj_m)\
**Replies:** 1\
**Last updated:** [December 12, 2024, 1:39pm UTC](https://forums.percona.com/t/multiple-services-servers-with-monitoring-status-as-failed-in-pmm-inventory-services-mongodb/35627 "2024-12-12T13:39:49Z")

</div>

Description: Multiple services/servers with Monitoring status as failed in PMM Inventory/Services MongoDB Steps to Reproduce: Multiple services are having Monitoring status as failed in PMM inventory Version: 2.43.2 L…

---

## [Mysql User Details dashboard does not show query when filtering in QAN](https://forums.percona.com/t/mysql-user-details-dashboard-does-not-show-query-when-filtering-in-qan/35561)

<div class="topic-metadata">

**Author:** [@Duygu](https://forums.percona.com/u/Duygu)\
**Replies:** 4\
**Last updated:** [December 10, 2024, 12:45pm UTC](https://forums.percona.com/t/mysql-user-details-dashboard-does-not-show-query-when-filtering-in-qan/35561 "2024-12-10T12:45:44Z")

</div>

Mysql User Details dashboard does not show queries when filtering QAN When I click on a user’s filter, QAN dashboard opens. but it does not filter. “No queries available for this combination of filters in the selected t…

---

## ["N/A" show but not displaying username on the QAN dashboard for Mysql queries](https://forums.percona.com/t/n-a-show-but-not-displaying-username-on-the-qan-dashboard-for-mysql-queries/35442)

<div class="topic-metadata">

**Author:** [@Duygu](https://forums.percona.com/u/Duygu)\
**Replies:** 7\
**Last updated:** [December 6, 2024, 10:52pm UTC](https://forums.percona.com/t/n-a-show-but-not-displaying-username-on-the-qan-dashboard-for-mysql-queries/35442 "2024-12-06T22:52:24Z")

</div>

Description: Hello, I am using PMM (managed via Docker on a VM). I want to display “User” information in the QAN dashboard for my MySQL and MongoDB instances and filter queries based on it. While QAN can accurately disp…

---

## [Adding PMM dashboards and QAN into Grafana](https://forums.percona.com/t/adding-pmm-dashboards-and-qan-into-grafana/34667)

<div class="topic-metadata">

**Author:** [@Andrew2](https://forums.percona.com/u/Andrew2)\
**Replies:** 3\
**Last updated:** [December 5, 2024, 1:23pm UTC](https://forums.percona.com/t/adding-pmm-dashboards-and-qan-into-grafana/34667 "2024-12-05T13:23:02Z")

</div>

We have moved from having disparate monitoring systems where we ran a PMM instance in docker for the databases, to a centralised Grafana service for all platforms. We’ve been attempting to include some of the PMM dashbo…

---

## [QAN Not showing any data for the Service/DB](https://forums.percona.com/t/qan-not-showing-any-data-for-the-service-db/35125)

<div class="topic-metadata">

**Author:** [@Thomas\_Baran](https://forums.percona.com/u/Thomas_Baran)\
**Replies:** 5\
**Last updated:** [December 4, 2024, 7:29am UTC](https://forums.percona.com/t/qan-not-showing-any-data-for-the-service-db/35125 "2024-12-04T07:29:30Z")

</div>

Description: PMM QAN won’t show the service/db of a specific Postgres Target any further after a few hours of it working. Tried performing a reboot of my ec2 instance which is running the pmm docker, didn’t help any.. p…

---

## [PMM server installation error using docker](https://forums.percona.com/t/pmm-server-installation-error-using-docker/35405)

<div class="topic-metadata">

**Author:** [@Aditya1](https://forums.percona.com/u/Aditya1)\
**Replies:** 4\
**Last updated:** [December 3, 2024, 9:39am UTC](https://forums.percona.com/t/pmm-server-installation-error-using-docker/35405 "2024-12-03T09:39:42Z")

</div>

We are not able to start the pmm server image through docker. Error - Fatal glibc error: CPU does not support x86-64-v2 in docker container logs We are using RHEL OS - Red Hat Enterprise Linux release 8.10 (Ootpa) Kin…

---

## [SMTP Settings in PMM Appliance](https://forums.percona.com/t/smtp-settings-in-pmm-appliance/29614)

<div class="topic-metadata">

**Author:** [@davidl](https://forums.percona.com/u/davidl)\
**Replies:** 6\
**Last updated:** [November 28, 2024, 3:13pm UTC](https://forums.percona.com/t/smtp-settings-in-pmm-appliance/29614 "2024-11-28T15:13:58Z")

</div>

Hi all, I am using the PMM appliance on AWS and trying to set up SMTP settings but I cannot for the life of me find out where they are stored or can be changed. There are immutable settings in the web interface but thes…

---

## [How to extend victoriametrics-promscrape.yaml](https://forums.percona.com/t/how-to-extend-victoriametrics-promscrape-yaml/16383)

<div class="topic-metadata">

**Author:** [@Fan](https://forums.percona.com/u/Fan)\
**Replies:** 7\
**Last updated:** [November 28, 2024, 11:38am UTC](https://forums.percona.com/t/how-to-extend-victoriametrics-promscrape-yaml/16383 "2024-11-28T11:38:29Z")

</div>

I remember when PMM use prometheus, I could customize some configuration by creating the file /srv/prometheus/prometheus.base.yml FAQ - Percona Monitoring and Management Now that we are using victoriametics, is it st…

---

## [Identifying Blocked Queries from ClickHouse PMM Data](https://forums.percona.com/t/identifying-blocked-queries-from-clickhouse-pmm-data/35133)

<div class="topic-metadata">

**Author:** [@Asuwini\_P](https://forums.percona.com/u/Asuwini_P)\
**Replies:** 1\
**Last updated:** [November 20, 2024, 3:36pm UTC](https://forums.percona.com/t/identifying-blocked-queries-from-clickhouse-pmm-data/35133 "2024-11-20T15:36:42Z")

</div>

Hi Team, Using the ClickHouse PMM data, we can observe the lock wait time for each query. Is it possible to identify which queries were blocked during this time, either through ClickHouse data or PMM’s default graphs? T…

---

## [Troubleshooting QAN: Delayed Updates on Collection/Database Deletion and Client Info](https://forums.percona.com/t/troubleshooting-qan-delayed-updates-on-collection-database-deletion-and-client-info/34442)

<div class="topic-metadata">

**Author:** [@nagaa](https://forums.percona.com/u/nagaa)\
**Replies:** 1\
**Last updated:** [November 17, 2024, 8:25am UTC](https://forums.percona.com/t/troubleshooting-qan-delayed-updates-on-collection-database-deletion-and-client-info/34442 "2024-11-17T08:25:53Z")

</div>

Hi I enabled Query Analytics (QAN) for my MongoDB, which is set up with primary and secondary instances in a replica set. When I drop 4 or 5 collections in the database, the changes appear in QAN almost immediately. How…

---

## [Is there a way to monitor Aurora MySQL instances in other AWS accounts with PMM?](https://forums.percona.com/t/is-there-a-way-to-monitor-aurora-mysql-instances-in-other-aws-accounts-with-pmm/35033)

<div class="topic-metadata">

**Author:** [@Sun](https://forums.percona.com/u/Sun)\
**Replies:** 1\
**Last updated:** [November 14, 2024, 3:40pm UTC](https://forums.percona.com/t/is-there-a-way-to-monitor-aurora-mysql-instances-in-other-aws-accounts-with-pmm/35033 "2024-11-14T15:40:05Z")

</div>

Hi there, I’m trying to monitor RDS instances across multiple AWS accounts using PMM. PMM is in an AWS account named monitor, while service1 Aurora MySQL is in the serv1 AWS account, and service2 Aurora MySQL is in the …

---

## [Not able to login into PMM dashboard](https://forums.percona.com/t/not-able-to-login-into-pmm-dashboard/34871)

<div class="topic-metadata">

**Author:** [@skotakonda](https://forums.percona.com/u/skotakonda)\
**Replies:** 4\
**Last updated:** [November 8, 2024, 1:13pm UTC](https://forums.percona.com/t/not-able-to-login-into-pmm-dashboard/34871 "2024-11-08T13:13:20Z")

</div>

Hi Team, I have installed PMM and for few days it was working fine, but now it looks like I can not login. It complains about Invalid credentials. Tried to use Forgot password but am not getting any kind of emails duri…

---

## [QAN not showing any data in PMM2 x Percona MySQL 8.0.34](https://forums.percona.com/t/qan-not-showing-any-data-in-pmm2-x-percona-mysql-8-0-34/34842)

<div class="topic-metadata">

**Author:** [@virin\_t](https://forums.percona.com/u/virin_t)\
**Replies:** 5\
**Last updated:** [November 8, 2024, 12:46pm UTC](https://forums.percona.com/t/qan-not-showing-any-data-in-pmm2-x-percona-mysql-8-0-34/34842 "2024-11-08T12:46:57Z")

</div>

Description: We have recently upgraded mysql to percona 8.0.34, We already have PMM2 working However, I am unable to to view data under Query Analytics. What would be the cause and troubleshooting steps to fix or have Q…

---

## [Percona MySQL InnoDB Storage Summary](https://forums.percona.com/t/percona-mysql-innodb-storage-summary/34845)

<div class="topic-metadata">

**Author:** [@adamrodrigues98](https://forums.percona.com/u/adamrodrigues98)\
**Replies:** 4\
**Last updated:** [November 7, 2024, 5:12pm UTC](https://forums.percona.com/t/percona-mysql-innodb-storage-summary/34845 "2024-11-07T17:12:38Z")

</div>

Description: I’m having trouble displaying InnoDB Storage Summary. Steps to Reproduce: MySQL \> InnoDB Details \> InnoDB Storage Summary Additional Information: The necessary settings are already enabled, only the InnoDB…

---

## [Impossible to track application slow query in PMM on RDS Amazon](https://forums.percona.com/t/impossible-to-track-application-slow-query-in-pmm-on-rds-amazon/34796)

<div class="topic-metadata">

**Author:** [@Skipper\_Technicolor](https://forums.percona.com/u/Skipper_Technicolor)\
**Replies:** 7\
**Last updated:** [November 6, 2024, 9:49pm UTC](https://forums.percona.com/t/impossible-to-track-application-slow-query-in-pmm-on-rds-amazon/34796 "2024-11-06T21:49:08Z")

</div>

Description: Hi there, I am trying to monitor in PMM an RDS Amazon MySQL database. To do so, I have followed the official procedure Percona Monitoring and Management by creating a specific IAM account with all the grants…

---

## [PMM GUI backup error](https://forums.percona.com/t/pmm-gui-backup-error/30965)

<div class="topic-metadata">

**Author:** [@bloodlust](https://forums.percona.com/u/bloodlust)\
**Replies:** 1\
**Last updated:** [November 1, 2024, 11:18am UTC](https://forums.percona.com/t/pmm-gui-backup-error/30965 "2024-11-01T11:18:17Z")

</div>

Description: Hello, there is such a problem when trying to make a backup through PMM, if I do it through the PBM console, physical and logical backups are made and restored as required. software “mongodb” is not install…

---

## [PMM 2.43.2 Upgrade?](https://forums.percona.com/t/pmm-2-43-2-upgrade/34674)

<div class="topic-metadata">

**Author:** [@meyerder](https://forums.percona.com/u/meyerder)\
**Replies:** 1\
**Last updated:** [October 30, 2024, 3:32pm UTC](https://forums.percona.com/t/pmm-2-43-2-upgrade/34674 "2024-10-30T15:32:15Z")

</div>

I try to keep pretty up to date on items but have noticed the last couple of upgrades where the PMM Upgrade box shows an update but the What’s new link is broken, and I can not find anything about it. Are you aware of…

---

## [Add PMM as a datasource in Grafana](https://forums.percona.com/t/add-pmm-as-a-datasource-in-grafana/34608)

<div class="topic-metadata">

**Author:** [@skp15](https://forums.percona.com/u/skp15)\
**Replies:** 1\
**Last updated:** [October 30, 2024, 12:07pm UTC](https://forums.percona.com/t/add-pmm-as-a-datasource-in-grafana/34608 "2024-10-30T12:07:16Z")

</div>

Hello, I have a pmm-server hosted on an AWS EKS cluster and exposed it on localhost, I am able to access the PMM UI as well as the /prometheus endpoint that has Single-node VictoriaMetrics. We have a native Grafana ins…

---

## [Mongod threads continuously increasing](https://forums.percona.com/t/mongod-threads-continuously-increasing/34638)

<div class="topic-metadata">

**Author:** [@danb](https://forums.percona.com/u/danb)\
**Replies:** 3\
**Last updated:** [October 29, 2024, 7:02am UTC](https://forums.percona.com/t/mongod-threads-continuously-increasing/34638 "2024-10-29T07:02:49Z")

</div>

Description: I Installed pmm-agent on MongoDB instance with default settings according to the setup instructions. When the agent is running, the threads count is increasing in MongoDb service (mongod). After few hours, t…

---

## [Getting error while backing up PMM 2 data](https://forums.percona.com/t/getting-error-while-backing-up-pmm-2-data/34597)

<div class="topic-metadata">

**Author:** [@pravata\_dash](https://forums.percona.com/u/pravata_dash)\
**Replies:** 7\
**Last updated:** [October 28, 2024, 11:15am UTC](https://forums.percona.com/t/getting-error-while-backing-up-pmm-2-data/34597 "2024-10-28T11:15:46Z")

</div>

I have a usecase to backup and store PMM2 data (both victoria metrics and clickhouse) for future reference usecase. Refering below doc, while exporting the data I am getting error, how to fix this?? Error: remoteAddr:…

---

## [Pmm default admin password not working](https://forums.percona.com/t/pmm-default-admin-password-not-working/34568)

<div class="topic-metadata">

**Author:** [@skp15](https://forums.percona.com/u/skp15)\
**Replies:** 9\
**Last updated:** [October 25, 2024, 4:21pm UTC](https://forums.percona.com/t/pmm-default-admin-password-not-working/34568 "2024-10-25T16:21:24Z")

</div>

Hello, I am using helm to deploy ‘pmm’ on a AWS EKS cluster. The plain helm installation worked fine and I was able to login to pmm UI. I add serviceAnnotations to assume a IAM role and now when I decrypt the default pa…

---

## [Clickhouse FATAL can't find command '/usr/bin/clickhouse-server'](https://forums.percona.com/t/clickhouse-fatal-cant-find-command-usr-bin-clickhouse-server/34560)

<div class="topic-metadata">

**Author:** [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Replies:** 4\
**Last updated:** [October 24, 2024, 4:10pm UTC](https://forums.percona.com/t/clickhouse-fatal-cant-find-command-usr-bin-clickhouse-server/34560 "2024-10-24T16:10:44Z")

</div>

Hi Team, We are trying to upgrade the PMM version from 2.41.1 to 2.43.1, but upgrade is failed with the below errors. When I check the supervisorctl status clickhouse, then we are getting the below error. clickhouse …

---

## [Add Service Leverage Proxy](https://forums.percona.com/t/add-service-leverage-proxy/34563)

<div class="topic-metadata">

**Author:** [@meyerder](https://forums.percona.com/u/meyerder)\
**Replies:** 0\
**Last updated:** [October 23, 2024, 2:21pm UTC](https://forums.percona.com/t/add-service-leverage-proxy/34563 "2024-10-23T14:21:08Z")

</div>

I am attempting to figure out how to add a http\_proxy/no\_proxy/https\_proxy or where to config this info… I figured out how to make it work in grafana using those in the ini file but adding a service for a /metrics item I…

---

## [Changing IP Addresses of PMM and Database Servers Without Losing historical Data?](https://forums.percona.com/t/changing-ip-addresses-of-pmm-and-database-servers-without-losing-historical-data/34443)

<div class="topic-metadata">

**Author:** [@Futureweb](https://forums.percona.com/u/Futureweb)\
**Replies:** 2\
**Last updated:** [October 22, 2024, 10:07pm UTC](https://forums.percona.com/t/changing-ip-addresses-of-pmm-and-database-servers-without-losing-historical-data/34443 "2024-10-22T22:07:45Z")

</div>

Hello, We are currently undergoing some major changes in our network infrastructure, which involves updating the IP addresses of both our PMM server and all our database servers. Is there a way to change the IP address…

---

## [Issue Passing Environment Variables to vm\_agent in PMM Client](https://forums.percona.com/t/issue-passing-environment-variables-to-vm-agent-in-pmm-client/34450)

<div class="topic-metadata">

**Author:** [@Adrian\_Castillo](https://forums.percona.com/u/Adrian_Castillo)\
**Replies:** 5\
**Last updated:** [October 22, 2024, 11:46am UTC](https://forums.percona.com/t/issue-passing-environment-variables-to-vm-agent-in-pmm-client/34450 "2024-10-22T11:46:10Z")

</div>

Description: I am encountering an issue with PMM Client where the vm\_agent process fails to scrape metrics due to exceeding the default -promscrape.maxScrapeSize limit. I enabled debug mode and captured the following err…

---

## [Upgrade grafana version within PMM 2.42.0](https://forums.percona.com/t/upgrade-grafana-version-within-pmm-2-42-0/34497)

<div class="topic-metadata">

**Author:** [@edicarlos](https://forums.percona.com/u/edicarlos)\
**Replies:** 3\
**Last updated:** [October 21, 2024, 6:36pm UTC](https://forums.percona.com/t/upgrade-grafana-version-within-pmm-2-42-0/34497 "2024-10-21T18:36:09Z")

</div>

Description: I’m using PMM version 2.42.0 and in this version the Grafana used is version 9.2.20. I need to use Grafana version 11 due to new features that have been made available. Is it possible to upgrade Grafana wi…

---

## [EOF/RPC error when use https in external service](https://forums.percona.com/t/eof-rpc-error-when-use-https-in-external-service/34272)

<div class="topic-metadata">

**Author:** [@edicarlos](https://forums.percona.com/u/edicarlos)\
**Replies:** 5\
**Last updated:** [October 21, 2024, 3:34pm UTC](https://forums.percona.com/t/eof-rpc-error-when-use-https-in-external-service/34272 "2024-10-21T15:34:22Z")

</div>

Description: Hi guys, I’m using PMM version 2.42.0 and when adding an external service using https on port 8443 an RPC error occurs: pmm-managed.log:time="2024-10-09T15:34:32.415+00:00" level=info msg="CheckConnection …

---

## [Telegram Alert Failing](https://forums.percona.com/t/telegram-alert-failing/13385)

<div class="topic-metadata">

**Author:** [@tayeen.sslwireless](https://forums.percona.com/u/tayeen.sslwireless)\
**Replies:** 4\
**Last updated:** [December 8, 2021, 4:43am UTC](https://forums.percona.com/t/telegram-alert-failing/13385 "2021-12-08T04:43:17Z")

</div>

We have installed pmm-server using docker. Our server uses Proxy Internet and has the necessary privileges for docker to “pull image”. Meaning, the Docker has internet access as well (although I am not sure if the contai…

[Previous page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=1)

[Next page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/percona-monitoring-and-management-pmm-v2/31.md?page=3)
