# Percona Monitoring and Management (PMM)

**URL:** https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [Enable Real Client IP Visibility in Percona PostgreSQL Behind HAProxy](https://forums.percona.com/t/enable-real-client-ip-visibility-in-percona-postgresql-behind-haproxy/40130)

<div class="topic-metadata">

**Author:** [@ashishpilania18](https://forums.percona.com/u/ashishpilania18)\
**Replies:** 1\
**Last updated:** [February 20, 2026, 4:39pm UTC](https://forums.percona.com/t/enable-real-client-ip-visibility-in-percona-postgresql-behind-haproxy/40130 "2026-02-20T16:39:08Z")

</div>

Issue Summary We have a Percona PostgreSQL cluster deployed behind HAProxy for load-balancing and high availability. Currently, PostgreSQL logs and pg\_stat\_activity only show the HAProxy IP as the client address instead…

---

## [Percona PMM tool giving performance issues on Prod environments](https://forums.percona.com/t/percona-pmm-tool-giving-performance-issues-on-prod-environments/37390)

<div class="topic-metadata">

**Author:** [@siddharth0204](https://forums.percona.com/u/siddharth0204)\
**Replies:** 8\
**Last updated:** [February 19, 2026, 6:06pm UTC](https://forums.percona.com/t/percona-pmm-tool-giving-performance-issues-on-prod-environments/37390 "2026-02-19T18:06:26Z")

</div>

hello, Thanks for helping out on our issues. Recently when using PMM for our postgresql instance, we saw significant performance issue that took a toll on performance of the database because of below sql fired by PMM a…

---

## [Monitoring ProxySQL for PostgreSQL](https://forums.percona.com/t/monitoring-proxysql-for-postgresql/40221)

<div class="topic-metadata">

**Author:** [@shigaev.s](https://forums.percona.com/u/shigaev.s)\
**Replies:** 2\
**Last updated:** [February 17, 2026, 8:19am UTC](https://forums.percona.com/t/monitoring-proxysql-for-postgresql/40221 "2026-02-17T08:19:06Z")

</div>

Hello! I’m testing the new release of ProxySQL 3.0.5 for PostgreSQL 15. pmm-client 3.6.0-7 installed. I really miss ProxySQL monitoring for PostgreSQL, similar to MySQL. Currently, I’m manually monitoring statistics …

---

## [How to monitor Patroni metrics by PMM3.5.0，percona patroni 4.1.0](https://forums.percona.com/t/how-to-monitor-patroni-metrics-by-pmm3-5-0-percona-patroni-4-1-0/40178)

<div class="topic-metadata">

**Author:** [@jollogn](https://forums.percona.com/u/jollogn)\
**Replies:** 1\
**Last updated:** [February 16, 2026, 2:14pm UTC](https://forums.percona.com/t/how-to-monitor-patroni-metrics-by-pmm3-5-0-percona-patroni-4-1-0/40178 "2026-02-16T14:14:53Z")

</div>

I have add service by http://localhost:8008/metrics,but monitoring always failed. Also,/metrics doesn’t even have cluster member information, is there any solution?

---

## [Service Summary -\> ERROR 1045 (28000): Access denied for user 'pmm'@'localhost' (using password: YES)](https://forums.percona.com/t/service-summary-error-1045-28000-access-denied-for-user-pmm-localhost-using-password-yes/40193)

<div class="topic-metadata">

**Author:** [@Tomasz\_Chmielewski](https://forums.percona.com/u/Tomasz_Chmielewski)\
**Replies:** 1\
**Last updated:** [February 12, 2026, 1:51pm UTC](https://forums.percona.com/t/service-summary-error-1045-28000-access-denied-for-user-pmm-localhost-using-password-yes/40193 "2026-02-12T13:51:23Z")

</div>

Description: In MySQL → Summary → Service Summary, I’m getting: ERROR 1045 (28000): Access denied for user 'pmm'@'localhost' (using password: YES) 2026\_02\_11\_13\_06\_44 Cannot connect to MySQL. Check that MySQL is runnin…

---

## [How to set the default interval to 15 minutes for all users and switch to manual metrics refresh in Grafana PMM?](https://forums.percona.com/t/how-to-set-the-default-interval-to-15-minutes-for-all-users-and-switch-to-manual-metrics-refresh-in-grafana-pmm/40186)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 2\
**Last updated:** [February 11, 2026, 6:45am UTC](https://forums.percona.com/t/how-to-set-the-default-interval-to-15-minutes-for-all-users-and-switch-to-manual-metrics-refresh-in-grafana-pmm/40186 "2026-02-11T06:45:43Z")

</div>

Hi! Percona Monitoring and Manager is connected to about 130 hosts and approximately 150 PostgreSQL services. A very large number of metrics arrive over 12 hours. By default, in the PMM Grafana, the setting is for the l…

---

## [Insufficient access permissions error after upgrade to pmm 3.5.0](https://forums.percona.com/t/insufficient-access-permissions-error-after-upgrade-to-pmm-3-5-0/39783)

<div class="topic-metadata">

**Author:** [@Marvin\_Stelter](https://forums.percona.com/u/Marvin_Stelter)\
**Replies:** 8\
**Last updated:** [February 9, 2026, 9:12am UTC](https://forums.percona.com/t/insufficient-access-permissions-error-after-upgrade-to-pmm-3-5-0/39783 "2026-02-09T09:12:31Z")

</div>

Hi! PMM was automatically updated to version 3.5.0. After the upgrade, the dashboard was not accessible — we only saw the “Upgrade in progress” screen. After restarting, the dashboard became accessible again, but both F…

---

## [Get-pmm.sh Script PMM2 to 3 upgrade not working](https://forums.percona.com/t/get-pmm-sh-script-pmm2-to-3-upgrade-not-working/40118)

<div class="topic-metadata">

**Author:** [@Jimmy\_Chen](https://forums.percona.com/u/Jimmy_Chen)\
**Replies:** 14\
**Last updated:** [February 6, 2026, 11:53pm UTC](https://forums.percona.com/t/get-pmm-sh-script-pmm2-to-3-upgrade-not-working/40118 "2026-02-06T23:53:39Z")

</div>

I’m trying to follow the documentation on Migrate PMM 2 to PMM 3 - Percona Monitoring and Management to migrate from PMM2 to 3. However, the script get-pmm.sh is not working. It is attempting to create a Docker volume to…

---

## [Pmm3 can connect to database, throws pg\_hba error on pt-pg-summary](https://forums.percona.com/t/pmm3-can-connect-to-database-throws-pg-hba-error-on-pt-pg-summary/37908)

<div class="topic-metadata">

**Author:** [@yngmntr](https://forums.percona.com/u/yngmntr)\
**Replies:** 3\
**Last updated:** [February 3, 2026, 11:00am UTC](https://forums.percona.com/t/pmm3-can-connect-to-database-throws-pg-hba-error-on-pt-pg-summary/37908 "2026-02-03T11:00:34Z")

</div>

Hi, I have a pmm3.1 server that monitors a couple of Azure Flexible Server for Postgresql instances, looking at the ‘PostgreSQL Instance Summary’ Dashboard i can see live data, but opening the service-summary pane (that…

---

## [Mongodb\_exporter giving error after successfully connecting and showing down as a service in PMM](https://forums.percona.com/t/mongodb-exporter-giving-error-after-successfully-connecting-and-showing-down-as-a-service-in-pmm/39245)

<div class="topic-metadata">

**Author:** [@standon22](https://forums.percona.com/u/standon22)\
**Replies:** 2\
**Last updated:** [January 29, 2026, 10:44pm UTC](https://forums.percona.com/t/mongodb-exporter-giving-error-after-successfully-connecting-and-showing-down-as-a-service-in-pmm/39245 "2026-01-29T22:44:20Z")

</div>

Description: Service is added successfully but getting errors “context deadlne exceeded” Steps to Reproduce: Simply add a service using service add command. pmm-admin add mongodb psmdb\_node\_1 --replication-set=ReplSet …

---

## [Request to upgrade VictoriaMetrics in PMM to v1.133.0 or later (per-partition index support)](https://forums.percona.com/t/request-to-upgrade-victoriametrics-in-pmm-to-v1-133-0-or-later-per-partition-index-support/40124)

<div class="topic-metadata">

**Author:** [@hyunyoungjung](https://forums.percona.com/u/hyunyoungjung)\
**Replies:** 3\
**Last updated:** [January 29, 2026, 10:39pm UTC](https://forums.percona.com/t/request-to-upgrade-victoriametrics-in-pmm-to-v1-133-0-or-later-per-partition-index-support/40124 "2026-01-29T22:39:18Z")

</div>

Summary We are running PMM 3 (Percona Monitoring and Management) to monitor MySQL instances. Since December 18, 2025, we have been experiencing abnormal growth of VictoriaMetrics indexdb, which leads to high disk usage…

---

## [PMM Client Credentials in Helm Chart](https://forums.percona.com/t/pmm-client-credentials-in-helm-chart/40068)

<div class="topic-metadata">

**Author:** [@Rodrigo\_Junior\_de\_As](https://forums.percona.com/u/Rodrigo_Junior_de_As)\
**Replies:** 6\
**Last updated:** [January 29, 2026, 1:07pm UTC](https://forums.percona.com/t/pmm-client-credentials-in-helm-chart/40068 "2026-01-29T13:07:33Z")

</div>

How to configure PMM Client credentials in Percona Mongodb Chart in a way that PMM Server can list all backups, storages, etc? Custom sidecar?

---

## [How can we prevent PMM queries from appearing in the RDS MySQL slow query log?](https://forums.percona.com/t/how-can-we-prevent-pmm-queries-from-appearing-in-the-rds-mysql-slow-query-log/40079)

<div class="topic-metadata">

**Author:** [@srinivasms](https://forums.percona.com/u/srinivasms)\
**Replies:** 2\
**Last updated:** [January 24, 2026, 10:32pm UTC](https://forums.percona.com/t/how-can-we-prevent-pmm-queries-from-appearing-in-the-rds-mysql-slow-query-log/40079 "2026-01-24T22:32:36Z")

</div>

Description: we have around 2000 rds mysql instance being monitored by the PMM we have set the long\_query\_time set to 1 sec some times the pmm queries also get logged in the slow query log , which we dont want. how we c…

---

## [Metrics Retention Not Working as Expected in PMM Server 3.1.0 on Kubernetes](https://forums.percona.com/t/metrics-retention-not-working-as-expected-in-pmm-server-3-1-0-on-kubernetes/38282)

<div class="topic-metadata">

**Author:** [@Arul\_Deepan\_Anbumani](https://forums.percona.com/u/Arul_Deepan_Anbumani)\
**Replies:** 1\
**Last updated:** [January 23, 2026, 1:43am UTC](https://forums.percona.com/t/metrics-retention-not-working-as-expected-in-pmm-server-3-1-0-on-kubernetes/38282 "2026-01-23T01:43:09Z")

</div>

We’re running PMM Server v3.1.0 deployed in Kubernetes using the official Helm chart. As part of our configuration, we’ve explicitly set the following in our Helm values to retain metrics for 90 days pmmEnv: DATA\_RETE…

---

## [PMM 3.5 vulnerabilities](https://forums.percona.com/t/pmm-3-5-vulnerabilities/40038)

<div class="topic-metadata">

**Author:** [@Sai\_Teja\_Varma](https://forums.percona.com/u/Sai_Teja_Varma)\
**Replies:** 1\
**Last updated:** [January 22, 2026, 9:01am UTC](https://forums.percona.com/t/pmm-3-5-vulnerabilities/40038 "2026-01-22T09:01:54Z")

</div>

Description: There are vulnerabilities on PMM (underlying grafana) Steps to Reproduce: We used trivy to scan the pmm images Version: 3.5 Logs: \[If applicable, include any relevant log files or error messages\] Expected…

---

## [PMM3 Postgresql custom queries](https://forums.percona.com/t/pmm3-postgresql-custom-queries/40065)

<div class="topic-metadata">

**Author:** [@makuartur](https://forums.percona.com/u/makuartur)\
**Replies:** 6\
**Last updated:** [January 20, 2026, 5:00pm UTC](https://forums.percona.com/t/pmm3-postgresql-custom-queries/40065 "2026-01-20T17:00:32Z")

</div>

Description: I am trying to configure the execution of a PostgreSQL query using pmm-agent (via its built-in postgresql\_exporter). The problem is that database auto-discovery is enabled and works as expected, but my query…

---

## [OS metrics not accessible](https://forums.percona.com/t/os-metrics-not-accessible/40053)

<div class="topic-metadata">

**Author:** [@Bobleponge](https://forums.percona.com/u/Bobleponge)\
**Replies:** 2\
**Last updated:** [January 20, 2026, 1:08pm UTC](https://forums.percona.com/t/os-metrics-not-accessible/40053 "2026-01-20T13:08:29Z")

</div>

Description: Hello, on the pmm console I cannot see anymore OS metrics since I use v2.44 I tried from the client curl http://127.0.0.1:42001/metrics but it gives Unauthorized I there a way to solve it ? is it possible …

---

## [MariaDB: slow stored procedures, performance schema vs slow log](https://forums.percona.com/t/mariadb-slow-stored-procedures-performance-schema-vs-slow-log/40021)

<div class="topic-metadata">

**Author:** [@laund](https://forums.percona.com/u/laund)\
**Replies:** 6\
**Last updated:** [January 13, 2026, 10:29pm UTC](https://forums.percona.com/t/mariadb-slow-stored-procedures-performance-schema-vs-slow-log/40021 "2026-01-13T22:29:34Z")

</div>

Heyo! I’ve been using PMM to find and resolve performance issues, and i’m running into a slight hurdle: QAN shows that some stored procedures are quite slow. Now, i know its entirely possible to find out why its slow wi…

---

## [Mongodb\_exporter failed to create PBM client from uri](https://forums.percona.com/t/mongodb-exporter-failed-to-create-pbm-client-from-uri/39224)

<div class="topic-metadata">

**Author:** [@Pjotz](https://forums.percona.com/u/Pjotz)\
**Replies:** 4\
**Last updated:** [January 12, 2026, 11:13am UTC](https://forums.percona.com/t/mongodb-exporter-failed-to-create-pbm-client-from-uri/39224 "2026-01-12T11:13:35Z")

</div>

I´m stuck at an issue with percona\_mongodb\_exporter, the log is getting flooded with the error below, wich results in extreme memory usage, and cpu usage. everything is running in containers. After some time, the contai…

---

## [Getting pg\_stat\_statements.blk\_read\_time error on Postgresql RDS 17](https://forums.percona.com/t/getting-pg-stat-statements-blk-read-time-error-on-postgresql-rds-17/39282)

<div class="topic-metadata">

**Author:** [@Selva1](https://forums.percona.com/u/Selva1)\
**Replies:** 2\
**Last updated:** [January 7, 2026, 11:33am UTC](https://forums.percona.com/t/getting-pg-stat-statements-blk-read-time-error-on-postgresql-rds-17/39282 "2026-01-07T11:33:27Z")

</div>

Description: Setting up Percona monitoring for AWS RDS PostgreSQL 17.5 Steps to Reproduce: Launch AWS RDS PostgreSQL 17.5 and Perform Percona Monitoring with PMM 2.41.2 Version: AWS RDS PostgreSQL 17.5 Percona Monitor…

---

## [Installation pmm server 3 on k8s not successful](https://forums.percona.com/t/installation-pmm-server-3-on-k8s-not-successful/39950)

<div class="topic-metadata">

**Author:** [@alexst](https://forums.percona.com/u/alexst)\
**Replies:** 5\
**Last updated:** [December 31, 2025, 10:14am UTC](https://forums.percona.com/t/installation-pmm-server-3-on-k8s-not-successful/39950 "2025-12-31T10:14:30Z")

</div>

I installed pmm server3 on k8s v. 1.27 via helm chart. when i check logs ,i get k logs pmm-0 2025-12-29 10:31:15,086 INFO exited: qan-api2 (exit status 1; not expected) 2025-12-29 10:31:15,125 INFO exited: postgresql…

---

## [Why was the query not captured in PMM?](https://forums.percona.com/t/why-was-the-query-not-captured-in-pmm/39922)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 5\
**Last updated:** [December 29, 2025, 9:37am UTC](https://forums.percona.com/t/why-was-the-query-not-captured-in-pmm/39922 "2025-12-29T09:37:55Z")

</div>

The server is running PostgreSQL version 14 with the pg\_stat\_statements and pg\_profile extensions installed. Pg\_profile snapshots are created hourly at minute 00. A query was started at 00:05 and completed at 04:23. T…

---

## [Getting Started with Contributing to PMM as a beginner](https://forums.percona.com/t/getting-started-with-contributing-to-pmm-as-a-beginner/39934)

<div class="topic-metadata">

**Author:** [@Balaji\_Jothi](https://forums.percona.com/u/Balaji_Jothi)\
**Replies:** 1\
**Last updated:** [December 24, 2025, 6:40am UTC](https://forums.percona.com/t/getting-started-with-contributing-to-pmm-as-a-beginner/39934 "2025-12-24T06:40:37Z")

</div>

Hi, I’m Balaji, a pre final year student interested in contributing to open source. I m particularly interested in databases and backend systems mainly using Go and Python. When I look at the issues page, many of the is…

---

## [No query examples in the Examples tab](https://forums.percona.com/t/no-query-examples-in-the-examples-tab/39894)

<div class="topic-metadata">

**Author:** [@AndreKR](https://forums.percona.com/u/AndreKR)\
**Replies:** 3\
**Last updated:** [December 16, 2025, 11:23pm UTC](https://forums.percona.com/t/no-query-examples-in-the-examples-tab/39894 "2025-12-16T23:23:35Z")

</div>

Description: I just set up PMM. I’m seeing queries in QAN, but the Examples tab (and the Plan tab as well) are empty: When I go to Explore and run select example from pmm.metrics limit 10; on ClickHouse, I get a lis…

---

## [Pmm 3 and sqlserver](https://forums.percona.com/t/pmm-3-and-sqlserver/39878)

<div class="topic-metadata">

**Author:** [@Bobleponge](https://forums.percona.com/u/Bobleponge)\
**Replies:** 1\
**Last updated:** [December 12, 2025, 9:21pm UTC](https://forums.percona.com/t/pmm-3-and-sqlserver/39878 "2025-12-12T21:21:30Z")

</div>

Hello, I would like to monitor some mssql databases in PMM. I installed an exporter: awaragi/prometheus-mssql-exporter and can access to the metrics of my mssql db : http://vtldtbpmm101:9187/metrics Is there a way to…

---

## [If you're seeing this Grafana has failed to load its application files](https://forums.percona.com/t/if-youre-seeing-this-grafana-has-failed-to-load-its-application-files/39872)

<div class="topic-metadata">

**Author:** [@Bobleponge](https://forums.percona.com/u/Bobleponge)\
**Replies:** 2\
**Last updated:** [December 11, 2025, 1:26pm UTC](https://forums.percona.com/t/if-youre-seeing-this-grafana-has-failed-to-load-its-application-files/39872 "2025-12-11T13:26:47Z")

</div>

Hello, When installing with docker V3 I get the following error when trying to reach grafana : If you’re seeing this Grafana has failed to load its application file I use pmm v2 it works well but not v3. On rocky 9.5…

---

## [PMM3 postgres on Read only =\> pg\_custom\_replication\_wal pq: recovery is in progress](https://forums.percona.com/t/pmm3-postgres-on-read-only-pg-custom-replication-wal-pq-recovery-is-in-progress/38681)

<div class="topic-metadata">

**Author:** [@bart.schelstraete](https://forums.percona.com/u/bart.schelstraete)\
**Replies:** 6\
**Last updated:** [December 11, 2025, 9:45am UTC](https://forums.percona.com/t/pmm3-postgres-on-read-only-pg-custom-replication-wal-pq-recovery-is-in-progress/38681 "2025-12-11T09:45:45Z")

</div>

Since the last version, our syslog is being spammed on read only postgres slaves: Jul 15 10:15:59 pmm-agent\[2743907\]: time=“2025-07-15T10:15:59.975+01:00” level=error msg=“ts=2025-07-15T09:15:59.974Z caller=server.go:1…

---

## [PMM QAN for prepared statements with AWS RDS mysql](https://forums.percona.com/t/pmm-qan-for-prepared-statements-with-aws-rds-mysql/39855)

<div class="topic-metadata">

**Author:** [@Christoph\_Mayrhofer](https://forums.percona.com/u/Christoph_Mayrhofer)\
**Replies:** 6\
**Last updated:** [December 9, 2025, 8:03pm UTC](https://forums.percona.com/t/pmm-qan-for-prepared-statements-with-aws-rds-mysql/39855 "2025-12-09T20:03:10Z")

</div>

I use aws rds mysql and successfully set everything up with using performance\_schema as the source. Unfortunately I had to notice that QAN does not show any of my application queries and I found out that this is because…

---

## [Series labels missing (series A, series B, ...)](https://forums.percona.com/t/series-labels-missing-series-a-series-b/39852)

<div class="topic-metadata">

**Author:** [@Christoph\_Mayrhofer](https://forums.percona.com/u/Christoph_Mayrhofer)\
**Replies:** 1\
**Last updated:** [December 8, 2025, 9:14am UTC](https://forums.percona.com/t/series-labels-missing-series-a-series-b/39852 "2025-12-08T09:14:39Z")

</div>

I am new to percona PMM and just set it up with aws rds mysql. I followed these instructions: Data is also showing up in the PMM UI, but the graph labels all just show series-A, series-B, etc Did I miss some setting…

---

## [Pg\_stat\_monitor 2.2 - Collapsing similar queries](https://forums.percona.com/t/pg-stat-monitor-2-2-collapsing-similar-queries/39763)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 5\
**Last updated:** [November 25, 2025, 3:24pm UTC](https://forums.percona.com/t/pg-stat-monitor-2-2-collapsing-similar-queries/39763 "2025-11-25T15:24:14Z")

</div>

Why doesn’t pg\_stat\_monitor 2.2 collapse such similar queries? Under high TPS, all buckets get filled with identical queries. As a result, it starts consuming more shared memory. It can collapse similar queries. In pg\_s…

[Previous page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md?page=1)

[Next page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md?page=3)
