# Percona Monitoring and Management (PMM)

**URL:** https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md?page=1

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 2

---

## [I built a Chrome extension that explains PMM charts with AI — looking for feedback](https://forums.percona.com/t/i-built-a-chrome-extension-that-explains-pmm-charts-with-ai-looking-for-feedback/40648)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0\
**Last updated:** [April 17, 2026, 8:05am UTC](https://forums.percona.com/t/i-built-a-chrome-extension-that-explains-pmm-charts-with-ai-looking-for-feedback/40648 "2026-04-17T08:05:43Z")

</div>

Hey everyone :waving\_hand: I want to share a small side project I’ve been working on and get some feedback from the community. The problem I spend a lot of time in PMM dashboards, and honestly — I don’t always know wh…

---

## [PMM3.7 - Getting error "refused to connect" on all panels after upgrade to 3.7.0](https://forums.percona.com/t/pmm3-7-getting-error-refused-to-connect-on-all-panels-after-upgrade-to-3-7-0/40635)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 3\
**Last updated:** [April 17, 2026, 7:46am UTC](https://forums.percona.com/t/pmm3-7-getting-error-refused-to-connect-on-all-panels-after-upgrade-to-3-7-0/40635 "2026-04-17T07:46:50Z")

</div>

Hello dear Percona team, after upgrading PMM from 3.5.0 to 3.7.0, we started to observed an error on some pages. Not the entire page, actually, but on frames within the page. The console loads without any issues, and we…

---

## [NOT able get the collection metrics and DBs in the PMM MongoDB collections overview dashboard](https://forums.percona.com/t/not-able-get-the-collection-metrics-and-dbs-in-the-pmm-mongodb-collections-overview-dashboard/40586)

<div class="topic-metadata">

**Author:** [@vishnu](https://forums.percona.com/u/vishnu)\
**Replies:** 3\
**Last updated:** [April 10, 2026, 7:14am UTC](https://forums.percona.com/t/not-able-get-the-collection-metrics-and-dbs-in-the-pmm-mongodb-collections-overview-dashboard/40586 "2026-04-10T07:14:44Z")

</div>

Hi I am currently running PMM Server v3.7.0 as a Docker container on a separate server, and PMM Client v3.7.0 on the host machine for a MongoDB replica set. I am working on a secondary node. I am able to view basic met…

---

## [PMM3.7 - Getting error "tls: failed to verify certificate: x509: certificate is valid for" while adding a MySQL database](https://forums.percona.com/t/pmm3-7-getting-error-tls-failed-to-verify-certificate-x509-certificate-is-valid-for-while-adding-a-mysql-database/40581)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 4\
**Last updated:** [April 9, 2026, 7:36am UTC](https://forums.percona.com/t/pmm3-7-getting-error-tls-failed-to-verify-certificate-x509-certificate-is-valid-for-while-adding-a-mysql-database/40581 "2026-04-09T07:36:32Z")

</div>

Hello dear Percona team, I am testing PMM 3.7 (Docker container). Setup was all good, but while adding a MySQL database as a target with this command: sudo pmm-admin add mysql --server-url='https://admin:\<pwd\>@\<host-wh…

---

## [Documentation gap: PMM\_CLICKHOUSE\_IS\_CLUSTER / PMM\_CLICKHOUSE\_CLUSTER\_NAME for HA + external ClickHouse](https://forums.percona.com/t/documentation-gap-pmm-clickhouse-is-cluster-pmm-clickhouse-cluster-name-for-ha-external-clickhouse/40591)

<div class="topic-metadata">

**Author:** [@ddkozyreva](https://forums.percona.com/u/ddkozyreva)\
**Replies:** 0\
**Last updated:** [April 9, 2026, 1:13am UTC](https://forums.percona.com/t/documentation-gap-pmm-clickhouse-is-cluster-pmm-clickhouse-cluster-name-for-ha-external-clickhouse/40591 "2026-04-09T01:13:56Z")

</div>

Hi team! I’d like to flag a documentation gap that cost us several hours of debugging in a PMM 3.6.0 HA setup with an external 3-node ClickHouse cluster (one shard, three replicas, ZooKeeper present, macros configured). …

---

## [Possible HA issue with /srv/pmm-encryption.key not being shared between nodes](https://forums.percona.com/t/possible-ha-issue-with-srv-pmm-encryption-key-not-being-shared-between-nodes/40583)

<div class="topic-metadata">

**Author:** [@ddkozyreva](https://forums.percona.com/u/ddkozyreva)\
**Replies:** 1\
**Last updated:** [April 8, 2026, 10:30am UTC](https://forums.percona.com/t/possible-ha-issue-with-srv-pmm-encryption-key-not-being-shared-between-nodes/40583 "2026-04-08T10:30:45Z")

</div>

Hi team, I’ve been running a 3-node PMM Server HA cluster (PMM 3.6.0, Docker, deployed per the official HA guide with shared external PostgreSQL and ClickHouse) and ran into something that looks like a regression compar…

---

## [Pmm dashboard's taking too long to load](https://forums.percona.com/t/pmm-dashboards-taking-too-long-to-load/40578)

<div class="topic-metadata">

**Author:** [@Divinstar\_S](https://forums.percona.com/u/Divinstar_S)\
**Replies:** 4\
**Last updated:** [April 7, 2026, 5:46pm UTC](https://forums.percona.com/t/pmm-dashboards-taking-too-long-to-load/40578 "2026-04-07T17:46:57Z")

</div>

Description: I have setup Pmm server in a monitor node and it is responsible for 128 or so DB server’s(almost all of it is RDS). The issue is when I try to access Pmm UI’s System overview or any db overview like PSQL, it…

---

## [Discovered a bug in PMM 3.6.0 PostgreSQL exporter (CloudSQL)](https://forums.percona.com/t/discovered-a-bug-in-pmm-3-6-0-postgresql-exporter-cloudsql/40384)

<div class="topic-metadata">

**Author:** [@Simeon\_Petkov](https://forums.percona.com/u/Simeon_Petkov)\
**Replies:** 1\
**Last updated:** [April 2, 2026, 7:58pm UTC](https://forums.percona.com/t/discovered-a-bug-in-pmm-3-6-0-postgresql-exporter-cloudsql/40384 "2026-04-02T19:58:08Z")

</div>

Hello all, Yesterday after some debugging I have found that PostgreSQL exporter crashes when adding a new CloudSQL service when in “pg\_settings” we have “google\_dataplex.max\_messages” with a value like “-1:132” More de…

---

## [Renaming node and service](https://forums.percona.com/t/renaming-node-and-service/40408)

<div class="topic-metadata">

**Author:** [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Replies:** 3\
**Last updated:** [March 30, 2026, 3:18am UTC](https://forums.percona.com/t/renaming-node-and-service/40408 "2026-03-30T03:18:18Z")

</div>

Help! How to rename a host and services without an unregister operation? So as not to lose all the metric history for the host and its services. PMM version 3.5.0

---

## [\[RFC\] Redesigning QAN: Help us nail the new UX/UI](https://forums.percona.com/t/rfc-redesigning-qan-help-us-nail-the-new-ux-ui/40401)

<div class="topic-metadata">

**Author:** [@pedro.fernandes](https://forums.percona.com/u/pedro.fernandes)\
**Replies:** 0\
**Last updated:** [March 25, 2026, 8:37am UTC](https://forums.percona.com/t/rfc-redesigning-qan-help-us-nail-the-new-ux-ui/40401 "2026-03-25T08:37:37Z")

</div>

Hi everyone, The PMM team is working on a major frontend-focused redesign for Query Analytics (QAN). Our goal is to make troubleshooting faster and less cluttered without losing the deep technical DNA you rely on. W…

---

## [Not able to change pmm password in kube](https://forums.percona.com/t/not-able-to-change-pmm-password-in-kube/39369)

<div class="topic-metadata">

**Author:** [@Pramod\_Kumar\_Gupta](https://forums.percona.com/u/Pramod_Kumar_Gupta)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:32am UTC](https://forums.percona.com/t/not-able-to-change-pmm-password-in-kube/39369 "2026-03-24T08:32:59Z")

</div>

change-admin-password pramod123 this command show changed successfully but its not working i am using this deployment apiVersion: apps/v1 kind: Deployment metadata: name: pmm-server namespace: pmm spec: replicas…

---

## [PMM Discovery Error](https://forums.percona.com/t/pmm-discovery-error/39791)

<div class="topic-metadata">

**Author:** [@Sarma\_Chavali](https://forums.percona.com/u/Sarma_Chavali)\
**Replies:** 2\
**Last updated:** [March 24, 2026, 8:20am UTC](https://forums.percona.com/t/pmm-discovery-error/39791 "2026-03-24T08:20:20Z")

</div>

Description: We have installed PMM from AWS Market place; Trying to add RDS server discovery AWS using below methos IAM user credentials IAM Role(with assume role) Got timeout error; We have downloaded the logs;In li…

---

## [How i can create custom dashboard which is all rds instances running in B account via Assume role between A and B accounts](https://forums.percona.com/t/how-i-can-create-custom-dashboard-which-is-all-rds-instances-running-in-b-account-via-assume-role-between-a-and-b-accounts/39818)

<div class="topic-metadata">

**Author:** [@vasu1](https://forums.percona.com/u/vasu1)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:15am UTC](https://forums.percona.com/t/how-i-can-create-custom-dashboard-which-is-all-rds-instances-running-in-b-account-via-assume-role-between-a-and-b-accounts/39818 "2026-03-24T08:15:13Z")

</div>

Hello Team, I have a few questions regarding PMM 3.x and its integration with multiple AWS accounts. Environment Details I have multiple AWS accounts (A, B, C, D, etc.). PMM Server is deployed using the AWS Marke…

---

## [QAN: Is there a way to change a column in Overview to show "Sum" or "Per Query stats" instead?](https://forums.percona.com/t/qan-is-there-a-way-to-change-a-column-in-overview-to-show-sum-or-per-query-stats-instead/40042)

<div class="topic-metadata">

**Author:** [@laund](https://forums.percona.com/u/laund)\
**Replies:** 1\
**Last updated:** [March 24, 2026, 8:06am UTC](https://forums.percona.com/t/qan-is-there-a-way-to-change-a-column-in-overview-to-show-sum-or-per-query-stats-instead/40042 "2026-03-24T08:06:28Z")

</div>

Hello! In QAN, when i click on a query to see its details, its statistics shows me 3 views/aggregates of the stats: Rate/Second Sum Per Query Stats But when i add a column to the overview, it seems to always use “Rat…

---

## [After upgrade from pmm 2.41 to pmm 2.44](https://forums.percona.com/t/after-upgrade-from-pmm-2-41-to-pmm-2-44/39986)

<div class="topic-metadata">

**Author:** [@Frak](https://forums.percona.com/u/Frak)\
**Replies:** 5\
**Last updated:** [March 24, 2026, 7:49am UTC](https://forums.percona.com/t/after-upgrade-from-pmm-2-41-to-pmm-2-44/39986 "2026-03-24T07:49:35Z")

</div>

Description: Problems after upgrade from pmm 2.41.0 to 2.44 Steps to Reproduce: After the upgrade i’m unable to access to the server both with admin user and personal user Logs: supervisorctl status shows alertmanager…

---

## [MongoDB Instance Summary dashboard shows "No data" for mongos services on PMM 3.6.0](https://forums.percona.com/t/mongodb-instance-summary-dashboard-shows-no-data-for-mongos-services-on-pmm-3-6-0/40383)

<div class="topic-metadata">

**Author:** [@helloyeops](https://forums.percona.com/u/helloyeops)\
**Replies:** 2\
**Last updated:** [March 23, 2026, 11:26am UTC](https://forums.percona.com/t/mongodb-instance-summary-dashboard-shows-no-data-for-mongos-services-on-pmm-3-6-0/40383 "2026-03-23T11:26:35Z")

</div>

Description: The MongoDB Instance Summary dashboard in PMM 3.6.0 shows “No data” on several panels when a mongos service is selected. The Service Name dropdown includes mongos services, so users expect data to appear, bu…

---

## [MongoDB Collection overview - missing data](https://forums.percona.com/t/mongodb-collection-overview-missing-data/40381)

<div class="topic-metadata">

**Author:** [@MarekPlichta](https://forums.percona.com/u/MarekPlichta)\
**Replies:** 1\
**Last updated:** [March 20, 2026, 11:26am UTC](https://forums.percona.com/t/mongodb-collection-overview-missing-data/40381 "2026-03-20T11:26:01Z")

</div>

Edit: I managed to fix it. For anyone dealing with a similar problem, the issue was that the default max-collections-limit is set to 200, but since my instance had over 300 collections in total, it wasn’t getting collect…

---

## [Conditions for ExternalVM are skipped when HA\_mode is true](https://forums.percona.com/t/conditions-for-externalvm-are-skipped-when-ha-mode-is-true/40367)

<div class="topic-metadata">

**Author:** [@ddkozyreva](https://forums.percona.com/u/ddkozyreva)\
**Replies:** 1\
**Last updated:** [March 17, 2026, 11:09pm UTC](https://forums.percona.com/t/conditions-for-externalvm-are-skipped-when-ha-mode-is-true/40367 "2026-03-17T23:09:25Z")

</div>

Hi! I have two problems with HA mode on the largest installations. And both of them probably caused by this commit which added \`&& !HA.Enabled\` to the condition that previously skipped config validation for external VM s…

---

## [Service status showing unspecified](https://forums.percona.com/t/service-status-showing-unspecified/39494)

<div class="topic-metadata">

**Author:** [@mughees52](https://forums.percona.com/u/mughees52)\
**Replies:** 1\
**Last updated:** [March 17, 2026, 12:07pm UTC](https://forums.percona.com/t/service-status-showing-unspecified/39494 "2026-03-17T12:07:09Z")

</div>

Description: Hello team X Perconian, I need your help. I have a strange issue with PMM3. I tried to add a PostgreSQL service running in k8, but after adding it, the service is showing as unspecified in the service sectio…

---

## [Missing \`orgs:read\` permission as "Admin" since upgrade to PMM v3.6.0](https://forums.percona.com/t/missing-orgs-read-permission-as-admin-since-upgrade-to-pmm-v3-6-0/40357)

<div class="topic-metadata">

**Author:** [@hvtilborg](https://forums.percona.com/u/hvtilborg)\
**Replies:** 4\
**Last updated:** [March 16, 2026, 3:35pm UTC](https://forums.percona.com/t/missing-orgs-read-permission-as-admin-since-upgrade-to-pmm-v3-6-0/40357 "2026-03-16T15:35:28Z")

</div>

Although I have the “Admin” role (provisioned using generic OAuth), I cannot open PMM v3.6.0’s: Opening “Configuration” \> “Org. management” \> “Organizations”, results in: While opening “Configuration” \> “Org. ma…

---

## [PMM 3.6.0 – ClickHouse background merge loop on system.metric\_log causing 100% CPU and repeated MEMORY\_LIMIT\_EXCEEDED](https://forums.percona.com/t/pmm-3-6-0-clickhouse-background-merge-loop-on-system-metric-log-causing-100-cpu-and-repeated-memory-limit-exceeded/40362)

<div class="topic-metadata">

**Author:** [@Henryx](https://forums.percona.com/u/Henryx)\
**Replies:** 1\
**Last updated:** [March 15, 2026, 9:34am UTC](https://forums.percona.com/t/pmm-3-6-0-clickhouse-background-merge-loop-on-system-metric-log-causing-100-cpu-and-repeated-memory-limit-exceeded/40362 "2026-03-15T09:34:54Z")

</div>

Hello, I am experiencing a severe performance issue with PMM 3.6.0 where the server becomes extremely slow and CPU usage reaches 100% continuously. Investigation shows that ClickHouse repeatedly attempts background mer…

---

## [UI annoyances when PMM upgrades are disabled in v3.6.0](https://forums.percona.com/t/ui-annoyances-when-pmm-upgrades-are-disabled-in-v3-6-0/40356)

<div class="topic-metadata">

**Author:** [@hvtilborg](https://forums.percona.com/u/hvtilborg)\
**Replies:** 3\
**Last updated:** [March 13, 2026, 2:25pm UTC](https://forums.percona.com/t/ui-annoyances-when-pmm-upgrades-are-disabled-in-v3-6-0/40356 "2026-03-13T14:25:07Z")

</div>

Because reasons™, we have disabled upgrades for PMM (using PMM\_ENABLE\_UPDATES=false). This results in some UI annoyances in PMM v3.6.0: In the “Updates” pane, there are very many non-numbers: In the menu, “Updates” …

---

## [Pmm-agent is not running. Please re-run \`pmm-agent setup\` with --config-file flag](https://forums.percona.com/t/pmm-agent-is-not-running-please-re-run-pmm-agent-setup-with-config-file-flag/22998)

<div class="topic-metadata">

**Author:** [@farhan.ext](https://forums.percona.com/u/farhan.ext)\
**Replies:** 6\
**Last updated:** [March 13, 2026, 10:09am UTC](https://forums.percona.com/t/pmm-agent-is-not-running-please-re-run-pmm-agent-setup-with-config-file-flag/22998 "2026-03-13T10:09:49Z")

</div>

Hello, i am getting this below error while configuring mysql host: \[root@stg01 rroot\]# pmm-admin config --force --server-insecure-tls --server-url=https://admin:password@pmm-server-IP Checking local pmm-agent status… …

---

## [Connect\_timeout=1s is too short](https://forums.percona.com/t/connect-timeout-1s-is-too-short/40338)

<div class="topic-metadata">

**Author:** [@zoyaaboujaish](https://forums.percona.com/u/zoyaaboujaish)\
**Replies:** 1\
**Last updated:** [March 7, 2026, 2:52pm UTC](https://forums.percona.com/t/connect-timeout-1s-is-too-short/40338 "2026-03-07T14:52:18Z")

</div>

Main Issue: frequent connection drops are occurring to certain databases connected to PMM. The drop is happening because the connect timeout value is not long enough for the current setup to establish a connection. The …

---

## [PMM databases showed intermittent "down" status due to scrape timeouts being too short](https://forums.percona.com/t/pmm-databases-showed-intermittent-down-status-due-to-scrape-timeouts-being-too-short/40328)

<div class="topic-metadata">

**Author:** [@zoyaaboujaish](https://forums.percona.com/u/zoyaaboujaish)\
**Replies:** 3\
**Last updated:** [March 4, 2026, 7:45pm UTC](https://forums.percona.com/t/pmm-databases-showed-intermittent-down-status-due-to-scrape-timeouts-being-too-short/40328 "2026-03-04T19:45:40Z")

</div>

Is there a better way to resolve this issue permanently?\*\* Problem\*\* PMM databases showed intermittent “down” status due to scrape timeouts being too short: HR jobs: 9s (too short) MR jobs: 13.5s (too short) LR…

---

## [PMM cannot restore MySQL backup data](https://forums.percona.com/t/pmm-cannot-restore-mysql-backup-data/39981)

<div class="topic-metadata">

**Author:** [@hey](https://forums.percona.com/u/hey)\
**Replies:** 1\
**Last updated:** [March 4, 2026, 8:04am UTC](https://forums.percona.com/t/pmm-cannot-restore-mysql-backup-data/39981 "2026-03-04T08:04:18Z")

</div>

Hello, first, allow me to outline my current service setup. I have created the following containers on the same server using Docker: pmm-server, pmm-client, MySQL (8.0.35), and minio-server. After setting up these servic…

---

## [No query examples in PMM QAN with pg\_stat\_monitor normalized queries enabled](https://forums.percona.com/t/no-query-examples-in-pmm-qan-with-pg-stat-monitor-normalized-queries-enabled/40209)

<div class="topic-metadata">

**Author:** [@choi](https://forums.percona.com/u/choi)\
**Replies:** 1\
**Last updated:** [March 2, 2026, 11:50pm UTC](https://forums.percona.com/t/no-query-examples-in-pmm-qan-with-pg-stat-monitor-normalized-queries-enabled/40209 "2026-03-02T23:50:46Z")

</div>

Hi I’m using PMM 3.6.0 to monitor PostgreSQL and I’m seeing an issue in QAN: for some queries, the Examples section shows the message: “Sorry, no examples found for this query” This happens when pg\_stat\_monitor is en…

---

## [ERROR: 57014: canceling statement due to user request](https://forums.percona.com/t/error-57014-canceling-statement-due-to-user-request/40247)

<div class="topic-metadata">

**Author:** [@Bharath\_K](https://forums.percona.com/u/Bharath_K)\
**Replies:** 1\
**Last updated:** [February 22, 2026, 11:32am UTC](https://forums.percona.com/t/error-57014-canceling-statement-due-to-user-request/40247 "2026-02-22T11:32:18Z")

</div>

Description: ERROR: 57014: canceling statement due to user request We have installed and Configured PMM for our PostgreSQL clusters and then we are encountering this error message in our cluster logs frequently. Steps …

---

## [Pmm3.5 & proxysql\_exporter error due to caching\_sha2\_password auth](https://forums.percona.com/t/pmm3-5-proxysql-exporter-error-due-to-caching-sha2-password-auth/40191)

<div class="topic-metadata">

**Author:** [@Lalit\_Choudhary](https://forums.percona.com/u/Lalit_Choudhary)\
**Replies:** 2\
**Last updated:** [February 22, 2026, 9:43am UTC](https://forums.percona.com/t/pmm3-5-proxysql-exporter-error-due-to-caching-sha2-password-auth/40191 "2026-02-22T09:43:03Z")

</div>

Issue: PMM proxysql\_exporter monitoring not working with pxc operator proxysql scheduler. Using pxc-operator 1.19 with ProxySQL , pxc 8.4 , monitor use auth\_plugin “caching\_sha2\_password” proxysql version: pmm 3.5 …

---

## [Unable to create pmm-client docker container instance - file permissions issue inside container](https://forums.percona.com/t/unable-to-create-pmm-client-docker-container-instance-file-permissions-issue-inside-container/40176)

<div class="topic-metadata">

**Author:** [@bbtpd](https://forums.percona.com/u/bbtpd)\
**Replies:** 1\
**Last updated:** [February 22, 2026, 1:11am UTC](https://forums.percona.com/t/unable-to-create-pmm-client-docker-container-instance-file-permissions-issue-inside-container/40176 "2026-02-22T01:11:39Z")

</div>

Description: When attempting to start a new pmm-client docker container, the following error is thrown during the setup steps: Failed to start Agent: mkdir /usr/local/percona/pmm/tmp/agent\_type\_vm\_agent: permission denie…

[Previous page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md)

[Next page](https://forums.percona.com/c/percona-monitoring-and-management-pmm/30.md?page=2)
