# Percona Everest

**URL:** https://forums.percona.com/c/percona-everest/81.md?page=1

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 2

---

## [MySQL 5.7 deployment with Percona Everest](https://forums.percona.com/t/mysql-5-7-deployment-with-percona-everest/38065)

<div class="topic-metadata">

**Author:** [@an-toine](https://forums.percona.com/u/an-toine)\
**Replies:** 1\
**Last updated:** [May 22, 2025, 3:46pm UTC](https://forums.percona.com/t/mysql-5-7-deployment-with-percona-everest/38065 "2025-05-22T15:46:12Z")

</div>

Hello, We are currently evaluating Percona Everest to migrate some legacy databases. For a first POC, we have deployed Everest 1.6.0 on one of our Vanilla Kubernetes cluster. When creating a new MySQL server, there is…

---

## [MySQL Cluster goes into full crash every 5-10mins](https://forums.percona.com/t/mysql-cluster-goes-into-full-crash-every-5-10mins/38005)

<div class="topic-metadata">

**Author:** [@Aurimas\_Niekis](https://forums.percona.com/u/Aurimas_Niekis)\
**Replies:** 15\
**Last updated:** [May 20, 2025, 12:24pm UTC](https://forums.percona.com/t/mysql-cluster-goes-into-full-crash-every-5-10mins/38005 "2025-05-20T12:24:57Z")

</div>

Hi everyone, I’ve been testing Percona Everest with Percona XtraDB Cluster on our private (non production) Kubernetes (k3s) environment (hosted on big vSphere cluster). The goal is to validate and prepare deployment wor…

---

## [Everest questions](https://forums.percona.com/t/everest-questions/32183)

<div class="topic-metadata">

**Author:** [@silent](https://forums.percona.com/u/silent)\
**Replies:** 9\
**Last updated:** [May 20, 2025, 11:55am UTC](https://forums.percona.com/t/everest-questions/32183 "2025-05-20T11:55:24Z")

</div>

Hi all, I have a couple of questions regarding Everest: Annotating Services: Is there a way to configure additional labels and annotations for the services generated by Everest? Backup Retention Count: I noticed that …

---

## [AWS S3 integration](https://forums.percona.com/t/aws-s3-integration/36706)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 1\
**Last updated:** [May 20, 2025, 11:43am UTC](https://forums.percona.com/t/aws-s3-integration/36706 "2025-05-20T11:43:39Z")

</div>

Hey guys, I have a question about connection S3 storage to Everest. In my organization we are not using IAM users, instead we prefer IAM roles + service\_account. Is it possible to connect S3 bucket to the everest using …

---

## [Liveness probe failed and Readiness probe failed on HAProxy when creating MySQL](https://forums.percona.com/t/liveness-probe-failed-and-readiness-probe-failed-on-haproxy-when-creating-mysql/37952)

<div class="topic-metadata">

**Author:** [@chchch486](https://forums.percona.com/u/chchch486)\
**Replies:** 0\
**Last updated:** [May 15, 2025, 5:23am UTC](https://forums.percona.com/t/liveness-probe-failed-and-readiness-probe-failed-on-haproxy-when-creating-mysql/37952 "2025-05-15T05:23:11Z")

</div>

Hello, We are using Everest version 1.6.0 installed on VMware with Kubernetes version 1.32.2. When creating a MySQL instance, the Percona XtraDB Cluster (PXC) is successfully deployed, but HAProxy fails to start due to…

---

## [Stale GroupVersion discovery: packages.operators.coreos.com/v1 after Upgrade to Everest 1.6](https://forums.percona.com/t/stale-groupversion-discovery-packages-operators-coreos-com-v1-after-upgrade-to-everest-1-6/37700)

<div class="topic-metadata">

**Author:** [@pstekunov](https://forums.percona.com/u/pstekunov)\
**Replies:** 1\
**Last updated:** [May 14, 2025, 7:41pm UTC](https://forums.percona.com/t/stale-groupversion-discovery-packages-operators-coreos-com-v1-after-upgrade-to-everest-1-6/37700 "2025-05-14T19:41:36Z")

</div>

unable to retrieve the complete list of server APIs: packages.operators.coreos.com/v1: stale GroupVersion discovery: packages.operators.coreos.com/v1 Any ideas how to fix it? I’ve been digging around on other forums an…

---

## [Percona Everest 1.6.0 is here! 🤩](https://forums.percona.com/t/percona-everest-1-6-0-is-here/37779)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [April 30, 2025, 10:57am UTC](https://forums.percona.com/t/percona-everest-1-6-0-is-here/37779 "2025-04-30T10:57:13Z")

</div>

Our latest version of Percona Everest 1.6.0 was released days ago, it has exciting updates! :rocket: What’s New? Manual storage scale via UI :white\_check\_mark: Mongodb major upgrades (7.0 → 8.0) :rocket: PostgreSQL O…

---

## [Is there any way to temporary disable liveness probe on pg operator managed pods?](https://forums.percona.com/t/is-there-any-way-to-temporary-disable-liveness-probe-on-pg-operator-managed-pods/37027)

<div class="topic-metadata">

**Author:** [@pstekunov](https://forums.percona.com/u/pstekunov)\
**Replies:** 2\
**Last updated:** [April 23, 2025, 7:42am UTC](https://forums.percona.com/t/is-there-any-way-to-temporary-disable-liveness-probe-on-pg-operator-managed-pods/37027 "2025-04-23T07:42:31Z")

</div>

Dear gents. I just setup everest + pg operator + pg Cluster. Trying to restore a database, but after some minutes database pod container is being restarted… Liveness probe failed: HTTP probe failed with statuscode: 50…

---

## [Unable to change disk size in Everest UI after PV resize](https://forums.percona.com/t/unable-to-change-disk-size-in-everest-ui-after-pv-resize/37597)

<div class="topic-metadata">

**Author:** [@daccetturi](https://forums.percona.com/u/daccetturi)\
**Replies:** 6\
**Last updated:** [April 18, 2025, 9:14am UTC](https://forums.percona.com/t/unable-to-change-disk-size-in-everest-ui-after-pv-resize/37597 "2025-04-18T09:14:19Z")

</div>

Hello everyone, I’ve enalarged the DB PV following this tutorial: Percona Operator Volume Expansion Without Downtime The disks are resized and pods have increased their size. Unfortunately the Everest UI continues to s…

---

## [Dynamically create Postgres DB](https://forums.percona.com/t/dynamically-create-postgres-db/31124)

<div class="topic-metadata">

**Author:** [@SaasHQ](https://forums.percona.com/u/SaasHQ)\
**Replies:** 6\
**Last updated:** [April 10, 2025, 2:04pm UTC](https://forums.percona.com/t/dynamically-create-postgres-db/31124 "2025-04-10T14:04:46Z")

</div>

Hi: Finally a private dbaas! My application needs to spin up a new postgres db every time I create a new project. I’d like to have Everest running in my K8s cloud. I was wondering what would be a simple approach to make …

---

## [Everest-olm resources/containers failed](https://forums.percona.com/t/everest-olm-resources-containers-failed/37213)

<div class="topic-metadata">

**Author:** [@Sahil\_Marhatta](https://forums.percona.com/u/Sahil_Marhatta)\
**Replies:** 1\
**Last updated:** [April 5, 2025, 8:39am UTC](https://forums.percona.com/t/everest-olm-resources-containers-failed/37213 "2025-04-05T08:39:41Z")

</div>

ContainerCannotRun (failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: exec: “/util/cpb”: permi…

---

## [Road Map for OpenShift for Percona Everest](https://forums.percona.com/t/road-map-for-openshift-for-percona-everest/37225)

<div class="topic-metadata">

**Author:** [@viveksingh23](https://forums.percona.com/u/viveksingh23)\
**Replies:** 4\
**Last updated:** [April 3, 2025, 3:37pm UTC](https://forums.percona.com/t/road-map-for-openshift-for-percona-everest/37225 "2025-04-03T15:37:19Z")

</div>

hello, Would it be possible to share what is planned for Percona Everest on OpenShift? Any approximate time line for supportability of Percona everest on OpenShift.

---

## [Percona Everest 1.5.0 is here! 🎉](https://forums.percona.com/t/percona-everest-1-5-0-is-here/37081)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [March 6, 2025, 5:08pm UTC](https://forums.percona.com/t/percona-everest-1-5-0-is-here/37081 "2025-03-06T17:08:41Z")

</div>

The latest version of Percona Everest 1.5.0 is now available with exciting updates! :rocket: What’s New? RBAC for External IDP Groups – Makes managing user permissions easier. Upgrade Notifications – You’ll now get an…

---

## [Video tutorial: MongoDB on Amazon EKS using Percona Everest](https://forums.percona.com/t/video-tutorial-mongodb-on-amazon-eks-using-percona-everest/28658)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 3\
**Last updated:** [February 5, 2025, 7:54pm UTC](https://forums.percona.com/t/video-tutorial-mongodb-on-amazon-eks-using-percona-everest/28658 "2025-02-05T19:54:21Z")

</div>

Hi, You’ve already read a lot from me about Everest, I’m sure many of you have wanted to try it but didn’t have the time or a ready-made environment. I thought you might like a video course on how to install and config…

---

## [Pmm client getting OOM after few days in everest deployed cluster](https://forums.percona.com/t/pmm-client-getting-oom-after-few-days-in-everest-deployed-cluster/32615)

<div class="topic-metadata">

**Author:** [@beta-auction](https://forums.percona.com/u/beta-auction)\
**Replies:** 8\
**Last updated:** [January 18, 2025, 4:58pm UTC](https://forums.percona.com/t/pmm-client-getting-oom-after-few-days-in-everest-deployed-cluster/32615 "2025-01-18T16:58:54Z")

</div>

I am running a PXC 3 node cluster using everest. After a few days I am getting this error. terminated Reason:Reason: OOMKilled - exit code: 137 for the pmm-client container alone and this is happening for the first no…

---

## [How to upgrade a DB and storage which is currently running in Everest?](https://forums.percona.com/t/how-to-upgrade-a-db-and-storage-which-is-currently-running-in-everest/36083)

<div class="topic-metadata">

**Author:** [@Timothy\_Elder](https://forums.percona.com/u/Timothy_Elder)\
**Replies:** 5\
**Last updated:** [January 16, 2025, 8:35am UTC](https://forums.percona.com/t/how-to-upgrade-a-db-and-storage-which-is-currently-running-in-everest/36083 "2025-01-16T08:35:04Z")

</div>

I have been looking for this in the Everest documentation with no success and it seems like it isn’t editable from the GUI, but how does one go about upgrading their MongoDB cluster once it is running in Everest? Also it…

---

## [How to configure proxy for everest-operator-controller-manager](https://forums.percona.com/t/how-to-configure-proxy-for-everest-operator-controller-manager/31711)

<div class="topic-metadata">

**Author:** [@duytq02](https://forums.percona.com/u/duytq02)\
**Replies:** 3\
**Last updated:** [January 13, 2025, 5:52pm UTC](https://forums.percona.com/t/how-to-configure-proxy-for-everest-operator-controller-manager/31711 "2025-01-13T17:52:55Z")

</div>

Hi all, I am trying to install Percona Everest in my private environment, In this env, All nodes must go through a proxy server in order to access the internet. I have a RKE2 cluster version 1.27 installed and running…

---

## [Loadbalancer creation](https://forums.percona.com/t/loadbalancer-creation/35559)

<div class="topic-metadata">

**Author:** [@Timothy\_Elder](https://forums.percona.com/u/Timothy_Elder)\
**Replies:** 3\
**Last updated:** [January 10, 2025, 9:43pm UTC](https://forums.percona.com/t/loadbalancer-creation/35559 "2025-01-10T21:43:08Z")

</div>

We are wanting to use Everest for internal only DB’s. We noticed that when creating a DB there is only an external/Internet facing NLB being created. How Can we confiogure this so that only an Internal NLB is being creat…

---

## [Install Percona Everest in kubernetes with helm Chart](https://forums.percona.com/t/install-percona-everest-in-kubernetes-with-helm-chart/33043)

<div class="topic-metadata">

**Author:** [@sbou](https://forums.percona.com/u/sbou)\
**Replies:** 6\
**Last updated:** [January 10, 2025, 11:09am UTC](https://forums.percona.com/t/install-percona-everest-in-kubernetes-with-helm-chart/33043 "2025-01-10T11:09:05Z")

</div>

Hi I search how to install everest percona with helm Chart. But the only documentation I found, details the installation with everestctl. Thanks in advance

---

## [Readiness Probe failed everest-operator-controller-manager](https://forums.percona.com/t/readiness-probe-failed-everest-operator-controller-manager/35957)

<div class="topic-metadata">

**Author:** [@benpat](https://forums.percona.com/u/benpat)\
**Replies:** 1\
**Last updated:** [January 9, 2025, 3:54pm UTC](https://forums.percona.com/t/readiness-probe-failed-everest-operator-controller-manager/35957 "2025-01-09T15:54:22Z")

</div>

Trying to figure out root cause for crash. during upgrade from 1.2 to 1.3. deployment in GCP Unable to upgrade it just hangs \*\* percona-postgresql-operator v2.3.1 will be upgraded to v2.4.1 % everestctl upgrade 🚀 You'…

---

## [Percona Everest 1.4.0: Now with Helm Charts and Improved User Experience! 🎉](https://forums.percona.com/t/percona-everest-1-4-0-now-with-helm-charts-and-improved-user-experience/36056)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [January 9, 2025, 1:08pm UTC](https://forums.percona.com/t/percona-everest-1-4-0-now-with-helm-charts-and-improved-user-experience/36056 "2025-01-09T13:08:38Z")

</div>

Introducing Percona Everest 1.4.0: Release Highlights :tada: We’re super excited to announce the release of Percona Everest 1.4.0, packed with exciting new features and improvements to make your database management on K…

---

## [Creation of new db from backup not possible - more than 63 characters](https://forums.percona.com/t/creation-of-new-db-from-backup-not-possible-more-than-63-characters/35919)

<div class="topic-metadata">

**Author:** [@balu](https://forums.percona.com/u/balu)\
**Replies:** 5\
**Last updated:** [January 7, 2025, 12:37pm UTC](https://forums.percona.com/t/creation-of-new-db-from-backup-not-possible-more-than-63-characters/35919 "2025-01-07T12:37:43Z")

</div>

Hi folks, I have a interesting issue: I’ve created a recurring backup job of my pxc db with name backup-apr (generated by everest). I’ve also created a backup location with name hetzner-fsn-prod This backup job now c…

---

## [Readiness Probe failed on Mysql pod](https://forums.percona.com/t/readiness-probe-failed-on-mysql-pod/32451)

<div class="topic-metadata">

**Author:** [@duytq02](https://forums.percona.com/u/duytq02)\
**Replies:** 2\
**Last updated:** [December 27, 2024, 8:03am UTC](https://forums.percona.com/t/readiness-probe-failed-on-mysql-pod/32451 "2024-12-27T08:03:29Z")

</div>

Hi, I am using percona everest version 1.1.0 I was trying to deploy a Mysql server from the Everest UI, the DB kept initializing and I checked the mysql pods that created by everest and see the mysql pods are failing t…

---

## [Everest Postgres Repo1-Host wrong](https://forums.percona.com/t/everest-postgres-repo1-host-wrong/32252)

<div class="topic-metadata">

**Author:** [@mbaba-03](https://forums.percona.com/u/mbaba-03)\
**Replies:** 1\
**Last updated:** [December 17, 2024, 4:16pm UTC](https://forums.percona.com/t/everest-postgres-repo1-host-wrong/32252 "2024-12-17T16:16:40Z")

</div>

Hi there, I’ve noticed in all of our Everest postgres clusters, the repo1-host defined in pgbackrest-config is appended with .kubernetes. e.g. (from the configmap): \[global\] … repo1-host = dbname-repo-host-0.dbname…

---

## [A demo application for experimenting with databases and PMM. Test load on databases](https://forums.percona.com/t/a-demo-application-for-experimenting-with-databases-and-pmm-test-load-on-databases/35685)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0\
**Last updated:** [December 16, 2024, 2:30pm UTC](https://forums.percona.com/t/a-demo-application-for-experimenting-with-databases-and-pmm-test-load-on-databases/35685 "2024-12-16T14:30:34Z")

</div>

Hi, I want to tell you about an application I developed and maybe you will find it useful. I have installed Percona Everest many times and created databases in it. I have also installed databases many times using Docke…

---

## [Backup page is throwing 500 error for PostgreSQL](https://forums.percona.com/t/backup-page-is-throwing-500-error-for-postgresql/35414)

<div class="topic-metadata">

**Author:** [@beta-auction](https://forums.percona.com/u/beta-auction)\
**Replies:** 3\
**Last updated:** [December 12, 2024, 12:27pm UTC](https://forums.percona.com/t/backup-page-is-throwing-500-error-for-postgresql/35414 "2024-12-12T12:27:08Z")

</div>

I recently upgraded from 1.1.1 to 1.2.0 then to 1.3.0 Went to PostgreSQL database that was running and had backup, now pages shows that i don’t have any backups. saw network calls and /backup was throwing 500 error with…

---

## [Everest 1.3.0 upgrade pgOperator to 2.5.0](https://forums.percona.com/t/everest-1-3-0-upgrade-pgoperator-to-2-5-0/35452)

<div class="topic-metadata">

**Author:** [@oavril](https://forums.percona.com/u/oavril)\
**Replies:** 1\
**Last updated:** [December 10, 2024, 3:09pm UTC](https://forums.percona.com/t/everest-1-3-0-upgrade-pgoperator-to-2-5-0/35452 "2024-12-10T15:09:30Z")

</div>

Hello everyone! I am using version 1.3.0 of Everest. The interface does not offer me an upgrade button to the Postgres operator 2.5.0. How can I use the latest version of the operator? Thank you for your future respo…

---

## [HTTPS Percona Everest](https://forums.percona.com/t/https-percona-everest/35487)

<div class="topic-metadata">

**Author:** [@viveksingh23](https://forums.percona.com/u/viveksingh23)\
**Replies:** 1\
**Last updated:** [December 7, 2024, 9:10am UTC](https://forums.percona.com/t/https-percona-everest/35487 "2024-12-07T09:10:08Z")

</div>

hello, I deployed percona everest and UI is accessible over port 8080. I am looking for a way to access UI over HTTPS with certificate e.g. self signed. Please provide some guidance to achieve access of UI over HTTPS

---

## [GitOps way to install Everest](https://forums.percona.com/t/gitops-way-to-install-everest/35007)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 3\
**Last updated:** [December 4, 2024, 2:21pm UTC](https://forums.percona.com/t/gitops-way-to-install-everest/35007 "2024-12-04T14:21:13Z")

</div>

Hello folks, I am wondering if is there a possibility to skip the CLI tool for installing Everest infrastructure and use gitops way with gitlab+ArgoCD for instance? Our company insists on infrastructure as a code for ev…

---

## [Percona everest - Create Database not available](https://forums.percona.com/t/percona-everest-create-database-not-available/35447)

<div class="topic-metadata">

**Author:** [@viveksingh23](https://forums.percona.com/u/viveksingh23)\
**Replies:** 2\
**Last updated:** [December 4, 2024, 8:17am UTC](https://forums.percona.com/t/percona-everest-create-database-not-available/35447 "2024-12-04T08:17:51Z")

</div>

hello, I deployed percona everest on a kubernetes cluster following quick start guide. All went well. However when i login to percona everest i dont get optiion in UI to create database. Where as in documentation i …

[Previous page](https://forums.percona.com/c/percona-everest/81.md)

[Next page](https://forums.percona.com/c/percona-everest/81.md?page=2)
