# Percona Everest

**URL:** https://forums.percona.com/c/percona-everest/81.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [OpenEverest has a new home! Where to find us and our community](https://forums.percona.com/t/openeverest-has-a-new-home-where-to-find-us-and-our-community/40126)

<div class="topic-metadata">

**Author:** [@spronin](https://forums.percona.com/u/spronin)\
**Replies:** 0\
**Last updated:** [January 29, 2026, 7:27am UTC](https://forums.percona.com/t/openeverest-has-a-new-home-where-to-find-us-and-our-community/40126 "2026-01-29T07:27:41Z")

</div>

Hi everyone, Sergey here, maintainer of OpenEverest and founder at Solanica. As we continue our transition from Percona Everest to OpenEverest, we want to ensure our community discussions are happening where the project…

---

## [About the Percona Everest category](https://forums.percona.com/t/about-the-percona-everest-category/25607)

<div class="topic-metadata">

**Author:** [@daniil.bazhenov](https://forums.percona.com/u/daniil.bazhenov)\
**Replies:** 0\
**Last updated:** [October 2, 2023, 6:20pm UTC](https://forums.percona.com/t/about-the-percona-everest-category/25607 "2023-10-02T18:20:10Z")

</div>

Percona Everest is the first open-source, cloud-native platform for automated database provisioning and management. It supports PostgreSQL, MongoDB, and MySQL clusters. It enables multi-database and multi-cluster configu…

---

## [SSO login does not work with Authentik](https://forums.percona.com/t/sso-login-does-not-work-with-authentik/40326)

<div class="topic-metadata">

**Author:** [@Stephen\_Hoogendijk](https://forums.percona.com/u/Stephen_Hoogendijk)\
**Replies:** 1\
**Last updated:** [March 3, 2026, 11:58am UTC](https://forums.percona.com/t/sso-login-does-not-work-with-authentik/40326 "2026-03-03T11:58:45Z")

</div>

Hi all, OIDC integration with Authentik fails after successful login. Authentication completes and the redirect works, but the session cannot be established. The Everest API server logs the following error repeatedly: {…

---

## [Create backup storage fails - invalid request invalid bucketName](https://forums.percona.com/t/create-backup-storage-fails-invalid-request-invalid-bucketname/40223)

<div class="topic-metadata">

**Author:** [@Michael\_Shield](https://forums.percona.com/u/Michael_Shield)\
**Replies:** 1\
**Last updated:** [February 19, 2026, 12:30pm UTC](https://forums.percona.com/t/create-backup-storage-fails-invalid-request-invalid-bucketname/40223 "2026-02-19T12:30:40Z")

</div>

Hi, I’ve been using Everest to create test DB’s for both MongoDB and Postgresql on a Hetzner Kubernetes cluster. Came back to create backup storage for Postgres in S3, which failed due to the bucket name format containi…

---

## [Pmm-client cannot connect to pmm3.0](https://forums.percona.com/t/pmm-client-cannot-connect-to-pmm3-0/39896)

<div class="topic-metadata">

**Author:** [@jjpark](https://forums.percona.com/u/jjpark)\
**Replies:** 6\
**Last updated:** [January 28, 2026, 9:05am UTC](https://forums.percona.com/t/pmm-client-cannot-connect-to-pmm3-0/39896 "2026-01-28T09:05:30Z")

</div>

latest release of everest begin to support pmm3.0 but when using latest everest helm chart and deploy mongodb 8.0.12 pmm-client cannot connect to my pmm-server pmm-server is running on external host, everest is runni…

---

## [Is there a way to install a custom PPG image from private repo when using everest to create instances?](https://forums.percona.com/t/is-there-a-way-to-install-a-custom-ppg-image-from-private-repo-when-using-everest-to-create-instances/40113)

<div class="topic-metadata">

**Author:** [@VarshithM](https://forums.percona.com/u/VarshithM)\
**Replies:** 0\
**Last updated:** [January 27, 2026, 11:20am UTC](https://forums.percona.com/t/is-there-a-way-to-install-a-custom-ppg-image-from-private-repo-when-using-everest-to-create-instances/40113 "2026-01-27T11:20:25Z")

</div>

I have a custom PPG image based off of the Percona Docker PGDB Dockerfile which installs Paradedb pg\_search extension and custom init scripts. I have the image hosted on our private container registry. We would like to …

---

## [Modify pgbouncer.ini](https://forums.percona.com/t/modify-pgbouncer-ini/32050)

<div class="topic-metadata">

**Author:** [@mbaba-03](https://forums.percona.com/u/mbaba-03)\
**Replies:** 2\
**Last updated:** [January 12, 2026, 11:39am UTC](https://forums.percona.com/t/modify-pgbouncer-ini/32050 "2026-01-12T11:39:07Z")

</div>

We’re currently facing an issue where we need to use schemas as part of regular migration activities on our postgres databases. We’re running into an issue with pgbouncer rejecting connections based upon them having sear…

---

## [Workflow identity for backup storage (AKS/Azure Blog Storage)](https://forums.percona.com/t/workflow-identity-for-backup-storage-aks-azure-blog-storage/39912)

<div class="topic-metadata">

**Author:** [@Till](https://forums.percona.com/u/Till)\
**Replies:** 5\
**Last updated:** [January 12, 2026, 10:13am UTC](https://forums.percona.com/t/workflow-identity-for-backup-storage-aks-azure-blog-storage/39912 "2026-01-12T10:13:41Z")

</div>

Hi, I want to use workflow identity for my backup storage, or rather for the jobs. I found a thread that received no answers recently, hence I am making another one. The thread: How do we add an AWS IRSA annotation to …

---

## [Everest SSO with Authelia IDP](https://forums.percona.com/t/everest-sso-with-authelia-idp/40022)

<div class="topic-metadata">

**Author:** [@Iaroslav\_Tverdokhlib](https://forums.percona.com/u/Iaroslav_Tverdokhlib)\
**Replies:** 3\
**Last updated:** [January 10, 2026, 9:38pm UTC](https://forums.percona.com/t/everest-sso-with-authelia-idp/40022 "2026-01-10T21:38:26Z")

</div>

Hi, Does anybody have experience with Authelia? Following Everest manual gives me “message=missing or malformed jwt, internal=missing value in request header" on Everest side, but all good on Authelia.

---

## [Announcing OpenEverest: the next step for the Everest project](https://forums.percona.com/t/announcing-openeverest-the-next-step-for-the-everest-project/39996)

<div class="topic-metadata">

**Author:** [@blair.rampling](https://forums.percona.com/u/blair.rampling)\
**Replies:** 0\
**Last updated:** [January 6, 2026, 4:53pm UTC](https://forums.percona.com/t/announcing-openeverest-the-next-step-for-the-everest-project/39996 "2026-01-06T16:53:24Z")

</div>

We want to share an important update about the future of the project you know as Percona Everest. Percona is transitioning Percona Everest into an independent open source project called OpenEverest (https://openeverest.…

---

## [Using everest deploying pg error](https://forums.percona.com/t/using-everest-deploying-pg-error/39897)

<div class="topic-metadata">

**Author:** [@jjpark](https://forums.percona.com/u/jjpark)\
**Replies:** 2\
**Last updated:** [December 17, 2025, 9:47am UTC](https://forums.percona.com/t/using-everest-deploying-pg-error/39897 "2025-12-17T09:47:50Z")

</div>

/go/pkg/mod/sigs.k8s.io/controller-runtime@v0.21.0/pkg/internal/controller/controller.go:202 │ … │ \[spec.resources.requests\[cpu\]: Invalid value: “50m”: m…

---

## [Declarative Database & User Management in DatabaseCluster CR](https://forums.percona.com/t/declarative-database-user-management-in-databasecluster-cr/39785)

<div class="topic-metadata">

**Author:** [@eneriz](https://forums.percona.com/u/eneriz)\
**Replies:** 1\
**Last updated:** [November 26, 2025, 9:20am UTC](https://forums.percona.com/t/declarative-database-user-management-in-databasecluster-cr/39785 "2025-11-26T09:20:00Z")

</div>

Hi Percona Team and Community, First of all, I want to say a huge thank you to the contributors for Percona Everest. It is an amazing tool that has significantly simplified our database provisioning on Kubernetes. I am…

---

## [MySQL 8.4 Instances](https://forums.percona.com/t/mysql-8-4-instances/39754)

<div class="topic-metadata">

**Author:** [@kjordan2001](https://forums.percona.com/u/kjordan2001)\
**Replies:** 1\
**Last updated:** [November 21, 2025, 1:34pm UTC](https://forums.percona.com/t/mysql-8-4-instances/39754 "2025-11-21T13:34:54Z")

</div>

When will Everest have the ability to create a MySQL 8.4 instance?

---

## [Why should we have automatic backups via jobs in postgres? #1690](https://forums.percona.com/t/why-should-we-have-automatic-backups-via-jobs-in-postgres-1690/39535)

<div class="topic-metadata">

**Author:** [@ahmad\_taknet](https://forums.percona.com/u/ahmad_taknet)\
**Replies:** 3\
**Last updated:** [October 16, 2025, 2:22pm UTC](https://forums.percona.com/t/why-should-we-have-automatic-backups-via-jobs-in-postgres-1690/39535 "2025-10-16T14:22:04Z")

</div>

Why does Postgres create a backup job for me in a pvc of the same size as the space I used when creating the database in Kuber when creating the database? I really don’t need this repo1 that was created when i started th…

---

## [MySQL PITR limitation in Everest](https://forums.percona.com/t/mysql-pitr-limitation-in-everest/38813)

<div class="topic-metadata">

**Author:** [@eprevost](https://forums.percona.com/u/eprevost)\
**Replies:** 5\
**Last updated:** [October 10, 2025, 12:52pm UTC](https://forums.percona.com/t/mysql-pitr-limitation-in-everest/38813 "2025-10-10T12:52:06Z")

</div>

Hi, I’m testing Everest’s Point in time restore feature for MySQL. According to the interface, PITR can only be done for a point in time between the last full backup and the latest transaction: Is there a way to do…

---

## [Percona Everest 1.9.0 Released! 🚀](https://forums.percona.com/t/percona-everest-1-9-0-released/39458)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [September 26, 2025, 11:15am UTC](https://forums.percona.com/t/percona-everest-1-9-0-released/39458 "2025-09-26T11:15:24Z")

</div>

:partying\_face: Percona Everest v1.9.0 is now available! :new\_button: Load Balancer Configuration :tada: Provisioning external access in Kubernetes is often cloud-specific (AWS, GCP, Azure), which means many manual anno…

---

## [Backup Container goes OOM on everest 1.9.0](https://forums.percona.com/t/backup-container-goes-oom-on-everest-1-9-0/39451)

<div class="topic-metadata">

**Author:** [@mPrad](https://forums.percona.com/u/mPrad)\
**Replies:** 0\
**Last updated:** [September 25, 2025, 12:15pm UTC](https://forums.percona.com/t/backup-container-goes-oom-on-everest-1-9-0/39451 "2025-09-25T12:15:48Z")

</div>

Description: I currently have few mongo databases on EKS with Everest 1.9.0. While trying to create a scheduled backup/adhoc backup using S3( the aws bucket is configured) we can observe the backup is triggered, the mong…

---

## [Failed to pull image "bitnami/kubectl:latest](https://forums.percona.com/t/failed-to-pull-image-bitnami-kubectl-latest/39407)

<div class="topic-metadata">

**Author:** [@VladoDov](https://forums.percona.com/u/VladoDov)\
**Replies:** 3\
**Last updated:** [September 19, 2025, 10:05am UTC](https://forums.percona.com/t/failed-to-pull-image-bitnami-kubectl-latest/39407 "2025-09-19T10:05:40Z")

</div>

Today, I tried to create a new namespace with this command “everestctl namespaces add mysqlx” for mysql operator, but Job “everest-operators-installer-…” failed with this error: Failed to pull image “bitnami/kubectl:lat…

---

## [ACTION REQUIRED: Percona Everest and Bitnami Container Catalog Changes ⚠️](https://forums.percona.com/t/action-required-percona-everest-and-bitnami-container-catalog-changes/39419)

<div class="topic-metadata">

**Author:** [@Diogo\_Recharte](https://forums.percona.com/u/Diogo_Recharte)\
**Replies:** 0\
**Last updated:** [September 19, 2025, 10:00am UTC](https://forums.percona.com/t/action-required-percona-everest-and-bitnami-container-catalog-changes/39419 "2025-09-19T10:00:44Z")

</div>

Attention Percona Everest Users: Bitnami is restructuring its container catalog on September 29, 2025. To ensure your Percona Everest operations remain seamless, you must take a few proactive steps now. Mandatory Fix to…

---

## [Everest import mysql from backup to new cluster](https://forums.percona.com/t/everest-import-mysql-from-backup-to-new-cluster/39382)

<div class="topic-metadata">

**Author:** [@VladoDov](https://forums.percona.com/u/VladoDov)\
**Replies:** 2\
**Last updated:** [September 17, 2025, 10:41am UTC](https://forums.percona.com/t/everest-import-mysql-from-backup-to-new-cluster/39382 "2025-09-17T10:41:22Z")

</div>

My scenario is as following: I installed percona everest on my k8s and created namespace for mysql. In UI I created mysql db server and successfully made backup to minio S3 bucket, and also saved credentials from the s…

---

## [Upgrade to Everest 1.8.0 fails with context canceled due to hanging pre-upgrade hook](https://forums.percona.com/t/upgrade-to-everest-1-8-0-fails-with-context-canceled-due-to-hanging-pre-upgrade-hook/39026)

<div class="topic-metadata">

**Author:** [@pstekunov](https://forums.percona.com/u/pstekunov)\
**Replies:** 3\
**Last updated:** [August 8, 2025, 4:09pm UTC](https://forums.percona.com/t/upgrade-to-everest-1-8-0-fails-with-context-canceled-due-to-hanging-pre-upgrade-hook/39026 "2025-08-08T16:09:13Z")

</div>

Sure! Here’s the bug report text translated into clear and professional English: Title: Upgrade to Everest 1.8.0 fails with context canceled due to hanging pre-upgrade hook :pushpin: Problem Description Attempting to…

---

## [OIDC with Azure not working](https://forums.percona.com/t/oidc-with-azure-not-working/39018)

<div class="topic-metadata">

**Author:** [@Till](https://forums.percona.com/u/Till)\
**Replies:** 1\
**Last updated:** [August 8, 2025, 12:06pm UTC](https://forums.percona.com/t/oidc-with-azure-not-working/39018 "2025-08-08T12:06:36Z")

</div>

everestctl settings oidc configure \\ --issuer-url="https://login.microsoftonline.com/$TENANT/v2.0" \\ --client-id="$APP" \\ --scopes="openid,profile,email,$APP/.default" I setup th…

---

## [How to Add Node Tolerations to Everest Operators? (Dedicated DB Nodes)](https://forums.percona.com/t/how-to-add-node-tolerations-to-everest-operators-dedicated-db-nodes/38832)

<div class="topic-metadata">

**Author:** [@skowrons](https://forums.percona.com/u/skowrons)\
**Replies:** 0\
**Last updated:** [July 25, 2025, 12:29pm UTC](https://forums.percona.com/t/how-to-add-node-tolerations-to-everest-operators-dedicated-db-nodes/38832 "2025-07-25T12:29:20Z")

</div>

Hi everyone, we are running Percona Everest on a Kubernetes cluster with several dedicated database nodes. To ensure operators and deployments are correctly scheduled on these nodes, we would like to configure custom no…

---

## [Can't add a backup storage](https://forums.percona.com/t/cant-add-a-backup-storage/38797)

<div class="topic-metadata">

**Author:** [@eprevost](https://forums.percona.com/u/eprevost)\
**Replies:** 1\
**Last updated:** [July 23, 2025, 3:33pm UTC](https://forums.percona.com/t/cant-add-a-backup-storage/38797 "2025-07-23T15:33:30Z")

</div>

Hi, I’m starting to do some tests with Percona Everest 1.8.0 on a a local minikube Kubernetes cluster. I installed minio in my cluster to test backups. When I try to add a backup storage in Everest console, nothing hap…

---

## [Percona Everest 1.8.0 is here! DataImporters! 🚀](https://forums.percona.com/t/percona-everest-1-8-0-is-here-dataimporters/38767)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [July 21, 2025, 1:08pm UTC](https://forums.percona.com/t/percona-everest-1-8-0-is-here-dataimporters/38767 "2025-07-21T13:08:45Z")

</div>

:partying\_face: Percona Everest v1.8.0 is now available! What’s New? :new\_button: DataImporters (Technical Preview): Bring your existing data to Everest! With the new DataImporters feature, you can now import database ba…

---

## [PITR pod error - context deadline exceded](https://forums.percona.com/t/pitr-pod-error-context-deadline-exceded/38412)

<div class="topic-metadata">

**Author:** [@daccetturi](https://forums.percona.com/u/daccetturi)\
**Replies:** 1\
**Last updated:** [June 27, 2025, 9:15am UTC](https://forums.percona.com/t/pitr-pod-error-context-deadline-exceded/38412 "2025-06-27T09:15:35Z")

</div>

Hello, we have recently migrated a critical workload to the Everest solution. We also implemented backup using MinIO S3 storage and enabled the Point-In-Time Recovery (PITR) feature. For the first two days everything w…

---

## [Documentation for managing databases via k8s resource](https://forums.percona.com/t/documentation-for-managing-databases-via-k8s-resource/35704)

<div class="topic-metadata">

**Author:** [@Colin\_Griffin](https://forums.percona.com/u/Colin_Griffin)\
**Replies:** 2\
**Last updated:** [June 19, 2025, 12:49pm UTC](https://forums.percona.com/t/documentation-for-managing-databases-via-k8s-resource/35704 "2025-06-19T12:49:50Z")

</div>

Hi folks, Is there documentation specific to managing databases through creation of DatabaseCluster objects? This is working for me provisionally, but I want to make sure I’m doing things as intended. Use case: I’m cre…

---

## [OIDC login not working because of content security headers](https://forums.percona.com/t/oidc-login-not-working-because-of-content-security-headers/38145)

<div class="topic-metadata">

**Author:** [@silent](https://forums.percona.com/u/silent)\
**Replies:** 1\
**Last updated:** [June 3, 2025, 9:38am UTC](https://forums.percona.com/t/oidc-login-not-working-because-of-content-security-headers/38145 "2025-06-03T09:38:54Z")

</div>

Hello, I just installed percona everest (HELM) with OIDC (using Authentik): server: oidc: issuerUrl: “https://auth.my.domain.io/application/o/everest/” clientId: “xxx” scopes: - openid - profile - email - group…

---

## [Percona Everest 1.7.0 is here! 🚀](https://forums.percona.com/t/percona-everest-1-7-0-is-here/38186)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [June 2, 2025, 2:36pm UTC](https://forums.percona.com/t/percona-everest-1-7-0-is-here/38186 "2025-06-02T14:36:15Z")

</div>

:tada: Percona Everest v1.7.0 is here! What’s New? :cloud: GKE Autopilot Support Percona Everest can now be deployed on GKE Autopilot for fully managed, secure, and auto-scaled Kubernetes database workloads. …

---

## [PMM sub-chart with Everest 1.6.0](https://forums.percona.com/t/pmm-sub-chart-with-everest-1-6-0/37892)

<div class="topic-metadata">

**Author:** [@jimmyspets](https://forums.percona.com/u/jimmyspets)\
**Replies:** 7\
**Last updated:** [May 29, 2025, 1:11pm UTC](https://forums.percona.com/t/pmm-sub-chart-with-everest-1-6-0/37892 "2025-05-29T13:11:33Z")

</div>

I have installed Everest 1.6.0 with pmm.enabled=true. Everest is setup with a service type of LoadBalancer. How should I configure PMM to also use the loadbalancer and how should I add it as a monitoring endpoint in E…

[Next page](https://forums.percona.com/c/percona-everest/81.md?page=1)
