# Percona XtraDB Cluster 8.x

**URL:** https://forums.percona.com/c/mysql-mariadb/percona-xtradb-cluster-8-x/37.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Percona XtraDB Cluster 8.x category](https://forums.percona.com/t/about-the-percona-xtradb-cluster-8-x-category/42)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 0

</div>

Percona XtraDB Cluster is an open source, cost-effective, and robust MySQL® clustering solution for businesses.

---

## [Tarball-based Percona SST/IST failure after upgrading from 8.4.4-4.1 to 8.4.8-8.1](https://forums.percona.com/t/tarball-based-percona-sst-ist-failure-after-upgrading-from-8-4-4-4-1-to-8-4-8-8-1/41279)

<div class="topic-metadata">

**Author:** [@mahesh\_d](https://forums.percona.com/u/mahesh_d)\
**Replies:** 6\
**Last updated:** [September 23, 2026, 8:59am UTC](https://forums.percona.com/t/tarball-based-percona-sst-ist-failure-after-upgrading-from-8-4-4-4-1-to-8-4-8-8-1/41279 "2026-09-23T08:59:14Z")

</div>

We have successfully deployed a 3 node Percona XtraDB Cluster v8.4.4 via the el8 (glibc2.28) “miminal” tarballs on 3 RHEL8.10 servers. Everything is running as root and deployed under /root directory (tarball extracted i…

---

## [Percona XtraDB 84 - Clone SST joiner aborts with “Operation not permitted” on Ubuntu 24.04: mv -n exits 1 under errexit when datadir already has \*.pem](https://forums.percona.com/t/percona-xtradb-84-clone-sst-joiner-aborts-with-operation-not-permitted-on-ubuntu-24-04-mv-n-exits-1-under-errexit-when-datadir-already-has-pem/41268)

<div class="topic-metadata">

**Author:** [@moro15011](https://forums.percona.com/u/moro15011)\
**Replies:** 2\
**Last updated:** [September 17, 2026, 1:08am UTC](https://forums.percona.com/t/percona-xtradb-84-clone-sst-joiner-aborts-with-operation-not-permitted-on-ubuntu-24-04-mv-n-exits-1-under-errexit-when-datadir-already-has-pem/41268 "2026-09-17T01:08:11Z")

</div>

Project: PXC Component: SST (clone) Affects version: 8.4.10-10 (code path also present on 8.0 and trunk branches) Severity: a node that previously belonged to the cluster cannot rejoin via clone SST Summary On Ubuntu…

---

## [PXC 8.0.46-38 remains in Donor/Desynced after mydumper backup](https://forums.percona.com/t/pxc-8-0-46-38-remains-in-donor-desynced-after-mydumper-backup/41146)

<div class="topic-metadata">

**Author:** [@DeBuXer](https://forums.percona.com/u/DeBuXer)\
**Replies:** 3\
**Last updated:** [September 13, 2026, 12:49pm UTC](https://forums.percona.com/t/pxc-8-0-46-38-remains-in-donor-desynced-after-mydumper-backup/41146 "2026-09-13T12:49:16Z")

</div>

Since upgrading our Percona XtraDB Cluster to 8.0.46-38, one node remains stuck in Donor/Desynced after a mydumper backup. This backup setup had been working for years before the upgrade. Our original backup script was…

---

## [How should GCache size be determined for PXC?](https://forums.percona.com/t/how-should-gcache-size-be-determined-for-pxc/41230)

<div class="topic-metadata">

**Author:** [@Sekhri](https://forums.percona.com/u/Sekhri)\
**Replies:** 3\
**Last updated:** [September 7, 2026, 7:46am UTC](https://forums.percona.com/t/how-should-gcache-size-be-determined-for-pxc/41230 "2026-09-07T07:46:27Z")

</div>

I am running a 3-node Percona XtraDB Cluster on Kubernetes, where the PV size is selected dynamically by the user on the dashboard (minimum 50GB). What is the recommended approach for determining gcache.size? Is there …

---

## [XtraDB Cluster Nodes Vertical Scaling](https://forums.percona.com/t/xtradb-cluster-nodes-vertical-scaling/41209)

<div class="topic-metadata">

**Author:** [@Sekhri](https://forums.percona.com/u/Sekhri)\
**Replies:** 2\
**Last updated:** [August 27, 2026, 6:16pm UTC](https://forums.percona.com/t/xtradb-cluster-nodes-vertical-scaling/41209 "2026-08-27T18:16:18Z")

</div>

I have a 3-node Rancher Kubernetes cluster running Percona XtraDB Cluster (PXC). Each Kubernetes worker node currently has 4 vCPU and 16 GB RAM, and I would like to vertically scale each node to 8 vCPU and 32 GB RAM. Th…

---

## [How to migrate Secret Keys generated by component\_keyring\_vault from HashiCorp Vault to Azure Key Vault?](https://forums.percona.com/t/how-to-migrate-secret-keys-generated-by-component-keyring-vault-from-hashicorp-vault-to-azure-key-vault/41175)

<div class="topic-metadata">

**Author:** [@Sergey\_Ogurtsov](https://forums.percona.com/u/Sergey_Ogurtsov)\
**Replies:** 2\
**Last updated:** [August 18, 2026, 2:56pm UTC](https://forums.percona.com/t/how-to-migrate-secret-keys-generated-by-component-keyring-vault-from-hashicorp-vault-to-azure-key-vault/41175 "2026-08-18T14:56:10Z")

</div>

Hello colleagues, We currently use component\_keyring\_vault to manage encryption keys for Percona XtraDB Cluster with HashiCorp Vault. We are planning to migrate from HashiCorp Vault to Azure Key Vault. However, accordi…

---

## [Mysql\_config\_editor - missing from latest pxc-84-lts](https://forums.percona.com/t/mysql-config-editor-missing-from-latest-pxc-84-lts/40693)

<div class="topic-metadata">

**Author:** [@moro15011](https://forums.percona.com/u/moro15011)\
**Replies:** 8\
**Last updated:** [August 6, 2026, 9:28am UTC](https://forums.percona.com/t/mysql-config-editor-missing-from-latest-pxc-84-lts/40693 "2026-08-06T09:28:42Z")

</div>

Hi guys, I’ve recently installed a new Percona Mysql XtraDB Cluster but there seems to be no package which provides mysql\_config\_editor These are the enabled repos \> percona-release show The following repositories ar…

---

## [Percona-xtradb-cluster-server 1:8.4.10-10-1.noble now uses libperconaserverclient22 instead of libperconaserverclient24?](https://forums.percona.com/t/percona-xtradb-cluster-server-1-8-4-10-10-1-noble-now-uses-libperconaserverclient22-instead-of-libperconaserverclient24/41143)

<div class="topic-metadata">

**Author:** [@moro15011](https://forums.percona.com/u/moro15011)\
**Replies:** 2\
**Last updated:** [August 6, 2026, 8:54am UTC](https://forums.percona.com/t/percona-xtradb-cluster-server-1-8-4-10-10-1-noble-now-uses-libperconaserverclient22-instead-of-libperconaserverclient24/41143 "2026-08-06T08:54:36Z")

</div>

Hello Guys Yesterday I’ve installed the lastest vesion of percona-xtradb-cluster and since version 8.4.8 it started to use libperconaserverclient24 instead of libperconaserverclient22. Now on the newest version it goes …

---

## [Tool repo nuked, percona-release setup broken for pxc80](https://forums.percona.com/t/tool-repo-nuked-percona-release-setup-broken-for-pxc80/40107)

<div class="topic-metadata">

**Author:** [@bvitnik](https://forums.percona.com/u/bvitnik)\
**Replies:** 8\
**Last updated:** [July 21, 2026, 2:17pm UTC](https://forums.percona.com/t/tool-repo-nuked-percona-release-setup-broken-for-pxc80/40107 "2026-07-21T14:17:18Z")

</div>

Hi all. I’ve just noticed that tools repo has been removed, i.e. it does not show in directory listing at: which is referenced by percona-release script. Technically it is still there: http :// repo . percona . com…

---

## [PXC 8.4.6-6.1: recurring MY-013183 assertions (btr0cur.cc:298, btr0pcur.cc:383)](https://forums.percona.com/t/pxc-8-4-6-6-1-recurring-my-013183-assertions-btr0cur-cc-298-btr0pcur-cc-383/40825)

<div class="topic-metadata">

**Author:** [@abhi\_sati](https://forums.percona.com/u/abhi_sati)\
**Replies:** 3\
**Last updated:** [July 10, 2026, 7:43am UTC](https://forums.percona.com/t/pxc-8-4-6-6-1-recurring-my-013183-assertions-btr0cur-cc-298-btr0pcur-cc-383/40825 "2026-07-10T07:43:12Z")

</div>

Hi all, We’re seeing a sustained pattern of InnoDB B-tree and page-invariant assertion failures across two independent 3-node Percona XtraDB Cluster deployments running the same build, and would appreciate any insight —…

---

## [Galera/PXC Cluster Permanent Stall: Failed DDL Voting Storm + Pending TOI Deadlock](https://forums.percona.com/t/galera-pxc-cluster-permanent-stall-failed-ddl-voting-storm-pending-toi-deadlock/40709)

<div class="topic-metadata">

**Author:** [@reddy\_nishanth](https://forums.percona.com/u/reddy_nishanth)\
**Replies:** 5\
**Last updated:** [July 7, 2026, 6:07am UTC](https://forums.percona.com/t/galera-pxc-cluster-permanent-stall-failed-ddl-voting-storm-pending-toi-deadlock/40709 "2026-07-07T06:07:24Z")

</div>

Description: A burst of ~50 failed ALTER TABLE … DROP PARTITION statements (Error 1507 - “Error in list of partitions to DROP”) issued sequentially across ~50 databases by a single application thread caused all three no…

---

## [Percona xtradb cluster Settings](https://forums.percona.com/t/percona-xtradb-cluster-settings/40841)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 4\
**Last updated:** [June 18, 2026, 6:48am UTC](https://forums.percona.com/t/percona-xtradb-cluster-settings/40841 "2026-06-18T06:48:35Z")

</div>

Dear members Request suggestion. Default value of pc.wait\_prim\_timeout is 30S. In a 3 node cluster, if I set it to 180S, will it help in a situation where bootstrap node starts after other 2 cluster members within 3min…

---

## [XtraDB & Kubernetes compatibility matrix](https://forums.percona.com/t/xtradb-kubernetes-compatibility-matrix/13577)

<div class="topic-metadata">

**Author:** [@katajistok](https://forums.percona.com/u/katajistok)\
**Replies:** 5\
**Last updated:** [June 16, 2026, 5:50pm UTC](https://forums.percona.com/t/xtradb-kubernetes-compatibility-matrix/13577 "2026-06-16T17:50:10Z")

</div>

Hello, Is there a compatibility matrix somewhere regarding to XtraDB (MySQL) and Kubernetes versioning?

---

## [What is the recommended way to rotate vault token for mysql?](https://forums.percona.com/t/what-is-the-recommended-way-to-rotate-vault-token-for-mysql/40864)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 3\
**Last updated:** [June 4, 2026, 5:31pm UTC](https://forums.percona.com/t/what-is-the-recommended-way-to-rotate-vault-token-for-mysql/40864 "2026-06-04T17:31:24Z")

</div>

I want to rotate the vault token inside the keyring.conf file, but I was concerned that if mysql only reads the token at startup and stores it in memory, how would it know when to read a fresh token from the keyring.conf…

---

## [Forced reboot a node and doesn't start automatically](https://forums.percona.com/t/forced-reboot-a-node-and-doesnt-start-automatically/40217)

<div class="topic-metadata">

**Author:** [@chernandez\_a3sec](https://forums.percona.com/u/chernandez_a3sec)\
**Replies:** 7\
**Last updated:** [May 16, 2026, 1:19am UTC](https://forums.percona.com/t/forced-reboot-a-node-and-doesnt-start-automatically/40217 "2026-05-16T01:19:57Z")

</div>

Hi I’m testing a 3-node percona cluster and when a node is forced rebooted, mysql doesn’t start automatically. systemctl status mysql gives me: mysql-systemd\[618\]: WARNING: Node has been rebooted, /var/lib/mysql/gra…

---

## [Getting a lot of Wsrep\_rollback\_local logs and failed transactions](https://forums.percona.com/t/getting-a-lot-of-wsrep-rollback-local-logs-and-failed-transactions/40415)

<div class="topic-metadata">

**Author:** [@karl123](https://forums.percona.com/u/karl123)\
**Replies:** 5\
**Last updated:** [May 1, 2026, 10:01am UTC](https://forums.percona.com/t/getting-a-lot-of-wsrep-rollback-local-logs-and-failed-transactions/40415 "2026-05-01T10:01:31Z")

</div>

Hi, I have finally migrated my DB from 5.7 to 8.4. Everything nominally works… But I am frequently getting Wsrep\_rollback\_local log entries (1 per min) on each of my 3 nodes. I did not have this problem on 5.7… It is ca…

---

## [\[ERROR\] \[MY-013709\] \[Server\] Received an error while processing components from manifest file: Failed to load components from manifest file](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 5\
**Last updated:** [April 17, 2026, 4:58am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561 "2026-04-17T04:58:23Z")

</div>

node1\_config.txt (1.4 KB) node2\_config .txt (1.4 KB) OS version: rhel 9.6 xtradb version: 8.4.6 xtrabackup version 8.4.0-4 Keyring Encryption : /appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.gli…

---

## [Sst-idle-timeout killing sst after the donor has transferred all the data](https://forums.percona.com/t/sst-idle-timeout-killing-sst-after-the-donor-has-transferred-all-the-data/40634)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 2\
**Last updated:** [April 15, 2026, 8:46am UTC](https://forums.percona.com/t/sst-idle-timeout-killing-sst-after-the-donor-has-transferred-all-the-data/40634 "2026-04-15T08:46:56Z")

</div>

Setup: 3 node percona pxc cluster with the following percona images Operator: 1.19.0 Cluster: 8.0.42-33.1 Xtrabackup: 8.0.35-34.1 I was trying triggering sst transfer after deleting pvc’s for one of the node, but th…

---

## [PXC configured as async replica can not decrease replication lag](https://forums.percona.com/t/pxc-configured-as-async-replica-can-not-decrease-replication-lag/40485)

<div class="topic-metadata">

**Author:** [@Perica\_Jakimov](https://forums.percona.com/u/Perica_Jakimov)\
**Replies:** 9\
**Last updated:** [April 2, 2026, 1:13am UTC](https://forums.percona.com/t/pxc-configured-as-async-replica-can-not-decrease-replication-lag/40485 "2026-04-02T01:13:39Z")

</div>

We have x3 node PXC 8.0.36 setup that was used as the Primary DB for our workload. The specs for each node are: 40 CPUs, 768G RAM, 10G network. Dataset size is ~8TB. We were using it as single-writer and it was perform…

---

## [Sql\_generate\_invisible\_primary\_key on XtraDB Cluster](https://forums.percona.com/t/sql-generate-invisible-primary-key-on-xtradb-cluster/40365)

<div class="topic-metadata">

**Author:** [@stofa.kenida](https://forums.percona.com/u/stofa.kenida)\
**Replies:** 7\
**Last updated:** [March 19, 2026, 2:10am UTC](https://forums.percona.com/t/sql-generate-invisible-primary-key-on-xtradb-cluster/40365 "2026-03-19T02:10:55Z")

</div>

Hi There, We have a cluster with 3 nodes ( 2 nodes and a gardb ). The used version is : 8.0.44-35.1 Percona XtraDB Cluster (GPL), Release rel35, Revision 7284a5c, WSREP version 26.1.4.3 We observed that, when the…

---

## [PXC on Kubernetes - ProxySQL load balancing](https://forums.percona.com/t/pxc-on-kubernetes-proxysql-load-balancing/21640)

<div class="topic-metadata">

**Author:** [@bac.aro](https://forums.percona.com/u/bac.aro)\
**Replies:** 8\
**Last updated:** [March 11, 2026, 2:37pm UTC](https://forums.percona.com/t/pxc-on-kubernetes-proxysql-load-balancing/21640 "2026-03-11T14:37:25Z")

</div>

Hi Community, We’re currently working on a MySQL cluster setup in order to replace our current MySQL standalone server. We’ve setup a K8S cluster last year, and we wanted to test PXC on this cluster. We started from P…

---

## [Issue with Trigger Causing Update Errors in Busy Node on Galera Cluster](https://forums.percona.com/t/issue-with-trigger-causing-update-errors-in-busy-node-on-galera-cluster/40337)

<div class="topic-metadata">

**Author:** [@Nazmul](https://forums.percona.com/u/Nazmul)\
**Replies:** 5\
**Last updated:** [March 10, 2026, 1:57am UTC](https://forums.percona.com/t/issue-with-trigger-causing-update-errors-in-busy-node-on-galera-cluster/40337 "2026-03-10T01:57:12Z")

</div>

We are experiencing an issue with a trigger in our MySQL Galera Cluster. We have a table, referred to as financial, defined as follows: CREATE TABLE \`financial\` ( \`TransactionId\` int unsigned NOT NULL AUTO\_INCREMENT, …

---

## [Flow Control, wsrep\_cluster\_size = 0?](https://forums.percona.com/t/flow-control-wsrep-cluster-size-0/40334)

<div class="topic-metadata">

**Author:** [@Hans\_Schou](https://forums.percona.com/u/Hans_Schou)\
**Replies:** 4\
**Last updated:** [March 6, 2026, 1:10pm UTC](https://forums.percona.com/t/flow-control-wsrep-cluster-size-0/40334 "2026-03-06T13:10:44Z")

</div>

Hi We have a Percona Xtradb Cluster 8.0.36-28.1 with 3 nodes running with ProxySQL in front. In PMM we see a lot of Flow Control Message Sent each day. I have found some anormalies: Node A show status like 'wsrep\_clu…

---

## [PXC connection timeout in multidc environment](https://forums.percona.com/t/pxc-connection-timeout-in-multidc-environment/40279)

<div class="topic-metadata">

**Author:** [@shirisha](https://forums.percona.com/u/shirisha)\
**Replies:** 6\
**Last updated:** [March 6, 2026, 5:19am UTC](https://forums.percona.com/t/pxc-connection-timeout-in-multidc-environment/40279 "2026-03-06T05:19:34Z")

</div>

Hi I have 5 node PXC cluster, 2 nodes in DC1, 3 nodes in DC2. I use GTM to manage active-passive cluster setup. Issue: Initially app was pointed to Node1 in DC1, which got timed out as seen from other node. But Node1 s…

---

## [Missing grants for mysql.pxc.sst.role after in-place upgrade to PXC 8.4.7](https://forums.percona.com/t/missing-grants-for-mysql-pxc-sst-role-after-in-place-upgrade-to-pxc-8-4-7/40229)

<div class="topic-metadata">

**Author:** [@Ricky](https://forums.percona.com/u/Ricky)\
**Replies:** 10\
**Last updated:** [March 2, 2026, 7:34am UTC](https://forums.percona.com/t/missing-grants-for-mysql-pxc-sst-role-after-in-place-upgrade-to-pxc-8-4-7/40229 "2026-03-02T07:34:32Z")

</div>

Hi everyone, I recently performed an in-place upgrade of Percona XtraDB Cluster from 8.0.37 to 8.4.7. After the upgrade, I noticed that the mysql.pxc.sst.role is missing several grants compared to a fresh installation o…

---

## [MySQL 8.0 information\_schema Corruption - Cannot Expand PXC Cluster](https://forums.percona.com/t/mysql-8-0-information-schema-corruption-cannot-expand-pxc-cluster/40132)

<div class="topic-metadata">

**Author:** [@kevink](https://forums.percona.com/u/kevink)\
**Replies:** 3\
**Last updated:** [February 23, 2026, 5:37pm UTC](https://forums.percona.com/t/mysql-8-0-information-schema-corruption-cannot-expand-pxc-cluster/40132 "2026-02-23T17:37:20Z")

</div>

Environment PXC Version: 8.0.42-33.1 Percona XtraDB Cluster (GPL), Release rel33, Revision 6673f8e WSREP Version: 26.1.4.3 OS: Ubuntu 24.04 Cluster: 3-node setup Data Size: ~161GB production data Problem…

---

## [Encrypted Backup and Restore is failing for PXC 8.0.32-24.2](https://forums.percona.com/t/encrypted-backup-and-restore-is-failing-for-pxc-8-0-32-24-2/40251)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 3\
**Last updated:** [February 22, 2026, 2:04am UTC](https://forums.percona.com/t/encrypted-backup-and-restore-is-failing-for-pxc-8-0-32-24-2/40251 "2026-02-22T02:04:02Z")

</div>

I’ve been trying Backup and Restore for encrypted InnoDB tables using auto generated transition keys. I’m using hashicorp vault as a keying store. I got it working fine for the following setup PERCONA\_OPERATOR\_VERSION …

---

## [Is pxc-84-lts available for Rocky Linux 9.x](https://forums.percona.com/t/is-pxc-84-lts-available-for-rocky-linux-9-x/40199)

<div class="topic-metadata">

**Author:** [@Frak](https://forums.percona.com/u/Frak)\
**Replies:** 8\
**Last updated:** [February 17, 2026, 3:44pm UTC](https://forums.percona.com/t/is-pxc-84-lts-available-for-rocky-linux-9-x/40199 "2026-02-17T15:44:56Z")

</div>

Hi, i’m unable to install pxc-84-lts on Rocky Linux 9.x (9.7) via repositories. If i have to download and install the rpm availables, which would you suggest for 8.4.4 version considering that on board there is gcc 2.34…

---

## [Error Encountered "Malformed packet" when Executing GRANT Statements in MySQL Galera Cluster](https://forums.percona.com/t/error-encountered-malformed-packet-when-executing-grant-statements-in-mysql-galera-cluster/40168)

<div class="topic-metadata">

**Author:** [@Nazmul](https://forums.percona.com/u/Nazmul)\
**Replies:** 2\
**Last updated:** [February 12, 2026, 8:03am UTC](https://forums.percona.com/t/error-encountered-malformed-packet-when-executing-grant-statements-in-mysql-galera-cluster/40168 "2026-02-12T08:03:03Z")

</div>

Hi everyone, I am facing a challenge in my MySQL Galera Cluster setup while trying to generate and execute GRANT statements for a user with a bash script. Here’s a brief overview of my setup and the script I’m using: #…

[Next page](https://forums.percona.com/c/mysql-mariadb/percona-xtradb-cluster-8-x/37.md?page=1)
