# Percona XtraBackup

**URL:** https://forums.percona.com/c/mysql-mariadb/percona-xtrabackup/10.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Percona XtraBackup category](https://forums.percona.com/t/about-the-percona-xtrabackup-category/15)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 0

</div>

Percona XtraBackup is a free, online, open source, complete database backups solution for all versions of Percona Server for MySQL and MySQL®.

---

## [Percona XtraBackup Incompatibilities with MySQL 5.7.32 & 8.0.22](https://forums.percona.com/t/percona-xtrabackup-incompatibilities-with-mysql-5-7-32-8-0-22/8183)

<div class="topic-metadata">

**Author:** [@Tom\_Basil](https://forums.percona.com/u/Tom_Basil)\
**Replies:** 2\
**Last updated:** [January 5, 2021, 10:02am UTC](https://forums.percona.com/t/percona-xtrabackup-incompatibilities-with-mysql-5-7-32-8-0-22/8183 "2021-01-05T10:02:20Z")

</div>

October 23, 2020, see blog at https://www.percona.com/blog/2020/10/23/mysql-new-releases-and-percona-xtrabackup-incompatibilities

---

## [Percona XtraBackup Troubleshooting and How to Report a Bug](https://forums.percona.com/t/percona-xtrabackup-troubleshooting-and-how-to-report-a-bug/6156)

<div class="topic-metadata">

**Author:** [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)\
**Replies:** 0\
**Last updated:** [January 26, 2018, 8:42am UTC](https://forums.percona.com/t/percona-xtrabackup-troubleshooting-and-how-to-report-a-bug/6156 "2018-01-26T08:42:11Z")

</div>

We have a separate system for recording and reporting on bugs, for Percona XtraBackup and for other Percona Software. The forum is oriented towards discussion and advice rather than to bug reporting and fixing. You may …

---

## [Xbcloud get from s3 fail](https://forums.percona.com/t/xbcloud-get-from-s3-fail/34570)

<div class="topic-metadata">

**Author:** [@j\_olivia](https://forums.percona.com/u/j_olivia)\
**Replies:** 6\
**Last updated:** [September 21, 2026, 1:37pm UTC](https://forums.percona.com/t/xbcloud-get-from-s3-fail/34570 "2026-09-21T13:37:32Z")

</div>

I can’t not get backup data from s3 to use xbcloud. my command is xbcloud get s3://bucket/path/ –s3-access-key=\*\*\*\* –s3-secret-key=\*\*\*\* –s3-region=\*\*\*\* | xbstream restore -x -C /backup/FULL/ and then i got re…

---

## [Download only "xtrabackup\_checkpoints" and "xtrabackup\_info" files from S3](https://forums.percona.com/t/download-only-xtrabackup-checkpoints-and-xtrabackup-info-files-from-s3/41114)

<div class="topic-metadata">

**Author:** [@FabricioPedrosoJorge](https://forums.percona.com/u/FabricioPedrosoJorge)\
**Replies:** 2\
**Last updated:** [August 5, 2026, 10:03am UTC](https://forums.percona.com/t/download-only-xtrabackup-checkpoints-and-xtrabackup-info-files-from-s3/41114 "2026-08-05T10:03:38Z")

</div>

Hello Percona team, currently, we are backing up some MySQL databases via Xtrabackup (8.0) to S3 (xtrabackup + xbcloud) and also saving the files “xtrabackup\_checkpoints” and “xtrabackup\_info” locally. But if there are …

---

## [Xtrabackup --prepare fails: xtrabackup\_info file missing in streaming backup directory](https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790)

<div class="topic-metadata">

**Author:** [@Justin\_Swanhart](https://forums.percona.com/u/Justin_Swanhart)\
**Replies:** 1\
**Last updated:** [May 13, 2026, 5:12am UTC](https://forums.percona.com/t/xtrabackup-prepare-fails-xtrabackup-info-file-missing-in-streaming-backup-directory/40790 "2026-05-13T05:12:12Z")

</div>

I’ve tested this twice now. i am using xtrabackup to stream a backup over netcat to another host: $ xtrabackup --backup --stream=xbstream | pigz | nc REDACTED 9999 and $ nc -l -p 9999 | gzip -d | xbstream -x -C /var/…

---

## [Failed to connect error when trying to backup XtraDB Cluster Node](https://forums.percona.com/t/failed-to-connect-error-when-trying-to-backup-xtradb-cluster-node/40487)

<div class="topic-metadata">

**Author:** [@bhuang](https://forums.percona.com/u/bhuang)\
**Replies:** 1\
**Last updated:** [March 31, 2026, 7:07am UTC](https://forums.percona.com/t/failed-to-connect-error-when-trying-to-backup-xtradb-cluster-node/40487 "2026-03-31T07:07:49Z")

</div>

Hi all, I’m doing some testing with a Percona XtraDB Cluster and I am attempting to use XtraBackup to create a backup of one of the nodes. The XtraDB Cluster is running on a Docker Swarm and I am following the documenta…

---

## [Are there cases where Percona XtraBackup Restore can break the cluster?](https://forums.percona.com/t/are-there-cases-where-percona-xtrabackup-restore-can-break-the-cluster/40376)

<div class="topic-metadata">

**Author:** [@na50r](https://forums.percona.com/u/na50r)\
**Replies:** 6\
**Last updated:** [March 26, 2026, 9:47am UTC](https://forums.percona.com/t/are-there-cases-where-percona-xtrabackup-restore-can-break-the-cluster/40376 "2026-03-26T09:47:33Z")

</div>

I have a PXC (PerconaXtraDBCluster) deployed with Helm Chart Version 1.14.5 and then had to upgrade to 1.19.0. The Helm Chart allows setting up a cronjob that creates a backup of the cluster. My cronjob runs every day an…

---

## [Streaming backups with xtrabackup failing mid-transfer due to broken pipe errors](https://forums.percona.com/t/streaming-backups-with-xtrabackup-failing-mid-transfer-due-to-broken-pipe-errors/40386)

<div class="topic-metadata">

**Author:** [@shevy](https://forums.percona.com/u/shevy)\
**Replies:** 1\
**Last updated:** [March 23, 2026, 2:13pm UTC](https://forums.percona.com/t/streaming-backups-with-xtrabackup-failing-mid-transfer-due-to-broken-pipe-errors/40386 "2026-03-23T14:13:25Z")

</div>

Hello Percona Community, I’m running Percona MySQL 5.7.36 with xtrabackup 2.4.29. I’m attempting to stream backups from one host to a remote server using nc and xbstream. On the source host, I run: xtrabackup --backup …

---

## [Please upload the binary file to the repo.percona.com](https://forums.percona.com/t/please-upload-the-binary-file-to-the-repo-percona-com/40370)

<div class="topic-metadata">

**Author:** [@fengzhao1124](https://forums.percona.com/u/fengzhao1124)\
**Replies:** 2\
**Last updated:** [March 18, 2026, 5:22pm UTC](https://forums.percona.com/t/please-upload-the-binary-file-to-the-repo-percona-com/40370 "2026-03-18T17:22:39Z")

</div>

I can’t find the file from the repo.percona.com , please add the binary relase file to the repo https://downloads.percona.com/downloads/Percona-XtraBackup-8.4/Percona-XtraBackup-8.4.0-5/binary/tarball/percona-xtraback…

---

## [Backups via PMM are failing with \`xtrabackup is not compatible with mysql version\`](https://forums.percona.com/t/backups-via-pmm-are-failing-with-xtrabackup-is-not-compatible-with-mysql-version/40277)

<div class="topic-metadata">

**Author:** [@Marko\_Todoric](https://forums.percona.com/u/Marko_Todoric)\
**Replies:** 3\
**Last updated:** [February 24, 2026, 10:14am UTC](https://forums.percona.com/t/backups-via-pmm-are-failing-with-xtrabackup-is-not-compatible-with-mysql-version/40277 "2026-02-24T10:14:41Z")

</div>

Hello team, as the title states, when attempting to run backups via PMM (Version 3.6.0) i get an error: xtrabackup version "8.0.35-35" is not compatible with mysql version "8.0.44-35.1": incompatible xtrabackup Howeve…

---

## [XtraBackup 2.4 Full Backup Taking \>24 Hours on 10TB MySQL 5.7 Galera Cluster over NFS (HDD Storage)](https://forums.percona.com/t/xtrabackup-2-4-full-backup-taking-24-hours-on-10tb-mysql-5-7-galera-cluster-over-nfs-hdd-storage/40227)

<div class="topic-metadata">

**Author:** [@aycelen](https://forums.percona.com/u/aycelen)\
**Replies:** 2\
**Last updated:** [February 20, 2026, 4:09pm UTC](https://forums.percona.com/t/xtrabackup-2-4-full-backup-taking-24-hours-on-10tb-mysql-5-7-galera-cluster-over-nfs-hdd-storage/40227 "2026-02-20T16:09:21Z")

</div>

Hello, I am running a production MySQL 5.7 (Galera Cluster, 3 nodes) environment and facing extremely long backup times with XtraBackup (innobackupex 2.4.29). I would like to validate whether this behavior is expected g…

---

## [Xtrabackup 8.0.30 issue. \[ERROR\] \[MY-011825\] \[Xtrabackup\] read\_logfile() failed](https://forums.percona.com/t/xtrabackup-8-0-30-issue-error-my-011825-xtrabackup-read-logfile-failed/21184)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 4\
**Last updated:** [February 13, 2026, 4:38am UTC](https://forums.percona.com/t/xtrabackup-8-0-30-issue-error-my-011825-xtrabackup-read-logfile-failed/21184 "2026-02-13T04:38:39Z")

</div>

Hello folks. After upgrade from MySQL 8.0.26 to 8.0.30 and xtrabackup to the corresponding version for xtrabackup is 8.0.30-23 I faced that I can’t take a backup from few clusters. I have 9 clusters from 10Gb up to 7Tb…

---

## [Cannot specify custom --transition-key for XtraBackup in Percona PXC Cluster](https://forums.percona.com/t/cannot-specify-custom-transition-key-for-xtrabackup-in-percona-pxc-cluster/40129)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 14\
**Last updated:** [February 8, 2026, 12:40pm UTC](https://forums.percona.com/t/cannot-specify-custom-transition-key-for-xtrabackup-in-percona-pxc-cluster/40129 "2026-02-08T12:40:31Z")

</div>

Hi, I’m using Percona Operator 1.19.0 with PXC 8.0 and trying to use --transition-key for InnoDB encrypted backups. but while trying to restore using the same transition key I’m getting “Wrong transition key?“ error. Ba…

---

## [Restore a backup to an patched version](https://forums.percona.com/t/restore-a-backup-to-an-patched-version/40155)

<div class="topic-metadata">

**Author:** [@ultrapain](https://forums.percona.com/u/ultrapain)\
**Replies:** 2\
**Last updated:** [February 4, 2026, 4:11pm UTC](https://forums.percona.com/t/restore-a-backup-to-an-patched-version/40155 "2026-02-04T16:11:03Z")

</div>

If I take a backup of a cluster that is on v8.0.21 using xtraBackup, can I restore that backup to an instance running v8.0.40?

---

## [Percona-xtrabackup-84 cannot be installed on Rocky Linux 9.7 with Percona Server 8.4 (missing libmysqlclient.so.21)](https://forums.percona.com/t/percona-xtrabackup-84-cannot-be-installed-on-rocky-linux-9-7-with-percona-server-8-4-missing-libmysqlclient-so-21/40150)

<div class="topic-metadata">

**Author:** [@Simeon\_Petkov](https://forums.percona.com/u/Simeon_Petkov)\
**Replies:** 4\
**Last updated:** [February 4, 2026, 3:19pm UTC](https://forums.percona.com/t/percona-xtrabackup-84-cannot-be-installed-on-rocky-linux-9-7-with-percona-server-8-4-missing-libmysqlclient-so-21/40150 "2026-02-04T15:19:27Z")

</div>

Environment: OS: Rocky Linux 9.7 Percona Server: 8.4 (ps-84-lts) ps-84-lts → enabled pxb-84-lts → enabled ps-80 → disabled (normal configuration after upgrade) We have upgraded our database servers from Percona Ser…

---

## [Xtrabackup ignores --tables option](https://forums.percona.com/t/xtrabackup-ignores-tables-option/39768)

<div class="topic-metadata">

**Author:** [@ncapeyron](https://forums.percona.com/u/ncapeyron)\
**Replies:** 3\
**Last updated:** [February 3, 2026, 5:38am UTC](https://forums.percona.com/t/xtrabackup-ignores-tables-option/39768 "2026-02-03T05:38:07Z")

</div>

When trying to make a partial backup with the –tables option, every tables are skipped and nothing is backed up : root@test-lxc-2:/var/lib/mysql# xtrabackup --backup --tables='test1.Persons1 test1.Persons2' --parallel=2…

---

## [Decompressing backups taken with newer version backup in xbstream format](https://forums.percona.com/t/decompressing-backups-taken-with-newer-version-backup-in-xbstream-format/39923)

<div class="topic-metadata">

**Author:** [@hualong\_qiao](https://forums.percona.com/u/hualong_qiao)\
**Replies:** 1\
**Last updated:** [December 21, 2025, 8:02am UTC](https://forums.percona.com/t/decompressing-backups-taken-with-newer-version-backup-in-xbstream-format/39923 "2025-12-21T08:02:05Z")

</div>

Hi, I don’t believe this was raise before, or I’ve missed this. Is there any problem using an older version of xbstream to decompress backups created by a newer version of xtrabackup (in xbstream format) For example: g…

---

## [Percona Xtrabackup Linux Generic Backups are not working On SUSE15.6 MySQL 8.4.7](https://forums.percona.com/t/percona-xtrabackup-linux-generic-backups-are-not-working-on-suse15-6-mysql-8-4-7/39917)

<div class="topic-metadata">

**Author:** [@trimurthy](https://forums.percona.com/u/trimurthy)\
**Replies:** 4\
**Last updated:** [December 18, 2025, 11:22am UTC](https://forums.percona.com/t/percona-xtrabackup-linux-generic-backups-are-not-working-on-suse15-6-mysql-8-4-7/39917 "2025-12-18T11:22:18Z")

</div>

Percona Xtrabackup Linux Generic Backups are not working On SUSE15.6 MySQL 8.4.7 Backups are failing with the following error. xtrabackup: error while loading shared libraries: libproc2.so.0: cannot open shared object …

---

## [Xtrabackup and SST replication broken](https://forums.percona.com/t/xtrabackup-and-sst-replication-broken/39750)

<div class="topic-metadata">

**Author:** [@balu](https://forums.percona.com/u/balu)\
**Replies:** 1\
**Last updated:** [November 20, 2025, 1:18am UTC](https://forums.percona.com/t/xtrabackup-and-sst-replication-broken/39750 "2025-11-20T01:18:42Z")

</div>

We can no longer perform backups with xtrabackup. SST replication is also broken. The error message from xtrabackup is: 025-11-19T10:39:22.303761+01:00 0 \[Note\] \[MY-011825\] \[Xtrabackup\] recognized server arguments: --s…

---

## [Unable to restore backup via xtrabackup](https://forums.percona.com/t/unable-to-restore-backup-via-xtrabackup/39460)

<div class="topic-metadata">

**Author:** [@cosmicOpie](https://forums.percona.com/u/cosmicOpie)\
**Replies:** 1\
**Last updated:** [October 17, 2025, 3:58am UTC](https://forums.percona.com/t/unable-to-restore-backup-via-xtrabackup/39460 "2025-10-17T03:58:07Z")

</div>

I’m trying to restore one of my incremental backup. I applied 4 incremental to my base, but during the 5th one it crashed. ata.ibd2025-09-26T17:24:30.085192-00:00 0 \[Note\] \[MY-011825\] \[Xtrabackup\] page size for /xbacku…

---

## [PMM Backups fail, says latest XtraBackup 8.4.0-4 is incompatible with XtraDB cluster 8.4.5-5.1](https://forums.percona.com/t/pmm-backups-fail-says-latest-xtrabackup-8-4-0-4-is-incompatible-with-xtradb-cluster-8-4-5-5-1/39478)

<div class="topic-metadata">

**Author:** [@Jay\_McNab](https://forums.percona.com/u/Jay_McNab)\
**Replies:** 4\
**Last updated:** [October 3, 2025, 3:02am UTC](https://forums.percona.com/t/pmm-backups-fail-says-latest-xtrabackup-8-4-0-4-is-incompatible-with-xtradb-cluster-8-4-5-5-1/39478 "2025-10-03T03:02:55Z")

</div>

Here is the error I get when trying to perform a backup from PMM Console: xtrabackup version “8.4.0-4” is not compatible with mysql version “8.4.5-5.1”: incompatible xtrabackup WTH? If I installed the latest production…

---

## [Order of the tables - suggestion for performance improvement](https://forums.percona.com/t/order-of-the-tables-suggestion-for-performance-improvement/39487)

<div class="topic-metadata">

**Author:** [@edhunter](https://forums.percona.com/u/edhunter)\
**Replies:** 2\
**Last updated:** [October 2, 2025, 8:25pm UTC](https://forums.percona.com/t/order-of-the-tables-suggestion-for-performance-improvement/39487 "2025-10-02T20:25:12Z")

</div>

My specific scenario is: 20TB mysql instance with about 400 innodb tables. From that many tables there are only a few very large (\>2TB). The tables sizes are varaying 1-100G. The time it takes to do full xtrabackup is s…

---

## [Xbcloud get incorrect listing on GET](https://forums.percona.com/t/xbcloud-get-incorrect-listing-on-get/39414)

<div class="topic-metadata">

**Author:** [@jon.hartley](https://forums.percona.com/u/jon.hartley)\
**Replies:** 1\
**Last updated:** [September 19, 2025, 3:26pm UTC](https://forums.percona.com/t/xbcloud-get-incorrect-listing-on-get/39414 "2025-09-19T15:26:49Z")

</div>

xbcloud get s3://${OBJECTBUCKET}/${NAMESPACE}/${CLUSTER\_NAME}/${BACKUP} --insecure --storage=s3 --s3-endpoint=${OBJECTENDPOINT} --s3-access-key=${ACCESSKEY} --s3-secret-key=${SECRETKEY} --s3-bucket=${OBJECTBUCKET} \> /dev…

---

## [Xtrabackup crashed when redo log size exceed 128G](https://forums.percona.com/t/xtrabackup-crashed-when-redo-log-size-exceed-128g/39236)

<div class="topic-metadata">

**Author:** [@ksql-team](https://forums.percona.com/u/ksql-team)\
**Replies:** 1\
**Last updated:** [September 1, 2025, 3:52am UTC](https://forums.percona.com/t/xtrabackup-crashed-when-redo-log-size-exceed-128g/39236 "2025-09-01T03:52:52Z")

</div>

Using xtrabackup version 8.0.33 with MySQL 8.0.32. When using xtrabackup to back up a MySQL instance with a very large dataset, the redo log generated during the backup can be extremely large, exceeding 128GB. In such ca…

---

## [Lost percona-xtrabackup-84\_8.4.0-3 in the tools repo](https://forums.percona.com/t/lost-percona-xtrabackup-84-8-4-0-3-in-the-tools-repo/39072)

<div class="topic-metadata">

**Author:** [@dimetrius](https://forums.percona.com/u/dimetrius)\
**Replies:** 2\
**Last updated:** [August 18, 2025, 3:38pm UTC](https://forums.percona.com/t/lost-percona-xtrabackup-84-8-4-0-3-in-the-tools-repo/39072 "2025-08-18T15:38:48Z")

</div>

Hello, we use mirror of tools and don’t see ‘percona-xtrabackup-84\_8.4.0-3-1’ package. The latest available is ‘percona-xtrabackup-84\_8.4.0-2-1’. But in the pxb-84-lts repo i see package ‘percona-xtrabackup-84\_8.4.0-3-1…

---

## [Trying to track down the cause of an error](https://forums.percona.com/t/trying-to-track-down-the-cause-of-an-error/38607)

<div class="topic-metadata">

**Author:** [@Gerwin\_van\_de\_Steeg](https://forums.percona.com/u/Gerwin_van_de_Steeg)\
**Replies:** 7\
**Last updated:** [August 18, 2025, 2:09pm UTC](https://forums.percona.com/t/trying-to-track-down-the-cause-of-an-error/38607 "2025-08-18T14:09:52Z")

</div>

Folks, I’m seeing an error with the backup of one of our Percona XtraDB databases which is: 2025-06-30 00:03:48.591 INFO: RECV thread exiting 0: Success 2025-06-30 00:03:48.591 INFO: Terminating SST script 2025-06-30…

---

## [All xtrabackup\_checkpoints file disappears after first incremental is prepared](https://forums.percona.com/t/all-xtrabackup-checkpoints-file-disappears-after-first-incremental-is-prepared/39033)

<div class="topic-metadata">

**Author:** [@dcbrown73](https://forums.percona.com/u/dcbrown73)\
**Replies:** 4\
**Last updated:** [August 18, 2025, 9:42am UTC](https://forums.percona.com/t/all-xtrabackup-checkpoints-file-disappears-after-first-incremental-is-prepared/39033 "2025-08-18T09:42:21Z")

</div>

Hi, I’m trying to setup xtrabackup automation, but I’m having an issue with preparing the backups. I run prepare on the base backup with –apply-log-only and it’s fine. I run prepare on the first incremental backup (in…

---

## [Why does the size of the xtraback Docker image grow so quickly?](https://forums.percona.com/t/why-does-the-size-of-the-xtraback-docker-image-grow-so-quickly/38999)

<div class="topic-metadata">

**Author:** [@Kymo\_Wang](https://forums.percona.com/u/Kymo_Wang)\
**Replies:** 1\
**Last updated:** [August 7, 2025, 7:10am UTC](https://forums.percona.com/t/why-does-the-size-of-the-xtraback-docker-image-grow-so-quickly/38999 "2025-08-07T07:10:45Z")

</div>

tag 8.3 is less than 200MB, while tag 8.4 is close to 400MB, doubling in size. when I pulled to local, the image is more than 1.4G.

---

## [Prepare seems to fail](https://forums.percona.com/t/prepare-seems-to-fail/38877)

<div class="topic-metadata">

**Author:** [@rsodhia](https://forums.percona.com/u/rsodhia)\
**Replies:** 2\
**Last updated:** [July 29, 2025, 3:15pm UTC](https://forums.percona.com/t/prepare-seems-to-fail/38877 "2025-07-29T15:15:29Z")

</div>

I’m using a modified version of the command given in the documentation to create and prepare a backup: docker run --rm --name "$backup\_container\_name" \\ --volumes-from "$db\_container" \\ -v "$volume\_name":/backup…

[Next page](https://forums.percona.com/c/mysql-mariadb/percona-xtrabackup/10.md?page=1)
