# Percona Server for MySQL 8.0

**URL:** https://forums.percona.com/c/mysql-mariadb/percona-server-for-mysql-8-0/20.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [Unable to restore from point-in-time physical backup](https://forums.percona.com/t/unable-to-restore-from-point-in-time-physical-backup/37291)

<div class="topic-metadata">

**Author:** [@john.a](https://forums.percona.com/u/john.a)\
**Replies:** 9\
**Last updated:** [March 28, 2025, 6:36pm UTC](https://forums.percona.com/t/unable-to-restore-from-point-in-time-physical-backup/37291 "2025-03-28T18:36:20Z")

</div>

Hi, Trying to do a test backup and restore from a point-in-time storage snapshot and Percona MySQL 8.0 is failing to start with the following error: 2025-03-21T01:26:13.004557Z 1 \[System\] \[MY-013576\] \[InnoDB\] InnoDB in…

---

## [High CPU Load after updating from Percona 8.0.39 to 8.0.41 on 2 out of 7](https://forums.percona.com/t/high-cpu-load-after-updating-from-percona-8-0-39-to-8-0-41-on-2-out-of-7/37038)

<div class="topic-metadata">

**Author:** [@alexanderdeprez](https://forums.percona.com/u/alexanderdeprez)\
**Replies:** 3\
**Last updated:** [March 28, 2025, 5:23pm UTC](https://forums.percona.com/t/high-cpu-load-after-updating-from-percona-8-0-39-to-8-0-41-on-2-out-of-7/37038 "2025-03-28T17:23:27Z")

</div>

After upgrading all my percona servers from 8.0.39 to 8.0.41, two of my servers show very high CPU load. At night we sync data from external sources with means allot of deletes, inserts and some analytical queries. A pea…

---

## [Facing issue while using percona 3.0.6, it is converting ENUM values from upper-case to lower-case in the table schema](https://forums.percona.com/t/facing-issue-while-using-percona-3-0-6-it-is-converting-enum-values-from-upper-case-to-lower-case-in-the-table-schema/36976)

<div class="topic-metadata">

**Author:** [@Bony\_Mondal](https://forums.percona.com/u/Bony_Mondal)\
**Replies:** 3\
**Last updated:** [March 5, 2025, 6:18am UTC](https://forums.percona.com/t/facing-issue-while-using-percona-3-0-6-it-is-converting-enum-values-from-upper-case-to-lower-case-in-the-table-schema/36976 "2025-03-05T06:18:32Z")

</div>

We are using the Percona Toolkit 3.0.6 version for running the MySQL queries specifically ALTER statements but we have started using this recently and identified one issue, while users are expecting and giving the values…

---

## [MySQL Threadpool with admin port/connection behavior](https://forums.percona.com/t/mysql-threadpool-with-admin-port-connection-behavior/36944)

<div class="topic-metadata">

**Author:** [@nitin](https://forums.percona.com/u/nitin)\
**Replies:** 6\
**Last updated:** [February 28, 2025, 1:10am UTC](https://forums.percona.com/t/mysql-threadpool-with-admin-port-connection-behavior/36944 "2025-02-28T01:10:07Z")

</div>

Hello Percona Team, I am trying out MySQL threadpool and observed a behavior. Wanted to confirm if it is by design! Say, I am running threadpool with threadpool\_size=1 and threadpool\_oversubscribe=3. Then I try to con…

---

## [Table alter to drop a partition takes 10mins or more to complete](https://forums.percona.com/t/table-alter-to-drop-a-partition-takes-10mins-or-more-to-complete/33399)

<div class="topic-metadata">

**Author:** [@darren.butts](https://forums.percona.com/u/darren.butts)\
**Replies:** 11\
**Last updated:** [February 26, 2025, 7:19am UTC](https://forums.percona.com/t/table-alter-to-drop-a-partition-takes-10mins-or-more-to-complete/33399 "2025-02-26T07:19:02Z")

</div>

We have a large database that is managed in a cluster of 3 hosts, 2 replicas and one primary. A recent maintenance required us to drop some old partitions ~250GB in file size, i had already created hardlinks as i know t…

---

## [Percona 8.0.40 : Compiling from source on aarch64 the Bgc\_ticket\_manager\_test unit test fails](https://forums.percona.com/t/percona-8-0-40-compiling-from-source-on-aarch64-the-bgc-ticket-manager-test-unit-test-fails/36818)

<div class="topic-metadata">

**Author:** [@Conrad\_Burger](https://forums.percona.com/u/Conrad_Burger)\
**Replies:** 0\
**Last updated:** [February 20, 2025, 1:10pm UTC](https://forums.percona.com/t/percona-8-0-40-compiling-from-source-on-aarch64-the-bgc-ticket-manager-test-unit-test-fails/36818 "2025-02-20T13:10:06Z")

</div>

When compiling Percona 8.0.40 with build type = RelWithDebInfo on aarch64 (Graviton) the Bgc\_ticket\_manager\_test fails. The test succeeds when creating a debug build. Has anyone seen this before? Could someone possibly…

---

## [GTID Consistency failed](https://forums.percona.com/t/gtid-consistency-failed/36533)

<div class="topic-metadata">

**Author:** [@srikar\_arutla](https://forums.percona.com/u/srikar_arutla)\
**Replies:** 3\
**Last updated:** [February 11, 2025, 6:30pm UTC](https://forums.percona.com/t/gtid-consistency-failed/36533 "2025-02-11T18:30:44Z")

</div>

I want to set enforce\_gtid\_consistency= WARN and gtid\_mode=ON\_PERMISSIVE , and eliminate all queires that violate GTID consistency from applications from the warnings. after that i plan to set enforce\_gtid\_consistency= …

---

## [FR: Please add includedir /etc/my.cnf.d/ to my.cnf](https://forums.percona.com/t/fr-please-add-includedir-etc-my-cnf-d-to-my-cnf/36613)

<div class="topic-metadata">

**Author:** [@zigi](https://forums.percona.com/u/zigi)\
**Replies:** 2\
**Last updated:** [February 11, 2025, 1:39am UTC](https://forums.percona.com/t/fr-please-add-includedir-etc-my-cnf-d-to-my-cnf/36613 "2025-02-11T01:39:54Z")

</div>

Hello, small feature request: Could you add !includedir /etc/my.cnf.d/ to the default “Percona Server template configuration” file my.cnf? With best regards Karel Ziegler

---

## [Why does at least the percona-server-server-8.4 depend on the obsolete net-tools package](https://forums.percona.com/t/why-does-at-least-the-percona-server-server-8-4-depend-on-the-obsolete-net-tools-package/36610)

<div class="topic-metadata">

**Author:** [@zigi](https://forums.percona.com/u/zigi)\
**Replies:** 2\
**Last updated:** [February 10, 2025, 10:52pm UTC](https://forums.percona.com/t/why-does-at-least-the-percona-server-server-8-4-depend-on-the-obsolete-net-tools-package/36610 "2025-02-10T22:52:41Z")

</div>

Hello, Why does at least the percona-server-server-8.4.3-3.1.el9.x86\_64 RPM package depend on the obsolete net-tools package (on obsolete tools like arp, ifconfig, route, etc.)? PS: There is no subcategory for Percona …

---

## [Dockerfile for Percona Server 8.4 missing in repo](https://forums.percona.com/t/dockerfile-for-percona-server-8-4-missing-in-repo/36588)

<div class="topic-metadata">

**Author:** [@David\_Vrtel](https://forums.percona.com/u/David_Vrtel)\
**Replies:** 4\
**Last updated:** [February 10, 2025, 8:43am UTC](https://forums.percona.com/t/dockerfile-for-percona-server-8-4-missing-in-repo/36588 "2025-02-10T08:43:27Z")

</div>

I am unable to find Dockerfiles for Percona Server 8.4. I can find images with the correct filter for 8.4 in percona/percona-server Docker Hub page. I see a tag that, I suppose, corresponds to version 8.4 percona/percon…

---

## [Insert with unique\_checks=OFF into table with TTL crashing MyRocks 8.0.39](https://forums.percona.com/t/insert-with-unique-checks-off-into-table-with-ttl-crashing-myrocks-8-0-39/36559)

<div class="topic-metadata">

**Author:** [@Vamsi\_P](https://forums.percona.com/u/Vamsi_P)\
**Replies:** 0\
**Last updated:** [February 6, 2025, 12:58am UTC](https://forums.percona.com/t/insert-with-unique-checks-off-into-table-with-ttl-crashing-myrocks-8-0-39/36559 "2025-02-06T00:58:10Z")

</div>

hi there, It used to work in MyRocks 8.0.26 but is crashing MyRocks 8.0.39. I put some details in https://perconadev.atlassian.net/browse/DISTMYSQL-506 Any workarounds for doing blind inserts? INSERT ON DUPLICATE UPD…

---

## [MySQL 8.0.24 / 8.0.25 connection problems with \`FEDERATED\` storage engine (Communication link failure)](https://forums.percona.com/t/mysql-8-0-24-8-0-25-connection-problems-with-federated-storage-engine-communication-link-failure/11487)

<div class="topic-metadata">

**Author:** [@onlime](https://forums.percona.com/u/onlime)\
**Replies:** 15\
**Last updated:** [January 31, 2025, 7:53am UTC](https://forums.percona.com/t/mysql-8-0-24-8-0-25-connection-problems-with-federated-storage-engine-communication-link-failure/11487 "2025-01-31T07:53:58Z")

</div>

Since latest Percona Server for MySQL 8.0.25 upgrade, I am struggling with severe connection issues between two servers. I could track this down to FEDERATED storage engine. On application/client level, the sporadic err…

---

## [Mysql\_config\_editor missing on 8.4-lts](https://forums.percona.com/t/mysql-config-editor-missing-on-8-4-lts/36134)

<div class="topic-metadata">

**Author:** [@Fabio\_Vavassori](https://forums.percona.com/u/Fabio_Vavassori)\
**Replies:** 2\
**Last updated:** [January 20, 2025, 1:36pm UTC](https://forums.percona.com/t/mysql-config-editor-missing-on-8-4-lts/36134 "2025-01-20T13:36:13Z")

</div>

Hello, I have enabled the pxc-84-lts repository and installed the package percona-xtradb-cluster-full, but I can’t find the command “mysql\_config\_editor”. I installed it on a Ubuntu 22.04 server and following the comma…

---

## [How can compress Percona MySQL8 audit logs](https://forums.percona.com/t/how-can-compress-percona-mysql8-audit-logs/19356)

<div class="topic-metadata">

**Author:** [@Muhammad\_Usman](https://forums.percona.com/u/Muhammad_Usman)\
**Replies:** 3\
**Last updated:** [January 15, 2025, 3:59pm UTC](https://forums.percona.com/t/how-can-compress-percona-mysql8-audit-logs/19356 "2025-01-15T15:59:49Z")

</div>

Dear Team, plugin-load = audit\_log.so audit-log = FORCE\_PLUS\_PERMANENT audit\_log\_policy = ALL audit\_log\_format = OLD …

---

## [Consider providing ARM64 builds](https://forums.percona.com/t/consider-providing-arm64-builds/18502)

<div class="topic-metadata">

**Author:** [@vahid\_shirvani](https://forums.percona.com/u/vahid_shirvani)\
**Replies:** 26\
**Last updated:** [January 14, 2025, 11:46am UTC](https://forums.percona.com/t/consider-providing-arm64-builds/18502 "2025-01-14T11:46:24Z")

</div>

Please consider providing ARM support! Note: By Intel I mean x86-64 or x64 or x86\_64 or AMD64 or Intel 64. Note: By ARM I mean ARMv8 or ARM64 or AArch64. Apple Macbook with M1 chip are becoming more prevalent. These m…

---

## [Percona Binary issue with libssl.so.1.1](https://forums.percona.com/t/percona-binary-issue-with-libssl-so-1-1/36030)

<div class="topic-metadata">

**Author:** [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Replies:** 3\
**Last updated:** [January 10, 2025, 11:30am UTC](https://forums.percona.com/t/percona-binary-issue-with-libssl-so-1-1/36030 "2025-01-10T11:30:19Z")

</div>

Hi, We encountered this issue same again 8.0.39/40. In the past when we raised similar concern, Percona fixed and uploaded new binaries(linux generic). Similarly, when we install with 8.0.39 and 8.0.40, we see this er…

---

## [Percona Server 8.0.39 Linux Generic missing glibc 2.17 tar](https://forums.percona.com/t/percona-server-8-0-39-linux-generic-missing-glibc-2-17-tar/35727)

<div class="topic-metadata">

**Author:** [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Replies:** 1\
**Last updated:** [January 9, 2025, 9:02am UTC](https://forums.percona.com/t/percona-server-8-0-39-linux-generic-missing-glibc-2-17-tar/35727 "2025-01-09T09:02:07Z")

</div>

Hi, Any reason for not releasing 8.0.39 libc 2.17 tar in linux generic category ? (Xtradb cluster for same version has it) Thank you

---

## [Many unauthenticated user thread after start slave](https://forums.percona.com/t/many-unauthenticated-user-thread-after-start-slave/13740)

<div class="topic-metadata">

**Author:** [@aoerqileng](https://forums.percona.com/u/aoerqileng)\
**Replies:** 5\
**Last updated:** [January 9, 2025, 2:51am UTC](https://forums.percona.com/t/many-unauthenticated-user-thread-after-start-slave/13740 "2025-01-09T02:51:03Z")

</div>

I have a Percona mysql8.0.23 cluster, 1 master with 2 slaves on Ubuntu20, after I start io thread on slave, there are many unauthenticated user on the master, once I stop io thread, they are immediately gone, any ideas h…

---

## [Percona Server for MYSQL 8.0 very slow performance on all myISAM tables](https://forums.percona.com/t/percona-server-for-mysql-8-0-very-slow-performance-on-all-myisam-tables/36010)

<div class="topic-metadata">

**Author:** [@Dario\_Rigolin](https://forums.percona.com/u/Dario_Rigolin)\
**Replies:** 1\
**Last updated:** [January 7, 2025, 6:24pm UTC](https://forums.percona.com/t/percona-server-for-mysql-8-0-very-slow-performance-on-all-myisam-tables/36010 "2025-01-07T18:24:38Z")

</div>

Is quite strange but mysqldump and also alter table to convert to InnoDB are very slow but very very slow. For example converting a table of 5800 rows from myisam to innodb requires about 35 minutes. Server is running on…

---

## [Proxy\_protocol\_networks for Percona Server for MySQL 8.0 category](https://forums.percona.com/t/proxy-protocol-networks-for-percona-server-for-mysql-8-0-category/22828)

<div class="topic-metadata">

**Author:** [@sujitagarwal](https://forums.percona.com/u/sujitagarwal)\
**Replies:** 2\
**Last updated:** [January 3, 2025, 1:57pm UTC](https://forums.percona.com/t/proxy-protocol-networks-for-percona-server-for-mysql-8-0-category/22828 "2025-01-03T13:57:56Z")

</div>

The proxy protocol for kubernets operator for mysql 8 is not working as per the documnets.

---

## [Warning message about keyring component metadata query service in error.log](https://forums.percona.com/t/warning-message-about-keyring-component-metadata-query-service-in-error-log/11892)

<div class="topic-metadata">

**Author:** [@Serhii\_Bulieienko](https://forums.percona.com/u/Serhii_Bulieienko)\
**Replies:** 3\
**Last updated:** [January 2, 2025, 2:41pm UTC](https://forums.percona.com/t/warning-message-about-keyring-component-metadata-query-service-in-error-log/11892 "2025-01-02T14:41:26Z")

</div>

Hello, After upgrade the Percona MySQL 8.0.23 to 8.0.25 I see every night the warning in error log like this: 2021-08-23T21:00:02.911820Z 229549 \[Warning\] \[MY013712\] \[Server\] No suitable ‘keyring\_component\_metadata\_que…

---

## [Util.dumpinstance running very slow for data size 25TB](https://forums.percona.com/t/util-dumpinstance-running-very-slow-for-data-size-25tb/35857)

<div class="topic-metadata">

**Author:** [@Chiranjib\_Bhattachar](https://forums.percona.com/u/Chiranjib_Bhattachar)\
**Replies:** 1\
**Last updated:** [December 31, 2024, 7:19pm UTC](https://forums.percona.com/t/util-dumpinstance-running-very-slow-for-data-size-25tb/35857 "2024-12-31T19:19:46Z")

</div>

Percona MySQL 8.0.33-25 Community Edition is running on Ubuntu 22.04 server having 64 CPU and 128 GB RAM. The volume of data is 25 TB. We are running util.dumpinstance with 55 threads but the dump is running very slow an…

---

## [NUMA (Function not implemented)](https://forums.percona.com/t/numa-function-not-implemented/35872)

<div class="topic-metadata">

**Author:** [@asamofal](https://forums.percona.com/u/asamofal)\
**Replies:** 1\
**Last updated:** [December 30, 2024, 4:05pm UTC](https://forums.percona.com/t/numa-function-not-implemented/35872 "2024-12-30T16:05:49Z")

</div>

Hi! I’m upgrading my docker image: FROM percona/percona-server:8.0.36-28.1 to FROM percona/percona-server:8.4.3-3.1-multi I run it on my MacBook Pro M3 and getting these NUMA-related warnings: 2024-12-28T21:46:14.70606…

---

## [MYSQL Down and Inability of Restarting because of database crash](https://forums.percona.com/t/mysql-down-and-inability-of-restarting-because-of-database-crash/35735)

<div class="topic-metadata">

**Author:** [@Sanuri](https://forums.percona.com/u/Sanuri)\
**Replies:** 0\
**Last updated:** [December 19, 2024, 8:38am UTC](https://forums.percona.com/t/mysql-down-and-inability-of-restarting-because-of-database-crash/35735 "2024-12-19T08:38:10Z")

</div>

There is a Database as “LOG\_MONTH” and I was going to filter monthly wise data from this database and inserted to databases “LOG\_SEP”,“LOG\_OCT”,“LOG\_NOV” by the use of a script. Unfortunately, space of /data mount reache…

---

## [Kerberos Authentication on MySQL](https://forums.percona.com/t/kerberos-authentication-on-mysql/35634)

<div class="topic-metadata">

**Author:** [@damienka](https://forums.percona.com/u/damienka)\
**Replies:** 1\
**Last updated:** [December 17, 2024, 6:56pm UTC](https://forums.percona.com/t/kerberos-authentication-on-mysql/35634 "2024-12-17T18:56:15Z")

</div>

Hi, I would like to use Kerberos Authentication which is available under Oracle’s Enterprise MySQL distribution. Is this authentication feature available in the Percona MySQL Pro? Is it possible to drop-in the pro kerbe…

---

## [MySQL end of life?](https://forums.percona.com/t/mysql-end-of-life/35648)

<div class="topic-metadata">

**Author:** [@ipcmlr](https://forums.percona.com/u/ipcmlr)\
**Replies:** 4\
**Last updated:** [December 13, 2024, 9:56pm UTC](https://forums.percona.com/t/mysql-end-of-life/35648 "2024-12-13T21:56:10Z")

</div>

I am a little confused about the end of life date for MySQL 8.0. Is the end of life april 2025 or april 2026? according to this https://www.mysql.com/support/eol-notice.html Starting with MySQL 8.1 and future releases…

---

## [Named pipe for general log](https://forums.percona.com/t/named-pipe-for-general-log/35463)

<div class="topic-metadata">

**Author:** [@Andrew2](https://forums.percona.com/u/Andrew2)\
**Replies:** 2\
**Last updated:** [December 5, 2024, 2:08pm UTC](https://forums.percona.com/t/named-pipe-for-general-log/35463 "2024-12-05T14:08:33Z")

</div>

I’d like to use a named pipe for the general log to track the frequency of queries with specific columns in the where clause (don’t you love technical debt?) I’ve used… mkfifo \[general.log\] chmod mysql:mysql \[general.…

---

## [Kubernetes - \[Galera\] Handshake failed due to unknown CA](https://forums.percona.com/t/kubernetes-galera-handshake-failed-due-to-unknown-ca/25636)

<div class="topic-metadata">

**Author:** [@David\_Ramage](https://forums.percona.com/u/David_Ramage)\
**Replies:** 4\
**Last updated:** [November 26, 2024, 11:42am UTC](https://forums.percona.com/t/kubernetes-galera-handshake-failed-due-to-unknown-ca/25636 "2024-11-26T11:42:35Z")

</div>

Hello, I am running the Percona operator for MySQL and PerconaXtradb on an EKS cluster, installed via the associated Helm charts (versions 1.12.0 and 1.13.0). Earlier today I changed the values for the Xtradb chart and…

---

## [Repairing just one channel in multi-source master replica with GTID](https://forums.percona.com/t/repairing-just-one-channel-in-multi-source-master-replica-with-gtid/35002)

<div class="topic-metadata">

**Author:** [@Vukopras](https://forums.percona.com/u/Vukopras)\
**Replies:** 7\
**Last updated:** [November 13, 2024, 10:34pm UTC](https://forums.percona.com/t/repairing-just-one-channel-in-multi-source-master-replica-with-gtid/35002 "2024-11-13T22:34:38Z")

</div>

Hello I’m trying to set up multi-source replica, so one server will have 2 databases, each database will be replica from another remote server. I set up first channel fine but I’m having issues setting up second one. …

---

## [ERROR: Unknown alias specification: ps84-lts](https://forums.percona.com/t/error-unknown-alias-specification-ps84-lts/34555)

<div class="topic-metadata">

**Author:** [@User\_Userovich](https://forums.percona.com/u/User_Userovich)\
**Replies:** 1\
**Last updated:** [October 23, 2024, 8:37am UTC](https://forums.percona.com/t/error-unknown-alias-specification-ps84-lts/34555 "2024-10-23T08:37:59Z")

</div>

Try to update from 8.0 latest to 8.4 LOG root@dev:~# percona-release setup ps-84-lts Disabling all Percona Repositories ERROR: Unknown alias specification: ps84-lts Available product aliases are: mysql-shell pbm pd…

[Previous page](https://forums.percona.com/c/mysql-mariadb/percona-server-for-mysql-8-0/20.md?page=1)

[Next page](https://forums.percona.com/c/mysql-mariadb/percona-server-for-mysql-8-0/20.md?page=3)
