# Percona Server for MySQL 8.0

**URL:** https://forums.percona.com/c/mysql-mariadb/percona-server-for-mysql-8-0/20.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [Experimental support for Stored Programs in JS in Percona Server for MySQL](https://forums.percona.com/t/experimental-support-for-stored-programs-in-js-in-percona-server-for-mysql/38215)

<div class="topic-metadata">

**Author:** [@dmitry.lenev](https://forums.percona.com/u/dmitry.lenev)\
**Replies:** 1\
**Last updated:** [June 5, 2025, 12:52pm UTC](https://forums.percona.com/t/experimental-support-for-stored-programs-in-js-in-percona-server-for-mysql/38215 "2025-06-05T12:52:26Z")

</div>

Hello! Percona Server for MySQL now offers experimental support for stored programs in the JS language, a free and open-source alternative to Oracle’s Enterprise/ Cloud-only feature, enabling users to write stored pro…

---

## [About the Percona Server for MySQL 8.0 category](https://forums.percona.com/t/about-the-percona-server-for-mysql-8-0-category/25)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 1\
**Last updated:** [May 2, 2023, 6:39am UTC](https://forums.percona.com/t/about-the-percona-server-for-mysql-8-0-category/25 "2023-05-02T06:39:47Z")

</div>

Percona Server for MySQL® is a free, fully compatible, enhanced and open source drop-in replacement for any MySQL database. It provides superior performance, scalability and instrumentation.

---

## [Percona MySQL 8.0 migration to Aurora MySQL](https://forums.percona.com/t/percona-mysql-8-0-migration-to-aurora-mysql/41319)

<div class="topic-metadata">

**Author:** [@carlos.mejia.ven](https://forums.percona.com/u/carlos.mejia.ven)\
**Replies:** 0\
**Last updated:** [October 7, 2026, 3:02pm UTC](https://forums.percona.com/t/percona-mysql-8-0-migration-to-aurora-mysql/41319 "2026-10-07T15:02:36Z")

</div>

Hello, I’m trying to restore a backup of an on-premise Percona MySQL 8.0 database in AWS but the operation never ends. I’m testing with a 30GB Percona MySQL replica (real DB is 2TB): mysql\> SHOW VARIABLES LIKE 'versio…

---

## [Double entry about disconnection audit\_log\_filter Mysql 8.4.10](https://forums.percona.com/t/double-entry-about-disconnection-audit-log-filter-mysql-8-4-10/41180)

<div class="topic-metadata">

**Author:** [@Kobold](https://forums.percona.com/u/Kobold)\
**Replies:** 7\
**Last updated:** [August 20, 2026, 7:19am UTC](https://forums.percona.com/t/double-entry-about-disconnection-audit-log-filter-mysql-8-4-10/41180 "2026-08-20T07:19:08Z")

</div>

I have next settings: SELECT audit\_log\_filter\_set\_filter('only\_logins', '{"filter": {"class": \[{"name": "connection", "event": \[{"name": "connect"}, {"name": "disconnect"}\]}\]}}'); SELECT audit\_log\_filter\_set\_user('%', …

---

## [ 45/5000 When using xtrabackup 8.0.33-27 to back up MySQL 8.0.1, I encountered a long backup time.](https://forums.percona.com/t/45-5000-when-using-xtrabackup-8-0-33-27-to-back-up-mysql-8-0-1-i-encountered-a-long-backup-time/40853)

<div class="topic-metadata">

**Author:** [@cheng](https://forums.percona.com/u/cheng)\
**Replies:** 1\
**Last updated:** [June 2, 2026, 4:35am UTC](https://forums.percona.com/t/45-5000-when-using-xtrabackup-8-0-33-27-to-back-up-mysql-8-0-1-i-encountered-a-long-backup-time/40853 "2026-06-02T04:35:18Z")

</div>

The backup process has not been completed for a long time. I checked and found that there is a slow SQL query. How can we adjust it? # User@Host: webuser\[webuser\] @ localhost \[\] Id: 352018 Query\_time: 70501.609143 Lo…

---

## [Percona Postgresql-17 pg\_tde configuration abd setup](https://forums.percona.com/t/percona-postgresql-17-pg-tde-configuration-abd-setup/40006)

<div class="topic-metadata">

**Author:** [@Johnathan](https://forums.percona.com/u/Johnathan)\
**Replies:** 4\
**Last updated:** [May 15, 2026, 5:44am UTC](https://forums.percona.com/t/percona-postgresql-17-pg-tde-configuration-abd-setup/40006 "2026-05-15T05:44:18Z")

</div>

I want to taste pg\_tde and need help configuring the global and masterkeys. I will later immplement a proper key management later

---

## [MyRocks File Hints](https://forums.percona.com/t/myrocks-file-hints/40762)

<div class="topic-metadata">

**Author:** [@Jay\_Rafati](https://forums.percona.com/u/Jay_Rafati)\
**Replies:** 1\
**Last updated:** [May 11, 2026, 3:43pm UTC](https://forums.percona.com/t/myrocks-file-hints/40762 "2026-05-11T15:43:54Z")

</div>

Hi, does MyRocks sends file hints during compaction automatically or we have to configure that? I am running Sysbench/Percona MySQL/MyRocks with io\_uring. Want to make sure MyRocks Hints are getting passed to io\_uring a…

---

## [Missing mysql\_config\_editor from Percona Server for MySQL 8.4.8-8](https://forums.percona.com/t/missing-mysql-config-editor-from-percona-server-for-mysql-8-4-8-8/40364)

<div class="topic-metadata">

**Author:** [@onlime](https://forums.percona.com/u/onlime)\
**Replies:** 4\
**Last updated:** [April 21, 2026, 4:18pm UTC](https://forums.percona.com/t/missing-mysql-config-editor-from-percona-server-for-mysql-8-4-8-8/40364 "2026-04-21T16:18:54Z")

</div>

On all previous Percona Server for MySQL 8.4.x releases, mysql\_config\_editor was always bundled with libperconaserverclient22-dev, but since Percona for MySQL Server 8.4.8-8, libperconaserverclient22 is no longer compati…

---

## [Confusion about Audit\_log\_filter rules and excludes](https://forums.percona.com/t/confusion-about-audit-log-filter-rules-and-excludes/39388)

<div class="topic-metadata">

**Author:** [@Daniel\_Wake](https://forums.percona.com/u/Daniel_Wake)\
**Replies:** 17\
**Last updated:** [April 14, 2026, 5:20am UTC](https://forums.percona.com/t/confusion-about-audit-log-filter-rules-and-excludes/39388 "2026-04-14T05:20:29Z")

</div>

Hi All, I’m having trouble understanding the logic of the audit\_log\_filter. Even trying the simplest two filter system of log\_all and log\_none where a specific user or set of users is set to log\_none the system will sti…

---

## [Percona audit\_log\_filter component does not work on the slave server 8.4](https://forums.percona.com/t/percona-audit-log-filter-component-does-not-work-on-the-slave-server-8-4/39205)

<div class="topic-metadata">

**Author:** [@Mastervi](https://forums.percona.com/u/Mastervi)\
**Replies:** 6\
**Last updated:** [March 28, 2026, 2:04am UTC](https://forums.percona.com/t/percona-audit-log-filter-component-does-not-work-on-the-slave-server-8-4/39205 "2026-03-28T02:04:58Z")

</div>

I’m testing the new percona audit\_log\_filter component and found a strange behavior when using it on the replica server. The component is installed, filter rules exist, and the user is added. On the master, I can see t…

---

## [Migrate database encrypted with oracle mysql](https://forums.percona.com/t/migrate-database-encrypted-with-oracle-mysql/40354)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 3\
**Last updated:** [March 23, 2026, 1:51am UTC](https://forums.percona.com/t/migrate-database-encrypted-with-oracle-mysql/40354 "2026-03-23T01:51:07Z")

</div>

Hello Experts Need clarification. I have a database which was created using oracle mysql. Want to use percona . Database is currently encrypted using component\_keyring\_encrypted\_file However I dont see component\_keyr…

---

## [BUG: component\_percona\_udf Does Not Register Any UDFs on Percona Server 8.4.7‑7 (EL9)](https://forums.percona.com/t/bug-component-percona-udf-does-not-register-any-udfs-on-percona-server-8-4-7-7-el9/40305)

<div class="topic-metadata">

**Author:** [@mikepalmergee](https://forums.percona.com/u/mikepalmergee)\
**Replies:** 1\
**Last updated:** [March 1, 2026, 9:09pm UTC](https://forums.percona.com/t/bug-component-percona-udf-does-not-register-any-udfs-on-percona-server-8-4-7-7-el9/40305 "2026-03-01T21:09:52Z")

</div>

BUG: component\_percona\_udf Does Not Register Any UDFs on Percona Server 8.4.7‑7 (EL9) Missing component\_udf\_registration Component in EL9 Packaging I believe I’ve encountered a packaging bug in Percona Server for MySQL 8…

---

## [Upgrading Percona Server from 8.0.44 to 8.4.7 on GTID based replication environments?](https://forums.percona.com/t/upgrading-percona-server-from-8-0-44-to-8-4-7-on-gtid-based-replication-environments/40196)

<div class="topic-metadata">

**Author:** [@Ramasamy](https://forums.percona.com/u/Ramasamy)\
**Replies:** 14\
**Last updated:** [February 12, 2026, 2:10pm UTC](https://forums.percona.com/t/upgrading-percona-server-from-8-0-44-to-8-4-7-on-gtid-based-replication-environments/40196 "2026-02-12T14:10:49Z")

</div>

We are planning to upgrade our Percona Server 8.0.44 to 8.4.7. Our environment is setup GTID based replication (replica is read only). During the upgrade (after 8.4.7), we need to uninstall and install some plugins like…

---

## [Podman start MySQL container failed on Azure pipeline](https://forums.percona.com/t/podman-start-mysql-container-failed-on-azure-pipeline/40149)

<div class="topic-metadata">

**Author:** [@honpon](https://forums.percona.com/u/honpon)\
**Replies:** 1\
**Last updated:** [February 5, 2026, 4:29pm UTC](https://forums.percona.com/t/podman-start-mysql-container-failed-on-azure-pipeline/40149 "2026-02-05T16:29:42Z")

</div>

Podman start MySQL container failed on Azure pipeline podman run -name perconadb -e MYSQL\_ROOT\_PASSWORD=secret -e MYSQL\_DATABASE=tsdb -e MYSQL\_USER=user -e MYSQL\_PASSWORD=user -d docker.io/percona/percona-server:8.4.6 …

---

## [Replication error on a replica](https://forums.percona.com/t/replication-error-on-a-replica/39793)

<div class="topic-metadata">

**Author:** [@simon.tardif](https://forums.percona.com/u/simon.tardif)\
**Replies:** 6\
**Last updated:** [January 29, 2026, 6:07am UTC](https://forums.percona.com/t/replication-error-on-a-replica/39793 "2026-01-29T06:07:28Z")

</div>

Hi we are using 8.0.36-28 Percona Server in a simple master-slave setup. Since the beginning on the week our replication broke two time. We are using row based replication. When the replication break it break on an up…

---

## [Confusing state of Percona Software Repositories (apt)](https://forums.percona.com/t/confusing-state-of-percona-software-repositories-apt/40092)

<div class="topic-metadata">

**Author:** [@rwunderer](https://forums.percona.com/u/rwunderer)\
**Replies:** 6\
**Last updated:** [January 25, 2026, 8:01am UTC](https://forums.percona.com/t/confusing-state-of-percona-software-repositories-apt/40092 "2026-01-25T08:01:24Z")

</div>

Honestly, I find the current state of Percona Software repositories for apt tremendously confusing (not sure if the state of rpm repositories is the same): The documentation ( MySQL software repositories - Percona Soft…

---

## [Multi-Primary Write problem with ProxySQL in the Percona MySQL Operator on Kubernetes](https://forums.percona.com/t/multi-primary-write-problem-with-proxysql-in-the-percona-mysql-operator-on-kubernetes/40037)

<div class="topic-metadata">

**Author:** [@Arsenal\_Dong](https://forums.percona.com/u/Arsenal_Dong)\
**Replies:** 6\
**Last updated:** [January 14, 2026, 2:45am UTC](https://forums.percona.com/t/multi-primary-write-problem-with-proxysql-in-the-percona-mysql-operator-on-kubernetes/40037 "2026-01-14T02:45:57Z")

</div>

I deployed ProxySQL and MySQL on Kubernetes according to the official documentation, but it always ends up being configured in multi-primary (multi-writer) mode. How can I resolve this problem? SELECT hostgroup\_id, host…

---

## [MySQL Server 8.4.7 RPM dependancy on OPENSSL 3.4.0 on AL2023 (AWS Linux - RHEL 9 related)](https://forums.percona.com/t/mysql-server-8-4-7-rpm-dependancy-on-openssl-3-4-0-on-al2023-aws-linux-rhel-9-related/40036)

<div class="topic-metadata">

**Author:** [@paulpete](https://forums.percona.com/u/paulpete)\
**Replies:** 2\
**Last updated:** [January 13, 2026, 8:17am UTC](https://forums.percona.com/t/mysql-server-8-4-7-rpm-dependancy-on-openssl-3-4-0-on-al2023-aws-linux-rhel-9-related/40036 "2026-01-13T08:17:23Z")

</div>

When attempting to upgrade from MySQL 8.4.6 to 8.4.7 on AL2023, I encountered an OPENSSL 3.4.0 # dnf update percona\* Last metadata expiration check: 0:08:23 ago on Fri Jan 9 02:33:42 2026. Dependencies resolved. Pr…

---

## [Any way to install Percona on Debian 13 Trixie?](https://forums.percona.com/t/any-way-to-install-percona-on-debian-13-trixie/38916)

<div class="topic-metadata">

**Author:** [@dkech](https://forums.percona.com/u/dkech)\
**Replies:** 13\
**Last updated:** [December 23, 2025, 2:25pm UTC](https://forums.percona.com/t/any-way-to-install-percona-on-debian-13-trixie/38916 "2025-12-23T14:25:40Z")

</div>

Debian 13 is on a hard freeze to be released in 8 days, so I am looking into upgrading our docker images, and I normally use Percona for MySQL, but I’ve hit a wall installing it. You see Debian 13 does not seem to have a…

---

## [Replica crashed with MY-012869,MY-013183](https://forums.percona.com/t/replica-crashed-with-my-012869-my-013183/27543)

<div class="topic-metadata">

**Author:** [@Hussain\_Patel](https://forums.percona.com/u/Hussain_Patel)\
**Replies:** 2\
**Last updated:** [December 19, 2025, 12:56am UTC](https://forums.percona.com/t/replica-crashed-with-my-012869-my-013183/27543 "2025-12-19T00:56:48Z")

</div>

Replica crashed with below error in error log: Server Version: 8.0.32-24 Percona Server (GPL), Release 24, Revision e5c6e9d2 2023-12-19T21:09:39.578419Z 698457 \[ERROR\] \[MY-012869\] \[InnoDB\] Record in index index\_views\_o…

---

## [Percona Server dosent read config](https://forums.percona.com/t/percona-server-dosent-read-config/34192)

<div class="topic-metadata">

**Author:** [@pscloud](https://forums.percona.com/u/pscloud)\
**Replies:** 9\
**Last updated:** [December 19, 2025, 12:03am UTC](https://forums.percona.com/t/percona-server-dosent-read-config/34192 "2025-12-19T00:03:08Z")

</div>

hey there, I installed the percona-server-server package on Ubuntu 24. I first tried to set the config file before installing the package by using debconf setting the value for percona-server-server/data-dir to /etc/mys…

---

## [Mysqld got signal 11 when restoring database](https://forums.percona.com/t/mysqld-got-signal-11-when-restoring-database/35268)

<div class="topic-metadata">

**Author:** [@artsiom82](https://forums.percona.com/u/artsiom82)\
**Replies:** 8\
**Last updated:** [December 18, 2025, 11:48pm UTC](https://forums.percona.com/t/mysqld-got-signal-11-when-restoring-database/35268 "2025-12-18T23:48:45Z")

</div>

Hello we are using CentOS Stream 9 with 8.0.36-28 Percona Server (GPL), Release 28, Revision 47601f19. We are restoring database and receive Mysqld got signal 11 mysql.err –removed-- pass 194194 dump –removed-- pas…

---

## [Simple LDAP authentication with role mapping issues](https://forums.percona.com/t/simple-ldap-authentication-with-role-mapping-issues/39605)

<div class="topic-metadata">

**Author:** [@Jimmy\_Chen](https://forums.percona.com/u/Jimmy_Chen)\
**Replies:** 2\
**Last updated:** [December 18, 2025, 9:07am UTC](https://forums.percona.com/t/simple-ldap-authentication-with-role-mapping-issues/39605 "2025-12-18T09:07:51Z")

</div>

I’m testing LDAP(s) auth with Percona Server 8.4.6. The following is the configuration I have. I’m able to log in with the LDAP user. If I explicitly grant the user with permissions, then everything is working expected. …

---

## [Mysqldump: Got error: 1160: Got an error writing communication packets when using LOCK TABLES](https://forums.percona.com/t/mysqldump-got-error-1160-got-an-error-writing-communication-packets-when-using-lock-tables/29971)

<div class="topic-metadata">

**Author:** [@bitone](https://forums.percona.com/u/bitone)\
**Replies:** 28\
**Last updated:** [November 27, 2025, 6:11pm UTC](https://forums.percona.com/t/mysqldump-got-error-1160-got-an-error-writing-communication-packets-when-using-lock-tables/29971 "2025-11-27T18:11:14Z")

</div>

We get this error almost every second day on our nightly DB dump cron job. Often for two days in a row. This is on Debian 10.13, all recent updates installed. It started around February when using 8.0.34-26. It’s still…

---

## [Building percona mysql shell 8.0 from percona src rpm](https://forums.percona.com/t/building-percona-mysql-shell-8-0-from-percona-src-rpm/39766)

<div class="topic-metadata">

**Author:** [@Ranit\_Goyal](https://forums.percona.com/u/Ranit_Goyal)\
**Replies:** 7\
**Last updated:** [November 25, 2025, 10:31am UTC](https://forums.percona.com/t/building-percona-mysql-shell-8-0-from-percona-src-rpm/39766 "2025-11-25T10:31:23Z")

</div>

Facing issue building the percona shell, compiling it source code requires percona server source code as input, but it keeps failing while linking libmysqlclient, libmysqlxclient and many other binaries during build. I’m…

---

## [Installing for ARM64 - Missing Telemetry Agent](https://forums.percona.com/t/installing-for-arm64-missing-telemetry-agent/32253)

<div class="topic-metadata">

**Author:** [@Tobias\_Wilson](https://forums.percona.com/u/Tobias_Wilson)\
**Replies:** 11\
**Last updated:** [November 12, 2025, 4:29am UTC](https://forums.percona.com/t/installing-for-arm64-missing-telemetry-agent/32253 "2025-11-12T04:29:39Z")

</div>

Hi all, I’ve read the announcement about Percona Server for MySQL packages for ARM64 @ Percona Server for MySQL and Percona XtraBackup Now Available for ARM64 and trying to follow the instructions but hitting a wall wit…

---

## [Unable to run util.checkForServerUpgrade()](https://forums.percona.com/t/unable-to-run-util-checkforserverupgrade/38189)

<div class="topic-metadata">

**Author:** [@ipcmlr](https://forums.percona.com/u/ipcmlr)\
**Replies:** 4\
**Last updated:** [November 12, 2025, 4:21am UTC](https://forums.percona.com/t/unable-to-run-util-checkforserverupgrade/38189 "2025-11-12T04:21:59Z")

</div>

Hi, I am trying to run util.checkForServerUpgrade and I get an error that I am using the incorrect syntax. I’m sure its something simple but I am just trying to run the util.checkForServerUpgrade without any options an…

---

## [Rocksdb: Alter table fails silently and drops all data: Global seqno is required, but disabled,](https://forums.percona.com/t/rocksdb-alter-table-fails-silently-and-drops-all-data-global-seqno-is-required-but-disabled/27038)

<div class="topic-metadata">

**Author:** [@peterdk](https://forums.percona.com/u/peterdk)\
**Replies:** 6\
**Last updated:** [November 12, 2025, 3:48am UTC](https://forums.percona.com/t/rocksdb-alter-table-fails-silently-and-drops-all-data-global-seqno-is-required-but-disabled/27038 "2025-11-12T03:48:37Z")

</div>

I did alter a fairly small rocksdb table yesterday, and it reported that everything went ok. So I was happy. Today I did another table which was a bit larger, and added a field there as well. It reported that all went f…

---

## [Can't get SELECT WHERE IN (huge list of items) to use index, does table scan](https://forums.percona.com/t/cant-get-select-where-in-huge-list-of-items-to-use-index-does-table-scan/27418)

<div class="topic-metadata">

**Author:** [@peterdk](https://forums.percona.com/u/peterdk)\
**Replies:** 4\
**Last updated:** [November 12, 2025, 3:41am UTC](https://forums.percona.com/t/cant-get-select-where-in-huge-list-of-items-to-use-index-does-table-scan/27418 "2025-11-12T03:41:42Z")

</div>

So I recently reimported my ROCKSDB database from a backup, with a fresh bulk\_load and all inserted in primary key order. Took some time, but now it’s fresh and shiny ;). However, without having changed anything in the …

---

## [Automated way to get notified on Percona Downloads](https://forums.percona.com/t/automated-way-to-get-notified-on-percona-downloads/39682)

<div class="topic-metadata">

**Author:** [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Replies:** 1\
**Last updated:** [November 5, 2025, 10:43am UTC](https://forums.percona.com/t/automated-way-to-get-notified-on-percona-downloads/39682 "2025-11-05T10:43:55Z")

</div>

Hi, I am trying to build a small utility to automatically download Percona Server 8.4.x binaries as soon as Percona Releases it. Is there a way around to interpret the exact version (specifically linux generic 2.28 and…

[Next page](https://forums.percona.com/c/mysql-mariadb/percona-server-for-mysql-8-0/20.md?page=1)
