# Other MySQL® Questions

**URL:** https://forums.percona.com/c/mysql-mariadb/other-mysql-questions/7.md

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

---

## [About the Other MySQL® Questions category](https://forums.percona.com/t/about-the-other-mysql-questions-category/12)

<div class="topic-metadata">

**Author:** [@system](https://forums.percona.com/u/system)\
**Replies:** 0

</div>

MySQL-related questions which don’t fit neatly under any other category.

---

## [Guidance needed for pt-table-checksum on MySQL master-master / source-source replication](https://forums.percona.com/t/guidance-needed-for-pt-table-checksum-on-mysql-master-master-source-source-replication/41142)

<div class="topic-metadata">

**Author:** [@degokul](https://forums.percona.com/u/degokul)\
**Replies:** 5\
**Last updated:** [September 6, 2026, 2:04am UTC](https://forums.percona.com/t/guidance-needed-for-pt-table-checksum-on-mysql-master-master-source-source-replication/41142 "2026-09-06T02:04:48Z")

</div>

Hi Percona community, I’m looking for guidance on the safest operational pattern for using \`pt-table-checksum\` in a MySQL master-master / source-source replication setup. Environment summary: Database: MySQL Enterpri…

---

## [Conflict MariaDB when dnf from Percona repository](https://forums.percona.com/t/conflict-mariadb-when-dnf-from-percona-repository/40882)

<div class="topic-metadata">

**Author:** [@abh](https://forums.percona.com/u/abh)\
**Replies:** 5\
**Last updated:** [June 21, 2026, 11:05am UTC](https://forums.percona.com/t/conflict-mariadb-when-dnf-from-percona-repository/40882 "2026-06-21T11:05:27Z")

</div>

I usually install Percona and this is very weir when i see Marina as dependencies and of course it will conflict with Percona OS: Rocky Linux 10.x yum install https://repo.percona.com/yum/percona-release-latest.noarch.…

---

## [Does percona pam mondule for mysql support AD groups](https://forums.percona.com/t/does-percona-pam-mondule-for-mysql-support-ad-groups/4987)

<div class="topic-metadata">

**Author:** [@tharun](https://forums.percona.com/u/tharun)\
**Replies:** 1\
**Last updated:** [May 5, 2026, 5:16am UTC](https://forums.percona.com/t/does-percona-pam-mondule-for-mysql-support-ad-groups/4987 "2026-05-05T05:16:58Z")

</div>

Have anyone tried using percona pam module to get to work with Microsoft AD to map groups ? I was able to do the authentication but the group / proxy mapping seems to not work.

---

## [Is Percona PAM Authentication plugin compatible with MySQL 5.7?](https://forums.percona.com/t/is-percona-pam-authentication-plugin-compatible-with-mysql-5-7/4882)

<div class="topic-metadata">

**Author:** [@vitaly\_il](https://forums.percona.com/u/vitaly_il)\
**Replies:** 1\
**Last updated:** [May 5, 2026, 3:07am UTC](https://forums.percona.com/t/is-percona-pam-authentication-plugin-compatible-with-mysql-5-7/4882 "2026-05-05T03:07:37Z")

</div>

Is Percona PAM Authentication plugin compatible with MySQL 5.7? TIA, Vitaly

---

## [Audit\_log\_filter not working with new version of MySQL](https://forums.percona.com/t/audit-log-filter-not-working-with-new-version-of-mysql/40706)

<div class="topic-metadata">

**Author:** [@IGGt](https://forums.percona.com/u/IGGt)\
**Replies:** 1\
**Last updated:** [April 27, 2026, 2:55am UTC](https://forums.percona.com/t/audit-log-filter-not-working-with-new-version-of-mysql/40706 "2026-04-27T02:55:22Z")

</div>

Having finally managed to get the audit\_log\_filter component to work with MySQL 8.4, I downloaded the new version of MySQL 8.4.9, and now it doesn’t work again. In fact it just causes the database to crash. I appreciate…

---

## [Audit\_log\_filter, Bug or no Bug?](https://forums.percona.com/t/audit-log-filter-bug-or-no-bug/40628)

<div class="topic-metadata">

**Author:** [@IGGt](https://forums.percona.com/u/IGGt)\
**Replies:** 1\
**Last updated:** [April 15, 2026, 1:18am UTC](https://forums.percona.com/t/audit-log-filter-bug-or-no-bug/40628 "2026-04-15T01:18:31Z")

</div>

interesting problem with the audit\_log\_filter, that may or may not be a bug, what do people think? I have two databases set up as a source and a replica. I am using Row Based Replication. If I run a DDL or DCL query on…

---

## [NCSC‑2026‑0032 CVEs affecting PXC 8.4.7‑7.1](https://forums.percona.com/t/ncsc-2026-0032-cves-affecting-pxc-8-4-7-7-1/40348)

<div class="topic-metadata">

**Author:** [@Peters](https://forums.percona.com/u/Peters)\
**Replies:** 3\
**Last updated:** [April 8, 2026, 5:33pm UTC](https://forums.percona.com/t/ncsc-2026-0032-cves-affecting-pxc-8-4-7-7-1/40348 "2026-04-08T17:33:15Z")

</div>

Hi Percona team, We are currently running Percona XtraDB Cluster 8.4.7‑7.1 with the Percona Operator 1.19.0. This version is based on Percona Server for MySQL 8.4.7, which itself is based on Oracle MySQL 8.4.7. Accor…

---

## [Recovering MySql Database](https://forums.percona.com/t/recovering-mysql-database/39138)

<div class="topic-metadata">

**Author:** [@AsifRafiq](https://forums.percona.com/u/AsifRafiq)\
**Replies:** 4\
**Last updated:** [March 2, 2026, 6:46am UTC](https://forums.percona.com/t/recovering-mysql-database/39138 "2026-03-02T06:46:37Z")

</div>

Hi everyone, I had lost my database. I had recover the database folder using third-party recovery tool, and it had successfully recovered all the .frm and .idb files. I have no ibdata1 file. How can I recover the databas…

---

## [Primary node forwarding/failing over due to "Too many connections"](https://forums.percona.com/t/primary-node-forwarding-failing-over-due-to-too-many-connections/40258)

<div class="topic-metadata">

**Author:** [@SQLCaesar](https://forums.percona.com/u/SQLCaesar)\
**Replies:** 2\
**Last updated:** [February 23, 2026, 9:11am UTC](https://forums.percona.com/t/primary-node-forwarding-failing-over-due-to-too-many-connections/40258 "2026-02-23T09:11:14Z")

</div>

Hi all, I would like to discuss a common situation in a Galera Cluster setup where the intended primary writer (Node 1) stops accepting new requests, causing the loadbalancer to forward write traffic to Node 2. This res…

---

## [Avoid OOM for the MySQL Service](https://forums.percona.com/t/avoid-oom-for-the-mysql-service/40185)

<div class="topic-metadata">

**Author:** [@lbmdkap](https://forums.percona.com/u/lbmdkap)\
**Replies:** 2\
**Last updated:** [February 12, 2026, 8:14am UTC](https://forums.percona.com/t/avoid-oom-for-the-mysql-service/40185 "2026-02-12T08:14:15Z")

</div>

Hi So I have an database (with OK’ish traffic). We sometimes see that the database is killed with OOM, I’ve tried to adjust the OOM score, set to -1000. Unfortunately, this has caused the whole server to crash again, so…

---

## [Out of memory doing import](https://forums.percona.com/t/out-of-memory-doing-import/40076)

<div class="topic-metadata">

**Author:** [@lbmdkap](https://forums.percona.com/u/lbmdkap)\
**Replies:** 7\
**Last updated:** [February 2, 2026, 12:14pm UTC](https://forums.percona.com/t/out-of-memory-doing-import/40076 "2026-02-02T12:14:00Z")

</div>

I have an MySQL instance (an innodb cluster server, put in standalone, so it should not really be important). And I have a couple of servers I need to do this on, so I would like to get to the bottom of this one. Second…

---

## [Audit log filter component issue in MySQL 8.4.4](https://forums.percona.com/t/audit-log-filter-component-issue-in-mysql-8-4-4/39856)

<div class="topic-metadata">

**Author:** [@Dhivya\_Arumugam](https://forums.percona.com/u/Dhivya_Arumugam)\
**Replies:** 12\
**Last updated:** [December 16, 2025, 5:56am UTC](https://forums.percona.com/t/audit-log-filter-component-issue-in-mysql-8-4-4/39856 "2025-12-16T05:56:09Z")

</div>

Hello Team, The Percona MySQL 8.0 Audit Plugin works very well with MySQL 8.0 Community Edition, and we have been using it successfully. We are now evaluating options for MySQL 8.4.4 Community Edition. I noticed that t…

---

## [Increased Statistics Ratio in Database Load on Performance Insights When vCPU is Exceeded in AWS RDS for MySQL (8.0.42) During Load Spikes](https://forums.percona.com/t/increased-statistics-ratio-in-database-load-on-performance-insights-when-vcpu-is-exceeded-in-aws-rds-for-mysql-8-0-42-during-load-spikes/39171)

<div class="topic-metadata">

**Author:** [@wanskim](https://forums.percona.com/u/wanskim)\
**Replies:** 1\
**Last updated:** [August 24, 2025, 4:44am UTC](https://forums.percona.com/t/increased-statistics-ratio-in-database-load-on-performance-insights-when-vcpu-is-exceeded-in-aws-rds-for-mysql-8-0-42-during-load-spikes/39171 "2025-08-24T04:44:53Z")

</div>

Hello, I am using AWS RDS for MySQL (8.0.42). For performance testing related to an event, I applied a spike load to the database. The load was approximately 7 to 8 times the current vCPU capacity, with a sudden influx …

---

## [Using fpsync in a two-stage approach for MySQL 8.4 replica setup – is data corruption a risk during the first stage?](https://forums.percona.com/t/using-fpsync-in-a-two-stage-approach-for-mysql-8-4-replica-setup-is-data-corruption-a-risk-during-the-first-stage/39105)

<div class="topic-metadata">

**Author:** [@CharlesR](https://forums.percona.com/u/CharlesR)\
**Replies:** 2\
**Last updated:** [August 14, 2025, 12:51am UTC](https://forums.percona.com/t/using-fpsync-in-a-two-stage-approach-for-mysql-8-4-replica-setup-is-data-corruption-a-risk-during-the-first-stage/39105 "2025-08-14T00:51:28Z")

</div>

Hello everyone, I’m planning to set up a MySQL 8.4 replica and I’m looking for the most efficient way to minimize downtime. My proposed strategy involves a two-stage process using fpsync. First Synchronization (With …

---

## [Percona mysql 8.4 audit log filter component log rotation using logrotate](https://forums.percona.com/t/percona-mysql-8-4-audit-log-filter-component-log-rotation-using-logrotate/38896)

<div class="topic-metadata">

**Author:** [@Charly\_Wu](https://forums.percona.com/u/Charly_Wu)\
**Replies:** 2\
**Last updated:** [August 1, 2025, 6:34am UTC](https://forums.percona.com/t/percona-mysql-8-4-audit-log-filter-component-log-rotation-using-logrotate/38896 "2025-08-01T06:34:15Z")

</div>

Hi, I would like to use logrotate to perform log rotation of audit log generated by Percona’s audit log filter component (MySQL 8.4). when the format is set to JSON, I notice the file begins with ‘\[‘ which indicate tha…

---

## [\[ERROR\] \[MY-012800\] \[InnoDB\] \[FATAL\] Unknown error code 21: Skip locked records](https://forums.percona.com/t/error-my-012800-innodb-fatal-unknown-error-code-21-skip-locked-records/25843)

<div class="topic-metadata">

**Author:** [@Pavlo\_Tkachenko](https://forums.percona.com/u/Pavlo_Tkachenko)\
**Replies:** 5\
**Last updated:** [July 24, 2025, 5:35pm UTC](https://forums.percona.com/t/error-my-012800-innodb-fatal-unknown-error-code-21-skip-locked-records/25843 "2025-07-24T17:35:26Z")

</div>

we have a cluster with 3 nodes, but recently it crashes with the following error logs: 2 nodes crash with this error and the cluster stops accepting requests. 2023-10-10T23:20:02.208122Z 703 \[ERROR\] \[MY-012800\] \[InnoDB…

---

## [Why SELECT INTO Fails Silently Inside MySQL IF Blocks During PL/SQL Logic Migration](https://forums.percona.com/t/why-select-into-fails-silently-inside-mysql-if-blocks-during-pl-sql-logic-migration/38623)

<div class="topic-metadata">

**Author:** [@benof](https://forums.percona.com/u/benof)\
**Replies:** 2\
**Last updated:** [July 10, 2025, 10:58pm UTC](https://forums.percona.com/t/why-select-into-fails-silently-inside-mysql-if-blocks-during-pl-sql-logic-migration/38623 "2025-07-10T22:58:36Z")

</div>

Hello I am facing an issue in MySQL where a stored procedure using SELECT INTO inside an IF block sometimes fails to populate the variable; even though the query returns a row when executed independently. …

---

## [Audit\_log\_filter component and MySQL 8.4](https://forums.percona.com/t/audit-log-filter-component-and-mysql-8-4/36704)

<div class="topic-metadata">

**Author:** [@IGGt](https://forums.percona.com/u/IGGt)\
**Replies:** 19\
**Last updated:** [May 7, 2025, 1:05pm UTC](https://forums.percona.com/t/audit-log-filter-component-and-mysql-8-4/36704 "2025-05-07T13:05:58Z")

</div>

The old Percona Audit Log plugin works fine with MySQL 8.0. Does anyone know if the new audit\_log\_filter component works with MySQL 8.4? I’ve been trying to install it and it doesn’t seem to install properly. Just wanti…

---

## [Finding statement based replication in the binlog vs row based](https://forums.percona.com/t/finding-statement-based-replication-in-the-binlog-vs-row-based/37391)

<div class="topic-metadata">

**Author:** [@Matthew\_Lenz\_L1T](https://forums.percona.com/u/Matthew_Lenz_L1T)\
**Replies:** 2\
**Last updated:** [March 27, 2025, 6:56pm UTC](https://forums.percona.com/t/finding-statement-based-replication-in-the-binlog-vs-row-based/37391 "2025-03-27T18:56:39Z")

</div>

Seeing something odd with pt-table-checksum in that the ts field in percona.checksums is identical across all replicas. If it is truly using statement based replication shouldn’t these be slightly different? Either way…

---

## [Creating openssl certificates for replication](https://forums.percona.com/t/creating-openssl-certificates-for-replication/37372)

<div class="topic-metadata">

**Author:** [@ipcmlr](https://forums.percona.com/u/ipcmlr)\
**Replies:** 1\
**Last updated:** [March 27, 2025, 4:07pm UTC](https://forums.percona.com/t/creating-openssl-certificates-for-replication/37372 "2025-03-27T16:07:04Z")

</div>

EDIT: I might have had typos copy pasting last time. I have made the certificates without error today. Are there instructions/documetation to create ssl certificates for mysql? I will use them for mysql replication i…

---

## [Audit log rotation failing setting is enabled audit\_log\_flush=1, rotations not occurring preventing file closure](https://forums.percona.com/t/audit-log-rotation-failing-setting-is-enabled-audit-log-flush-1-rotations-not-occurring-preventing-file-closure/37333)

<div class="topic-metadata">

**Author:** [@Harveer](https://forums.percona.com/u/Harveer)\
**Replies:** 7\
**Last updated:** [March 26, 2025, 6:25pm UTC](https://forums.percona.com/t/audit-log-rotation-failing-setting-is-enabled-audit-log-flush-1-rotations-not-occurring-preventing-file-closure/37333 "2025-03-26T18:25:03Z")

</div>

Audit log rotation isn’t functioning as expected. With audit\_log\_flush enabled (set to 1), the audit log files remain open, preventing the rotation process from completing successfully. I’ve tried manually rotating the l…

---

## [Percona toolkit execution failure](https://forums.percona.com/t/percona-toolkit-execution-failure/34610)

<div class="topic-metadata">

**Author:** [@Leszek\_Kotzian](https://forums.percona.com/u/Leszek_Kotzian)\
**Replies:** 12\
**Last updated:** [February 15, 2025, 12:45am UTC](https://forums.percona.com/t/percona-toolkit-execution-failure/34610 "2025-02-15T00:45:59Z")

</div>

The attempts to run Percona toolkit programs are failing with following error, for example: $ pt-heartbeat … install\_driver(mysql) failed: Attempt to reload DBD/mysql.pm aborted. Compilation failed in require at (eval…

---

## [Looking for Percona 5.7.41-44](https://forums.percona.com/t/looking-for-percona-5-7-41-44/36659)

<div class="topic-metadata">

**Author:** [@daneeyxvi](https://forums.percona.com/u/daneeyxvi)\
**Replies:** 8\
**Last updated:** [February 14, 2025, 1:15pm UTC](https://forums.percona.com/t/looking-for-percona-5-7-41-44/36659 "2025-02-14T13:15:24Z")

</div>

Hi been trying to look for a repository with the same exact version as this. mysql Ver 14.14 Distrib 5.7.41-44, for debian-linux-gnu (x86\_64) using 8.0 Been looking for repositories but I can’t find any. Also, i’m us…

---

## [To create data warehousing server in MySQL](https://forums.percona.com/t/to-create-data-warehousing-server-in-mysql/36623)

<div class="topic-metadata">

**Author:** [@todkar2130](https://forums.percona.com/u/todkar2130)\
**Replies:** 1\
**Last updated:** [February 11, 2025, 1:16am UTC](https://forums.percona.com/t/to-create-data-warehousing-server-in-mysql/36623 "2025-02-11T01:16:39Z")

</div>

We have single master DB and 3 replication server environment. From that 3 replication servers we need one DB to be historical server ( i.e. Data warehousing ) We will be deleting some records from every table on maste…

---

## [Slight "mess" in the repositories for at least for EL9](https://forums.percona.com/t/slight-mess-in-the-repositories-for-at-least-for-el9/36612)

<div class="topic-metadata">

**Author:** [@zigi](https://forums.percona.com/u/zigi)\
**Replies:** 3\
**Last updated:** [February 10, 2025, 10:55pm UTC](https://forums.percona.com/t/slight-mess-in-the-repositories-for-at-least-for-el9/36612 "2025-02-10T22:55:56Z")

</div>

Hello, Let me point out to a slight “mess” in the repositories at least for EL9: On page MySQL software repositories you don’t mention The Percona Distribution for MySQL repositories at all. The percona-release script…

---

## [Ubuntu 24.04 Packages](https://forums.percona.com/t/ubuntu-24-04-packages/29931)

<div class="topic-metadata">

**Author:** [@mmbih5ro](https://forums.percona.com/u/mmbih5ro)\
**Replies:** 17\
**Last updated:** [January 20, 2025, 9:37am UTC](https://forums.percona.com/t/ubuntu-24-04-packages/29931 "2025-01-20T09:37:00Z")

</div>

Hey, I am planning to upgrade my machines to Ubuntu 24.04 LTS in the near future. I today noticed, that https://repo.percona.com/ does not yet seem to provide packages for Ubuntu Noble for MySQL Server 8.0.X ProxySQL…

---

## [MySQL 8.4 - Disabling InnoDB Redo Log During Restore - Safe Practice?](https://forums.percona.com/t/mysql-8-4-disabling-innodb-redo-log-during-restore-safe-practice/35675)

<div class="topic-metadata">

**Author:** [@CharlesR](https://forums.percona.com/u/CharlesR)\
**Replies:** 24\
**Last updated:** [December 24, 2024, 1:33pm UTC](https://forums.percona.com/t/mysql-8-4-disabling-innodb-redo-log-during-restore-safe-practice/35675 "2024-12-24T13:33:11Z")

</div>

I’m planning to restore a database in MySQL 8.4 using mysqldump or util.loadDump(). I’ve heard that disabling the InnoDB redo log with ALTER INSTANCE DISABLE INNODB REDO\_LOG can significantly speed up the restore process…

---

## [SQL Performance with sysbench on different disks](https://forums.percona.com/t/sql-performance-with-sysbench-on-different-disks/35693)

<div class="topic-metadata">

**Author:** [@Chrisoft](https://forums.percona.com/u/Chrisoft)\
**Replies:** 0\
**Last updated:** [December 16, 2024, 9:28pm UTC](https://forums.percona.com/t/sql-performance-with-sysbench-on-different-disks/35693 "2024-12-16T21:28:33Z")

</div>

Hello everybody, I have some problem about performance with sysbench on my different OVH servers, here are my results : With this command : sysbench --test=fileio --file-test-mode=seqwr run RISE-2 server : ( Intel Xeo…

---

## [MySQL memory usage is high](https://forums.percona.com/t/mysql-memory-usage-is-high/13838)

<div class="topic-metadata">

**Author:** [@radirobi97](https://forums.percona.com/u/radirobi97)\
**Replies:** 6\
**Last updated:** [December 2, 2024, 9:54am UTC](https://forums.percona.com/t/mysql-memory-usage-is-high/13838 "2024-12-02T09:54:33Z")

</div>

Hi community, I am trying to get a deep insight on how memory usage works in MySQL. My problem is related to Azure Database for MySQL which is a managed service by Microsoft. So unfortunately I can not reach the VM dire…

[Next page](https://forums.percona.com/c/mysql-mariadb/other-mysql-questions/7.md?page=1)
