# MySQL & MariaDB

**URL:** https://forums.percona.com/c/mysql-mariadb/36.md?page=5

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 6

---

## [Xtradb backup failing with permission issue](https://forums.percona.com/t/xtradb-backup-failing-with-permission-issue/39908)

<div class="topic-metadata">

**Author:** [@acelayir](https://forums.percona.com/u/acelayir)\
**Replies:** 4\
**Last updated:** [December 18, 2025, 10:24am UTC](https://forums.percona.com/t/xtradb-backup-failing-with-permission-issue/39908 "2025-12-18T10:24:20Z")

</div>

We get following errors sometimes during the backup 2025-11-21 00:00:59.857 INFO: (2957505e-8792, ‘ssl://0.0.0.0:4567’) connection established to bd74745f-bcef ssl://10.128.14.196:4567 2025-11-21 00:00:59.861 INFO: (…

---

## [Simple LDAP authentication with role mapping issues](https://forums.percona.com/t/simple-ldap-authentication-with-role-mapping-issues/39605)

<div class="topic-metadata">

**Author:** [@Jimmy\_Chen](https://forums.percona.com/u/Jimmy_Chen)\
**Replies:** 2\
**Last updated:** [December 18, 2025, 9:07am UTC](https://forums.percona.com/t/simple-ldap-authentication-with-role-mapping-issues/39605 "2025-12-18T09:07:51Z")

</div>

I’m testing LDAP(s) auth with Percona Server 8.4.6. The following is the configuration I have. I’m able to log in with the LDAP user. If I explicitly grant the user with permissions, then everything is working expected. …

---

## [Audit log filter component issue in MySQL 8.4.4](https://forums.percona.com/t/audit-log-filter-component-issue-in-mysql-8-4-4/39856)

<div class="topic-metadata">

**Author:** [@Dhivya\_Arumugam](https://forums.percona.com/u/Dhivya_Arumugam)\
**Replies:** 12\
**Last updated:** [December 16, 2025, 5:56am UTC](https://forums.percona.com/t/audit-log-filter-component-issue-in-mysql-8-4-4/39856 "2025-12-16T05:56:09Z")

</div>

Hello Team, The Percona MySQL 8.0 Audit Plugin works very well with MySQL 8.0 Community Edition, and we have been using it successfully. We are now evaluating options for MySQL 8.4.4 Community Edition. I noticed that t…

---

## [Percona Xtradb Cluster upgrade](https://forums.percona.com/t/percona-xtradb-cluster-upgrade/39857)

<div class="topic-metadata">

**Author:** [@Inji\_Aslanbeyli](https://forums.percona.com/u/Inji_Aslanbeyli)\
**Replies:** 4\
**Last updated:** [December 15, 2025, 4:46pm UTC](https://forums.percona.com/t/percona-xtradb-cluster-upgrade/39857 "2025-12-15T16:46:12Z")

</div>

Hi team, l have 3 nodes running Percona Xtradb Cluster 5.7 version. Now l want to upgrdae them to version 8. For downtime requirement l want to do it like rolling upgrade. One node at a time. Is it possible doing major …

---

## [Mixing Galera and MariaDB/MySQL replication](https://forums.percona.com/t/mixing-galera-and-mariadb-mysql-replication/8146)

<div class="topic-metadata">

**Author:** [@davidc](https://forums.percona.com/u/davidc)\
**Replies:** 12\
**Last updated:** [December 14, 2025, 11:03am UTC](https://forums.percona.com/t/mixing-galera-and-mariadb-mysql-replication/8146 "2025-12-14T11:03:59Z")

</div>

Hello, reading about it online, it appears we can use both Galera replication and native MariaDB/MySQL replication together. Can anyone confirm that this is correct? I’m thinking of a scenario where Data Center A has 3 …

---

## [ProxySQL keeps sending SELECT traffic to a PXC node in Donor/Desynced](https://forums.percona.com/t/proxysql-keeps-sending-select-traffic-to-a-pxc-node-in-donor-desynced/39828)

<div class="topic-metadata">

**Author:** [@Siamion\_Davydau](https://forums.percona.com/u/Siamion_Davydau)\
**Replies:** 5\
**Last updated:** [December 12, 2025, 7:08am UTC](https://forums.percona.com/t/proxysql-keeps-sending-select-traffic-to-a-pxc-node-in-donor-desynced/39828 "2025-12-12T07:08:03Z")

</div>

Hello! ProxySQL keeps sending SELECT traffic to a PXC node in Donor/Desynced state during backups — how to exclude it? Description: I’m running Percona XtraDB Cluster Operator v1.17.0 (3 nodes) on Kubernetes with Pr…

---

## [Binlog gaps and slow restores](https://forums.percona.com/t/binlog-gaps-and-slow-restores/39830)

<div class="topic-metadata">

**Author:** [@Bernard\_Grymonpon](https://forums.percona.com/u/Bernard_Grymonpon)\
**Replies:** 1\
**Last updated:** [December 8, 2025, 2:31pm UTC](https://forums.percona.com/t/binlog-gaps-and-slow-restores/39830 "2025-12-08T14:31:12Z")

</div>

Description: No info on why binlog gaps might occur, and no info on how to debug/examine this. Additional Information: We have a PXC 8.0.42 with operator 1.18.0 setup running, 3 nodes on EKS and we see that most of our …

---

## [Clone instance failing after DB upgrade](https://forums.percona.com/t/clone-instance-failing-after-db-upgrade/39832)

<div class="topic-metadata">

**Author:** [@rafaelpastre](https://forums.percona.com/u/rafaelpastre)\
**Replies:** 3\
**Last updated:** [December 4, 2025, 5:35pm UTC](https://forums.percona.com/t/clone-instance-failing-after-db-upgrade/39832 "2025-12-04T17:35:34Z")

</div>

Hey guys, hope you are all doing well. I’ve just upgraded my Percona Server 8.0.17 to 8.4.6, and now my clone routine is failing. ERROR 3870 (HY000): Clone Donor plugin INNODB\_TABLESPACES\_ENCRYPTION is not active in Rec…

---

## [PerconaServerMySQL Fails to Start Up after Restore](https://forums.percona.com/t/perconaservermysql-fails-to-start-up-after-restore/38592)

<div class="topic-metadata">

**Author:** [@KSDreams](https://forums.percona.com/u/KSDreams)\
**Replies:** 4\
**Last updated:** [November 30, 2025, 4:31pm UTC](https://forums.percona.com/t/perconaservermysql-fails-to-start-up-after-restore/38592 "2025-11-30T16:31:49Z")

</div>

Description: Attempting to migrate a PerconaServerMySQL from one k8s cluster to another using a PerconaServerMySQLRestore. The PerconaServerMySQLBackup is run on an older version of the operator (0.4.0) with the Restore …

---

## [Operator mySQL Server: cannot upgrade from 8.0.35 to 8.0.41](https://forums.percona.com/t/operator-mysql-server-cannot-upgrade-from-8-0-35-to-8-0-41/38123)

<div class="topic-metadata">

**Author:** [@Ingo.Bez](https://forums.percona.com/u/Ingo.Bez)\
**Replies:** 1\
**Last updated:** [November 29, 2025, 5:49pm UTC](https://forums.percona.com/t/operator-mysql-server-cannot-upgrade-from-8-0-35-to-8-0-41/38123 "2025-11-29T17:49:16Z")

</div>

Description: I am running a percona mysql server cluster (NOT xtradb) in version 0.8.0 with mysql-server 8.0.35. When updating to operator 0.9.0 all is still running smooth. When trying to upgrade the server to any versi…

---

## [After upgrading to PXC 8.4.5-5.1, I see TLS init warnings, missing binlog\_utils\_udf.so, and constant Galera “End of file” messages despite a healthy cluster](https://forums.percona.com/t/after-upgrading-to-pxc-8-4-5-5-1-i-see-tls-init-warnings-missing-binlog-utils-udf-so-and-constant-galera-end-of-file-messages-despite-a-healthy-cluster/39676)

<div class="topic-metadata">

**Author:** [@noops](https://forums.percona.com/u/noops)\
**Replies:** 3\
**Last updated:** [November 29, 2025, 5:22pm UTC](https://forums.percona.com/t/after-upgrading-to-pxc-8-4-5-5-1-i-see-tls-init-warnings-missing-binlog-utils-udf-so-and-constant-galera-end-of-file-messages-despite-a-healthy-cluster/39676 "2025-11-29T17:22:16Z")

</div>

Description After upgrading to Percona XtraDB Cluster 8.4.5-5.1 via the Percona Operator (crVersion: 1.18.0), I’m seeing several recurring issues in the MySQL logs across all PXC nodes: 1. TLS initialization warning \[…

---

## [Mysqldump: Got error: 1160: Got an error writing communication packets when using LOCK TABLES](https://forums.percona.com/t/mysqldump-got-error-1160-got-an-error-writing-communication-packets-when-using-lock-tables/29971)

<div class="topic-metadata">

**Author:** [@bitone](https://forums.percona.com/u/bitone)\
**Replies:** 28\
**Last updated:** [November 27, 2025, 6:11pm UTC](https://forums.percona.com/t/mysqldump-got-error-1160-got-an-error-writing-communication-packets-when-using-lock-tables/29971 "2025-11-27T18:11:14Z")

</div>

We get this error almost every second day on our nightly DB dump cron job. Often for two days in a row. This is on Debian 10.13, all recent updates installed. It started around February when using 8.0.34-26. It’s still…

---

## [The number of wait/synch/mutex/sql/MDL\_ticket\_store::LOCK\_ticket\_store\_ops in mutex\_instances is constantly growing](https://forums.percona.com/t/the-number-of-wait-synch-mutex-sql-mdl-ticket-store-lock-ticket-store-ops-in-mutex-instances-is-constantly-growing/39571)

<div class="topic-metadata">

**Author:** [@iva3682](https://forums.percona.com/u/iva3682)\
**Replies:** 4\
**Last updated:** [November 27, 2025, 6:09am UTC](https://forums.percona.com/t/the-number-of-wait-synch-mutex-sql-mdl-ticket-store-lock-ticket-store-ops-in-mutex-instances-is-constantly-growing/39571 "2025-11-27T06:09:19Z")

</div>

Hello! I have a Percona xtradb Cluster 8.0.42-33.1 cluster installed using percona-operator 1.18.0. I’ve noticed a steady increase in the number of rows in performance\_schema.mutex\_instances with NAME=wait/synch/mutex/sq…

---

## [Building percona mysql shell 8.0 from percona src rpm](https://forums.percona.com/t/building-percona-mysql-shell-8-0-from-percona-src-rpm/39766)

<div class="topic-metadata">

**Author:** [@Ranit\_Goyal](https://forums.percona.com/u/Ranit_Goyal)\
**Replies:** 7\
**Last updated:** [November 25, 2025, 10:31am UTC](https://forums.percona.com/t/building-percona-mysql-shell-8-0-from-percona-src-rpm/39766 "2025-11-25T10:31:23Z")

</div>

Facing issue building the percona shell, compiling it source code requires percona server source code as input, but it keeps failing while linking libmysqlclient, libmysqlxclient and many other binaries during build. I’m…

---

## [Audit Log Read not working despite audit.json being written properly](https://forums.percona.com/t/audit-log-read-not-working-despite-audit-json-being-written-properly/39769)

<div class="topic-metadata">

**Author:** [@richard1307](https://forums.percona.com/u/richard1307)\
**Replies:** 2\
**Last updated:** [November 24, 2025, 9:31am UTC](https://forums.percona.com/t/audit-log-read-not-working-despite-audit-json-being-written-properly/39769 "2025-11-24T09:31:13Z")

</div>

mysql\> SELECT audit\_log\_read(‘{“start”: {“timestamp”: “2025-11-21 00:00:00”}}’); ±------------------------------------------------------------------+ | audit\_log\_read(‘{“start”: {“timestamp”: “2025-11-21 00:00:00”}}’) …

---

## [Issue joining bootstrapped cluster](https://forums.percona.com/t/issue-joining-bootstrapped-cluster/39764)

<div class="topic-metadata">

**Author:** [@stsirag](https://forums.percona.com/u/stsirag)\
**Replies:** 3\
**Last updated:** [November 21, 2025, 3:46pm UTC](https://forums.percona.com/t/issue-joining-bootstrapped-cluster/39764 "2025-11-21T15:46:53Z")

</div>

I’m following the docs Configure-nodes and Add-nodes to configure Percona 8.4 Mysql cluster I’ve bootstrapped the first node and started mysql on the 2nd node after generating and copying the cert, and configuring the m…

---

## [Xtrabackup and SST replication broken](https://forums.percona.com/t/xtrabackup-and-sst-replication-broken/39750)

<div class="topic-metadata">

**Author:** [@balu](https://forums.percona.com/u/balu)\
**Replies:** 1\
**Last updated:** [November 20, 2025, 1:18am UTC](https://forums.percona.com/t/xtrabackup-and-sst-replication-broken/39750 "2025-11-20T01:18:42Z")

</div>

We can no longer perform backups with xtrabackup. SST replication is also broken. The error message from xtrabackup is: 025-11-19T10:39:22.303761+01:00 0 \[Note\] \[MY-011825\] \[Xtrabackup\] recognized server arguments: --s…

---

## [Announcing the GA Release of the New Percona Operator for MySQL 🚀](https://forums.percona.com/t/announcing-the-ga-release-of-the-new-percona-operator-for-mysql/39751)

<div class="topic-metadata">

**Author:** [@Edith-Puclla](https://forums.percona.com/u/Edith-Puclla)\
**Replies:** 0\
**Last updated:** [November 19, 2025, 11:28am UTC](https://forums.percona.com/t/announcing-the-ga-release-of-the-new-percona-operator-for-mysql/39751 "2025-11-19T11:28:28Z")

</div>

A major milestone for the Kubernetes + MySQL community! Hi everyone! As many of you know, we’ve been working on the new Percona Operator for MySQL for almost two years. It has been a long journey filled with deep engin…

---

## [What is the difference between MyISAM and InnoDB tables?](https://forums.percona.com/t/what-is-the-difference-between-myisam-and-innodb-tables/39730)

<div class="topic-metadata">

**Author:** [@SQLCaesar](https://forums.percona.com/u/SQLCaesar)\
**Replies:** 3\
**Last updated:** [November 17, 2025, 7:07pm UTC](https://forums.percona.com/t/what-is-the-difference-between-myisam-and-innodb-tables/39730 "2025-11-17T19:07:52Z")

</div>

Hello Percona Community, We would like to better understand the following topic regarding the use of MyISAM and InnoDB tables. Is my understanding correct that PXC needs the transactional capabilities and row-level loc…

---

## [After importing data in pxc8.0, the restart failed without any error message.](https://forums.percona.com/t/after-importing-data-in-pxc8-0-the-restart-failed-without-any-error-message/39722)

<div class="topic-metadata">

**Author:** [@wxc](https://forums.percona.com/u/wxc)\
**Replies:** 1\
**Last updated:** [November 14, 2025, 9:36am UTC](https://forums.percona.com/t/after-importing-data-in-pxc8-0-the-restart-failed-without-any-error-message/39722 "2025-11-14T09:36:36Z")

</div>

After importing data in pxc 8.0, the restart failed without any error message.

---

## [Cluster broke after \[InnoDB\] Assertion failure: row0ins.cc:279:!cursor-\>index-\>is\_committed()](https://forums.percona.com/t/cluster-broke-after-innodb-assertion-failure-row0ins-cc-cursor-index-is-committed/39699)

<div class="topic-metadata">

**Author:** [@shakalandy](https://forums.percona.com/u/shakalandy)\
**Replies:** 5\
**Last updated:** [November 13, 2025, 5:04am UTC](https://forums.percona.com/t/cluster-broke-after-innodb-assertion-failure-row0ins-cc-cursor-index-is-committed/39699 "2025-11-13T05:04:59Z")

</div>

Hi, yesterday we had a severe incident on one of our productive clusters running the recent percona-xtradb-cluster-server version 8.0.43-34-1. The cluster consists of 3 nodes, of which 2 shutdown with the same error me…

---

## [Installing for ARM64 - Missing Telemetry Agent](https://forums.percona.com/t/installing-for-arm64-missing-telemetry-agent/32253)

<div class="topic-metadata">

**Author:** [@Tobias\_Wilson](https://forums.percona.com/u/Tobias_Wilson)\
**Replies:** 11\
**Last updated:** [November 12, 2025, 4:29am UTC](https://forums.percona.com/t/installing-for-arm64-missing-telemetry-agent/32253 "2025-11-12T04:29:39Z")

</div>

Hi all, I’ve read the announcement about Percona Server for MySQL packages for ARM64 @ Percona Server for MySQL and Percona XtraBackup Now Available for ARM64 and trying to follow the instructions but hitting a wall wit…

---

## [Unable to run util.checkForServerUpgrade()](https://forums.percona.com/t/unable-to-run-util-checkforserverupgrade/38189)

<div class="topic-metadata">

**Author:** [@ipcmlr](https://forums.percona.com/u/ipcmlr)\
**Replies:** 4\
**Last updated:** [November 12, 2025, 4:21am UTC](https://forums.percona.com/t/unable-to-run-util-checkforserverupgrade/38189 "2025-11-12T04:21:59Z")

</div>

Hi, I am trying to run util.checkForServerUpgrade and I get an error that I am using the incorrect syntax. I’m sure its something simple but I am just trying to run the util.checkForServerUpgrade without any options an…

---

## [Rocksdb: Alter table fails silently and drops all data: Global seqno is required, but disabled,](https://forums.percona.com/t/rocksdb-alter-table-fails-silently-and-drops-all-data-global-seqno-is-required-but-disabled/27038)

<div class="topic-metadata">

**Author:** [@peterdk](https://forums.percona.com/u/peterdk)\
**Replies:** 6\
**Last updated:** [November 12, 2025, 3:48am UTC](https://forums.percona.com/t/rocksdb-alter-table-fails-silently-and-drops-all-data-global-seqno-is-required-but-disabled/27038 "2025-11-12T03:48:37Z")

</div>

I did alter a fairly small rocksdb table yesterday, and it reported that everything went ok. So I was happy. Today I did another table which was a bit larger, and added a field there as well. It reported that all went f…

---

## [Can't get SELECT WHERE IN (huge list of items) to use index, does table scan](https://forums.percona.com/t/cant-get-select-where-in-huge-list-of-items-to-use-index-does-table-scan/27418)

<div class="topic-metadata">

**Author:** [@peterdk](https://forums.percona.com/u/peterdk)\
**Replies:** 4\
**Last updated:** [November 12, 2025, 3:41am UTC](https://forums.percona.com/t/cant-get-select-where-in-huge-list-of-items-to-use-index-does-table-scan/27418 "2025-11-12T03:41:42Z")

</div>

So I recently reimported my ROCKSDB database from a backup, with a fresh bulk\_load and all inserted in primary key order. Took some time, but now it’s fresh and shiny ;). However, without having changed anything in the …

---

## [Mysqld got signal 11 right after “Initiating SST cancellation” — race in wsrep 26.1.4.3?](https://forums.percona.com/t/mysqld-got-signal-11-right-after-initiating-sst-cancellation-race-in-wsrep-26-1-4-3/39689)

<div class="topic-metadata">

**Author:** [@Aleksander\_Lutsenko](https://forums.percona.com/u/Aleksander_Lutsenko)\
**Replies:** 7\
**Last updated:** [November 6, 2025, 3:46pm UTC](https://forums.percona.com/t/mysqld-got-signal-11-right-after-initiating-sst-cancellation-race-in-wsrep-26-1-4-3/39689 "2025-11-06T15:46:27Z")

</div>

We’re hitting intermittent crashes on one node when an SST cancellation is triggered: \[WSREP\] Initiating SST cancellation mysqld got signal 11 (Thread pointer: 0x0) Crashes occur intermittently during or shortly aft…

---

## [Percona Server 8.4-lts memory leakage](https://forums.percona.com/t/percona-server-8-4-lts-memory-leakage/39538)

<div class="topic-metadata">

**Author:** [@burlutskiy](https://forums.percona.com/u/burlutskiy)\
**Replies:** 6\
**Last updated:** [November 5, 2025, 1:34pm UTC](https://forums.percona.com/t/percona-server-8-4-lts-memory-leakage/39538 "2025-11-05T13:34:54Z")

</div>

Hello everyone! I decided to install a new MySQL 8.4 server for our new projects… Specifically, a Percona server, in group replication mode, not an extradb cluster… I discovered that when idle, the server constantly c…

---

## [Automated way to get notified on Percona Downloads](https://forums.percona.com/t/automated-way-to-get-notified-on-percona-downloads/39682)

<div class="topic-metadata">

**Author:** [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Replies:** 1\
**Last updated:** [November 5, 2025, 10:43am UTC](https://forums.percona.com/t/automated-way-to-get-notified-on-percona-downloads/39682 "2025-11-05T10:43:55Z")

</div>

Hi, I am trying to build a small utility to automatically download Percona Server 8.4.x binaries as soon as Percona Releases it. Is there a way around to interpret the exact version (specifically linux generic 2.28 and…

---

## [Unable to join node to Percona XtraDB Cluster 8.4.6](https://forums.percona.com/t/unable-to-join-node-to-percona-xtradb-cluster-8-4-6/39665)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 2\
**Last updated:** [November 1, 2025, 3:56am UTC](https://forums.percona.com/t/unable-to-join-node-to-percona-xtradb-cluster-8-4-6/39665 "2025-11-01T03:56:14Z")

</div>

Hello Experts Need your help My cluster version is 8.4.6, ssl is not enabled, firewall is not running , selinux is switched to permissive mode ============= begin node 1 Config file ==============================…

---

## [PXC cluster node crashed and cannot recover](https://forums.percona.com/t/pxc-cluster-node-crashed-and-cannot-recover/39153)

<div class="topic-metadata">

**Author:** [@Gerwin\_van\_de\_Steeg](https://forums.percona.com/u/Gerwin_van_de_Steeg)\
**Replies:** 8\
**Last updated:** [October 31, 2025, 4:09pm UTC](https://forums.percona.com/t/pxc-cluster-node-crashed-and-cannot-recover/39153 "2025-10-31T16:09:22Z")

</div>

Description: This happens frequently enough that it gets really annoying, out of the two database instances running they frequently enough crash with no easy to diagnose reason and cannot recover themselves leaving the p…

[Previous page](https://forums.percona.com/c/mysql-mariadb/36.md?page=4)

[Next page](https://forums.percona.com/c/mysql-mariadb/36.md?page=6)
