# MySQL & MariaDB

**URL:** https://forums.percona.com/c/mysql-mariadb/36.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [Missing mysql\_config\_editor from Percona Server for MySQL 8.4.8-8](https://forums.percona.com/t/missing-mysql-config-editor-from-percona-server-for-mysql-8-4-8-8/40364)

<div class="topic-metadata">

**Author:** [@onlime](https://forums.percona.com/u/onlime)\
**Replies:** 4\
**Last updated:** [April 21, 2026, 4:18pm UTC](https://forums.percona.com/t/missing-mysql-config-editor-from-percona-server-for-mysql-8-4-8-8/40364 "2026-04-21T16:18:54Z")

</div>

On all previous Percona Server for MySQL 8.4.x releases, mysql\_config\_editor was always bundled with libperconaserverclient22-dev, but since Percona for MySQL Server 8.4.8-8, libperconaserverclient22 is no longer compati…

---

## [Percona audit log filter not working](https://forums.percona.com/t/percona-audit-log-filter-not-working/40686)

<div class="topic-metadata">

**Author:** [@lxnguyen](https://forums.percona.com/u/lxnguyen)\
**Replies:** 4\
**Last updated:** [April 21, 2026, 9:38am UTC](https://forums.percona.com/t/percona-audit-log-filter-not-working/40686 "2026-04-21T09:38:04Z")

</div>

Percona for mysql 8.4 Ubuntu 24.04 I configured the server to use audit log component. I create the filter below to log connections and admin commands, and assigned it to ‘%’. It only captured only connections but no…

---

## [Percona audit log crashes mysql 8.4 CE](https://forums.percona.com/t/percona-audit-log-crashes-mysql-8-4-ce/40678)

<div class="topic-metadata">

**Author:** [@lxnguyen](https://forums.percona.com/u/lxnguyen)\
**Replies:** 6\
**Last updated:** [April 21, 2026, 7:36am UTC](https://forums.percona.com/t/percona-audit-log-crashes-mysql-8-4-ce/40678 "2026-04-21T07:36:02Z")

</div>

I installed Percona for MySQL server 8.4.8-8’s audit log filter component on mysql 8.4.8 community edition on Ubuntu 24.04. I then created a filter to log connections and admin commands (such as create/drop database, cre…

---

## [Can PXC over WAN be implemented in production](https://forums.percona.com/t/can-pxc-over-wan-be-implemented-in-production/40674)

<div class="topic-metadata">

**Author:** [@shirisha](https://forums.percona.com/u/shirisha)\
**Replies:** 7\
**Last updated:** [April 21, 2026, 4:38am UTC](https://forums.percona.com/t/can-pxc-over-wan-be-implemented-in-production/40674 "2026-04-21T04:38:02Z")

</div>

Hi Team, Can PXC over WAN be implemented in production ? If so what are the recommendations? Below is my use case can you please advise on how this can be achieved in MySQL database. I have a requirement for multi-mast…

---

## [PXC with 5 nodes in production across WAN](https://forums.percona.com/t/pxc-with-5-nodes-in-production-across-wan/40667)

<div class="topic-metadata">

**Author:** [@shirisha](https://forums.percona.com/u/shirisha)\
**Replies:** 2\
**Last updated:** [April 20, 2026, 7:41pm UTC](https://forums.percona.com/t/pxc-with-5-nodes-in-production-across-wan/40667 "2026-04-20T19:41:35Z")

</div>

Hello, I have 5 node PXC cluster ( 2 nodes in DC1, 3 nodes in DC2). Haproxy is configured such that it points to one primary write node in local dc and backend config has other nodes( localdc first and then remote dc) I…

---

## [\[ERROR\] \[MY-013709\] \[Server\] Received an error while processing components from manifest file: Failed to load components from manifest file](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 5\
**Last updated:** [April 17, 2026, 4:58am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561 "2026-04-17T04:58:23Z")

</div>

node1\_config.txt (1.4 KB) node2\_config .txt (1.4 KB) OS version: rhel 9.6 xtradb version: 8.4.6 xtrabackup version 8.4.0-4 Keyring Encryption : /appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.gli…

---

## [Sst-idle-timeout killing sst after the donor has transferred all the data](https://forums.percona.com/t/sst-idle-timeout-killing-sst-after-the-donor-has-transferred-all-the-data/40634)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 2\
**Last updated:** [April 15, 2026, 8:46am UTC](https://forums.percona.com/t/sst-idle-timeout-killing-sst-after-the-donor-has-transferred-all-the-data/40634 "2026-04-15T08:46:56Z")

</div>

Setup: 3 node percona pxc cluster with the following percona images Operator: 1.19.0 Cluster: 8.0.42-33.1 Xtrabackup: 8.0.35-34.1 I was trying triggering sst transfer after deleting pvc’s for one of the node, but th…

---

## [Audit\_log\_filter, Bug or no Bug?](https://forums.percona.com/t/audit-log-filter-bug-or-no-bug/40628)

<div class="topic-metadata">

**Author:** [@IGGt](https://forums.percona.com/u/IGGt)\
**Replies:** 1\
**Last updated:** [April 15, 2026, 1:18am UTC](https://forums.percona.com/t/audit-log-filter-bug-or-no-bug/40628 "2026-04-15T01:18:31Z")

</div>

interesting problem with the audit\_log\_filter, that may or may not be a bug, what do people think? I have two databases set up as a source and a replica. I am using Row Based Replication. If I run a DDL or DCL query on…

---

## [Migration between Percona MySQL \<=\> Oracle MySQL](https://forums.percona.com/t/migration-between-percona-mysql-oracle-mysql/30310)

<div class="topic-metadata">

**Author:** [@midson](https://forums.percona.com/u/midson)\
**Replies:** 7\
**Last updated:** [April 14, 2026, 3:38pm UTC](https://forums.percona.com/t/migration-between-percona-mysql-oracle-mysql/30310 "2026-04-14T15:38:19Z")

</div>

Is there any blog or document, which talks about the steps followed and hands-on experience in dealing with migration in both ways? Pre & Post migration checks Migration steps and Data sync ups Integrity & Performance …

---

## [Confusion about Audit\_log\_filter rules and excludes](https://forums.percona.com/t/confusion-about-audit-log-filter-rules-and-excludes/39388)

<div class="topic-metadata">

**Author:** [@Daniel\_Wake](https://forums.percona.com/u/Daniel_Wake)\
**Replies:** 17\
**Last updated:** [April 14, 2026, 5:20am UTC](https://forums.percona.com/t/confusion-about-audit-log-filter-rules-and-excludes/39388 "2026-04-14T05:20:29Z")

</div>

Hi All, I’m having trouble understanding the logic of the audit\_log\_filter. Even trying the simplest two filter system of log\_all and log\_none where a specific user or set of users is set to log\_none the system will sti…

---

## [Audit Log Filter Doesn't accept user@%](https://forums.percona.com/t/audit-log-filter-doesnt-accept-user/40612)

<div class="topic-metadata">

**Author:** [@IGGt](https://forums.percona.com/u/IGGt)\
**Replies:** 9\
**Last updated:** [April 13, 2026, 11:00am UTC](https://forums.percona.com/t/audit-log-filter-doesnt-accept-user/40612 "2026-04-13T11:00:42Z")

</div>

I am running the audit\_log\_filter component with MySQL 8.4.8 (Oracle MySQL). If I run: SELECT audit\_log\_filter\_set\_user(‘%’, ‘log\_connections\_and\_queries’); it works fine. If I run: SELECT audit\_log\_filter\_set\_user(…

---

## [How to install Percona MySQL server with component keyring and self signed certs by default on the RHEL 8/9?](https://forums.percona.com/t/how-to-install-percona-mysql-server-with-component-keyring-and-self-signed-certs-by-default-on-the-rhel-8-9/40611)

<div class="topic-metadata">

**Author:** [@Ramasamy](https://forums.percona.com/u/Ramasamy)\
**Replies:** 1\
**Last updated:** [April 10, 2026, 11:37am UTC](https://forums.percona.com/t/how-to-install-percona-mysql-server-with-component-keyring-and-self-signed-certs-by-default-on-the-rhel-8-9/40611 "2026-04-10T11:37:47Z")

</div>

We need to install the new version of Percona MySQL server on the RHEL 8/9 with component keyring by default and also default self signed certs. Please advise how to install Percona MySQL server on the RHEL 8/9 with com…

---

## [NCSC‑2026‑0032 CVEs affecting PXC 8.4.7‑7.1](https://forums.percona.com/t/ncsc-2026-0032-cves-affecting-pxc-8-4-7-7-1/40348)

<div class="topic-metadata">

**Author:** [@Peters](https://forums.percona.com/u/Peters)\
**Replies:** 3\
**Last updated:** [April 8, 2026, 5:33pm UTC](https://forums.percona.com/t/ncsc-2026-0032-cves-affecting-pxc-8-4-7-7-1/40348 "2026-04-08T17:33:15Z")

</div>

Hi Percona team, We are currently running Percona XtraDB Cluster 8.4.7‑7.1 with the Percona Operator 1.19.0. This version is based on Percona Server for MySQL 8.4.7, which itself is based on Oracle MySQL 8.4.7. Accor…

---

## [Questions related to Percona Telemetry Agent and Audit Log Filter plugin](https://forums.percona.com/t/questions-related-to-percona-telemetry-agent-and-audit-log-filter-plugin/40131)

<div class="topic-metadata">

**Author:** [@Ramasamy](https://forums.percona.com/u/Ramasamy)\
**Replies:** 5\
**Last updated:** [April 2, 2026, 6:24am UTC](https://forums.percona.com/t/questions-related-to-percona-telemetry-agent-and-audit-log-filter-plugin/40131 "2026-04-02T06:24:31Z")

</div>

Hi, We noticed that if Percona Telemetric Agent is installed, then we are able to successfully install the new audit log plugin. If we uninstall and remove the telemetry service agent, then not able to install the Audit…

---

## [PXC configured as async replica can not decrease replication lag](https://forums.percona.com/t/pxc-configured-as-async-replica-can-not-decrease-replication-lag/40485)

<div class="topic-metadata">

**Author:** [@Perica\_Jakimov](https://forums.percona.com/u/Perica_Jakimov)\
**Replies:** 9\
**Last updated:** [April 2, 2026, 1:13am UTC](https://forums.percona.com/t/pxc-configured-as-async-replica-can-not-decrease-replication-lag/40485 "2026-04-02T01:13:39Z")

</div>

We have x3 node PXC 8.0.36 setup that was used as the Primary DB for our workload. The specs for each node are: 40 CPUs, 768G RAM, 10G network. Dataset size is ~8TB. We were using it as single-writer and it was perform…

---

## [Failed to connect error when trying to backup XtraDB Cluster Node](https://forums.percona.com/t/failed-to-connect-error-when-trying-to-backup-xtradb-cluster-node/40487)

<div class="topic-metadata">

**Author:** [@bhuang](https://forums.percona.com/u/bhuang)\
**Replies:** 1\
**Last updated:** [March 31, 2026, 7:07am UTC](https://forums.percona.com/t/failed-to-connect-error-when-trying-to-backup-xtradb-cluster-node/40487 "2026-03-31T07:07:49Z")

</div>

Hi all, I’m doing some testing with a Percona XtraDB Cluster and I am attempting to use XtraBackup to create a backup of one of the nodes. The XtraDB Cluster is running on a Docker Swarm and I am following the documenta…

---

## [Issue with audit\_log\_filter component on Replica Nodes in 3-Node MySQL InnoDB Cluster (Percona MySQL 8.4.7)](https://forums.percona.com/t/issue-with-audit-log-filter-component-on-replica-nodes-in-3-node-mysql-innodb-cluster-percona-mysql-8-4-7/40412)

<div class="topic-metadata">

**Author:** [@Dhivya\_Arumugam](https://forums.percona.com/u/Dhivya_Arumugam)\
**Replies:** 3\
**Last updated:** [March 30, 2026, 12:48pm UTC](https://forums.percona.com/t/issue-with-audit-log-filter-component-on-replica-nodes-in-3-node-mysql-innodb-cluster-percona-mysql-8-4-7/40412 "2026-03-30T12:48:16Z")

</div>

Hi Percona Support Team, I am testing the audit\_log\_filter component of Percona MySQL 8.4.7 on a 3-node MySQL InnoDB Cluster (Group Replication) setup and have observed inconsistent behavior between the primary and repl…

---

## [Percona audit\_log\_filter component does not work on the slave server 8.4](https://forums.percona.com/t/percona-audit-log-filter-component-does-not-work-on-the-slave-server-8-4/39205)

<div class="topic-metadata">

**Author:** [@Mastervi](https://forums.percona.com/u/Mastervi)\
**Replies:** 6\
**Last updated:** [March 28, 2026, 2:04am UTC](https://forums.percona.com/t/percona-audit-log-filter-component-does-not-work-on-the-slave-server-8-4/39205 "2026-03-28T02:04:58Z")

</div>

I’m testing the new percona audit\_log\_filter component and found a strange behavior when using it on the replica server. The component is installed, filter rules exist, and the user is added. On the master, I can see t…

---

## [Are there cases where Percona XtraBackup Restore can break the cluster?](https://forums.percona.com/t/are-there-cases-where-percona-xtrabackup-restore-can-break-the-cluster/40376)

<div class="topic-metadata">

**Author:** [@na50r](https://forums.percona.com/u/na50r)\
**Replies:** 6\
**Last updated:** [March 26, 2026, 9:47am UTC](https://forums.percona.com/t/are-there-cases-where-percona-xtrabackup-restore-can-break-the-cluster/40376 "2026-03-26T09:47:33Z")

</div>

I have a PXC (PerconaXtraDBCluster) deployed with Helm Chart Version 1.14.5 and then had to upgrade to 1.19.0. The Helm Chart allows setting up a cronjob that creates a backup of the cluster. My cronjob runs every day an…

---

## [PXC Operator wsrep\_notify\_cmd handler hangs indefinitely on joiner state, curl to PITR has no timeout, blocks SST/IST](https://forums.percona.com/t/pxc-operator-wsrep-notify-cmd-handler-hangs-indefinitely-on-joiner-state-curl-to-pitr-has-no-timeout-blocks-sst-ist/40398)

<div class="topic-metadata">

**Author:** [@Yash\_Daga](https://forums.percona.com/u/Yash_Daga)\
**Replies:** 2\
**Last updated:** [March 25, 2026, 6:16pm UTC](https://forums.percona.com/t/pxc-operator-wsrep-notify-cmd-handler-hangs-indefinitely-on-joiner-state-curl-to-pitr-has-no-timeout-blocks-sst-ist/40398 "2026-03-25T18:16:07Z")

</div>

Hello, I’m was facing an issue in PXC Operator v1.19.0 where a missing curl timeout in the Galera notify handler permanently blocks nodes from rejoining the cluster. The Problem: When a PXC node enters joiner state, t…

---

## [Streaming backups with xtrabackup failing mid-transfer due to broken pipe errors](https://forums.percona.com/t/streaming-backups-with-xtrabackup-failing-mid-transfer-due-to-broken-pipe-errors/40386)

<div class="topic-metadata">

**Author:** [@shevy](https://forums.percona.com/u/shevy)\
**Replies:** 1\
**Last updated:** [March 23, 2026, 2:13pm UTC](https://forums.percona.com/t/streaming-backups-with-xtrabackup-failing-mid-transfer-due-to-broken-pipe-errors/40386 "2026-03-23T14:13:25Z")

</div>

Hello Percona Community, I’m running Percona MySQL 5.7.36 with xtrabackup 2.4.29. I’m attempting to stream backups from one host to a remote server using nc and xbstream. On the source host, I run: xtrabackup --backup …

---

## [Create audit filter for only failed logins](https://forums.percona.com/t/create-audit-filter-for-only-failed-logins/40387)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 2\
**Last updated:** [March 23, 2026, 9:10am UTC](https://forums.percona.com/t/create-audit-filter-for-only-failed-logins/40387 "2026-03-23T09:10:14Z")

</div>

Hello experts, I created audit filter to audit failed logins for application user, isnt working as expected SELECT audit\_log\_filter\_set\_filter(‘audit\_FL’, ‘{ “filter”: {“class”: \[{“name”: “connection”,“event”: \[{ “n…

---

## [Migrate database encrypted with oracle mysql](https://forums.percona.com/t/migrate-database-encrypted-with-oracle-mysql/40354)

<div class="topic-metadata">

**Author:** [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Replies:** 3\
**Last updated:** [March 23, 2026, 1:51am UTC](https://forums.percona.com/t/migrate-database-encrypted-with-oracle-mysql/40354 "2026-03-23T01:51:07Z")

</div>

Hello Experts Need clarification. I have a database which was created using oracle mysql. Want to use percona . Database is currently encrypted using component\_keyring\_encrypted\_file However I dont see component\_keyr…

---

## [Sql\_generate\_invisible\_primary\_key on XtraDB Cluster](https://forums.percona.com/t/sql-generate-invisible-primary-key-on-xtradb-cluster/40365)

<div class="topic-metadata">

**Author:** [@stofa.kenida](https://forums.percona.com/u/stofa.kenida)\
**Replies:** 7\
**Last updated:** [March 19, 2026, 2:10am UTC](https://forums.percona.com/t/sql-generate-invisible-primary-key-on-xtradb-cluster/40365 "2026-03-19T02:10:55Z")

</div>

Hi There, We have a cluster with 3 nodes ( 2 nodes and a gardb ). The used version is : 8.0.44-35.1 Percona XtraDB Cluster (GPL), Release rel35, Revision 7284a5c, WSREP version 26.1.4.3 We observed that, when the…

---

## [Please upload the binary file to the repo.percona.com](https://forums.percona.com/t/please-upload-the-binary-file-to-the-repo-percona-com/40370)

<div class="topic-metadata">

**Author:** [@fengzhao1124](https://forums.percona.com/u/fengzhao1124)\
**Replies:** 2\
**Last updated:** [March 18, 2026, 5:22pm UTC](https://forums.percona.com/t/please-upload-the-binary-file-to-the-repo-percona-com/40370 "2026-03-18T17:22:39Z")

</div>

I can’t find the file from the repo.percona.com , please add the binary relase file to the repo https://downloads.percona.com/downloads/Percona-XtraBackup-8.4/Percona-XtraBackup-8.4.0-5/binary/tarball/percona-xtraback…

---

## [Audit filter with query and user info in one record possible?](https://forums.percona.com/t/audit-filter-with-query-and-user-info-in-one-record-possible/40336)

<div class="topic-metadata">

**Author:** [@ipcmlr](https://forums.percona.com/u/ipcmlr)\
**Replies:** 8\
**Last updated:** [March 17, 2026, 12:47am UTC](https://forums.percona.com/t/audit-filter-with-query-and-user-info-in-one-record-possible/40336 "2026-03-17T00:47:08Z")

</div>

I have an audit filter which checks which users have created/dropped/altered users in the database. I need user and host in the info however I cannot seem to find a way to include it in one record. What I get in the au…

---

## [Percona alternative solutions to MySQL 8.0 InnoDB ClusterSet](https://forums.percona.com/t/percona-alternative-solutions-to-mysql-8-0-innodb-clusterset/40361)

<div class="topic-metadata">

**Author:** [@y840530](https://forums.percona.com/u/y840530)\
**Replies:** 1\
**Last updated:** [March 15, 2026, 8:50am UTC](https://forums.percona.com/t/percona-alternative-solutions-to-mysql-8-0-innodb-clusterset/40361 "2026-03-15T08:50:53Z")

</div>

I would like to ask about alternative solutions to MySQL InnoDB ClusterSet. For Group Replication + Asynchronous Replication topology, could elaborate on how this architecture is composed? Regarding the MySQL Innod…

---

## [PXC on Kubernetes - ProxySQL load balancing](https://forums.percona.com/t/pxc-on-kubernetes-proxysql-load-balancing/21640)

<div class="topic-metadata">

**Author:** [@bac.aro](https://forums.percona.com/u/bac.aro)\
**Replies:** 8\
**Last updated:** [March 11, 2026, 2:37pm UTC](https://forums.percona.com/t/pxc-on-kubernetes-proxysql-load-balancing/21640 "2026-03-11T14:37:25Z")

</div>

Hi Community, We’re currently working on a MySQL cluster setup in order to replace our current MySQL standalone server. We’ve setup a K8S cluster last year, and we wanted to test PXC on this cluster. We started from P…

---

## [Full crash Percona after OOM](https://forums.percona.com/t/full-crash-percona-after-oom/40148)

<div class="topic-metadata">

**Author:** [@reddy\_nishanth](https://forums.percona.com/u/reddy_nishanth)\
**Replies:** 27\
**Last updated:** [March 10, 2026, 11:41am UTC](https://forums.percona.com/t/full-crash-percona-after-oom/40148 "2026-03-10T11:41:56Z")

</div>

Description: Why did my cluster crash and become non-recoverable after OOM? Steps to Reproduce: PXC cluster pods did OOM, and there were many restarts polaris@RKLAB-RVMHM255S006481:~$ k get all -n percona-operator NAME…

---

## [Issue with Trigger Causing Update Errors in Busy Node on Galera Cluster](https://forums.percona.com/t/issue-with-trigger-causing-update-errors-in-busy-node-on-galera-cluster/40337)

<div class="topic-metadata">

**Author:** [@Nazmul](https://forums.percona.com/u/Nazmul)\
**Replies:** 5\
**Last updated:** [March 10, 2026, 1:57am UTC](https://forums.percona.com/t/issue-with-trigger-causing-update-errors-in-busy-node-on-galera-cluster/40337 "2026-03-10T01:57:12Z")

</div>

We are experiencing an issue with a trigger in our MySQL Galera Cluster. We have a table, referred to as financial, defined as follows: CREATE TABLE \`financial\` ( \`TransactionId\` int unsigned NOT NULL AUTO\_INCREMENT, …

[Previous page](https://forums.percona.com/c/mysql-mariadb/36.md?page=1)

[Next page](https://forums.percona.com/c/mysql-mariadb/36.md?page=3)
