# Percona Operator for MongoDB

**URL:** https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=3

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 4

---

## [\[Error\] backup-agent: couldn't find key MONGODB\_BACKUP\_PASSWORD\_ESCAPED in secret](https://forums.percona.com/t/error-backup-agent-couldnt-find-key-mongodb-backup-password-escaped-in-secret/37646)

<div class="topic-metadata">

**Author:** [@Pallavi](https://forums.percona.com/u/Pallavi)\
**Replies:** 1\
**Last updated:** [April 18, 2025, 11:34am UTC](https://forums.percona.com/t/error-backup-agent-couldnt-find-key-mongodb-backup-password-escaped-in-secret/37646 "2025-04-18T11:34:43Z")

</div>

Description: We were already using PSMDB operator 1.18.0. We want to upgrade it to 1.19.0. After upgrade, getting below error in Percona Server MongoDB. backup-agent: couldn’t find key MONGODB\_BACKUP\_PASSWORD\_ESCAPED in…

---

## [Error during an attempt to restore a physical backup of MongoDB](https://forums.percona.com/t/error-during-an-attempt-to-restore-a-physical-backup-of-mongodb/37169)

<div class="topic-metadata">

**Author:** [@sebastian.guesdon](https://forums.percona.com/u/sebastian.guesdon)\
**Replies:** 3\
**Last updated:** [March 20, 2025, 4:34pm UTC](https://forums.percona.com/t/error-during-an-attempt-to-restore-a-physical-backup-of-mongodb/37169 "2025-03-20T16:34:18Z")

</div>

Description: I deployed a MongoDB cluster using the Percona MongoDB Operator (version 1.19.1) with scheduled physical backups. When I attempt to restore on the same cluster, I encounter an error related to the Kubernetes…

---

## [Cluster can't create properly](https://forums.percona.com/t/cluster-cant-create-properly/37568)

<div class="topic-metadata">

**Author:** [@Sam\_Lin](https://forums.percona.com/u/Sam_Lin)\
**Replies:** 1\
**Last updated:** [April 11, 2025, 10:58am UTC](https://forums.percona.com/t/cluster-cant-create-properly/37568 "2025-04-11T10:58:02Z")

</div>

Description: if MONGODB\_CLUSTER\_MONITOR\_USER is not clusterMonitor, the cluster can’t initialize properly Steps to Reproduce: as above Version: 1.19.1 Logs: \[If applicable, include any relevant log files or error mess…

---

## [PSMDB Restore fails on zstd compression](https://forums.percona.com/t/psmdb-restore-fails-on-zstd-compression/37567)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 1\
**Last updated:** [April 11, 2025, 10:57am UTC](https://forums.percona.com/t/psmdb-restore-fails-on-zstd-compression/37567 "2025-04-11T10:57:23Z")

</div>

Hi folks, I have a problem with PSMDB restore in Kubernetes when using zstd compression. Description: I’ve created a simple replicaset cluster of 3 nodes with daily physical and logical backups using: compressionType:…

---

## [Installation of PSMDB resource failed with TLS error](https://forums.percona.com/t/installation-of-psmdb-resource-failed-with-tls-error/37281)

<div class="topic-metadata">

**Author:** [@surajm](https://forums.percona.com/u/surajm)\
**Replies:** 12\
**Last updated:** [April 7, 2025, 2:17pm UTC](https://forums.percona.com/t/installation-of-psmdb-resource-failed-with-tls-error/37281 "2025-04-07T14:17:04Z")

</div>

Installation of PSMDB fails with TLS error. This is fresh installation and followed the below procedure: Deploy the operator using the following command: $ kubectl apply --server-side -f https://raw.githubuserconten…

---

## [Mongodb collection overview page showing "No data"](https://forums.percona.com/t/mongodb-collection-overview-page-showing-no-data/37304)

<div class="topic-metadata">

**Author:** [@Amol\_Nagotkar\_Helo.a](https://forums.percona.com/u/Amol_Nagotkar_Helo.a)\
**Replies:** 11\
**Last updated:** [March 31, 2025, 7:30pm UTC](https://forums.percona.com/t/mongodb-collection-overview-page-showing-no-data/37304 "2025-03-31T19:30:40Z")

</div>

Description: Mongodb collection overview page showing no data Steps to Reproduce: connect mongo instance-\> mongo-\>collections Version: mongo 6.0.21 Expected Result: it should show all counts and graphs Additional In…

---

## [PerconaMongo Operator status is always in progressing](https://forums.percona.com/t/perconamongo-operator-status-is-always-in-progressing/37241)

<div class="topic-metadata">

**Author:** [@sri.kalapala](https://forums.percona.com/u/sri.kalapala)\
**Replies:** 0\
**Last updated:** [March 18, 2025, 6:33am UTC](https://forums.percona.com/t/perconamongo-operator-status-is-always-in-progressing/37241 "2025-03-18T06:33:05Z")

</div>

Description: Trying cross cluster replication in our environment with two different clusters. We used Istio mesh instead of load balancer due to internal restrictions to expose the replica sets. As it is cross cluster, …

---

## [Connection to an exposed replicaset is not working](https://forums.percona.com/t/connection-to-an-exposed-replicaset-is-not-working/27250)

<div class="topic-metadata">

**Author:** [@Markus](https://forums.percona.com/u/Markus)\
**Replies:** 15\
**Last updated:** [March 25, 2025, 10:52am UTC](https://forums.percona.com/t/connection-to-an-exposed-replicaset-is-not-working/27250 "2025-03-25T10:52:25Z")

</div>

Description: I exposed my mongodb cluster using istio service mesh and a virtualservice (see below). I can open a connection to every single node. When I try to connect to the replicaset, I get an error message ==\>\> Mon…

---

## [Mongob Operator. corp ACME for public ssl cert, self signed for internalssl](https://forums.percona.com/t/mongob-operator-corp-acme-for-public-ssl-cert-self-signed-for-internalssl/37307)

<div class="topic-metadata">

**Author:** [@Pierre\_OBLIN](https://forums.percona.com/u/Pierre_OBLIN)\
**Replies:** 0\
**Last updated:** [March 21, 2025, 2:21pm UTC](https://forums.percona.com/t/mongob-operator-corp-acme-for-public-ssl-cert-self-signed-for-internalssl/37307 "2025-03-21T14:21:48Z")

</div>

Description: Im creating a psmdb. I wanted to leverage certmanager corporate ACME to get a valid public PKI Steps to Reproduce: Define Certificate for public cert apiVersion: cert-manager.io/v1 kind: Certificate metad…

---

## [Getting errors UserNotFound , Read Concern Majority Not Available Yet, livness fails](https://forums.percona.com/t/getting-errors-usernotfound-read-concern-majority-not-available-yet-livness-fails/37287)

<div class="topic-metadata">

**Author:** [@naorsisense](https://forums.percona.com/u/naorsisense)\
**Replies:** 0\
**Last updated:** [March 20, 2025, 3:19pm UTC](https://forums.percona.com/t/getting-errors-usernotfound-read-concern-majority-not-available-yet-livness-fails/37287 "2025-03-20T15:19:20Z")

</div>

Description: I am have a multi-node cluster of amazon-linux 2023 with storage fsx, the psmdb-db storageClass is gp3, using ebs-csi-driver i configure my own user for mongodb authentication, getting failures such as UserN…

---

## [PerconaServerMongoDB CR design considerations around \`expose\` and \`externalNodes\`](https://forums.percona.com/t/perconaservermongodb-cr-design-considerations-around-expose-and-externalnodes/17896)

<div class="topic-metadata">

**Author:** [@Vitaly\_Orbidan](https://forums.percona.com/u/Vitaly_Orbidan)\
**Replies:** 6\
**Last updated:** [March 20, 2025, 7:19am UTC](https://forums.percona.com/t/perconaservermongodb-cr-design-considerations-around-expose-and-externalnodes/17896 "2025-03-20T07:19:09Z")

</div>

The ability to add spec.replsets\[\].externalNodes depends on spec.replsets\[\].expose.enabled: true, so in order to be able to add externalNodes one also needs to expose replica sets with a service-per-pod or MCS. I quite,…

---

## [Pods occasionally fail readiness check, can't find out why, but cluster otherwise works?](https://forums.percona.com/t/pods-occasionally-fail-readiness-check-cant-find-out-why-but-cluster-otherwise-works/36009)

<div class="topic-metadata">

**Author:** [@owlee](https://forums.percona.com/u/owlee)\
**Replies:** 4\
**Last updated:** [March 14, 2025, 5:02pm UTC](https://forums.percona.com/t/pods-occasionally-fail-readiness-check-cant-find-out-why-but-cluster-otherwise-works/36009 "2025-03-14T17:02:31Z")

</div>

I have a 3 machine cluster, 8c16t 64GBram 2x250GB SSDs in backup raid. Not much on it, rarely exceeds 10% resource usage. The problem I’m having is some pods very often fail the readiness check and I can’t connnect from…

---

## [Configuring backup storage (s3) secrets to use service account key or workdload identity federation](https://forums.percona.com/t/configuring-backup-storage-s3-secrets-to-use-service-account-key-or-workdload-identity-federation/36367)

<div class="topic-metadata">

**Author:** [@ranjithnairs84](https://forums.percona.com/u/ranjithnairs84)\
**Replies:** 1\
**Last updated:** [March 10, 2025, 10:05am UTC](https://forums.percona.com/t/configuring-backup-storage-s3-secrets-to-use-service-account-key-or-workdload-identity-federation/36367 "2025-03-10T10:05:59Z")

</div>

I am trying to follow Configure storage for backups - Percona Operator for MongoDB to configure backup storage secrets, and I wanted to understand if instead of access key id , workload-identity or service account key-pa…

---

## [Sudden \`mongos\` crash with no recovery](https://forums.percona.com/t/sudden-mongos-crash-with-no-recovery/37091)

<div class="topic-metadata">

**Author:** [@taglas\_tamas](https://forums.percona.com/u/taglas_tamas)\
**Replies:** 2\
**Last updated:** [March 8, 2025, 2:11pm UTC](https://forums.percona.com/t/sudden-mongos-crash-with-no-recovery/37091 "2025-03-08T14:11:52Z")

</div>

Description: On 03/01 Saturday at around 15:53 the mongos pods of our deployment crashed on our kubernetes cluster. Percona operator: 1.9.1 Kubernetes version: 1.30.3 image: percona/percona-server-mongodb:6.0.9-7 Wha…

---

## [Percona cluster not ready i.e error state after upgrade to mongodb 8](https://forums.percona.com/t/percona-cluster-not-ready-i-e-error-state-after-upgrade-to-mongodb-8/37041)

<div class="topic-metadata">

**Author:** [@Raj\_Burnwal](https://forums.percona.com/u/Raj_Burnwal)\
**Replies:** 1\
**Last updated:** [March 5, 2025, 8:55am UTC](https://forums.percona.com/t/percona-cluster-not-ready-i-e-error-state-after-upgrade-to-mongodb-8/37041 "2025-03-05T08:55:14Z")

</div>

getting below error on mongodb operator pod but other pods are working fine like mongos, rs and config. /go/pkg/mod/sigs.k8s.io/controller-runtime@v0.19.3/pkg/internal/controller/controller.go:224 2025-03-04T17:27:52.7…

---

## [Older backups are not getting deleted, with the keep argument specified](https://forums.percona.com/t/older-backups-are-not-getting-deleted-with-the-keep-argument-specified/34424)

<div class="topic-metadata">

**Author:** [@Mike\_Devresse](https://forums.percona.com/u/Mike_Devresse)\
**Replies:** 3\
**Last updated:** [March 4, 2025, 7:35pm UTC](https://forums.percona.com/t/older-backups-are-not-getting-deleted-with-the-keep-argument-specified/34424 "2025-03-04T19:35:53Z")

</div>

Description: I’ve setup two mongo clusters on different environments using the psmdb-db and psmdb-operator helm charts. I’ve setup for both of those cluster the following configuration concerning backups: backup: …

---

## [Error while creating backup: failed to find CERTIFICATE](https://forums.percona.com/t/error-while-creating-backup-failed-to-find-certificate/23101)

<div class="topic-metadata">

**Author:** [@Semantic](https://forums.percona.com/u/Semantic)\
**Replies:** 18\
**Last updated:** [February 27, 2025, 8:56pm UTC](https://forums.percona.com/t/error-while-creating-backup-failed-to-find-certificate/23101 "2025-02-27T20:56:16Z")

</div>

While creating a normal logical backup of a 1.3TB replica, its state changes to errored after about 16 hours of run with the following: check for concurrent jobs: getting pbm object: create PBM connection to mongo-rs0-2…

---

## [Adding custom user to repsets psmdb](https://forums.percona.com/t/adding-custom-user-to-repsets-psmdb/36852)

<div class="topic-metadata">

**Author:** [@Henry\_Smearman](https://forums.percona.com/u/Henry_Smearman)\
**Replies:** 4\
**Last updated:** [February 24, 2025, 4:31pm UTC](https://forums.percona.com/t/adding-custom-user-to-repsets-psmdb/36852 "2025-02-24T16:31:11Z")

</div>

I am trying to add a custom user to mongoDB database. I am not using sharding only using repsets. Can this be done ? Below is a snippet from my values file. So far I have no luck. Thanks for any insight. ( my spacin…

---

## [Metadata empty when creating a PVC for sidecar in MongoDB](https://forums.percona.com/t/metadata-empty-when-creating-a-pvc-for-sidecar-in-mongodb/36535)

<div class="topic-metadata">

**Author:** [@Henry\_Smearman](https://forums.percona.com/u/Henry_Smearman)\
**Replies:** 6\
**Last updated:** [February 12, 2025, 9:47am UTC](https://forums.percona.com/t/metadata-empty-when-creating-a-pvc-for-sidecar-in-mongodb/36535 "2025-02-12T09:47:41Z")

</div>

I am trying to create a PVC and mount to my sidecar using MongoDB cr version 1.19.0. When I look at the STS the metadata is empty. Below is an insert from the sts and the sidecar config. Im not sure why the metadata i…

---

## [Error when trying to backup with IRSA in AWS EKS in 1.19](https://forums.percona.com/t/error-when-trying-to-backup-with-irsa-in-aws-eks-in-1-19/36526)

<div class="topic-metadata">

**Author:** [@hipos](https://forums.percona.com/u/hipos)\
**Replies:** 6\
**Last updated:** [February 5, 2025, 1:00pm UTC](https://forums.percona.com/t/error-when-trying-to-backup-with-irsa-in-aws-eks-in-1-19/36526 "2025-02-05T13:00:27Z")

</div>

Hello, following the instructions in Configure storage for backups - Percona Operator for MongoDB I’m failing to backup the cluster to an S3 bucket. As explained in the documentation, I configured the IAM’s role trust …

---

## [Secret data changed. Updating users](https://forums.percona.com/t/secret-data-changed-updating-users/36534)

<div class="topic-metadata">

**Author:** [@Srinivasulu\_Kota](https://forums.percona.com/u/Srinivasulu_Kota)\
**Replies:** 0\
**Last updated:** [February 4, 2025, 10:41pm UTC](https://forums.percona.com/t/secret-data-changed-updating-users/36534 "2025-02-04T22:41:13Z")

</div>

Description: \[Detailed description of the issue or question\] Operator is continous posting this message in the log. Secret Data Changed ..updating users . we are using the operator 1.19. no mention of which secret or …

---

## [Psmdb-db-rs0 in crashloop after Upgrade](https://forums.percona.com/t/psmdb-db-rs0-in-crashloop-after-upgrade/36460)

<div class="topic-metadata">

**Author:** [@ranjithnairs84](https://forums.percona.com/u/ranjithnairs84)\
**Replies:** 10\
**Last updated:** [February 3, 2025, 10:23pm UTC](https://forums.percona.com/t/psmdb-db-rs0-in-crashloop-after-upgrade/36460 "2025-02-03T22:23:18Z")

</div>

psmdb-db-rs0 in crashloop after Percona Mongodb Upgrade (to v6.0.19-16) and Operator Upgrade (to v1.19.0).

---

## [Error upgrading to 1.19: failed to update cluster status](https://forums.percona.com/t/error-upgrading-to-1-19-failed-to-update-cluster-status/36422)

<div class="topic-metadata">

**Author:** [@hipos](https://forums.percona.com/u/hipos)\
**Replies:** 6\
**Last updated:** [February 1, 2025, 7:31am UTC](https://forums.percona.com/t/error-upgrading-to-1-19-failed-to-update-cluster-status/36422 "2025-02-01T07:31:13Z")

</div>

Description: When upgrading to version 1.19 the operator keep spamming an error message, however all seems to work nicely. Somehow it seems to get stuck updating the status of the Kubernetes object: \[status.replsets.cf…

---

## [Can one schedule a snapshot backup for pbm mongo db cluster ( and operator) running on GCP kubernetes workloads?](https://forums.percona.com/t/can-one-schedule-a-snapshot-backup-for-pbm-mongo-db-cluster-and-operator-running-on-gcp-kubernetes-workloads/36363)

<div class="topic-metadata">

**Author:** [@ranjithnairs84](https://forums.percona.com/u/ranjithnairs84)\
**Replies:** 2\
**Last updated:** [January 27, 2025, 2:05pm UTC](https://forums.percona.com/t/can-one-schedule-a-snapshot-backup-for-pbm-mongo-db-cluster-and-operator-running-on-gcp-kubernetes-workloads/36363 "2025-01-27T14:05:15Z")

</div>

I have a pbm mongo cluster (2 replicas) and operator running on GCP kubernetes pods. Looking to schedule snaptshot backups for this cluster. How do I get started ?

---

## [MongoDB Restore Failing](https://forums.percona.com/t/mongodb-restore-failing/36328)

<div class="topic-metadata">

**Author:** [@Adhiraj\_Singh](https://forums.percona.com/u/Adhiraj_Singh)\
**Replies:** 1\
**Last updated:** [January 26, 2025, 6:24am UTC](https://forums.percona.com/t/mongodb-restore-failing/36328 "2025-01-26T06:24:58Z")

</div>

Description: I’ve been trying to get the Percona Operator for MongoDB running in our production environment. So far, I’ve migrated all data from Atlas to our hosted DB using Percona operator. I encountered a few issues s…

---

## [Error on secret not found upgrading to operator 1.19.0](https://forums.percona.com/t/error-on-secret-not-found-upgrading-to-operator-1-19-0/36297)

<div class="topic-metadata">

**Author:** [@Claudio\_Bisegni](https://forums.percona.com/u/Claudio_Bisegni)\
**Replies:** 16\
**Last updated:** [January 22, 2025, 9:42pm UTC](https://forums.percona.com/t/error-on-secret-not-found-upgrading-to-operator-1-19-0/36297 "2025-01-22T21:42:49Z")

</div>

Upgrading to new operator i got this error when backup agent is spinend up: │ Warning Failed 5m39s (x3 over 5m43s) kubelet Error: couldn’t find key MONGODB\_BACKUP\_USER\_ESCAPED in Se…

---

## [Get metrics from percona backup mongodb to use grafana to monitor it](https://forums.percona.com/t/get-metrics-from-percona-backup-mongodb-to-use-grafana-to-monitor-it/36296)

<div class="topic-metadata">

**Author:** [@Claudio\_Bisegni](https://forums.percona.com/u/Claudio_Bisegni)\
**Replies:** 0\
**Last updated:** [January 22, 2025, 6:28pm UTC](https://forums.percona.com/t/get-metrics-from-percona-backup-mongodb-to-use-grafana-to-monitor-it/36296 "2025-01-22T18:28:11Z")

</div>

I was wondering if there’s a way to export metrics for Percona Backup for MongoDB or at least directly from the operator. Currently, using the MongoDB Exporter, I can view MongoDB database metrics on Grafana, which is gr…

---

## [Mongo pods constantly restart due to failed liveness probe](https://forums.percona.com/t/mongo-pods-constantly-restart-due-to-failed-liveness-probe/11757)

<div class="topic-metadata">

**Author:** [@vhphan](https://forums.percona.com/u/vhphan)\
**Replies:** 9\
**Last updated:** [January 9, 2025, 5:08pm UTC](https://forums.percona.com/t/mongo-pods-constantly-restart-due-to-failed-liveness-probe/11757 "2025-01-09T17:08:57Z")

</div>

Hello, When I create a PerconaServerMongoDB in replicaset mode, my pods restart constantly due to failed liveness probes with this error: “connection error: no reachable servers”. I can connect to the pod and run /data…

---

## [Split Horizon Issue](https://forums.percona.com/t/split-horizon-issue/36040)

<div class="topic-metadata">

**Author:** [@devopser](https://forums.percona.com/u/devopser)\
**Replies:** 0\
**Last updated:** [January 9, 2025, 7:12am UTC](https://forums.percona.com/t/split-horizon-issue/36040 "2025-01-09T07:12:30Z")

</div>

Description: MongoDB deployed with Percona Operator with split-horizon DNS doesn’t connect and I get the following error: MongoServerSelectionError Steps to Reproduce: Installed with latest Helm Percona Operator for M…

---

## [High memory consumption during restore](https://forums.percona.com/t/high-memory-consumption-during-restore/35844)

<div class="topic-metadata">

**Author:** [@avidalco](https://forums.percona.com/u/avidalco)\
**Replies:** 1\
**Last updated:** [December 27, 2024, 2:34pm UTC](https://forums.percona.com/t/high-memory-consumption-during-restore/35844 "2024-12-27T14:34:31Z")

</div>

Description: I am experiencing an issue when performing a restore of an 80GB backup from S3 using the Percona MongoDB Operator (version 1.13.0) on Kubernetes. During the restore process, the node running the database pod…

[Previous page](https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=2)

[Next page](https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=4)
