# Percona Operator for MongoDB

**URL:** https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=2

[Latest](https://forums.percona.com/latest.md) · [Categories](https://forums.percona.com/categories.md) · [Tags](https://forums.percona.com/tags.md)

**Page:** 3

---

## [TLS mode requireTLS not working](https://forums.percona.com/t/tls-mode-requiretls-not-working/39319)

<div class="topic-metadata">

**Author:** [@Fetah\_Jusufi](https://forums.percona.com/u/Fetah_Jusufi)\
**Replies:** 1\
**Last updated:** [September 10, 2025, 8:14am UTC](https://forums.percona.com/t/tls-mode-requiretls-not-working/39319 "2025-09-10T08:14:48Z")

</div>

Description: trying to make it enable but it doesnt work! always get --tlsMode disabled the cr.yaml spec: secrets: keyFile: percona-keyfile encryptionKey: percona-cluster-mongodb-encryption-key ssl: per…

---

## [Operator cannot start PMM because keys don't exist in the secrets, or secrets and internal secrets are out of sync?](https://forums.percona.com/t/operator-cannot-start-pmm-because-keys-dont-exist-in-the-secrets-or-secrets-and-internal-secrets-are-out-of-sync/39266)

<div class="topic-metadata">

**Author:** [@willr](https://forums.percona.com/u/willr)\
**Replies:** 3\
**Last updated:** [September 4, 2025, 10:42am UTC](https://forums.percona.com/t/operator-cannot-start-pmm-because-keys-dont-exist-in-the-secrets-or-secrets-and-internal-secrets-are-out-of-sync/39266 "2025-09-04T10:42:54Z")

</div>

Sorry, this is probably very basic but there’s a gap in the documentation between PSMDB Operator, MongoDB and PMM around exactly how to supply authentication secrets to pmm-admin. tldr: Please could someone tell me the …

---

## [Replica set fails: pmm-client to blame?](https://forums.percona.com/t/replica-set-fails-pmm-client-to-blame/39248)

<div class="topic-metadata">

**Author:** [@willr](https://forums.percona.com/u/willr)\
**Replies:** 2\
**Last updated:** [September 3, 2025, 10:12am UTC](https://forums.percona.com/t/replica-set-fails-pmm-client-to-blame/39248 "2025-09-03T10:12:00Z")

</div>

Hello. I am building a 3x3 sharded replica set on EKS, and for days now I have been running into the same weird situation: coredns has records for all the pods in rs1 and rs2, but none of the pods in rs0 rs0 fails to r…

---

## [Physical Restore from One Cluster to Another Fails with "not a member of the leader rs"](https://forums.percona.com/t/physical-restore-from-one-cluster-to-another-fails-with-not-a-member-of-the-leader-rs/39197)

<div class="topic-metadata">

**Author:** [@ciel](https://forums.percona.com/u/ciel)\
**Replies:** 1\
**Last updated:** [August 29, 2025, 9:34am UTC](https://forums.percona.com/t/physical-restore-from-one-cluster-to-another-fails-with-not-a-member-of-the-leader-rs/39197 "2025-08-29T09:34:27Z")

</div>

Hi Percona Team, I am trying to restore a physical backup from one MongoDB cluster (source-cluster) to another cluster (target-cluster) in Kubernetes using the Percona Server for MongoDB Operator. Here is the setup and …

---

## [Interactive confirm option when using pbm restore](https://forums.percona.com/t/interactive-confirm-option-when-using-pbm-restore/39156)

<div class="topic-metadata">

**Author:** [@cxmcxm](https://forums.percona.com/u/cxmcxm)\
**Replies:** 3\
**Last updated:** [August 20, 2025, 12:08pm UTC](https://forums.percona.com/t/interactive-confirm-option-when-using-pbm-restore/39156 "2025-08-20T12:08:21Z")

</div>

Hello engineers may encounter situations where misuse of command history (e.g., directly executing a previous \`pbm restore\` command from history) leads to restoring an incorrect backup to the production environment. I …

---

## [allowVolumeExpansion and autoResizePolicy](https://forums.percona.com/t/allowvolumeexpansion-and-autoresizepolicy/39114)

<div class="topic-metadata">

**Author:** [@jamoser](https://forums.percona.com/u/jamoser)\
**Replies:** 2\
**Last updated:** [August 15, 2025, 7:54am UTC](https://forums.percona.com/t/allowvolumeexpansion-and-autoresizepolicy/39114 "2025-08-15T07:54:26Z")

</div>

Hello allowVolumeExpansion is already a big step. Do you also support autoResizePolicy ? Thanks & Regards, John

---

## [Startup of replicaset takes very long](https://forums.percona.com/t/startup-of-replicaset-takes-very-long/35360)

<div class="topic-metadata">

**Author:** [@jamoser](https://forums.percona.com/u/jamoser)\
**Replies:** 8\
**Last updated:** [August 14, 2025, 7:52am UTC](https://forums.percona.com/t/startup-of-replicaset-takes-very-long/35360 "2025-08-14T07:52:42Z")

</div>

Hello I have replicas = 3 and during startup, why does one pod after the other get started? Lets say 1 pod takes 30min (after a “forced” shutdown), then you have to wait 3x30min. Any other options? Regards John

---

## [ERROR setup failed to register multicluster service {"error": "get api groups and resources:](https://forums.percona.com/t/error-setup-failed-to-register-multicluster-service-error-get-api-groups-and-resources/39048)

<div class="topic-metadata">

**Author:** [@Seshan\_Kannan](https://forums.percona.com/u/Seshan_Kannan)\
**Replies:** 0\
**Last updated:** [August 9, 2025, 4:36pm UTC](https://forums.percona.com/t/error-setup-failed-to-register-multicluster-service-error-get-api-groups-and-resources/39048 "2025-08-09T16:36:34Z")

</div>

Dear team, Need your help in resolving the following issue. The operator instance fails to come up with the following error. \[seshankannan@kubectl-instance ~\]$ kubectl logs -n default deployment/percona-operator-psmdb-…

---

## [Selective Backup Using Percona Operator](https://forums.percona.com/t/selective-backup-using-percona-operator/39034)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 2\
**Last updated:** [August 8, 2025, 6:21pm UTC](https://forums.percona.com/t/selective-backup-using-percona-operator/39034 "2025-08-08T18:21:40Z")

</div>

Hi folks, I’m working on implementing a selective logical backup for a relatively small collection in our MongoDB cluster managed by the Operator. Context: We have a cluster with two collections: One large collect…

---

## [Backup retention not applied in v1.17.0](https://forums.percona.com/t/backup-retention-not-applied-in-v1-17-0/38904)

<div class="topic-metadata">

**Author:** [@SuperHammer](https://forums.percona.com/u/SuperHammer)\
**Replies:** 4\
**Last updated:** [August 4, 2025, 11:04am UTC](https://forums.percona.com/t/backup-retention-not-applied-in-v1-17-0/38904 "2025-08-04T11:04:59Z")

</div>

Description: In an OKD SNO environment, installing the operator and running it works correctly. When making backups to a local minio, backups work fine, but the set retention is not applied, resulting in a large number o…

---

## [PerconaServerMongoDBRestore fails at storage-validation stage on iDrive E2 (HEAD request returns EOF)](https://forums.percona.com/t/perconaservermongodbrestore-fails-at-storage-validation-stage-on-idrive-e2-head-request-returns-eof/38946)

<div class="topic-metadata">

**Author:** [@Islam\_Saka](https://forums.percona.com/u/Islam_Saka)\
**Replies:** 0\
**Last updated:** [August 3, 2025, 11:19pm UTC](https://forums.percona.com/t/perconaservermongodbrestore-fails-at-storage-validation-stage-on-idrive-e2-head-request-returns-eof/38946 "2025-08-03T23:19:55Z")

</div>

Description: Attempting to restore a logical backup stored in iDrive E2 (S3-compatible). PerconaServerMongoDBRestore never leaves Error because PBM’s initial HeadObject on …/mongodb-backups/2025-05-26T00%3A00%3A21Z.pb…

---

## [How to migrate from existing MongoDB data to Percona MongoDB](https://forums.percona.com/t/how-to-migrate-from-existing-mongodb-data-to-percona-mongodb/38677)

<div class="topic-metadata">

**Author:** [@ciel](https://forums.percona.com/u/ciel)\
**Replies:** 10\
**Last updated:** [July 29, 2025, 5:20am UTC](https://forums.percona.com/t/how-to-migrate-from-existing-mongodb-data-to-percona-mongodb/38677 "2025-07-29T05:20:52Z")

</div>

Hello I am using Mongodb which AWS serves as “DocumentDB”. I want to migrate all data into my k8s cluster’s mongodb. But it seems “mongorestore” command not working on percona rs pods. Is there kubernetes-native way …

---

## [How to create mongo indexes in rolling fashion using percona operator..?](https://forums.percona.com/t/how-to-create-mongo-indexes-in-rolling-fashion-using-percona-operator/14822)

<div class="topic-metadata">

**Author:** [@bharad](https://forums.percona.com/u/bharad)\
**Replies:** 4\
**Last updated:** [July 28, 2025, 2:47pm UTC](https://forums.percona.com/t/how-to-create-mongo-indexes-in-rolling-fashion-using-percona-operator/14822 "2025-07-28T14:47:02Z")

</div>

I didn’t find any instruction on how to create new indexes while using percona kubernetes operator, appreciate the inputs. ~thanks

---

## [OCI runtime error when re-generate Statefulset](https://forums.percona.com/t/oci-runtime-error-when-re-generate-statefulset/38774)

<div class="topic-metadata">

**Author:** [@ciel](https://forums.percona.com/u/ciel)\
**Replies:** 1\
**Last updated:** [July 22, 2025, 1:04pm UTC](https://forums.percona.com/t/oci-runtime-error-when-re-generate-statefulset/38774 "2025-07-22T13:04:35Z")

</div>

Hello, I delete Statefulset psmdb-db-rs0 then it re-generated by applying helm chart. When the helm chart modified and new rs pod init, the error occurred and it is not started. Can you guess why this error occurred? …

---

## [Getting error "Waiting for restore metadata" while restoring mongodb](https://forums.percona.com/t/getting-error-waiting-for-restore-metadata-while-restoring-mongodb/38624)

<div class="topic-metadata">

**Author:** [@Aditya1523](https://forums.percona.com/u/Aditya1523)\
**Replies:** 4\
**Last updated:** [July 22, 2025, 6:03am UTC](https://forums.percona.com/t/getting-error-waiting-for-restore-metadata-while-restoring-mongodb/38624 "2025-07-22T06:03:39Z")

</div>

Description: I am testing restoration from s3 compatible r2 bucket (cloudflare) full backup restoration. Version: percona/percona-server-mongodb-operator:1.16.2 percona/percona-server-mongodb:6.0.16-13 Logs: these are…

---

## [splitHorizon DNS?](https://forums.percona.com/t/splithorizon-dns/20205)

<div class="topic-metadata">

**Author:** [@rdxmbr](https://forums.percona.com/u/rdxmbr)\
**Replies:** 14\
**Last updated:** [July 16, 2025, 1:52pm UTC](https://forums.percona.com/t/splithorizon-dns/20205 "2025-07-16T13:52:23Z")

</div>

Hello, I think about switching from MongoDBCommunity-Operator to the Percona MongoDB Operator. However, I need the splitHorizon for DNS, like it is documented here: Connect to a MongoDB Database Resource from Outside Ku…

---

## [Warm scalling a percona mongodb](https://forums.percona.com/t/warm-scalling-a-percona-mongodb/38574)

<div class="topic-metadata">

**Author:** [@Manjunath\_KP](https://forums.percona.com/u/Manjunath_KP)\
**Replies:** 1\
**Last updated:** [July 8, 2025, 9:38am UTC](https://forums.percona.com/t/warm-scalling-a-percona-mongodb/38574 "2025-07-08T09:38:38Z")

</div>

Description: We operate MongoDB clusters with collection sizes reaching several hundred GBs. The primary challenge we faced was the extended time required to add additional replicas due to lengthy initial synchronization…

---

## [Restore to new environment with Operator 1.16.0 and mongo v7](https://forums.percona.com/t/restore-to-new-environment-with-operator-1-16-0-and-mongo-v7/31209)

<div class="topic-metadata">

**Author:** [@Vivek\_Shinde](https://forums.percona.com/u/Vivek_Shinde)\
**Replies:** 7\
**Last updated:** [July 8, 2025, 9:35am UTC](https://forums.percona.com/t/restore-to-new-environment-with-operator-1-16-0-and-mongo-v7/31209 "2025-07-08T09:35:01Z")

</div>

HI All, I am facing an issue when trying to restore backup of psmdb v7 (with operator 1.16.0) on new kubernetes setup. (with same secret of psmdb users). Same backup works well when restore on same setup where backup is…

---

## ["FULL CLUSTER CRASH" during restore physical backup](https://forums.percona.com/t/full-cluster-crash-during-restore-physical-backup/38551)

<div class="topic-metadata">

**Author:** [@Stateros](https://forums.percona.com/u/Stateros)\
**Replies:** 3\
**Last updated:** [July 4, 2025, 3:46pm UTC](https://forums.percona.com/t/full-cluster-crash-during-restore-physical-backup/38551 "2025-07-04T15:46:51Z")

</div>

Hi everyone, Description: I’m encountering an issue during the physical backup restore process on the same Percona cluster. At some point during the restore, the operator logs indicating a “FULL CLUSTER CRASH”. However…

---

## [EACCES: permission denied with custom user and group ID](https://forums.percona.com/t/eacces-permission-denied-with-custom-user-and-group-id/38131)

<div class="topic-metadata">

**Author:** [@Laurentiu\_Soica](https://forums.percona.com/u/Laurentiu_Soica)\
**Replies:** 1\
**Last updated:** [June 5, 2025, 9:05am UTC](https://forums.percona.com/t/eacces-permission-denied-with-custom-user-and-group-id/38131 "2025-06-05T09:05:24Z")

</div>

Description: For the following CR config, with custom runAsUser and runAsGroup: replsets: - containerSecurityContext: allowPrivilegeEscalation: false capabilities: drop: - ALL name: r…

---

## [MongoDB Sharded Cluster Stuck Initializing Due to Denylisted Sync Source](https://forums.percona.com/t/mongodb-sharded-cluster-stuck-initializing-due-to-denylisted-sync-source/38185)

<div class="topic-metadata">

**Author:** [@Kay\_Khan](https://forums.percona.com/u/Kay_Khan)\
**Replies:** 1\
**Last updated:** [June 2, 2025, 3:29pm UTC](https://forums.percona.com/t/mongodb-sharded-cluster-stuck-initializing-due-to-denylisted-sync-source/38185 "2025-06-02T15:29:38Z")

</div>

Description: After deploying a MongoDB sharded cluster on Kubernetes, the custom resource remains in the “initializing” state for over 29 hours. The MongoDB pod logs show an error indicating that it “Cannot select sync s…

---

## [Unable to expose mongodb replicaset to nodeport Kubernetes](https://forums.percona.com/t/unable-to-expose-mongodb-replicaset-to-nodeport-kubernetes/29710)

<div class="topic-metadata">

**Author:** [@ra2](https://forums.percona.com/u/ra2)\
**Replies:** 2\
**Last updated:** [May 20, 2025, 9:51am UTC](https://forums.percona.com/t/unable-to-expose-mongodb-replicaset-to-nodeport-kubernetes/29710 "2025-05-20T09:51:48Z")

</div>

Description: Hello, Could you please suggest a functional solution? I’m trying, like several other people I imagine, to expose my MongoDB replica set on the NodePorts of my Kubernetes cluster so that I can connect other…

---

## [Authentication and liveness/readiness issues on new installation](https://forums.percona.com/t/authentication-and-liveness-readiness-issues-on-new-installation/37771)

<div class="topic-metadata">

**Author:** [@Kay\_Khan](https://forums.percona.com/u/Kay_Khan)\
**Replies:** 12\
**Last updated:** [May 19, 2025, 10:57pm UTC](https://forums.percona.com/t/authentication-and-liveness-readiness-issues-on-new-installation/37771 "2025-05-19T22:57:33Z")

</div>

Description: Ive deployed a new psmdb operator + mongodb to a new test cluster running aws eks 1.32. However it is in a state of error NAME ENDPOINT …

---

## [Frequent NoSuchTransaction Errors When Running mongosync with the Percona Kubernetes Operator for MongoDB](https://forums.percona.com/t/frequent-nosuchtransaction-errors-when-running-mongosync-with-the-percona-kubernetes-operator-for-mongodb/37919)

<div class="topic-metadata">

**Author:** [@Kay\_Khan](https://forums.percona.com/u/Kay_Khan)\
**Replies:** 2\
**Last updated:** [May 16, 2025, 1:02pm UTC](https://forums.percona.com/t/frequent-nosuchtransaction-errors-when-running-mongosync-with-the-percona-kubernetes-operator-for-mongodb/37919 "2025-05-16T13:02:43Z")

</div>

Description: I’m using mongosync to replicate data from one MongoDB cluster to another, both managed by the Percona Kubernetes Operator. I’m seeing a flood of NoSuchTransaction errors on the destination side, and it look…

---

## [Exposing Sharded Cluster on AWS EKS NLB Target Type](https://forums.percona.com/t/exposing-sharded-cluster-on-aws-eks-nlb-target-type/37796)

<div class="topic-metadata">

**Author:** [@Kay\_Khan](https://forums.percona.com/u/Kay_Khan)\
**Replies:** 1\
**Last updated:** [May 15, 2025, 1:11pm UTC](https://forums.percona.com/t/exposing-sharded-cluster-on-aws-eks-nlb-target-type/37796 "2025-05-15T13:11:18Z")

</div>

We have deployed a sharded mongodb cluster and we are running on aws eks and the mongos service is exposed via a load balancer we are using aws load balancer controller. We are interested to learn if aws-load-balancer-n…

---

## [Pvc taint with IP of node, pod stuck in pending in case of node restart/crash](https://forums.percona.com/t/pvc-taint-with-ip-of-node-pod-stuck-in-pending-in-case-of-node-restart-crash/25568)

<div class="topic-metadata">

**Author:** [@ahad\_khan](https://forums.percona.com/u/ahad_khan)\
**Replies:** 10\
**Last updated:** [April 29, 2025, 6:27am UTC](https://forums.percona.com/t/pvc-taint-with-ip-of-node-pod-stuck-in-pending-in-case-of-node-restart-crash/25568 "2025-04-29T06:27:28Z")

</div>

the issue is with the PVC, they are being automatically tainted with IP of the node on which the corresponding pod was scheduled, in case of a pod crash/restart, especially with using a few spot instances of additional c…

---

## [Installation of PSMDB with TLS disabled, sharding enabled and expose True flag is failing](https://forums.percona.com/t/installation-of-psmdb-with-tls-disabled-sharding-enabled-and-expose-true-flag-is-failing/37657)

<div class="topic-metadata">

**Author:** [@surajm](https://forums.percona.com/u/surajm)\
**Replies:** 3\
**Last updated:** [May 2, 2025, 5:47pm UTC](https://forums.percona.com/t/installation-of-psmdb-with-tls-disabled-sharding-enabled-and-expose-true-flag-is-failing/37657 "2025-05-02T17:47:32Z")

</div>

Hi, I am installing percona mongodb with TLS disabled and sharding enabled. Also, expose flag is set to True. There is no mongos pod created and installation is failing. cfg server and rs are going in restart mode. N…

---

## [GKE / MongoDB cluster under "stress" not accepting changes from cr.yaml](https://forums.percona.com/t/gke-mongodb-cluster-under-stress-not-accepting-changes-from-cr-yaml/37775)

<div class="topic-metadata">

**Author:** [@jamoser](https://forums.percona.com/u/jamoser)\
**Replies:** 2\
**Last updated:** [April 30, 2025, 2:48pm UTC](https://forums.percona.com/t/gke-mongodb-cluster-under-stress-not-accepting-changes-from-cr-yaml/37775 "2025-04-30T14:48:52Z")

</div>

Hello Just recently a MongoDB cluster did not have enough memory and failed right after the start when the first request hit the cluster. And the pods restarted “endlessly”. I adjusted memory setting in cr.yaml and app…

---

## [Unable to Start MongoDB After Resources Update, Possible Data Corruption](https://forums.percona.com/t/unable-to-start-mongodb-after-resources-update-possible-data-corruption/37763)

<div class="topic-metadata">

**Author:** [@Adhiraj\_Singh](https://forums.percona.com/u/Adhiraj_Singh)\
**Replies:** 2\
**Last updated:** [April 30, 2025, 4:23am UTC](https://forums.percona.com/t/unable-to-start-mongodb-after-resources-update-possible-data-corruption/37763 "2025-04-30T04:23:08Z")

</div>

Description: We’ve been using the Percona operator for MongoDB for many months now with success, not had an issue & backup/restore process working well. Yesterday we tried to increase the resources of our mongodb server …

---

## [Ssue Connecting to MongoDB via External Addresses (splitHorizons)](https://forums.percona.com/t/ssue-connecting-to-mongodb-via-external-addresses-splithorizons/37444)

<div class="topic-metadata">

**Author:** [@yabilyk](https://forums.percona.com/u/yabilyk)\
**Replies:** 1\
**Last updated:** [April 24, 2025, 11:42am UTC](https://forums.percona.com/t/ssue-connecting-to-mongodb-via-external-addresses-splithorizons/37444 "2025-04-24T11:42:01Z")

</div>

Description We are trying to use Percona Server for MongoDB Operator in Kubernetes with configured splitHorizons to allow external clients to connect via OCI Load Balancer. Our splitHorizons configuration: expose: …

[Previous page](https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=1)

[Next page](https://forums.percona.com/c/mongodb/percona-kubernetes-operator-for-mongodb/29.md?page=3)
